Subject: Error loading shared libraries.

From: "Girish Gulawani" <[email-masked]>
Date: Sun, 17 Mar 2002 10:32:30 +0900

Hello, all.
I know this is kind of weird problem at this point of time. I have a MIPS
board booted up with Linux 2.4.3 kernel. But it fails on the "init". I get
an error in the init process:

init: error in loading shared libraries
libutil.so.1: cannot map file data: Bad file descriptor ...

The compiler used is EGCS 2.91.66, downloaded from the net. Such error is
seen while loading any executable. I have a statically linked shell running.
Basically I dont know where the problem is. Please help me.
Many thanks in advance.
Girish.

_________________________________________________________
Do You Yahoo!?
Get your free @yahoo.com address at http://mail.yahoo.com

---

From: "Bradley D. LaRonde" <[email-masked]>
Date: Sat, 16 Mar 2002 20:38:32 -0500

----- Original Message -----
From: "Girish Gulawani" <[email-masked]>
To: "MIPS/Linux List (SGI)" <[email-masked]>
Sent: Saturday, March 16, 2002 8:32 PM
Subject: Error loading shared libraries.

> The compiler used is EGCS 2.91.66, downloaded from the net.

What glibc?  Could this be the MIPS base address bug?  Maybe this patch by
H. J. Lu. (updated by me) will help:

http://www.ltc.com/~brad/mips/glibc-2.2.3-mips-base-addr-got.diff

Regards,
Brad