Subject: Linux-mips porting issues

From: santhosh <[email-masked]>
Date: Tue, 12 Mar 2002 00:15:25 +0530

Hi All ...

      Subj: Linux-Porting  issue
Here I ported Linux -mips on  BCM1250 board(Broadcom)  had occurred
some error which showed below

CFE>Boot -z -elf 192.168.200.150:zimage
andkishore_rane: Loader:elf Filesys:tftp Dev:eth0
File:192.168.200.150:zimage Optionsnull)
Loading: 0x80100000/1342312 0x80248000/2297856 0x80479000/343232 Entry
at 0x8010
047c
*** command status = 0

nandkishore_rane: CFE> go
Closing network.
Starting program at 0x8010047c
RUN! CPU revision is: 01040101
Linux version 2.4.17sb20020206 (root@gda_Santhosh) (gcc version 3.0.1
with SiByt
e modifications) #1 SMP Fri Mar 8 11:26:50 IST 2002
This kernel optimized for board runs with CFE
Determined physical RAM map:
memory: 0026e000 @ 00000000 (usable)
memory: 01987748 @ 004788b8 (usable)
memory: 00000000 @ 01f04000 (usable)
memory: 0020a8b8 @ 0026e000 (reserved)
Initial ramdisk at: 0x8026e000 (2140344 bytes)
On node 0 totalpages: 7680
zone(0): 7680 pages.
zone(1): 0 pages.
zone(2): 0 pages.
Kernel command line: root=/dev/ram0
CPU revision is: 01040101
Linux version 2.4.17sb20020206 (root@gda_Santhosh) (gcc version 3.0.1
with SiByt
e modifications) #1 SMP Fri Mar 8 11:26:50 IST 2002

    Then hung ...........

with regards
santhosh

---

From: Justin Carlson <[email-masked]>
Date: 11 Mar 2002 10:45:21 -0500

> Loading: 0x80100000/1342312 0x80248000/2297856 0x80479000/343232 Entry

You're trying to boot the kernel image directly from CFE?  I hope you've
embedded a ramdisk for your root filesystem...that or there must be some
spiffy new features in CFE that weren't there last I looked at it.

> Kernel command line: root=/dev/ram0

That looks good...

Does it work fine with CONFIG_SMP=n?  Or have you not tried that?

-Justin