Subject: Re: Re: PCI VGA Card Initilization (SIS6326 / PT80)

From: "Girish Gulawani" <[email-masked]>
Date: Fri, 22 Mar 2002 20:47:02 +0900

hello, all
thank you very much for all these reply mails.
my saga of VGA initialization continues. it occurs to me that the x86
emulation for the VGA bios is a long process. SiS6326 chipset has support
inside XFree86 & digging out the BIOS code from here is also a big story.
hence i was looking for a rather quickish solution. currently i'm trying to
use sis_*.c files from XFree86 source. dont know how but my monitor displays
2 red & 1 green vertical lines. the sis_bios source code searched for the
mode, memory references inside the BIOS at 0x20A offset & it failed to find
the mode & other info. AOpen BIOS version is 2.25.
could anybody of you please share your success story of VGA initialization
on MIPS board with me??
many thanks in advance.
regards,
girish.

----- Original Message -----
From: "Dan Aizenstros" <[email-masked]>
To: <[email-masked]>; <[email-masked]>; <[email-masked]>;
<[email-masked]>
Sent: Friday, March 22, 2002 4:10 AM
Subject: Re: Re: PCI VGA Card Initilization (SIS6326 / PT80)

Hello Dominic,

Actually it was Girish Gulawani who said he used the
MILO bios not Zhang. He said he was using the files
vgaraw1.c and vgaraw2.c from MILO. Those files do not
use the x86emu BIOS emulator but try to directly
initialize the VGA adapter.

Dan Aizenstros
Software Project Manager
QuickLogic Canada

>>> Dominic Sweetman <[email-masked]> 03/21/02 08:28 AM >>>

Dan,

> Is Algorithmics BIOS emulator not the x86emu code
> that can be found in the Alpha MILO and the XFree86
> code base as Alan Cox mentioned?

It's an entirely indepedent invention of the same idea.  I've no idea
whether it's any better/worse, but it sounded like our binary was
working for Zhang better than the MILO he'd built.

Dominic
Algorithmics Ltd

_________________________________________________________
Do You Yahoo!?
Get your free @yahoo.com address at http://mail.yahoo.com

---

From: Dominic Sweetman <[email-masked]>
Date: Mon, 25 Mar 2002 18:18:24 +0000

Girish,

> it occurs to me that the x86 emulation for the VGA bios is a long
> process.

It is.  But I believe that video chip companies have the chip designer
and the BIOS/Windows driver developer working at adjacent desks.  If
you knew everything they'd ever said to each other, then there would
be no need for an x86 emulator.

We thought the x86 emulator was simpler; and evidently so did the MILO
people...

-- 
Dominic Sweetman
Algorithmics Ltd
The Fruit Farm, Ely Road, Chittering, CAMBS CB5 9PH, ENGLAND
phone +44 1223 706200/fax +44 1223 706250/direct +44 1223 706205
http://www.algor.co.uk