Subject: Kernel compile with -O0

From: [email-masked]
Date: Thu, 21 Mar 2002 19:36:06 +0100

Hi.

When I try to compile my 2.4.3 Kernel with -O0 I get a lot of undefined
references to functions like __cli, clear_bit etc. during linking. With -O1
it works.

Do I have to provide some special compile option to make this work?

best regards
--
Andre Messerschmidt

Application Engineer
Infineon Technologies AG

---

From: "Bradley D. LaRonde" <[email-masked]>
Date: Thu, 21 Mar 2002 15:06:29 -0500

That turns off inlining, which the kernel *requires*.

Regards,
Brad

---

From: Ralf Baechle <[email-masked]>
Date: Thu, 21 Mar 2002 17:24:58 -0800

> Do I have to provide some special compile option to make this work?

Stupid answer: Yes, -O.

Less stupid answer - -O1 and higher imply function inlining which is
required to build the kernel.

  Ralf