Subject: Re: broken devfs-support in SGI Zilog8530 serial driver

From: Ralf Baechle <[email-masked]>
Date: Mon, 1 Apr 2002 14:16:40 -0800

On Mon, Apr 01, 2002 at 09:29:57PM +0200, Florian Lohoff wrote:

> > Could you commit that too?
> > 
> 
> I thought the callout devices are officially "dead" and should disappear
> "Real Soon Now(tm)" as beeing a locking hell and unneeded.

Really Soon Now doesn't mean what you want it to mean in a world that is
driven by backward compatibility ...

  Ralf

---

From: Florian Lohoff <[email-masked]>
Date: Mon, 1 Apr 2002 21:29:57 +0200

On Sun, Mar 31, 2002 at 05:00:23PM +0200, Raoul Borenius wrote:
> Thanks for including the changes fr the ttyS's. But it seems you forgot the
> callout-devices:
> 
> > @@ -1911,7 +1915,11 @@
> >          * major number and the subtype code.
> >          */
> >         callout_driver = serial_driver;
> > +#ifdef CONFIG_DEVFS_FS
> > +       callout_driver.name = "cua/%d";
> > +#else
> >         callout_driver.name = "cua";
> > +#endif
> >         callout_driver.major = TTYAUX_MAJOR;
> >         callout_driver.subtype = SERIAL_TYPE_CALLOUT;
> > 
> 

Flo
-- 
Florian Lohoff                  [email-masked]             +49-5201-669912
Nine nineth on september the 9th              Welcome to the new billenium