Subject: Executing IRIX binary ?

From: "Robert Rusek" <[email-masked]>
Date: Wed, 22 May 2002 16:01:07 -0700

Is there anyway to run/execute irix 5/6 binaries in linux mips on an
Indy?  Good old Microsoft does not provide the source for it's frontpage
extensions, but they do provide a binary for IRIX.
 
Thanks
Rob.

---

From: [email-masked] (H�kon Eriksen)
Date: 24 May 2002 14:04:01 +0200

> extensions, but they do provide a binary for IRIX.

If FrontPage extensions is what you want, there are several ways of
getting this to run on linux. Microsoft may not supply the source, but
they do show you how to install it on Apache.
<URL:http://support.microsoft.com/default.aspx?scid=kb;EN-US;q202198> 
If this is not what you're looking for, try google.

-- 
 - håkon

---

From: Ralf Baechle <[email-masked]>
Date: Sat, 25 May 2002 00:27:23 -0700

> extensions, but they do provide a binary for IRIX.

We have IRIX5 binary compatibility code in the kernel but I don't have
any reports about it's status ever since I integrated those patch in about
May '97.

  Ralf

---

From: "robru" <[email-masked]>
Date: Sat, 25 May 2002 12:06:29 -0700

Ralf,

How can I find out if I compiled my kernel with the compatibility code?

Thanks,
Robert.

      -----Original Message-----
      From: [email-masked] 
      [mailto:[email-masked]] On Behalf Of Ralf Baechle
      Sent: Saturday, May 25, 2002 12:27 AM
      To: Robert Rusek
      Cc: [email-masked]
      Subject: Re: Executing IRIX binary ?

      On Wed, May 22, 2002 at 04:01:07PM -0700, Robert Rusek wrote:
      
      > Indy?  Good old Microsoft does not provide the source for it's 
      > frontpage extensions, but they do provide a binary for IRIX.
      
      We have IRIX5 binary compatibility code in the kernel but 
      I don't have any reports about it's status ever since I 
      integrated those patch in about May '97.
      
        Ralf

---

From: "Steven J. Hill" <[email-masked]>
Date: Sat, 25 May 2002 14:13:23 -0500

> How can I find out if I compiled my kernel with the compatibility code?
I don't mean to be critical, but read the code. If you look in the
'arch/mips/config.in' file you will find:

if [ "$CONFIG_CPU_LITTLE_ENDIAN" = "n" ]; then
    bool 'Include IRIX binary compatibility' CONFIG_BINFMT_IRIX
    bool 'Include forward keyboard' CONFIG_FORWARD_KEYBOARD
fi

at around line #522. You have to be a big endian machine since IRIX is
itself a big endian operating system. This option is under the menu
'General setup'.

-S

---

From: Ralf Baechle <[email-masked]>
Date: Sat, 25 May 2002 15:44:26 -0700

> How can I find out if I compiled my kernel with the compatibility code?

Make sure you have CONFIG_BINFMT_IRIX set in the kernel configuration.

You'll also need to install IRIX libraries.

  Ralf

---

From: "Robert Rusek" <[email-masked]>
Date: Sun, 26 May 2002 09:34:50 -0700

This may be a stupid question but which IRIX libraries?  All of them?
When I try to execute a IRIX biniary I get the following:

bash: ./owsadm: No such file or directory

Do I need to something special?

Thanks,
Robert.

      -----Original Message-----
      From: [email-masked] 
      [mailto:[email-masked]] On Behalf Of Ralf Baechle
      Sent: Saturday, May 25, 2002 3:44 PM
      To: robru
      Cc: [email-masked]
      Subject: Re: Executing IRIX binary ?

      On Sat, May 25, 2002 at 12:06:29PM -0700, robru wrote:
      
      > How can I find out if I compiled my kernel with the 
      compatibility 
      > code?
      
      Make sure you have CONFIG_BINFMT_IRIX set in the kernel 
      configuration.

        Ralf

---

From: "Robert Rusek" <[email-masked]>
Date: Mon, 27 May 2002 13:32:43 -0700

Ralf,

Looks like I have the kernal compiled with the IRIX binary support.  How
do I go about executing the binaries?  When I try to execute it tells me
that the file is not found.

Thanks in advance,
Robert.

      -----Original Message-----
      From: [email-masked] 
      [mailto:[email-masked]] On Behalf Of Ralf Baechle
      Sent: Saturday, May 25, 2002 3:44 PM
      To: robru
      Cc: [email-masked]
      Subject: Re: Executing IRIX binary ?

      compatibility 

      
        Ralf

---

From: Florian Lohoff <[email-masked]>
Date: Mon, 27 May 2002 23:15:13 +0200

> that the file is not found.

Are you shure you have the dynamic loader + libc + other libs of IRIX
installed in your system ?

Flo
-- 
Florian Lohoff                  [email-masked]             +49-5201-669912
                        Heisenberg may have been here.

---

From: "Robert Rusek" <[email-masked]>
Date: Mon, 27 May 2002 14:58:15 -0700

I have IRIX binary support turned on in the kernel.  I can copy over my
IRIX libs from my old IRIX partition (I just do not know which ones).  I
don't think I have the dynamic loader?  How would I check to see if I
have it?  If not where would I get it?  Sorry about all these newbie
questions it is just that I need to be able to run the IRIX version of
fronpage server extensions since MS does not provide the open source.

Thanks,
Robert.

      -----Original Message-----
      From: [email-masked] [mailto:[email-masked]] 
      Sent: Monday, May 27, 2002 2:15 PM
      To: Robert Rusek
      Cc: 'Ralf Baechle'; [email-masked]
      Subject: Re: Executing IRIX binary ?

      On Mon, May 27, 2002 at 01:32:43PM -0700, Robert Rusek wrote:
      > Ralf,
      > 
      > Looks like I have the kernal compiled with the IRIX 
      binary support.  
      > How do I go about executing the binaries?  When I try 
      to execute it 
      > tells me that the file is not found.
      
      Are you shure you have the dynamic loader + libc + other 
      libs of IRIX installed in your system ?
      
      Flo
      -- 
      Florian Lohoff                  [email-masked]            
       +49-5201-669912
                              Heisenberg may have been here.

---

From: Ralf Baechle <[email-masked]>
Date: Mon, 27 May 2002 23:46:24 -0700

> that the file is not found.

The file it didn't find is the dynamic linker /usr/lib/libc.so.1.  You
have to install this file and others in special magic places.  Also the
kernel contains broken code to distinguish IRIX and Linux executables
which you'd have to fix first before the code has any chance of working.

  Ralf