Subject: Indy SCSI Errors

From: "Robert Rusek" <[email-masked]>
Date: Wed, 8 May 2002 10:23:18 -0700

I am currently running kernel 2.4.17 and am getting sparatice errors
like the following.  I seen that there had been bugs in the scsi driver
in the earlier kernel versions.  Has anyone encountered this?  Is there
a newer kernal that maybe addresses this?

EXT2-fs error (device sd(8,1)): ext2_check_page: bad entry in directory
#110030: unaligned
 directory entry - offset=0, inode=6226015, rec_len=95, name_len=95

Thank you in advance,
--
Robert Rusek

---

From: Florian Lohoff <[email-masked]>
Date: Thu, 9 May 2002 17:43:27 +0200

>  directory entry - offset=0, inode=6226015, rec_len=95, name_len=95

The SCSI errors we had on the Indy and Indigo2 happened with multiple
disks, disconnects and were pure "read" errors. Filesystem corruption
was quite rare. Mostly we had file data corruption on copy. The bug is
fixed for at least half a year now.

Do you see any other errors than that ? SCSI errors ?

Flo
-- 
Florian Lohoff                  [email-masked]             +49-5201-669912
                        Heisenberg may have been here.

---

From: "Robert Rusek" <[email-masked]>
Date: Thu, 9 May 2002 09:31:01 -0700

I am familiar with the error that you are referring to.  I just fixed it
by upgrading to kernel 2.4.17.  The error that I am describing, should I
just ignore it and just do a fsck on my main drive every month?  I have
three drives sda1, sdb1, and sdc1 and it only seems to happened on the
sda1.  My sda2 is the swap drive, would that be affecting my sda1 ?

Thanks,
Rob.
     -----Original Message-----
     From: [email-masked] 
     [mailto:[email-masked]] On Behalf Of Florian Lohoff
     Sent: Thursday, May 09, 2002 8:43 AM
     To: Robert Rusek
     Cc: [email-masked]
     Subject: Re: Indy SCSI Errors

     On Wed, May 08, 2002 at 10:23:18AM -0700, Robert Rusek wrote:
     > like the following.  I seen that there had been bugs in the scsi 
     > driver in the earlier kernel versions.  Has anyone 
     encountered this?  
     > Is there a newer kernal that maybe addresses this?
     > 
     
     The SCSI errors we had on the Indy and Indigo2 happened 
     with multiple disks, disconnects and were pure "read" 
     errors. Filesystem corruption was quite rare. Mostly we 
     had file data corruption on copy. The bug is fixed for at 
     least half a year now.

     Flo
     -- 
     Florian Lohoff                  [email-masked]             
     +49-5201-669912
                             Heisenberg may have been here.

---

From: Florian Lohoff <[email-masked]>
Date: Fri, 10 May 2002 11:32:32 +0200

> sda1.  My sda2 is the swap drive, would that be affecting my sda1 ?

If its not the error i fixed a couple of months ago i would
suspect bad hardware - Either ram or disk. I wouldnt ignore it.

Flo