Subject: PCI Graphics/Video Card for Malta Board?

From: "Kevin D. Kissell" <[email-masked]>
Date: Mon, 27 May 2002 11:49:57 +0200

I'd like to get a video-capable graphics card up
and running on a MIPS Malta board (therefore
PCI), ideally something mainstream like ATI.
Does anyone on the list have any positive or
negative recommendations in terms of cards
and particularly in terms of the degree to which
the drivers (and PCI set-up) have been ported
to MIPS/Linux?  I'll do what I must, but I hate
re-inventing the wheel.

            Regards,

            Kevin K.

---

From: "Steven J. Hill" <[email-masked]>
Date: Mon, 27 May 2002 08:25:46 -0500

> to MIPS/Linux?  I'll do what I must, but I hate
I can think of two things. First, a lot of graphics cards
rely on BIOS calls to be set up before the operating system
even boots. Second, I would stick to graphics cards that
have framebuffer support in the kernel as you stand at least
half a chance that those cards don't rely so heavily on a
peecee bios. Just my $.02.

-Steve

---

From: Geert Uytterhoeven <[email-masked]>
Date: Mon, 27 May 2002 15:37:27 +0200 (MEST)

> peecee bios. Just my $.02.

Even then, most frame buffer device drivers rely on the firmware (PC BIOS or
SPARC/PPC Open Firmware) having set up the video card.

One of the exceptions is matroxfb, which is able to initialize older Matrox
cards. This should cover all their PCI cards (Matrox didn't release any new PCI
cards during the last few years).

Gr{oetje,eeting}s,

						Geert

--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- [email-masked]

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
							    -- Linus Torvalds

---

From: "Kevin D. Kissell" <[email-masked]>
Date: Mon, 27 May 2002 16:09:14 +0200

> cards during the last few years).

They still sell/support the G450PCI, which has TV output support,
and a flat-panel transmitter, and which might do the job for me.
Can anyone confirm that the matroxfb support works for it?

            Kevin K.

---

From: Geert Uytterhoeven <[email-masked]>
Date: Mon, 27 May 2002 16:14:38 +0200 (MEST)

> and a flat-panel transmitter, and which might do the job for me.

Oh, I didn't know they made PCI cards after the G200 (which was hard to get in
its PCI variant). In fact they responded negatively when we (the PPC guys,
thinking about designing our own PPC motherboards) asked them if they intended
to release other PCI chips after the G200, for platforms that lacked AGP
support.

BTW, the FAQ on Matrox' website says:

|  1. What happens if I use the Millennium G450 PCI in a system with a
|  non-Intel chipset?
|
|     1. The G450 PCI does not support bus-mastering with non-Intel chipsets.
|     While this lowers performance on synthetic benchmarks, it does not hinder
|     the everyday usability of the card. Additionally, the Millennium G450 PCI
|     does not support OpenGL acceleration (primarily used for 3D gaming) or
|     DVDMax with non-Intel chipsets.

> Can anyone confirm that the matroxfb support works for it?

I'm not sure matroxfb support full initialization of the '450. You best ask
Petr Vandrovec.

Gr{oetje,eeting}s,

						Geert

---

From: Jun Sun <[email-masked]>
Date: Tue, 28 May 2002 09:58:19 -0700

Geert Uytterhoeven wrote:

> One of the exceptions is matroxfb, 

Steve Longerbeam has a fb driver with BIOS init for ATI Xpert98 card, which 
you can still buy.  Dan Malek also wrote a driver for MQ200.  If you ask 
around, I am sure you can the patch somewhere.

For a while, I also had 3dfx voodoo3 working.  Not sure about its status now. 
  You can find the patch at http://www.medex.hu/~danthe/tdfx/.

Jun

---

From: "Kevin D. Kissell" <[email-masked]>
Date: Tue, 28 May 2002 19:43:55 +0200

From: "Jun Sun" <[email-masked]>
> you can still buy.

Yeah, but it's a pretty wimpy card (8MB) and has no TV output.
  
> Dan Malek also wrote a driver for MQ200.  

Which is essentially a handheld/webphone graphics chip,
for which the documentation is only available under NDA.
Not terribly useful for me, thanks.

> If you ask  around, I am sure you can the patch somewhere.

I *am* asking around - that's why I started this thread.

>   You can find the patch at http://www.medex.hu/~danthe/tdfx/.

3dfx, in case you hadn't heard, folded some time ago.

So it sounds like the Matrox G450 PCI is really the only
game in town...

            Kevin K.

---

From: Dan Malek <[email-masked]>
Date: Tue, 28 May 2002 18:19:31 -0400

>>Dan Malek also wrote a driver for MQ200.  

I can't really take credit for that :-).  It was a bunch of code
from various places I just turned into a driver.

> I *am* asking around - that's why I started this thread.

Look at some of the stuff from Epson.  You may find something there.

> So it sounds like the Matrox G450 PCI is really the only

It very well may be the only option.  I've been working with
"standard" graphic cards/chips for embedded devices for quite
some time.  The latest technology is always quite secret, seldom
even available under NDA.  Most of the cards I have used come
from the $5 cardboard box in one of the electronic salvage yards in
Silicon Valley.  Something so old they will tell you about the
registers on the board :-)

	-- Dan

---

From: Alan Cox <[email-masked]>
Date: 29 May 2002 00:54:27 +0100

Old S3 cards are very easy to configure. 3Dfx Voodoo 2 is great as we
have full code to configure it -and- it can do 3D. Alas no utah-glx
support so you can't do X with 3d on it right now.

---

From: Geert Uytterhoeven <[email-masked]>
Date: Wed, 29 May 2002 10:17:48 +0200 (MEST)

> Old S3 cards are very easy to configure. 3Dfx Voodoo 2 is great as we

<sarcastic>
I guess that's why we still don't have working frame buffer devices for them?
There are at least 3 frame buffer devices for the Trio floating around the net,
but none of them work on my cards.
</sarcastic>

Of course I'm part of the problem myself, since I never got anything out of the
Vision968 and Trio64V+ in my PPC box. Except by emulating the BIOS code and
using vga16fb...

Gr{oetje,eeting}s,

						Geert

---

From: Alan Cox <[email-masked]>
Date: 29 May 2002 13:49:58 +0100

> Vision968 and Trio64V+ in my PPC box. Except by emulating the BIOS code and

I've had no problem with Russell King's ARM code. And for the 3dfx
voodoo2 (UKP 9 off ebay) none at all. The voodoo seems to have always
been designed to be totally soft configured and as its not a primary
video card the bios/firmware all leaves it alone

---

From: James Simmons <[email-masked]>
Date: Fri, 31 May 2002 13:19:39 -0700 (PDT)

> Not terribly useful for me, thanks.

I have docs on this chipset. I forgot where I got them. I plan to work on
a driver for that chipset since I have a board with it on it.

---

From: James Simmons <[email-masked]>
Date: Fri, 31 May 2002 13:24:08 -0700 (PDT)

> but none of them work on my cards.

I have started a operation to find all the MIA framebuffer drivers that
have been posted. I really like to track those S3 drivers down.

---

From: James Simmons <[email-masked]>
Date: Fri, 31 May 2002 13:25:55 -0700 (PDT)

> I've had no problem with Russell King's ARM code.

The problem with older S3 cards is that they have so many different
RAMDACS and often 3rd party PLLs.

> And for the 3dfx

Yeap!! I was reading in the docs how to get voodoo cards to be multihead
freindly :-)