Subject: zsh on console

From: Kjeld Borch Egevang <[email-masked]>
Date: Mon, 6 May 2002 14:44:33 +0200 (CEST)

When I run zsh on the console (serial interface) the process hangs. I can 
login with /bin/bash, but when I start /bin/zsh it waits forever. I can 
interrupt the process and regain control.

It's only related to the console. If I login with telnet it works just 
fine.

Any idea, what could be wrong?

/Kjeld

-- 
_    _ ____  ___                       Mailto:[email-masked]
|\  /|||___)(___    MIPS Denmark       Direct: +45 44 86 55 85
| \/ |||    ____)   Lautrupvang 4 B    Switch: +45 44 86 55 55
  TECHNOLOGIES      DK-2750 Ballerup   Fax...: +45 44 86 55 56
                    Denmark            http://www.mips.com/

---

From: "Kevin D. Kissell" <[email-masked]>
Date: Mon, 6 May 2002 14:57:28 +0200

> Any idea, what could be wrong?

I don't know what it would be specifically, but having
dealt with similar problems on other Unix systems,
it's proably the case that zsh uses a particular tty
mode that isn't correctly supported by the serial
console driver, either due to a bug in the driver or
due to a conflict with some other feature enabled
on the console port.  The next step to take would
be to run "stty -all" under /bin/bash and under
/bin/zsh on a telnet session, and compare the 
outputs.

---

From: "H . J . Lu" <[email-masked]>
Date: Mon, 6 May 2002 12:16:06 -0700

> /bin/zsh on a telnet session, and compare the 

That sounds like a zsh bug I fixed. Please try zsh 3.0.8-8.1 in my RedHat 7.1
port and let me know if it doesn't work for you.

H.J.

---

From: Hartvig Ekner <[email-masked]>
Date: Tue, 7 May 2002 00:06:42 +0200 (CEST)

> port and let me know if it doesn't work for you.

You only have the source RPM on OSS?
I believe we compiled from another SRC RPM: zsh-4.0.4-5.src.rpm. 

What was your fix? 

/Hartvig

---

From: "H . J . Lu" <[email-masked]>
Date: Mon, 6 May 2002 16:06:51 -0700

> You only have the source RPM on OSS?

I didn't add cross compile support for zsh. You have to compile it natively.

> I believe we compiled from another SRC RPM: zsh-4.0.4-5.src.rpm. 

zsh-4.0.4-5 will be in my RedHat 7.3 port.

> What was your fix? 

zsh-3.0.8-open.patch is in baseline.tar.bz2.

H.J.

---

From: Ralf Baechle <[email-masked]>
Date: Mon, 6 May 2002 19:53:41 +0800

> Any idea, what could be wrong?

I recently fixed a simliar bug in the sb1250_duart.c driver.  Basically
a hangup of the tty did result in the close routine getting called thus
the driver's usage counter for ttyS0 eventually dropping to zero though
it was still open ...

  Ralf