Subject: Debian on Indy.

From: James Simmons <[email-masked]>
Date: Thu, 9 May 2002 09:40:11 -0700 (PDT)

I just recently attempted to install debian on a new indy I just got. I
entered the prom boot console and typed bootp()/tftpboot/tfptboot.img. It
failed. What steps am I missing?

   . ---
   |o_o |
   |:_/ |   Give Micro$oft the Bird!!!!
  //   \ \  Use Linux!!!!
 (|     | )
 /'_   _/`\
 ___)=(___/

---

From: Karsten Merker <[email-masked]>
Date: Thu, 9 May 2002 19:19:45 +0200

> failed. What steps am I missing?

Without more information on how it failed that is difficult to tell.
Any logfile entries on the bootp/tftp server?
Have you looked at http://www.linux-mips.org/technical_faq.html?
There you can find a list of possible problems when netbooting an Indy.

HTH,
Karsten
-- 
#include <standard_disclaimer>
Nach Paragraph 28 Abs. 3 Bundesdatenschutzgesetz widerspreche ich der Nutzung
oder Uebermittlung meiner Daten fuer Werbezwecke oder fuer die Markt- oder
Meinungsforschung.

---

From: Tim Moss <[email-masked]>
Date: Thu, 9 May 2002 10:28:05 -0700

> There you can find a list of possible problems when netbooting an Indy.
http://ftp.debian.org/debian/dists/woody/main/disks-mips/current/doc/ch-install-methods.en.html#s-install-tftp

In particular, make sure to set the two /proc settings on the tftp
server:
     echo 1 > /proc/sys/net/ipv4/ip_no_pmtu_disc
     echo "2048 32767" > /proc/sys/net/ipv4/ip_local_port_range

---

From: James Simmons <[email-masked]>
Date: Thu, 9 May 2002 11:03:21 -0700 (PDT)

>      echo "2048 32767" > /proc/sys/net/ipv4/ip_local_port_ran

Okay. Got it to boot. Now it fails with a bunch of SCSI errors. After it
complained it hanged. Any ideas or do you need th exact SCSI errors?

---

From: "nsauzede" <[email-masked]>
Date: Sun, 12 May 2002 01:08:13 +0200

> complained it hanged. Any ideas or do you need th exact SCSI errors?

Just for info : I managed to have the Debian Woody to work fine on my Indy
(kernel is 2.4.13 if I remember well...)

But when I tried to boot some kernel 2.5.?? (can't remember last number -- I
fetched the source from CVS) I cross compiled on an i386 platform, I got the
same problem : bootup crashes at SCSI probing time...

Must be some kind of SCSI code regression or something..

I think I already posted my problem to the list but didn't get reply....

Nicolas Sauzede.

---

From: Florian Lohoff <[email-masked]>
Date: Sun, 12 May 2002 15:35:15 +0200

> I think I already posted my problem to the list but didn't get reply....

The problem is the major block device change in 2.5 - It is still not
finished and needs more work in the individual drivers (IIRC the
driver itself has to do some error handling).

So the crash points to work to be done in the driver.

Flo
-- 
Florian Lohoff                  [email-masked]             +49-5201-669912
                        Heisenberg may have been here.