Subject: Heap test

From: "Siders, Keith" <[email-masked]>
Date: Wed, 14 Aug 2002 08:21:15 -0500

Does the kernel have a heap memory test? I could use one.

Keith

---

From: Alan Cox <[email-masked]>
Date: 14 Aug 2002 14:34:43 +0100

> Does the kernel have a heap memory test? I could use one.

It does some sanity checking as it goes, but its very hard to do this in
a kernel. Virtually allocated spaces have guard pages. Physically
allocated space does not, but we do support slab poisoning to spot
scribbles in freed memory and failure to do initializations