Subject: framebuffer + ethernet

From: "Simone Caronni" <[email-masked]>
Date: Tue, 13 Aug 2002 11:41:37 +0200

Hello, I have an O2 R5000 I would like to try Linux on. Can someone please
tell me the status and usability of the O2 fb and internal ethernet?

Many thanks

Simone

---

From: Vivien Chappelier <[email-masked]>
Date: Tue, 13 Aug 2002 13:29:32 +0200 (CEST)

On Tue, 13 Aug 2002, Simone Caronni wrote:

> Hello, I have an O2 R5000 I would like to try Linux on. 

Linux on the SGI O2 R5000 is still *very experimental*. You'll need
a 2.5 kernel from the CVS at oss.sgi.com and the patches available there:
http://www.linux-mips.org/~glaurung/

2.5.5 is work in progress, you might have higher chances with 2.5.4.

There are also compiled kernels available if you want to try.

> Can someone please tell me the status and usability of the O2 fb and
> internal ethernet?

The O2 ethernet is working for simple operations, but has a bug when
transmitting a lot of data from the O2. However I've a fix for that I'll
make available in the next few days (needs cleanup).
The framebuffer is also working approximatively, with two known
bugs: the display sometimes (randomly) appears as 'wrapped around' and the
colormap is not working properly in 8 bit mode. I've also tried Xfree86
on framebuffer which displays wrong colors (an X bug this time), but works
well apart from that.
Overall, the O2 is starting to work, but is not stable at all... rather a
hacker's toy currently :)

regards,
Vivien Chappelier.

---

From: "Simone Caronni" <[email-masked]>
Date: Tue, 13 Aug 2002 14:34:37 +0200

Many thanks, I will definitely give it a try.

Simone

-----Original Message-----
From: Vivien Chappelier [mailto:[email-masked]]
Sent: martedi 13 agosto 2002 13.30
To: Simone Caronni
Cc: [email-masked]
Subject: Re: framebuffer + ethernet

regards,
Vivien Chappelier.