Subject: ip22 build fix

From: Guido Guenther <[email-masked]>
Date: Fri, 9 Aug 2002 14:47:45 +0200

Hi, 
I need the attached patch against arch/mips/arc/Makefile to
get current CVS (linux_2_4) to build on IP22. Otherwise prom_meminit
is undefined. Please apply.

Index: arch/mips/arc/Makefile
===================================================================
RCS file: /cvs/linux/arch/mips/arc/Makefile,v
retrieving revision 1.5.2.1
diff -u -u -r1.5.2.1 Makefile
--- arch/mips/arc/Makefile	2002/08/01 22:26:40	1.5.2.1
+++ arch/mips/arc/Makefile	2002/08/09 12:44:57
@@ -4,7 +4,7 @@
 
 L_TARGET = arclib.a
 
-obj-y				+= cmdline.o console.o env.o file.o \
+obj-y				+= cmdline.o console.o env.o file.o memory.o \
 				   identify.o init.o misc.o time.o tree.o
 
 obj-$(CONFIG_ARC_MEMORY)	+= memory.o

Regards,
 -- Guido

---

From: "Maciej W. Rozycki" <[email-masked]>
Date: Fri, 9 Aug 2002 15:14:07 +0200 (MET DST)

> is undefined. Please apply.
[...]
>  obj-$(CONFIG_ARC_MEMORY)	+= memory.o

 Well, $(CONFIG_ARC_MEMORY) equals to "y" for IP22, so please check you
haven't got your configuration messed up.

-- 
+  Maciej W. Rozycki, Technical University of Gdansk, Poland   +
+--------------------------------------------------------------+
+        e-mail: [email-masked], PGP key available        +

---

From: Guido Guenther <[email-masked]>
Date: Fri, 9 Aug 2002 15:43:25 +0200

> haven't got your configuration messed up.
Hmmm...another "make oldconfig" fixed it and defines
CONFIG_ARC_MEMORY=y while the first one didn't - weird. Forget about the
patch then.
Judging from the notes in memory.c maybe the option should correctly be
called CONFIG_ARCS_MEMORY instead or will any subarch using ARC ever use
it?
Thanks,
 -- Guido