Subject: [PATCH 2.4] load average fix for lasat boards (timer interrupt handling fix)

From: Brian Murphy <[email-masked]>
Date: Sun, 17 Nov 2002 22:41:13 +0100

Hi Florian, Ralf,
	it seems the method of calling the new time code changed
or it was wrong all along, This patch fixes the problem of the
ksoftirqd running all the time on Lasat systems, can you apply
Ralf?

/Brian
	
Index: arch/mips/lasat/setup.c
===================================================================
RCS file: /cvs/linux/arch/mips/lasat/setup.c,v
retrieving revision 1.1.2.5
diff -u -r1.1.2.5 setup.c
--- arch/mips/lasat/setup.c	6 Oct 2002 11:38:14 -0000	1.1.2.5
+++ arch/mips/lasat/setup.c	17 Nov 2002 21:31:42 -0000
@@ -109,14 +109,10 @@
 	change_cp0_status(ST0_IM, IE_IRQ0 | IE_IRQ5);
 }
 
+#define MIPS_CPU_TIMER_IRQ 7
 asmlinkage void lasat_timer_interrupt(struct pt_regs *regs)
 {
-	int cpu = smp_processor_id();
-
-	timer_interrupt(7, NULL, regs);
-
-	if (softirq_pending(cpu))
-		do_softirq();
+	ll_timer_interrupt(MIPS_CPU_TIMER_IRQ, regs);
 }
 
 void __init lasat_setup(void)

---

From: Florian Lohoff <[email-masked]>
Date: Mon, 18 Nov 2002 20:27:20 +0100

> ksoftirqd running all the time on Lasat systems, can you apply

Works like a charm - Ralf already applied and i am running the CVS
from an hour after that happily ...

Flo
-- 
Florian Lohoff                  [email-masked]             +49-5201-669912
                        Heisenberg may have been here.