Subject: RE: Problem about porting mips kernel

From: "" <[email-masked]>
Date: Tue, 26 Nov 2002 02:22:02 +0000

Yes. I have disabled the cache once on menuconfig. But still same 
problem.

>From: "jeff" <[email-masked]>
>To: <[email-masked]>, <[email-masked]>
>CC: <[email-masked]>
>Subject: RE: Problem about porting mips kernel
>Date: Tue, 26 Nov 2002 10:23:05 +0800
>
>Hi, can you turn off the cache on menuconfig and try again?
>
>Regards,
>
>Jeff
>
>-----Original Message-----
>From: [email-masked] 
[mailto:[email-masked]]On Behalf Of 
[email-masked]
>Sent: Tuesday, November 26, 2002 10:06 AM
>To: [email-masked]
>Cc: [email-masked]
>Subject: Re: Problem about porting mips kernel
>
>
>I think that kernel had been configured properly, because I can open the
>ttyS0 device in ramdisk. It means no ramdisk problem. But I have not any
>experience to fix tlb or cache bug. If you can give some more advice? Thx.
>
>
>
>
> >From: Ralf Baechle <[email-masked]>
> >To: [email-masked]
> >CC: [email-masked]
> >Subject: Re: Problem about porting mips kernel
> >Date: Mon, 25 Nov 2002 13:53:10 +0100
> >
> >On Mon, Nov 25, 2002 at 12:47:28PM +0000, [email-masked] wrote:
> >
> > >   these days, I am busy with porting mips kernel to a board with 
vr4131
> > > core. This board has only SIU serial port, and some hw have been
>modified.
> > > Now, I have ported the kernel to it, and modified hw run well. But so
> > > puzzling me, the execution file cann't run at all. If some one can 
help
>me
> > > or give some advices. I have been crazy for the problem. Off hat for
>your
> > > help. Thanks a lot.
> > >  btw, I use the ramdisk with busybox.
> >
> >In general this kind of problem means the tlb or cache code for a
>particular
> >platform is faulty or the kernel not configured properly.
> >
> >   Ralf
>
>
>_________________________________________________________________
>免费下载 MSN Explorer:  http://explorer.msn.com/lccn/

_________________________________________________________________
与联机的朋友进行交流，请使用 MSN Messenger: http://messenger.msn.com/lccn/

---

From: "" <[email-masked]>
Date: Thu, 28 Nov 2002 02:42:22 +0000

I carefully check the codes of TLB, but no any problem found.
 And I debug my kernel, I found that before init task jump into 
application, it means after do_execve, sp is 0. it is for 
__strnlen_user_asm function return invalid result. And I done a little 
change(only for test), the system stop after ret_from_syscall. In normal, 
it should jump to user space to execute user task.
before ret_from_syscall, the start_thread arguments 
is:"elf_entry:0x2aaa8a00,user_sp is:0x7fff7f40,cp0_status is:0x200cc13".I 
determine that the arguments are correct. But why my application cann't run 
at all?
> >   these days, I am busy with porting mips kernel to a board with vr4131
modified.
> > puzzling me, the execution file cann't run at all. If some one can help 
me
your
particular

_________________________________________________________________
与联机的朋友进行交流，请使用 MSN Messenger: http://messenger.msn.com/cn