Subject: malta-5kc

From: amit lubovsky <[email-masked]>
Date: Tue, 14 Jan 2003 05:28:24 -0800 (PST)

Hi,
I try to load a linux image to a malta-5kc board with
a hw debugger.

Before I load the image I load YAMON in order to
initialize the board.

This doesn't work and I have understood that I have to
set up some of the cpu registers to certain values
(like for command line parameters, etc.)

Could anyone help me with that?, which registers and
to what values?

Thanks,
Amit.

__________________________________________________
Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now.
http://mailplus.yahoo.com

---

From: "Mike Connors" <[email-masked]>
Date: Tue, 14 Jan 2003 09:15:30 -0800

The easiest thing to do is have YAMON load the image, 
connect with your debugger and set a breakpoint at 
some starting point of the linux kernel, then enter 
the go command with the program arguments on the 
YAMON command line.  

The rest is debugger specific.  If you are using Green 
Hills Software's MULTI debugger, I can help you with 
the details.  If you are using MULTI and you give me a 
little time to figure it out, I could even give you a 
way to do it without YAMON. 

-- Mike 
--- 
Mike Connors			Green Hills Software, San Clemente 
Field Applications Engineer	131 Avenida Victoria 
mailto:[email-masked]		San Clemente, CA  92672 
phone: 1-949-369-3950		
cell:  1-949-412-3951		fax: 1-949-369-3959 

Green Hills in the News: 

INTEGRITYR RTOS Flies In F-16 Fighter Jet 
	http://www.ghs.com/news/221213b.html 
Boeing Selects INTEGRITYR RTOS for B-1B Avionics Upgrade 
	http://www.ghs.com/news/221213b.html 
INTEGRITYR RTOS selected by Boeing's C-17 Globemaster III 
	http://www.ghs.com/news/221104b.html 

Green Hills Software Inc.	phone: 	1-805-965-6044 
30 West Sola Street		toll-free: 1-800-765-GREEN (4733) 
Santa Barbara, CA 93101		Tech-Support: 1-877-GHS-TECH (447-8324) 
http://www.ghs.com		Email Support: mailto:[email-masked] 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of amit lubovsky
> Sent: Tuesday, January 14, 2003 5:28 AM
> To: mips-linux
> Subject: malta-5kc
> 
> 
> Hi,