Subject: Anyone running crashme?

From: Greg Lindahl <[email-masked]>
Date: Thu, 16 Jan 2003 17:26:44 -0800

I've been running crashme a little against Linux mips, and from the
bugs I immediately found I suspect that no one's been running it.
Crashme generates random bytes and then executes them, catching the
resulting signals and generating more random bytes. The random number
seed is provided by the user, so that problems are repeatable.

If you like debugging, you can find the source at:

http://people.delphiforums.com/gjc/crashme.html

-- greg

---

From: "Kevin D. Kissell" <[email-masked]>
Date: Fri, 17 Jan 2003 08:41:43 +0100

Actiually, we've been using crashme at MIPS
for several years now, both to torture the Linux 
kernel and to push our chip designs into unexpected 
corner cases.  We found a fair number of kernel
bugs, and fixed them in our internal sources
(snapshots are generally available under
ftp://ftp.mips.com/pub/linux/mips/kernel )
and have pushed our fixes out toward the
mainline distributions.  That's not to say that
they all get there.

Two things to watch out for: There is a class
of crashme misbehavior, usually manifest in
forked threads that do not terminate correctly
until the program is shut down, that arises not
from a kernel bug, but from a libc built with
downrev kernel headers.  And if you have a
CPU that supports EJTAG, you either need to
make sure that your boot ROM has code at the
EJTAG debug exception vector that jumps to the
EJTAG kseg0 pseudo-vector used by the Linux
kernel (well, *our* Linux kernel anyway ;-), 
or you need to put a filter in crashme to ensure 
that it does not generate EJTAG debug breakpoint 
instructions.

But I'm glad to see that someone else is using it.

---

From: Jun Sun <[email-masked]>
Date: Mon, 20 Jan 2003 11:44:05 -0800

I have crashme running on several boards here.  The only problem
found is that kernel does not check for MDMX exception
for newer CPUs, which is already fixed in the tree.

Jun