Subject: How to get the c source code in disassembly?

From: Long Li <[email-masked]>
Date: Thu, 30 Jan 2003 14:45:43 -0800 (PST)

Hi, 

I am having a problem with intermixing the C source
code in the disassembly. I am using a MIPS
crosscompiler on Redhat 7.1, gcc-3.0.4,
binutils-2.11.2. When I compiled the C code, I added
the -g option, and then use 'objdump -Sd' to get the
disassembly. However, I did not see any C code mixed
with the assembly, as said in the objdump manual when
using -S option. Could you give me some help or
suggestions? 

Thanks a lot!

Long

__________________________________________________
Do you Yahoo!?
Yahoo! Mail Plus - Powerful. Affordable. Sign up now.
http://mailplus.yahoo.com

---

From: Keith Owens <[email-masked]>
Date: Fri, 31 Jan 2003 11:27:34 +1100

On Thu, 30 Jan 2003 14:45:43 -0800 (PST), 
>using -S option. Could you give me some help or

objdump -S only works when the code is compiled with -g.  And sometimes
not even then, objdump -S is flaky for ia64, although that could be the
old gcc/binutils I have to use :(.