Subject: when does do_fpe() get called? (or when does FPE happen?)

From: Jun Sun <[email-masked]>
Date: Mon, 27 Jan 2003 19:04:23 -0800

Can someone enlighten me a little?  I am trying
to figure out what the FPU state should be (or can be) when
we are inside do_fpe() routine.

Jun

---

From: Ralf Baechle <[email-masked]>
Date: Tue, 28 Jan 2003 04:37:44 +0100

> we are inside do_fpe() routine.

Checkout the various flags in $fcr31.  Whenever one of the enabled
exceptions is triggered we get to handle_fpe via do_fpe.  In addition
the unimplemented exception can also result in invocation of do_fpe.

  Ralf

---

From: Jun Sun <[email-masked]>
Date: Tue, 28 Jan 2003 09:37:42 -0800

> the unimplemented exception can also result in invocation of do_fpe.

So it seems safe to assume FPU should have been enabled when we get
here, right?

Jun

---

From: Ralf Baechle <[email-masked]>
Date: Tue, 28 Jan 2003 18:45:29 +0100

> So it seems safe to assume FPU should have been enabled when we get

Yes, otherwise we'd get a coprocessur unusable exception.

  Ralf