Subject: Linux kernel for MIPS architecture

From: "santosh kumar gowda" <[email-masked]>
Date: 21 Jan 2003 04:30:50 -0000

Hi,
I want to compile the entire Linux Kernel 2.4.20
for MIPS architecture.
I have mipsel-linux-gcc cross compiler.
Is this cross compiler enough or i need something else..??
Can any one suggest me from where to start with...??
What changes to be made in the Makefile..???

-San

---

From: "Krishnakumar. R" <[email-masked]>
Date: Tue, 21 Jan 2003 12:28:47 +0530

Hi,

Change the following in the top level makefile

CROSS_COMPILE=mipsel-linux-
ARCH=mips

And change the link 
include/asm
of the top directory to point to
the asm-mips there.

Then try configuring and compiling the kernel
as usual.

Hope this helps
Regards
KK

---

From: Geert Uytterhoeven <[email-masked]>
Date: Tue, 21 Jan 2003 11:45:17 +0100 (MET)

> CROSS_COMPILE=mipsel-linux-

Or always say `make CROSS_COMPILE=mipsel-linux- ARCH=mips' instead of `make'.

> of the top directory to point to

Changing the link is not necessay. `make config' will do that for you.

> > I want to compile the entire Linux Kernel 2.4.20

And most probably you'll want to use the kernel source tree from Linux/MIPS
CVS, not the one on ftp.kernel.org.

Gr{oetje,eeting}s,

						Geert

--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- [email-masked]

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
							    -- Linus Torvalds