Subject: handling of s-record images by bootloader

From: "atul srivastava" <[email-masked]>
Date: 10 Jan 2003 10:17:15 -0000

Hello .

A quick question..

I have developed a primitive bootloader for custom board, that is 
successfuly doing the board bringup and loads linux os image
currently through serial link (kermit) only.
network link is also likely to be up soon.

but through serial it loads  kernel image only in raw binary 
format.
now i want to extend this for s-record images as well..

I am umware that, how differently s-record image need to be 
handled..?
i just need some idea or if possible any example code for that..

Best Reagards,
Atul

---

From: "Jon Burgess" <[email-masked]>
Date: Fri, 10 Jan 2003 10:21:42 +0000

> I am umware that, how differently s-record image need
> to be handled..?

Have you tried looking at binutils? objcopy can convert Binary<->S-Record

     Jon

---

From: "Jon Burgess" <[email-masked]>
Date: Fri, 10 Jan 2003 12:33:13 +0000

> i just need some idea or if possible any example code for that..

On second thoughts the binutils code is probably rather large. You could try the
pmon source

http://www.carmel.com/pmon/pmon.tgz

pmon/tools/rdsrec.c might do what you want.

     Jon

---

From: "Zajerko-McKee, Nick" <[email-masked]>
Date: Fri, 10 Jan 2003 10:22:15 -0500

I had a simular problem.  I ended up writing my own code for my
platform.  Here is a description of s-records:

http://www.amelek.gda.pl/avr/uisp/srecord.htm

-----Original Message-----
From: atul srivastava [mailto:[email-masked]]
Sent: Friday, January 10, 2003 5:17 AM
To: [email-masked]
Subject: handling of s-record images by bootloader

Hello .

A quick question..

Best Reagards,
Atul