Subject: System Call in MIPS

From: chamak man <[email-masked]>
Date: Thu, 2 Jan 2003 03:57:04 +0000 (GMT)

Hi,

   I am finding problems in adding a new system call
for MIPS kernel.  Where can i get information on it. 

with regards,
sumanth.g

________________________________________________________________________
Missed your favourite TV serial last night? Try the new, Yahoo! TV.
       visit http://in.tv.yahoo.com

---

From: Ralf Baechle <[email-masked]>
Date: Thu, 2 Jan 2003 12:05:28 +0100

> for MIPS kernel.  Where can i get information on it. 

See include include/asm-mips/unistd.h and arch/mips/kernel/scall_o32.S.

In general adding new syscalls is considered a bad idea you may want to
look into using ioctl, sysctl(2) or procfs.

  Ralf