Subject: insmod failure: "Unhandled relocation" errors

From: "Gilad Benjamini" <[email-masked]>
Date: Tue, 14 Jan 2003 12:06:46 +0200

Hi,
I've built,compiled and ran successfully a 64 bit kernel on my 
mips64 platform. Kernel was compiled with support for 32 bit binaries.

I am now trying to insert a module, a standard module from
the kernel tree, and get lots of errors such as:
"Unhandled relocation of type 18 for"
or
"Unhandled relocation of type 18 for <function_name>"

How can this be resolved ?

TIA

---

From: Ralf Baechle <[email-masked]>
Date: Tue, 14 Jan 2003 18:05:52 +0100

> How can this be resolved ?

Modules are not supported on 64-bit kernel yet.

  Ralf

---

From: Greg Lindahl <[email-masked]>
Date: Tue, 14 Jan 2003 11:14:18 -0800

> "Unhandled relocation of type 18 for <function_name>"

I'm impressed that it got this far -- let me guess, big endian?
Little endian didn't even get that far last time I tried it.

greg

---

From: Keith Owens <[email-masked]>
Date: Wed, 15 Jan 2003 10:34:33 +1100

On Tue, 14 Jan 2003 12:06:46 +0200, 
>"Unhandled relocation of type 18 for"

Type 18 is R_MIPS_64.  modutils does not support 64 bit mips
at all, nobody has sent me any code to handle this architecture.

modutils needs obj/obj_mips64.c.  The config and makefiles have to be
tweaked to handle mips64, including combined 32/64 bit code, as for
sparc32/sparc64.  Does anybody who knows mips64 feel like contributing
the modutils code?

---

From: Ralf Baechle <[email-masked]>
Date: Wed, 15 Jan 2003 13:15:50 +0100

> Little endian didn't even get that far last time I tried it.

The modules we also built with the wrong options which is the cause for
these specific error messages.  There was just no point mentioning these
because the actual showstopper was a 32-bit vs. 64-bit problem.

  Ralf

---

From: Ralf Baechle <[email-masked]>
Date: Wed, 15 Jan 2003 13:24:47 +0100

> sparc32/sparc64.  Does anybody who knows mips64 feel like contributing

Until recently the big problem with implementing modules support for mips64
was the complete unusability of binutils.  Compared to the complexity of
getting binutils to work what it takes to get modutils to work is plain
trivial ...

  Ralf