Subject: [OT] cross-compiler problem

From: "Indukumar Ilangovan" <[email-masked]>
Date: Thu, 9 Jan 2003 20:48:18 +0530

Hi All,

I tried to build cross compiler on Red Hat Linux
Kernel 2.4.2-2 on an i686.
I use binutils-2.13, gcc-3.2, glibc-2.2.5, glibc-2.2.5-mips-build-gmon.diff,
glibc-linuxthreads.tar.gz.
I followed the instructions from
http://www.ltc.com/~brad/mips/mipsel-linux-cross-toolchain-building.txt

I installed binutils  without any problems.

While compiling glibc2.2.5 I get the following error.

../sysdeps/unix/syscall.S: Assembler messages:
../sysdeps/unix/syscall.S:28: Error: absolute expression required `li'
make[2]: *** [/home/iilangov/crossGCC/mips/mips-glibc/misc/syscall.o] Error
1
make[2]: Leaving directory `/home/iilangov/crossGCC/mips/glibc-2.2.5/misc'
make[1]: *** [misc/subdir_lib] Error 2
make[1]: Leaving directory `/home/iilangov/crossGCC/mips/glibc-2.2.5'
make: *** [all] Error 2

I have "asm/unistd.h" in the include path, still this problem is happening.
Do you guys have any clue ?

Thanks in Advance !
Indu

----- Original Message -----
From: "Alexandre Oliva" <[email-masked]>
To: "Khantharat Anekboon" <[email-masked]>
Cc: <[email-masked]>
Sent: Saturday, December 28, 2002 12:22 PM
Subject: Re: cross-compiler problem

| On Dec 28, 2002, "Khantharat Anekboon" <[email-masked]> wrote:
|
| > ../sysdeps/unix/syscall.S:28: Error: absolute expression required 'li'
|
| Looks like you're missing the kernel headers where the syscall numbers
| are defined.  (.../include/asm/unistd.h)
|
| --
| Alexandre Oliva   Enjoy Guarana', see http://www.ic.unicamp.br/~oliva/
| Red Hat GCC Developer                 aoliva@{redhat.com, gcc.gnu.org}
| CS PhD student at IC-Unicamp        oliva@{lsd.ic.unicamp.br, gnu.org}
| Free Software Evangelist                Professional serial bug killer
|
| ------
| Want more information?  See the CrossGCC FAQ,
http://www.objsw.com/CrossGCC/
| Want to unsubscribe? Send a note to
[email-masked]

********************************************************
Indukumar Ilangovan
HCL-Cisco Offshore development center,
49-50, Nelson Manickam Road, Chennai - 600029 ,  India .
TEL:  +91-44-2374 1939 x 2215 FAX: +91-44-3741038
Email :[email-masked]

---

From: "Krishnakumar. R" <[email-masked]>
Date: Thu, 9 Jan 2003 21:01:12 +0530

Hi,

Have you changed the /usr/src/linux/include/asm 
link to point to the asm-mips.
IMHO you should do it.

Hope it helps
Regards
KK

On Thursday 09 January 2003 08:48 pm, you wrote:
> I use binutils-2.13, gcc-3.2, glibc-2.2.5,
> glibc-2.2.5-mips-build-gmon.diff, glibc-linuxthreads.tar.gz.