Subject: Re: linux_2_4 on RM7000

From: "Guo Michael" <[email-masked]>
Date: Sun, 04 May 2003 22:01:16 +0800

I've found the problem, I should define CONFIG_BOARD_SCACHE and 
CONFIG_RM7000_CPU_SCACHE first, right? But it still said scache_way_size is 
undefined in sc-rm7k.c and the printk on line 143 in rm7k_sc_probe need a 
little fix. After I fixed these it works.

Thanks.

>From: Ralf Baechle <[email-masked]>
>To: Guo Michael <[email-masked]>
>CC: [email-masked]
>Subject: Re: linux_2_4 on RM7000
>Date: Sun, 4 May 2003 15:16:22 +0200
>
>On Sun, May 04, 2003 at 11:15:40AM +0800, Guo Michael wrote:
>
> >      I've been using the kernel from linux-mips.org on my board with 
RM7000
> > CPU for several month with no problem. I checked out a new copy from
> > linux-mips.org recently and found the cache code had been rewritten all
> > over the place, and the new file sc-rm7k.c cannot even compile. After a
> > quick check on that file according to the error messages it seems that
> > nobody has even tried to compile this file.
> >
> > My question is: does the new cache code work with rm7k cpu now? or in 
the
> > future?  anybody tried that on rm7k with success?
>
>Somehow you're the only one to complain.  Details?
>
>   Ralf
>

_________________________________________________________________
免费下载 MSN Explorer:   http://explorer.msn.com/lccn

---

From: Ralf Baechle <[email-masked]>
Date: Sun, 4 May 2003 16:31:19 +0200

> little fix. After I fixed these it works.

Oh - seems like I fixed that little problem without noticing in this
source tree.  Actually I tried to fix some R10000 silliness :-)

  Ralf