Subject: Re: Linux for MIPS Atlas 4Kc board -problems :(

From: "Michael Anburaj" <[email-masked]>
Date: Thu, 01 May 2003 20:25:20 -0700

Hi,

I gave up on the linux source from Redhat 9. Now I pulled source from CVS
$ cvs -d :pserver:[email-masked]:/home/cvs co linux

Then I configured using,
$ make ARCH=mips menuconfig

selected Atlas board & saved it.

Then I get the following errors while trying to build the image:

[root@localhost linux]# make
make -f scripts/Makefile.build obj=arch/mips/kernel 
arch/mips/kernel/offset.s
  gcc -Wp,-MD,arch/mips/kernel/.offset.s.d -D__KERNEL__ -Iinclude -Wall 
-Wstrict-prototypes -Wno-trigraphs -O2 -fomit-frame-pointer 
-fno-strict-aliasing -fno-common -I /usr/src/linux/include/asm/gcc -G 0 
-mno-abicalls -fno-pic -pipe -mcpu=r4600 -mips2 -Wa,--trap -nostdinc 
-iwithprefix include    -DKBUILD_BASENAME=offset   -S -o 
arch/mips/kernel/offset.s arch/mips/kernel/offset.c
gcc: cannot specify -o with -c or -S and multiple compilations
make[1]: *** [arch/mips/kernel/offset.s] Error 1
make: *** [arch/mips/kernel/offset.s] Error 2

Please somebody, who built linux image for Atlas 4Kc board earlier, show me 
the procedure to build Redboot linux images (srec).

will this dream come true? I am new to linux & I could only affored a Atlas 
board for myself to learn linux on MIPS at home.

Please help me!!!

Thanks,
-Mike.

>From: "Michael Anburaj" <[email-masked]>
>To: [email-masked]
>Subject: Re: Linux for MIPS Atlas 4Kc board
>Date: Thu, 01 May 2003 01:53:21 -0700
>
>Hi,
>
>I got passed the config issue, Thanks to all & Greg.
>
>Now when I try making "make ARCH=mips", I get a lot of errors:
>
>/usr/src/linux-2.4.20-6/include/linux/mm.h:188: parse error before 
>`pte_addr_t'
>/usr/src/linux-2.4.20-6/include/linux/mm.h:188: warning: no semicolon at 
>end of
>struct or union
>/usr/src/linux-2.4.20-6/include/linux/mm.h:188: warning: no semicolon at 
>end of
>struct or union
>/usr/src/linux-2.4.20-6/include/linux/mm.h:189: warning: type defaults to 
>`int'
>in declaration of `pte'
>/usr/src/linux-2.4.20-6/include/linux/mm.h:189: warning: data definition 
>has no
>type or storage class
>/usr/src/linux-2.4.20-6/include/linux/mm.h:208: parse error before `}'
>
>
>I get more error like the ones above.
>
>Please let me know the reason for the same.
>
>Thanks,
>-Mike.
>
>_________________________________________________________________
>Protect your PC - get McAfee.com VirusScan Online  
>http://clinic.mcafee.com/clinic/ibuy/campaign.asp?cid=3963
>
>

_________________________________________________________________
Tired of spam? Get advanced junk mail protection with MSN 8. 
http://join.msn.com/?page=features/junkmail

---

From: Keith Owens <[email-masked]>
Date: Fri, 02 May 2003 14:18:13 +1000

On Thu, 01 May 2003 20:25:20 -0700, 
>make: *** [arch/mips/kernel/offset.s] Error 2

You have to specify ARCH=mips on _all_ make commands, not just make
*config.  Do 'make ARCH=mips' for the second one.

---

From: Ralf Baechle <[email-masked]>
Date: Sat, 3 May 2003 03:09:34 +0200

> *config.  Do 'make ARCH=mips' for the second one.

In the MIPS kernel source I've hardwired ARCH=mips.  He'd either have
to pass something like CROSS_COMPILE=mips-linux- or set the config
option CONFIG_CROSSCOMPILE.

  Ralf