Subject: The Linux binutils 2.14.90.0.1 is released

From: "H. J. Lu" <[email-masked]>
Date: Mon, 5 May 2003 22:33:01 -0700

This is the beta release of binutils 2.14.90.0.1 for Linux, which is
based on binutils 2003 0505 in CVS on sourecs.redhat.com plus various
changes. It is purely for Linux.

The Linux/mips support is added. You have to use

# rpm --target=[mips|mipsel] -ta binutils-xx.xx.xx.xx.xx.tar.gz

to build it. Or you can read mips/README in the source tree to apply
the mips patches and build it by hand.

Please report any bugs related to binutils 2.14.90.0.1 to [email-masked].

Changes from binutils 2.13.90.0.20:

1. Update from binutils 2003 0505.
2. Fix various ELF visibility bugs.
3. Fix some ia64 linker bugs.
4. Fix some ia64 assembler bugs.
5. Add some IAS compatibilities to ia64 assembler.
6. Fix ELF common symbol alignment.
7. Fix ELF weak symbol handling.

Changes from binutils 2.13.90.0.18:

1. Update from binutils 2003 0319.
2. Fix an ia64 linker brl relaxation bug.
3. Fix some ELF/ppc linker bugs.

Changes from binutils 2.13.90.0.16:

1. Update from binutils 2003 0121.
2. Fix an ia64 gas bug.
3. Fix some TLS bugs.
4. Fix some ELF/ppc bugs.
5. Fix an ELF/m68k bug.

2. Include /usr/bin/c++filt.
Changes from binutils 2.13.90.0.14:

1. Update from binutils 2002 1126.
2. Include /usr/bin/c++filt.
3. Fix "ld -r" with execption handling.

Changes from binutils 2.13.90.0.10:

1. Update from binutils 2002 1114.
2. Fix ELF/alpha bugs.
3. Fix an ELF/i386 assembler bug.

Changes from binutils 2.13.90.0.4:

1. Update from binutils 2002 1010.
2. More ELF/PPC linker bug fixes.
3. Fix an ELF/alpha linker bug.
4. Fix an ELF/sparc linker bug to support Solaris.
5. More TLS updates.

Changes from binutils 2.13.90.0.3:

1. Update from binutils 2002 0814.
2. Fix symbol versioning bugs for gcc 3.2.
3. Fix mips gas.

Changes from binutils 2.13.90.0.2:

1. Update from binutils 2002 0809.
2. Fix a mips gas compatibility bug.
3. Fix an x86 TLS bfd bug.
4. Fix an x86 PIC gas bug.
5. Improve symbol versioning support.

The file list:

1. binutils-2.14.90.0.1.tar.gz. Source code.
2. binutils-2.13.90.0.18-2.14.90.0.1.diff.gz. Patch against the
   previous beta source code.
3. binutils-2.14.90.0.1-1.i386.rpm. IA-32 binary RPM for RedHat 9.

There is no separate source rpm. You can do

# rpm -ta binutils-2.14.90.0.1.tar.gz

to create both binary and source rpms.

The primary sites for the beta Linux binutils are:

1. http://ftp.kernel.org/pub/linux/devel/binutils/

Thanks.

H.J. Lu
[email-masked]
05/05/2003

---

From: "H. J. Lu" <[email-masked]>
Date: Tue, 6 May 2003 08:41:19 -0700

On Tue, May 06, 2003 at 09:17:13AM +0200, Andreas Jaeger wrote:
> "H. J. Lu" <[email-masked]> writes:
> 
> HJ,
> the package is broken, the testsuite fails since the following
> (empty!) files from the ld/testsuite are not part of the tarball:
> 
> 
> ./testsuite/ld-elfvers/vers25b.c
> ./testsuite/ld-elfvers/vers25b.dsym
> ./testsuite/ld-elfvers/vers25b.ver
> ./testsuite/ld-elfvers/vers26b.dsym
> ./testsuite/ld-elfvers/vers26b.ver
> ./testsuite/ld-elfvers/vers27b.dsym
> ./testsuite/ld-elfvers/vers27b.ver
> ./testsuite/ld-elfvers/vers27c.c
> ./testsuite/ld-elfvers/vers27c.dsym
> ./testsuite/ld-elfvers/vers27c.ver
> 

It is not such a good idea to use empty files in CVS. I will check in
this patch. Please apply binutils-2.14.90.0.1-empty-test.patch to the
Linux binutils 2.14.90.0.1.

H.J.
2003-05-06  H.J. Lu <[email-masked]>

	* ld-elfvers/vers.exp (objdump_versionstuff): Support comment
	in expected version file.

	* ld-elfvers/vers25b.c: Add a line of comment.
	* ld-elfvers/vers25b.dsym: Likwise.
	* ld-elfvers/vers25b.ver: Likwise.
	* ld-elfvers/vers26b.dsym: Likwise.
	* ld-elfvers/vers26b.ver: Likwise.
	* ld-elfvers/vers27b.dsym: Likwise.
	* ld-elfvers/vers27b.ver: Likwise.
	* ld-elfvers/vers27c.c: Likwise.
	* ld-elfvers/vers27c.dsym: Likwise.
	* ld-elfvers/vers27c.ver: Likwise.

--- binutils-2.14.90.0.1/ld/testsuite/ld-elfvers/vers.exp.empty	2003-05-05 14:46:50.000000000 -0700
+++ binutils-2.14.90.0.1/ld/testsuite/ld-elfvers/vers.exp	2003-05-06 08:32:18.000000000 -0700
@@ -457,7 +457,11 @@ proc objdump_versionstuff { objdump obje
 
 	set f1 [open $tmpdir/objdump.out r]
 	set f2 [open $expectfile r]
-	gets $f2 l2
+	while { [gets $f2 l2] != -1 } {
+	    if { ![regexp "^#.*$" $l2] } then {
+		break
+	    }
+	} 
 	while { [gets $f1 l1] != -1 } {
 	    if { [string match $l2 $l1] } then {
 		if { [gets $f2 l2] == -1 } then {
--- binutils-2.14.90.0.1/ld/testsuite/ld-elfvers/vers25b.c.empty	2003-05-06 08:32:18.000000000 -0700
+++ binutils-2.14.90.0.1/ld/testsuite/ld-elfvers/vers25b.c	2003-05-06 08:32:18.000000000 -0700
@@ -0,0 +1 @@
+/* Empty file  */
--- binutils-2.14.90.0.1/ld/testsuite/ld-elfvers/vers25b.dsym.empty	2003-05-06 08:32:18.000000000 -0700
+++ binutils-2.14.90.0.1/ld/testsuite/ld-elfvers/vers25b.dsym	2003-05-06 08:32:18.000000000 -0700
@@ -0,0 +1 @@
+# Empty file.
--- binutils-2.14.90.0.1/ld/testsuite/ld-elfvers/vers25b.ver.empty	2003-05-06 08:32:18.000000000 -0700
+++ binutils-2.14.90.0.1/ld/testsuite/ld-elfvers/vers25b.ver	2003-05-06 08:32:18.000000000 -0700
@@ -0,0 +1 @@
+# Empty file
--- binutils-2.14.90.0.1/ld/testsuite/ld-elfvers/vers26b.dsym.empty	2003-05-06 08:32:18.000000000 -0700
+++ binutils-2.14.90.0.1/ld/testsuite/ld-elfvers/vers26b.dsym	2003-05-06 08:32:18.000000000 -0700
@@ -0,0 +1 @@
+# Empty file
--- binutils-2.14.90.0.1/ld/testsuite/ld-elfvers/vers26b.ver.empty	2003-05-06 08:32:18.000000000 -0700
+++ binutils-2.14.90.0.1/ld/testsuite/ld-elfvers/vers26b.ver	2003-05-06 08:32:18.000000000 -0700
@@ -0,0 +1 @@
+# Empty file
--- binutils-2.14.90.0.1/ld/testsuite/ld-elfvers/vers27b.dsym.empty	2003-05-06 08:32:18.000000000 -0700
+++ binutils-2.14.90.0.1/ld/testsuite/ld-elfvers/vers27b.dsym	2003-05-06 08:32:18.000000000 -0700
@@ -0,0 +1 @@
+# Empty file
--- binutils-2.14.90.0.1/ld/testsuite/ld-elfvers/vers27b.ver.empty	2003-05-06 08:32:18.000000000 -0700
+++ binutils-2.14.90.0.1/ld/testsuite/ld-elfvers/vers27b.ver	2003-05-06 08:32:18.000000000 -0700
@@ -0,0 +1 @@
+# Empty file
--- binutils-2.14.90.0.1/ld/testsuite/ld-elfvers/vers27c.c.empty	2003-05-06 08:32:18.000000000 -0700
+++ binutils-2.14.90.0.1/ld/testsuite/ld-elfvers/vers27c.c	2003-05-06 08:32:18.000000000 -0700
@@ -0,0 +1 @@
+/* Empty file  */
--- binutils-2.14.90.0.1/ld/testsuite/ld-elfvers/vers27c.dsym.empty	2003-05-06 08:32:18.000000000 -0700
+++ binutils-2.14.90.0.1/ld/testsuite/ld-elfvers/vers27c.dsym	2003-05-06 08:32:18.000000000 -0700
@@ -0,0 +1 @@
+# Empty file
--- binutils-2.14.90.0.1/ld/testsuite/ld-elfvers/vers27c.ver.empty	2003-05-06 08:32:18.000000000 -0700
+++ binutils-2.14.90.0.1/ld/testsuite/ld-elfvers/vers27c.ver	2003-05-06 08:32:18.000000000 -0700
@@ -0,0 +1 @@
+# Empty file