Subject: open file in kernel mode

From: JinuM <[email-masked]>
Date: Fri, 9 May 2003 11:24:25 +0530

Hi,

Can anyone help me with this simple problem.

I am trying to write a firmware loader driver. Instead of reading the
firmware as a buffer(predefined array)  we would like to read the firmware
from a file (say /root/firmware). Do we have some function which reads the
file contents in kernel mode.

-Jinu

---

From: Ralf Baechle <[email-masked]>
Date: Fri, 9 May 2003 17:06:12 +0200

> file contents in kernel mode.

This one seems a candidate for an faq ...

Provide some special file in /dev/ and use a small user application to
install the firmware by writing it into that file.

  Ralf