Subject: [PATCH] Embedded ramdisks

From: Geert Uytterhoeven <[email-masked]>
Date: Fri, 23 May 2003 15:52:45 +0200 (MEST)

Hi Ralf,

Fix the dependency for embedded ramdisks by using the contents of
CONFIG_EMBEDDED_RAMDISK_IMAGE (after stripping the leading and trailing double
quotes) instead of using the hardcoded filename `ramdisk.gz'.

--- linux-mips-2.4.x/arch/mips/ramdisk/Makefile	Tue Apr  1 16:22:04 2003
+++ linux/arch/mips/ramdisk/Makefile	Wed Apr  2 18:31:48 2003
@@ -8,7 +8,7 @@
 
 O_FORMAT = $(shell $(OBJDUMP) -i | head -2 | grep elf32)
 img = $(CONFIG_EMBEDDED_RAMDISK_IMAGE)
-ramdisk.o: ramdisk.gz ld.script
+ramdisk.o: $(subst ",,$(img)) ld.script
 	echo "O_FORMAT:  " $(O_FORMAT)
 	$(LD) -T ld.script -b binary --oformat $(O_FORMAT) -o $@ $(img)

Gr{oetje,eeting}s,

						Geert

--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- [email-masked]

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
							    -- Linus Torvalds

---

From: Ralf Baechle <[email-masked]>
Date: Tue, 27 May 2003 06:09:45 +0200

> quotes) instead of using the hardcoded filename `ramdisk.gz'.

Thanks, applied.

  Ralf