Subject: Re: Linux for MIPS Atlas 4Kc board

From: "Michael Anburaj" <[email-masked]>
Date: Thu, 08 May 2003 10:02:54 -0700

Hi JBG,

The MIPS box (Atlas running YAMON) has a fixed IP address assigned by me. 
TFTP boot works fine. But this IP is held within the boot monitor program 
(YAMON).

YAMON> set

baseboardserial (RO)   0000000197
bootfile        (R/W)  vmlinux.rec
bootprot        (R/W)  tftp
bootserport     (R/W)  tty0
bootserver      (R/W)  4.42.102.7
cpuconfig       (R/W)
ethaddr         (RO)   00.d0.a0.00.00.ed
fpu             (R/W)
gateway         (R/W)  12.235.80.1
ipaddr          (R/W)  4.42.102.6
memsize         (RO)   0x04000000
modetty0        (R/W)  115200,n,8,1,hw
modetty1        (R/W)  115200,n,8,1,hw
prompt          (R/W)  YAMON
start           (R/W)
startdelay      (R/W)
subnetmask      (R/W)  255.255.252.0
yamonrev        (RO)   02.04

Apart from the dynamic IP address assignment methods....
Suggest me a method to communicate this value to the RAM resident Linux 
kernel. Or can I assign a fixed IP addredd by passing it as a parameter when 
the linux kernel boots up? If so what is the syntax & please point me to the 
document that has this info. about passed parameter when booting the kernel.

Thanks,
-Mike.

>From: Jan-Benedict Glaw <[email-masked]>
>To: [email-masked]
>Subject: Re: Linux for MIPS Atlas 4Kc board
>Date: Thu, 8 May 2003 13:20:53 +0200
>
>On Thu, 2003-05-08 03:09:53 -0700, Michael Anburaj 
><[email-masked]>
>wrote in message <[email-masked]>:
> > Hi all,
> >
> > Finally I got the Atlas 4Kc board running YAMON to talk to Host PC 
>running
> > RedHat Linux 9 & download vmlinux.rec throught tftp. I have set-up NFS
> > export in the same PC under /export/RedHat7.1
> >
> > After the vmlinux.rec got downloaded, I issued the following command on 
>the
> > YAMON (MIPS tartget) prompt to start the downloaded linux kernel:
> >
> > go . nsfroot=4.42.102.7:/export/RedHat7.1
>                                            ^^^^^^^
>
>I think the box doesn't have an IP address, nor has it been told to pick
>one. You should add 'ip=bootp' or 'ip=dhcp' to your command line.
>
> > Protect your PC - get McAfee.com VirusScan Online
> > http://clinic.mcafee.com/clinic/ibuy/campaign.asp?cid=3963
>
>Protecting a PeeCee is more an act of not shooting one's own feet by
>running known-bad software...
>
>MfG, JBG
>
>--
>    Jan-Benedict Glaw       [email-masked]    . +49-172-7608481
>    "Eine Freie Meinung in  einem Freien Kopf    | Gegen Zensur | Gegen 
>Krieg
>     fuer einen Freien Staat voll Freier Bürger" | im Internet! |   im 
>Irak!
>       ret = do_actions((curr | FREE_SPEECH) & ~(IRAQ_WAR_2 | DRM | TCPA));
><< attach3 >>

_________________________________________________________________
MSN 8 helps eliminate e-mail viruses. Get 2 months FREE*.  
http://join.msn.com/?page=features/virus

---

From: Jan-Benedict Glaw <[email-masked]>
Date: Thu, 8 May 2003 23:40:57 +0200

On Thu, 2003-05-08 10:02:54 -0700, Michael Anburaj <[email-masked]>
> TFTP boot works fine. But this IP is held within the boot monitor program 
[...]

That doesn't help you. This is yamon, it's not Linux:)

> kernel. Or can I assign a fixed IP addredd by passing it as a parameter 

Look at ./linux/net/ipv4/ipconfig.c

> when the linux kernel boots up? If so what is the syntax & please point me 

Yes.

> to the document that has this info. about passed parameter when booting the 

The source file is the document, syntax is described there, too.

> kernel.

Please answer under old emails, not above them.

HTH, JBG

-- 
   Jan-Benedict Glaw       [email-masked]    . +49-172-7608481
   "Eine Freie Meinung in  einem Freien Kopf    | Gegen Zensur | Gegen Krieg
    fuer einen Freien Staat voll Freier Bürger" | im Internet! |   im Irak!
      ret = do_actions((curr | FREE_SPEECH) & ~(IRAQ_WAR_2 | DRM | TCPA));