Subject: about gas load_address

From: Fuxin Zhang <[email-masked]>
Date: Tue, 27 May 2003 17:35:04 +0800

hi,all

(sorry if it is somewhat out of topic,but i think most mips experts
are here:)

else if (mips_pic == SVR4_PIC && ! mips_big_got)
{
expressionS ex;

/* If this is a reference to an external symbol, we want
lw $reg,<sym>($gp) (BFD_RELOC_MIPS_GOT16)
Otherwise we want
lw $reg,<sym>($gp) (BFD_RELOC_MIPS_GOT16)
nop
QUESTION:
Could somebody tell me why we generate a unconditional 'nop' here?
addiu $reg,$reg,<sym> (BFD_RELOC_LO16)
If there is a constant, it must be added in after.

If we have NewABI, we want
lw $reg,<sym+cst>($gp) (BFD_RELOC_MIPS_GOT_DISP)
unless we're referencing a global symbol with a non-zero
offset, in which case cst must be added separately. */

Thanks in advance.

---

From: Ralf Baechle <[email-masked]>
Date: Tue, 27 May 2003 11:53:24 +0200

On Tue, May 27, 2003 at 05:35:04PM +0800, Fuxin Zhang wrote:
> Date:	Tue, 27 May 2003 17:35:04 +0800
> From:	Fuxin Zhang <[email-masked]>
> To:	MAKE FUN PRANK CALLS <[email-masked]>
        ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

Funny alias for this list :-)

> (sorry if it is somewhat out of topic,but i think most mips experts

Certainly more on topic than making prank calls ;-)

> If there is a constant, it must be added in after.

The nop would only be needed for the R2000/R3000 family where a load
instruction may not immediately be followed by it's consumer instruction.
NewABI implies MIPS III or higher so the nop wouldn't be required for
such processors.  Gcc and gas have sort of a tradition of throwing many
more nops in than needed ...

> offset, in which case cst must be added separately. */

  Ralf