Subject: [PATCH 2.5] ide.h fix(es)

From: Brian Murphy <[email-masked]>
Date: Fri, 20 Jun 2003 23:40:36 +0200

Hi Ralf,
this fixes some problems with undefined symbols in IDE and also
seems to work (as far as my limited testing can go at the moment).
Sorry if I was out of order in removing the big endian stuff, 
I just couldn't see the point.

/Brian

Index: include/asm-mips/ide.h
===================================================================
RCS file: /cvs/linux/include/asm-mips/ide.h,v
retrieving revision 1.21
diff -u -r1.21 ide.h
--- include/asm-mips/ide.h	3 Nov 2002 22:02:29 -0000	1.21
+++ include/asm-mips/ide.h	20 Jun 2003 21:36:59 -0000
@@ -64,28 +64,10 @@
 #endif
 }
 
-#ifdef __BIG_ENDIAN
-
-/* get rid of defs from io.h - ide has its private and conflicting versions */
-#ifdef insw
-#undef insw
-#endif
-#ifdef outsw
-#undef outsw
-#endif
-#ifdef insl
-#undef insl
-#endif
-#ifdef outsl
-#undef outsl
-#endif
-
-#define insw(port, addr, count) ide_insw(port, addr, count)
-#define insl(port, addr, count) ide_insl(port, addr, count)
-#define outsw(port, addr, count) ide_outsw(port, addr, count)
-#define outsl(port, addr, count) ide_outsl(port, addr, count)
-
-#endif /* __BIG_ENDIAN */
+#define __ide_mm_insw   ide_insw
+#define __ide_mm_insl   ide_insl
+#define __ide_mm_outsw  ide_outsw
+#define __ide_mm_outsl  ide_outsl
 
 #endif /* __KERNEL__ */

---

From: Ralf Baechle <[email-masked]>
Date: Sat, 21 Jun 2003 16:11:55 +0200

> Sorry if I was out of order in removing the big endian stuff, 

The big endian stuff was just old code, so from the point you were right
with removing it.  It's not an entirely correct solution though, on some
MIPS IDE systems the OS has to do endianess conversion, on some the
hardware takes care of it.  IDE as a big endian thing that was made
popular through the little endian PC platform has funny endianess issues
at times ...

  Ralf