Subject: [PATCH 2.4] cpu-probe.c error

From: Brian Murphy <[email-masked]>
Date: Fri, 20 Jun 2003 19:02:36 +0200

Hi Ralf,
	the latest change to cpu-probe.c requires a mips_cpu
variable which no longer exists. I presume you meant the following.

/Brian

Index: arch/mips/kernel/cpu-probe.c
===================================================================
RCS file: /cvs/linux/arch/mips/kernel/cpu-probe.c,v
retrieving revision 1.1.2.21
diff -u -r1.1.2.21 cpu-probe.c
--- arch/mips/kernel/cpu-probe.c	15 Jun 2003 23:35:54 -0000	1.1.2.21
+++ arch/mips/kernel/cpu-probe.c	20 Jun 2003 16:59:16 -0000
@@ -498,21 +498,21 @@
 #endif
 			break;
 		default:
-			mips_cpu.cputype = CPU_UNKNOWN;
+			c->cputype = CPU_UNKNOWN;
 			break;
 		}
 		break;
 
 	case PRID_COMP_SANDCRAFT:
-		switch (mips_cpu.processor_id & 0xff00) {
+		switch (c->processor_id & 0xff00) {
 		case PRID_IMP_SR71000:
-			mips_cpu.cputype = CPU_SR71000;
-			mips_cpu.isa_level = MIPS_CPU_ISA_M64;
-			mips_cpu.options = MIPS_CPU_TLB | MIPS_CPU_4KEX |
+			c->cputype = CPU_SR71000;
+			c->isa_level = MIPS_CPU_ISA_M64;
+			c->options = MIPS_CPU_TLB | MIPS_CPU_4KEX |
                                            MIPS_CPU_4KTLB | MIPS_CPU_FPU |
 			                   MIPS_CPU_COUNTER | MIPS_CPU_MCHECK;
-			mips_cpu.scache.ways = 8;
-			mips_cpu.tlbsize = 64;
+			c->scache.ways = 8;
+			c->tlbsize = 64;
 			break;
 		default:
 			c->cputype = CPU_UNKNOWN;

---

From: Pete Popov <[email-masked]>
Date: 20 Jun 2003 10:08:25 -0700

FYI, I had tried the same patch and it works fine on my boards. I think
mips64 may be broken as well, if I remember correctly.

Pete

---

From: Ladislav Michl <[email-masked]>
Date: Sat, 21 Jun 2003 10:06:28 +0100

> mips64 may be broken as well, if I remember correctly.

FYI, I sent patch which fixes mips/mips64; 2.4/2.5 at Mon, 16 Jun 2003
16:13:07 +0200 with subject "[PATCH] cpu-probe compile fix" and
Message-ID: <20030616141307.GA16721@simek>
Ralf could you please apply that one?

	ladis