Subject: schedule() and mipsel processor

From: fpga dsp <[email-masked]>
Date: Sat, 28 Jun 2003 12:57:49 +1000 (EST)

Hi all,
 
I may ask a stupid question here but I have problem of calling any functions such as interruptible_sleep_on_timeout, sleep_on ... in a timer handler, the kernel just crash straight away in the function schedule(). Now I go and do a diff between kern/sched.c on i686 source and mipsel source. clearly , they are different. So the question is from kernel programming point of view, the bottom-half of interrupt handler is still considered interrupt handler? I don't see any platform dependent code in the scheduler at all. So why a mips scheduler is different from intel scheduler ?
 
Many thanks
 
Duy Do

---------------------------------
Yahoo! Mobile
- Check & compose your email via SMS on your Telstra or Vodafone mobile.

---

From: Ralf Baechle <[email-masked]>
Date: Sun, 29 Jun 2003 19:35:23 +0200

> I may ask a stupid question here but I have problem of calling any functions such as interruptible_sleep_on_timeout, sleep_on ... in a timer handler, the kernel just crash straight away in the func…

Bs.  There was no need to change kernel/sched.c at all so you're probably
simply diffing the wrong versions.

  Ralf

---

From: Jun Sun <[email-masked]>
Date: Mon, 30 Jun 2003 10:00:13 -0700

On Sat, Jun 28, 2003 at 12:57:49PM +1000, fpga dsp wrote:
> Hi all,
>  
> I may ask a stupid question here but I have problem of calling any functions such as interruptible_sleep_on_timeout, sleep_on ... in a timer handler, the kernel just crash straight away in the function schedule(). Now I go and do a diff between kern/sched.c on i686 source and mipsel source. clearly , they are different. So the question is from kernel programming point of view, the bottom-half of interrupt handler is still considered interrupt handler? 

Correct.  You can't call those sleep functions from timer function.

Jun