Subject: [PATCH] vmlinux.lds.S

From: [email-masked]
Date: Tue, 3 Jun 2003 21:20:38 -0700

Without this generated image is weired, and cannot be loaded.

Index: arch/mips64/vmlinux.lds.S
===================================================================
RCS file: /home/cvs/linux/arch/mips64/vmlinux.lds.S,v
retrieving revision 1.11
diff -u -r1.11 vmlinux.lds.S
--- arch/mips64/vmlinux.lds.S   3 Jun 2003 17:04:11 -0000       1.11
+++ arch/mips64/vmlinux.lds.S   4 Jun 2003 04:18:05 -0000
@@ -46,6 +46,7 @@
   __kallsyms : { *(__kallsyms) }
   __stop___kallsyms = .;
 
+  RODATA
   . = ALIGN(64);
 
   /* writeable */

---

From: Jan-Benedict Glaw <[email-masked]>
Date: Wed, 4 Jun 2003 08:52:16 +0200

On Tue, 2003-06-03 21:20:38 -0700, [email-masked] <[email-masked]>
> Index: arch/mips64/vmlinux.lds.S

This is for 2.5.x? Maybe that's even what prevents my Indy to boot
(using a 32bit kernel). I'll test that tonight;)

MfG, JBG

-- 
   Jan-Benedict Glaw       [email-masked]    . +49-172-7608481
   "Eine Freie Meinung in  einem Freien Kopf    | Gegen Zensur | Gegen Krieg
    fuer einen Freien Staat voll Freier Bürger" | im Internet! |   im Irak!
      ret = do_actions((curr | FREE_SPEECH) & ~(IRAQ_WAR_2 | DRM | TCPA));

---

From: [email-masked]
Date: Wed, 4 Jun 2003 08:00:25 -0700

Yeap, this is for 2.5.59
Not anything earlier.
Without this patch PROM will tell you there is not enough memory to load the image.
On Wed, Jun 04, 2003 at 08:52:16AM +0200, Jan-Benedict Glaw wrote:
>     fuer einen Freien Staat voll Freier B?rger" | im Internet! |   im Irak!

---

From: Jan-Benedict Glaw <[email-masked]>
Date: Wed, 4 Jun 2003 22:33:10 +0200

On Wed, 2003-06-04 08:00:25 -0700, [email-masked] <[email-masked]>
> Without this patch PROM will tell you there is not enough memory to load the image.

My machine simply freezed. Looking at a tcpdump, I saw an error code
wich evaluates to "ELF allocation exceeded" - sounds pretty much like
your error...

MfG, JBG