Subject: Re: CVS [email-masked]: linux

From: Ralf Baechle <[email-masked]>
Date: Tue, 24 Jun 2003 11:31:57 +0200

On Tue, Jun 24, 2003 at 04:39:11AM +0100, [email-masked] wrote:

> CVSROOT:	/home/cvs
> Module name:	linux
> Changes by:	[email-masked]	03/06/24 04:39:11
> 
> Modified files:
> 	drivers/char   : Tag: linux_2_4 Makefile 
> 
> Log message:
> 	Added au1x00-serial.o to the exports list.

There doesn't seem to be a good reason to.  Only the register_serial and
unregister_serial are exported and they don't seem to be called from
anywhere outside.

  Ralf

---

From: Pete Popov <[email-masked]>
Date: 24 Jun 2003 10:51:05 -0700

> unregister_serial are exported and they don't seem to be called from

Strange, the kernel wouldn't compile without this. I'll try locally to
build it again and see what the problem is and if we can fix it without
modifying the Makefile.

Pete

---

From: Ralf Baechle <[email-masked]>
Date: Tue, 24 Jun 2003 23:10:40 +0200

> build it again and see what the problem is and if we can fix it without

Of course it'll build once you remove the unnecessary symbol exports :-)

  Ralf