Subject: RE: Cross Compilation

From: JinuM <[email-masked]>
Date: Wed, 23 Jul 2003 11:52:58 +0530

try http://www.linux-vr.org/tools.html

-Jinu

-----Original Message-----
From: SaravanaKumar [mailto:[email-masked]]
Sent: Wednesday, July 23, 2003 11:50 AM
To: [email-masked]
Subject: Cross Compilation

Dear All, 
    I am having my application in x86. 
 I have to cross compile that to MIPS architecture. 
How to do that. 

Is there is any document for doing the cross compilation to MIPS.

Cheers, 
N.S.Kumar

---

From: [email-masked]
Date: Wed, 23 Jul 2003 18:01:06 +0800

If I want to build big-endian mips, how can I do?
  In the www.linux-vr.org, there is only little-endian tools.

  regards.

This document is classified as     Normal

-Jinu

-----Original Message-----
From: SaravanaKumar [mailto:[email-masked]]
Sent: Wednesday, July 23, 2003 11:50 AM
To: [email-masked]
Subject: Cross Compilation

Dear All,

Cheers,
N.S.Kumar

---

From: "Jim Thompson" <[email-masked]>
Date: Wed, 23 Jul 2003 03:07:25 -0700

Unfortunately, its broken right now.

> From: Tiemo Krueger - mycable GmbH [mailto:[email-masked]]
> Sent: Wednesday, July 23, 2003 12:46 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Re: Cross Compilation
> 
> You could even use the buildroot thing from uclibc.org:
> 
> http://uclibc.org/cgi-bin/cvsweb/buildroot/buildroot.tar.gz?tarball=1
> 
> It's one of the most simple way for cross toolchain beginners, it
> provides you finally with a toolchain and rootfile system and more
> 
> Tiemo
> 
> SaravanaKumar wrote:
> 
> >Dear All,

---

From: "Jim Thompson" <[email-masked]>
Date: Wed, 23 Jul 2003 14:16:45 -0700

One more time, the current top-of-tree on 'buildroot' is broken.

Specifically, the 'chew' binary gets built for the target, but should be
built for the host.  The build fails when 'chew' gets run (because it
can't).

Erik is looking for a patch.

Jim

> From: Jeff Baitis [mailto:[email-masked]]
> Sent: Wednesday, July 23, 2003 11:27 AM
> To: Jun Sun
> Cc: Tiemo Krueger - mycable GmbH; [email-masked];
linux-
> [email-masked]
> I find that the uClibC tools are excellent, and have no problems
> generating
> MIPS binaries from an i386 host ;)
> 
> -Jeff
> 
> On Wed, Jul 23, 2003 at 10:09:46AM -0700, Jun Sun wrote:
> > On Wed, Jul 23, 2003 at 09:45:43AM +0200, Tiemo Krueger - mycable
GmbH
> wrote:
> > I took a look.  It looks similar to one project that I worked on
> > before.   Very interesting.
> >
> > Has anybody tried successfully to do a cross MIPS yet?  From a
> Linux/i386 host
> > obviously ...
> >
> > Jun
> >
> 
> --
>          Jeffrey Baitis - Associate Software Engineer
> 
>                     Evolution Robotics, Inc.
>                      130 West Union Street
>                        Pasadena CA 91103
> 
>  tel: 626.535.2776  |  fax: 626.535.2777  |  [email-masked]
>