Subject: Profiling tools

From: Dennis Castleman <[email-masked]>
Date: Tue, 22 Jul 2003 16:45:21 -0700

Any body have any experience will finding
Profile tool for mips-linux?

I'm running MontaVista 2.4.17 on a mips 5kc core.
I'm running linux on top of RTAI 2.24.1.8 
If I can find a profiler that work with the 5kc, then I'll add
RTAI support, if necessary.

Any thoughts?
Thanks
Dennis Castleman
OAK Technology

---

From: Wolfgang Denk <[email-masked]>
Date: Wed, 23 Jul 2003 02:04:24 +0200

Dear Dennis,

> Profile tool for mips-linux?

What exactly are you looking for? There can be several intentions  to
"profile" software.

> RTAI support, if necessary.

Did you have a look at the LTT? See http://www.opersys.com/LTT/index.html

> ------_=_NextPart_001_01C350AB.506AC4B0
> Content-Type: text/html
> 
> <!DOCTYPE HTML PUBLIC "-//W3C//DTD HTML 3.2//EN">

Please: don't post HTML to mailing lists.

Best regards,

Wolfgang Denk

-- 
Software Engineering:  Embedded and Realtime Systems,  Embedded Linux
Phone: (+49)-8142-4596-87  Fax: (+49)-8142-4596-88  Email: [email-masked]
I am not now, nor have I ever been, a member of the demigodic party.
                                                   -- Dennis Ritchie

---

From: fpga dsp <[email-masked]>
Date: Wed, 23 Jul 2003 15:50:31 +1000 (EST)

Hi all,

I just got my hand on a bdi2000 debugger recently and try to play around with it. It does everything i want but i am trying to figure out how to debug linux kernel. The linux kernel from AMD is used on a db1500 board. I did enable debuging option -g in the makefile, load it into the target and run it. But in the minicom window i alway got the TLB exception ( on load or store or instruction fetch). 

I suspect that i didn't initialize TLB table so it will cause the above error. However, what doesn't make sense to me is:

The same kernel, if i loaded using yamon through ethernet, it booted ok even i didn't initialize TLB table. Now if I loaded it by bdi2000, and run by bdi2000, it cause exception. In both methods, the hardware is initialized by yamon code. My assumption that it is the same in both case. So what is the difference? Any explanation will be appreciated. And am i correct that I need to initialize TLB before boot the kernel in bdi2000 ?

Many thanks!

Khuong

---------------------------------
Yahoo! Mobile
- Check & compose your email via SMS on your Telstra or Vodafone mobile.