Subject: My god! 2.5 is big

From: Brian Murphy <[email-masked]>
Date: Tue, 01 Jul 2003 23:35:50 +0200

My gzip'ped 2.4 kernel is 250k smaller than 2.5 and it works.
Perhaps I just need to remove some code... ;-)

/Brian

---

From: Ralf Baechle <[email-masked]>
Date: Wed, 2 Jul 2003 02:36:12 +0200

> Perhaps I just need to remove some code... ;-)

Old saying - "software is like gas, it fills all available space" ;-)

The MIPS 2.5 is still in it's quite early stages; I suspect we can still
regain part of the extra size.  More important than the pure kernel size
(users booting from flash throw your rotten vegies now ;-) is the in
memory size.  The greatly reduced size of struct page for example will
result in a net gain of memory available for applications for systems of
more than about 48MB.

  Ralf