Subject: Cross Compilation

From: SaravanaKumar <[email-masked]>
Date: 23 Jul 2003 11:50:29 +0530

Dear All, 
    I am having my application in x86. 
 I have to cross compile that to MIPS architecture. 
How to do that. 

Is there is any document for doing the cross compilation to MIPS.

Cheers, 
N.S.Kumar

---

From: debashis <[email-masked]>
Date: Wed, 23 Jul 2003 12:10:20 +0530

Hi,
see the url - http://www.linux-mips.org/toolchain.html
You need to install the appropiate toolchains.

Regards,
debashis

---

From: Tiemo Krueger - mycable GmbH <[email-masked]>
Date: Wed, 23 Jul 2003 09:45:43 +0200

You could even use the buildroot thing from uclibc.org:

http://uclibc.org/cgi-bin/cvsweb/buildroot/buildroot.tar.gz?tarball=1

It's one of the most simple way for cross toolchain beginners, it
provides you finally with a toolchain and rootfile system and more

Tiemo

---

From: Jun Sun <[email-masked]>
Date: Wed, 23 Jul 2003 10:09:46 -0700

> provides you finally with a toolchain and rootfile system and more

I took a look.  It looks similar to one project that I worked on
before.   Very interesting.

Has anybody tried successfully to do a cross MIPS yet?  From a Linux/i386 host
obviously ...

Jun

---

From: Bruno Randolf <[email-masked]>
Date: Wed, 23 Jul 2003 19:40:35 +0200

On Wednesday 23 July 2003 19:09, you wrote:

> Has anybody tried successfully to do a cross MIPS yet?  From a Linux/i386
> host obviously ...

yes, i have done that (last time around may 2003) and it worked great.

now it switched to a glibc based system, so i cant use it anymore 
unfortunately.

bruno

---

From: Jeff Baitis <[email-masked]>
Date: Wed, 23 Jul 2003 11:27:27 -0700

I find that the uClibC tools are excellent, and have no problems generating
MIPS binaries from an i386 host ;)

-Jeff

-- 
         Jeffrey Baitis - Associate Software Engineer

                    Evolution Robotics, Inc.
                     130 West Union Street
                       Pasadena CA 91103

 tel: 626.535.2776  |  fax: 626.535.2777  |  [email-masked]

---

From: "Lyle Bainbridge" <[email-masked]>
Date: Wed, 23 Jul 2003 19:55:56 -0500

> Has anybody tried successfully to do a cross MIPS yet?  From 
> a Linux/i386 host obviously ...

I have used the uclibc toolchain for big endian mips. It works great.  I
also have a gcc-3.2.3/glibc-2.2.5 based toolchain, and have used it to
cross compile a kernel and a simple root filesystem.

Lyle