Subject: [PATCH] 2.4 Alchemy Power management.

From: Liam Girdwood <[email-masked]>
Date: 17 Jul 2003 11:58:00 +0100

Hi,

This patch fixes some link errors with alchemy power management.

Index: arch/mips/au1000/common/power.c
===================================================================
RCS file: /home/cvs/linux/arch/mips/au1000/common/power.c,v
retrieving revision 1.2.2.7
diff -r1.2.2.7 power.c
55,58c55,58
< extern void set_au1000_speed(unsigned int new_freq);
< extern unsigned int get_au1000_speed(void);
< extern unsigned long get_au1000_uart_baud_base(void);
< extern void set_au1000_uart_baud_base(unsigned long new_baud_base);
---
> extern void set_au1x00_speed(unsigned int new_freq);
> extern unsigned int get_au1x00_speed(void);
> extern unsigned long get_au1x00_uart_baud_base(void);
> extern void set_au1x00_uart_baud_base(unsigned long new_baud_base);
191,192c191,192
<               old_baud_base = get_au1000_uart_baud_base();
<               old_cpu_freq = get_au1000_speed();
---
>               old_baud_base = get_au1x00_uart_baud_base();
>               old_cpu_freq = get_au1x00_speed();
196,197c196,197
<               set_au1000_speed(new_cpu_freq);
<               set_au1000_uart_baud_base(new_baud_base);
---
>               set_au1x00_speed(new_cpu_freq);
>               set_au1x00_uart_baud_base(new_baud_base);
326,330d325
< }
<
< void au1k_wait(void)
< {
<       __asm__("nop\n\t" "nop\n\t");

Liam

-- 
Liam Girdwood <[email-masked]>

Wolfson Microelectronics plc
http://www.wolfsonmicro.com
t: +44 131 272-7000
f: +44 131 272-7001
Registered in Scotland 89839

This message may contain confidential or proprietary information. If you receive this message in error, please
immediately delete it, destroy all copies of it and notify the sender. Any views expressed in this message are those of the individual sender,
except where the message states otherwise. We take reasonable precautions to ensure our Emails are virus free.
However, we cannot accept responsibility for any virus transmitted by us
and recommend that you subject any incoming Email to your own virus
checking procedures.

---

From: Geert Uytterhoeven <[email-masked]>
Date: Thu, 17 Jul 2003 13:16:57 +0200 (MEST)

> This patch fixes some link errors with alchemy power management.

Can you please use `diff -u' in the future? Thx!

Gr{oetje,eeting}s,

						Geert

--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- [email-masked]

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
							    -- Linus Torvalds