Subject: [PATCH 2.4] ndelay typo?

From: Brian Murphy <[email-masked]>
Date: Sat, 05 Jul 2003 15:22:22 +0200

Hi Ralf,
	I presume you meant this?

/Brian

Index: include/asm/delay.h
===================================================================
RCS file: /cvs/linux/include/asm-mips/delay.h,v
retrieving revision 1.10.2.4
diff -u -r1.10.2.4 delay.h
--- include/asm/delay.h	5 Jul 2003 03:23:46 -0000	1.10.2.4
+++ include/asm/delay.h	5 Jul 2003 13:18:24 -0000
@@ -73,6 +73,6 @@
 #endif
 
 #define udelay(usecs) __udelay((usecs),__udelay_val)
-#define ndelay(usecs) __udelay((usecs),__udelay_val)
+#define ndelay(usecs) __ndelay((usecs),__udelay_val)
 
 #endif /* _ASM_DELAY_H */

---

From: Ralf Baechle <[email-masked]>
Date: Sat, 5 Jul 2003 15:34:27 +0200

> 	I presume you meant this?

Yes, thanks, will fix.

> Index: include/asm/delay.h

Btw, don't diff anything in include/asm/.  That's a symlink ...

Btw, sorry if I toasted the Lasat support with the Galileo cleanup.  There
was just so much code duplication, it was insane to maintain.

I'm wondering about the Nile4 support btw.   Vrc5074 == NILE4, right?

   Ralf

---

From: Geert Uytterhoeven <[email-masked]>
Date: Sat, 5 Jul 2003 23:16:49 +0200 (MEST)

> > 	I presume you meant this?

And don't you want to rename the `usecs' parameter of ndelay() to `nsecs'?

> I'm wondering about the Nile4 support btw.   Vrc5074 == NILE4, right?

Yep.

Gr{oetje,eeting}s,

						Geert

--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- [email-masked]

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
							    -- Linus Torvalds

---

From: Ralf Baechle <[email-masked]>
Date: Sun, 6 Jul 2003 00:54:45 +0200

> And don't you want to rename the `usecs' parameter of ndelay() to `nsecs'?

You've not looked at what I actually checked in, I renamed the argument.

> > I'm wondering about the Nile4 support btw.   Vrc5074 == NILE4, right?

Well, I was wondering because the code in arch/mips/pci/ops-nile4.c which
was extraced from the lasat code is completly different from
ddb5xxx/ddb5074/pci_ops.c, so it's hard to extract the commonc code into
a shared file.

  Ralf

---

From: Geert Uytterhoeven <[email-masked]>
Date: Wed, 9 Jul 2003 09:58:08 +0200 (MEST)

> ddb5xxx/ddb5074/pci_ops.c, so it's hard to extract the commonc code into

If you know the chip, they are actually quite similar :-)

The differences between the Lasat and the DDB code are these:
  - The Lasat code checks the PCI error registers to detect the presence of PCI
    devices, while the DDB code doesn't,
  - The Lasat code is limited to 8 PCI devices on bus 0, while the DDB code
    uses a different access scheme to access the extra devices,
  - The DDB code uses abstraction functions to access the Nile 4 registers,
    while the Lasat code accesses the registers directly.

Gr{oetje,eeting}s,

						Geert

---

From: Ralf Baechle <[email-masked]>
Date: Thu, 10 Jul 2003 00:45:50 +0200

>     while the Lasat code accesses the registers directly.

Time to cleanup that mess also then.

Does anybody still care about the DDB5074?  I was just told somebody tried
it and it didn't boot into userspace ...

  Ralf

---

From: Geert Uytterhoeven <[email-masked]>
Date: Thu, 10 Jul 2003 09:29:29 +0200 (MEST)

> it and it didn't boot into userspace ...

A few weeks ago I gave it a try (2.4.21-pre4), but I didn't bother to set up a
Debian root on NFS to check userspace. At least the kernel booted until IP
autoconfig.

Gr{oetje,eeting}s,

						Geert