Subject: [PATCH] [2.6.0-test1] Alchemy Pb1500 - Power management

From: Liam Girdwood <[email-masked]>
Date: 16 Jul 2003 10:38:09 +0100

Hi,

I'm working my way through building the latest CVS for my Pb1500 and
I've run into a couple of build problems.

This patch fixes some function naming problems and removes duplicate
symbol au1k_wait() (defined in kernel/cpu-probe.c) in the Pb1500 power
management code.

Index: arch/mips/au1000/common/power.c
===================================================================
RCS file: /home/cvs/linux/arch/mips/au1000/common/power.c,v
retrieving revision 1.10
diff -r1.10 power.c
36a37
> #include <linux/jiffies.h>
54,55c55,56
< extern void set_au1000_speed(unsigned int new_freq);
< extern unsigned int get_au1000_speed(void);
---
> extern void set_au1x00_speed(unsigned int new_freq);
> extern unsigned int get_au1x00_speed(void);
190,191c191,192
< 		old_baud_base = get_au1000_uart_baud_base();
< 		old_cpu_freq = get_au1000_speed();
---
> 		old_baud_base = get_au1x00_uart_baud_base();
> 		old_cpu_freq = get_au1x00_speed();
195,196c196,197
< 		set_au1000_speed(new_cpu_freq);
< 		set_au1000_uart_baud_base(new_baud_base);
---
> 		set_au1x00_speed(new_cpu_freq);
> 		set_au1x00_uart_baud_base(new_baud_base);
325,329d325
< }
< 
< void au1k_wait(void)
< {
< 	__asm__("nop\n\t" "nop\n\t");

Liam

-- 
Liam Girdwood <[email-masked]>

Wolfson Microelectronics plc
http://www.wolfsonmicro.com
t: +44 131 272-7000
f: +44 131 272-7001
Registered in Scotland 89839

This message may contain confidential or proprietary information. If you receive this message in error, please
immediately delete it, destroy all copies of it and notify the sender. Any views expressed in this message are those of the individual sender,
except where the message states otherwise. We take reasonable precautions to ensure our Emails are virus free.
However, we cannot accept responsibility for any virus transmitted by us
and recommend that you subject any incoming Email to your own virus
checking procedures.

---

From: Pete Popov <[email-masked]>
Date: 16 Jul 2003 09:07:10 -0700

Thanks.

BTW, I'm waiting for some PM patches from Embedded Edge that will
cleanup and Au1x PM support.

Pete