Subject: Information required

From: Adeel Malik <[email-masked]>
Date: Wed, 27 Aug 2003 19:30:26 +0500

Hi All,
           I am involved in Embedded Linux Development for MIPS Processor. I
need to write a device driver for a MIPS Target Platform. When I insmod the
driver.o file, the linux bash script running on the target hardware gives me
the error message like ;
1. unable to resolve the printk function
2. unable to resolve the register_chardev function
etc.
Can you plz give me the direction as to how to proceed to tackle this
situation.
Regards,
 
ADEEL MALIK,
Design Engineer

---

From: Jun Sun <[email-masked]>
Date: Wed, 27 Aug 2003 09:51:27 -0700

> Can you plz give me the direction as to how to proceed to tackle this

Make sure your kernel compiled with module option turned on.
Does it use module version (CONFIG_MODVERSIONS)?
If so, add -DMODVERSIONS -include $(KERNEL_PATH)/include/linux/modversions.h
to your CFLAGS.

Jun