Subject: unresolved symbol dptoli

From: "durai" <[email-masked]>
Date: Thu, 11 Sep 2003 11:33:07 +0530

hi,
i compiled a wireless lan driver using the mips-linux-gcc compiler 2.95.3.
When i try to insmod the driver i got the following errors. any ideas?

insmod: unresolved symbol dptoli
insmod: unresolved symbol dpmul
insmod: unresolved symbol litodp

Note that, i havent used any of these above functions in my code. It appears
only in the .o files

Durairaj P
Senior Software Engineer
Integrated SoftTech Solutiond Pvt. Ltd
Chennai 600 018
India
Tel : +91(44)2436 4915 Ext 88
www.isofttech.com

---

From: Ralf Baechle <[email-masked]>
Date: Thu, 11 Sep 2003 16:06:08 +0200

> Note that, i havent used any of these above functions in my code. It appears

These are symbols used by gcc's software fp code.  Don't use floating
point in kernel code.

  Ralf