Subject: [PATCH] Fix unused variable warning in drivers/char/dz.c

From: Thiemo Seufer <[email-masked]>
Date: Sun, 21 Sep 2003 23:35:47 +0200

Hello Maciej,

this fixes an unused variable warning.

Thiemo

diff -abdpruNPX /bigdisk/src/dontdiff linux-orig/drivers/char/dz.c linux/drivers/char/dz.c
--- linux-orig/drivers/char/dz.c	Wed Apr 23 19:17:01 2003
+++ linux/drivers/char/dz.c	Sun Sep 21 22:28:40 2003
@@ -1299,9 +1299,12 @@ static void show_serial_version(void)
 
 int __init dz_init(void)
 {
-	int i, tmp;
+	int i;
 	long flags;
 	struct dz_serial *info;
+#ifndef CONFIG_SERIAL_DEC_CONSOLE
+	int tmp;
+#endif
 
 	/* Setup base handler, and timer table. */
 	init_bh(SERIAL_BH, do_serial_bh);

---

From: "Maciej W. Rozycki" <[email-masked]>
Date: Mon, 22 Sep 2003 20:00:09 +0200 (MET DST)

> this fixes an unused variable warning.

 Thanks for the report.  Since the variable isn't really needed at all,
I've removed it altogether.

-- 
+  Maciej W. Rozycki, Technical University of Gdansk, Poland   +
+--------------------------------------------------------------+
+        e-mail: [email-masked], PGP key available        +