Subject: Some Question about the kernel module on MIPS64

From: "广星" <[email-masked]>
Date: Thu, 11 Sep 2003 10:13:58 +0800

Hi, everyone!
   I am a newbie on doing some development on MIPS(of course it is the linux make me can touch it without any  hesitation).There are two questions  as follow hoping your enthusiastic answers.
   1) I want to know if the linux for mips64 support the customer's kernel module .if yes, is there any modutils i can use?And how can i get it.
   2) I have written a simplest simplest kernel module for linux for mips64 (only the init()and cleanup() we can see,and we do nothing.) and with the crossing compiling tool it is ok.One thing confused me is that it can be "insmod" in the linux for mips32, but when we try to "insmod" in the linux for mips64, we get the following error:
[root@(none) root]# insmod try.o
init_module: Invalid module header size.
A new version of the modutils is likely needed.
try.o: init_module: Invalid argument
Hint: insmod errors can be caused by incorrect module parameters, including invalid IO or IRQ parameters
Of course we do the above works in the same hardware platform .
Is there any thing I should pay attention to when I compile the Kernel Module or the linux for mips64? Eagering your help!!
Thank you  you in advance!

　　
　　　　　　　祝
  开心!
     Far and away the best prize that life offers is the chance to work hard at work worth doing. 广星
[email-masked]
2003-09-11
           \\\|///
          \\ - - //
           ( @ @ )
--------oOOo-(_)-oOOo---------

       广星祝您愉快健康
               0ooo
-------- oooO--(   )----------
        (   )   ) /
         \ (   (_/
          \_)

---

From: Ralf Baechle <[email-masked]>
Date: Thu, 11 Sep 2003 16:26:11 +0200

On Thu, Sep 11, 2003 at 10:13:58AM +0800, ???? wrote:

>    1) I want to know if the linux for mips64 support the customer's
>       kernel module .if yes, is there any modutils i can use?And how
>       can i get it.

There is currently no module support for mips64.

>    2) I have written a simplest simplest kernel module for linux for
>       mips64 (only the init()and cleanup() we can see,and we do nothing.)
>       and with the crossing compiling tool it is ok.One thing confused
>       me is that it can be "insmod" in the linux for mips32, but when we
>       try to "insmod" in the linux for mips64, we get the following error:

True.

> Is there any thing I should pay attention to when I compile the Kernel
> Module or the linux for mips64? Eagering your help!!

The problem isn't the kernel but modutils which don't support kernel
modules for 64-bit kernels.

  Ralf

---

From: Keith Owens <[email-masked]>
Date: Fri, 12 Sep 2003 00:36:35 +1000

On Thu, 11 Sep 2003 16:26:11 +0200, 
>modules for 64-bit kernels.

Nobody has sent me patches for mips64 (hint, hint).