Subject: How to increase download speed for UART

From: Adeel Malik <[email-masked]>
Date: Fri, 26 Sep 2003 20:32:50 +0500

Hi All,
         I am porting Linux to a MIPS based development platform. The UART
on the board provides a maximum baud rate of 115 kbps. But the download time
for the kernel Image of about 4.3 MB is about 4 hours !!!!!. 
 
Can someone help me address this problem ?. 
 
(I can't download the kernel image via tftp server using ethernet, as the
CPU doesn't have the MAC interface).
 
Regards,
ADEEL MALIK,

---

From: Pete Popov <[email-masked]>
Date: 26 Sep 2003 08:45:28 -0700

On Fri, 2003-09-26 at 08:32, Adeel Malik wrote:
> Hi All,
>          I am porting Linux to a MIPS based development platform. The
> UART on the board provides a maximum baud rate of 115 kbps. But the
> download time for the kernel Image of about 4.3 MB is about 4 hours
> !!!!!. 

4.3MB? Is this an SREC file? I've downloaded images over the serial port
(srec files) and it takes no more than 10 minutes.

Pete

> (I can't download the kernel image via tftp server using ethernet, as
> the CPU doesn't have the MAC interface).
>  
> Regards,
> ADEEL MALIK,
>  
>