Subject: [patch] simulate_llsc in v2.4

From: Yoichi Yuasa <[email-masked]>
Date: Wed, 10 Sep 2003 18:38:52 +0900

Hello Ralf,

I found a differece between v2.4 and v2.6 in simulate_llsc().

Please apply this patch to v2.4 tree.

Yoichi
diff -aruN --exclude=CVS --exclude=.cvsignore linux.orig/arch/mips/kernel/traps.c linux/arch/mips/kernel/traps.c
--- linux.orig/arch/mips/kernel/traps.c	Fri Jul 18 23:16:06 2003
+++ linux/arch/mips/kernel/traps.c	Wed Sep 10 18:34:40 2003
@@ -523,6 +523,8 @@
 		simulate_sc(regs, opcode);
 		return 0;
 	}
+
+	return -EFAULT;			/* Strange things going on ... */
 }
 
 asmlinkage void do_ov(struct pt_regs *regs)

---

From: Ralf Baechle <[email-masked]>
Date: Wed, 10 Sep 2003 12:10:35 +0200

> Please apply this patch to v2.4 tree.

Okay - you missed the same thing also needs to be applied to the 64-bit
kernel.

  Ralf

---

From: Yoichi Yuasa <[email-masked]>
Date: Wed, 10 Sep 2003 23:35:18 +0900

On Wed, 10 Sep 2003 12:10:35 +0200

> Okay - you missed the same thing also needs to be applied to the 64-bit

Oh, that's right.

Thanks,

Yoichi