Subject: Re: CVS [email-masked]: linux

From: "Maciej W. Rozycki" <[email-masked]>
Date: Tue, 9 Sep 2003 15:40:44 +0200 (MET DST)

On Tue, 9 Sep 2003 [email-masked] wrote:

> 	Avoid conflict with glibc on bigendian platforms when -O or higher
> 	is specified.  It's already in 2.6, and I'm not sure why it hasn't
> 	been seen in 2.4.  The symptom is that this program will not compile
> 	with -O2:
> 	
> 	#include <asm/byteorder.h>
> 	#include <netinet/in.h>
> 	int main () { }

 Is <asm/byteorder.h> ever included by glibc headers?  I hope not and user
programs *must* not include kernel headers.  Your program is buggy.

---

From: Ralf Baechle <[email-masked]>
Date: Wed, 10 Sep 2003 10:51:04 +0200

> programs *must* not include kernel headers.  Your program is buggy.

I'd not have accepted such a patch for exactly that reason if it wasn't
already in 2.6.

  Ralf