Subject: Page fault question

From: "Gill" <[email-masked]>
Date: Wed, 24 Sep 2003 08:36:38 +0100

Hello -

I'm currently porting vmlinux from NEC's EMMA2L platform to EMMA2.  The
problem I'm having is that linux hangs when it attempts to do its first page
fault: the page fault handler is successfully called, the call to
handle_mm_fault returns 2 (major fault).but then code execution appears to
just stop.  Linux is not completely dead, however - it still responds to a
timer interrupt.

As the code for handling page faults is standard code, and TLB hardware
should be the same on EMMA2 as on EMMA2L (where it works!), I don't
understand what's gone wrong!  Does anyone have any ideas?

Thanks for your help,

Gill

---

From: "Kevin D. Kissell" <[email-masked]>
Date: Wed, 24 Sep 2003 12:05:31 +0200

The EMMA2 (uPD61130) uses the NEC Vr4130 core, wheras the EMMA2L (uPD61120)
uses a MIPS 4Kc core.  The 4Kc is a MIPS32-compliant core, but the Vr41xx family
predates the MIPS32 spec for the MMU interface, and has some significant incompatibilities,
mostly due to the fact that the Vr4100's assume a 1K page granularity, versus 4K for the 4Kc
and almost all other MIPS processors.  You can't use the same MMU code for both chips.
One kernel needs to be configured for a "MIPS32" CPU, the other for "R41xx".
  ----- Original Message ----- 
  From: Gill 
  To: [email-masked] 
  Sent: Wednesday, September 24, 2003 9:36 AM
  Subject: Page fault question

  Hello -

  I'm currently porting vmlinux from NEC's EMMA2L platform to EMMA2.  The problem I'm having is that linux hangs when it attempts to do its first page fault: the page fault handler is successfully called, the call to handle_mm_fault returns 2 (major fault).but then code execution appears to just stop.  Linux is not completely dead, however - it still responds to a timer interrupt.

  As the code for handling page faults is standard code, and TLB hardware should be the same on EMMA2 as on EMMA2L (where it works!), I don't understand what's gone wrong!  Does anyone have any ideas?

  Thanks for your help,

  Gill