Subject: Kernel Profile Patch for Au1x00?

From: "Vince Bridgers" <[email-masked]>
Date: Wed, 1 Oct 2003 20:28:15 -0500

Is there a kernel profile patch that anyone is aware of for the AMD
(Alchemy) part Au1000/Au1500? If not, can anyone provide info on a good
starting point to start a port?
 
TIA,
 
Vince

---

From: "Vince Bridgers" <[email-masked]>
Date: Fri, 3 Oct 2003 09:45:21 -0500

Thanks, Eric. 
 
I was looking for something more simple, like kernel-based statistical
hit profiling - for example: a timer interrupt that fires at some
regular rate, collects the current Program Counter value, bucket-izes
that data and does a symbol lookup on those buckets when queried. I'll
take a look at LTT to see if I can get it to work for my purposes.
 
I sent an email to pcs.support previously, and Gerado told me there was
no patch available. I'll check with them again.
 
Cheers!
 
-----Original Message-----
From: Eric DeVolder [mailto:[email-masked]] 
Sent: Friday, October 03, 2003 9:30 AM
To: Vince Bridgers
Subject: Re: Kernel Profile Patch for Au1x00?
 
There is the LTT, Linux Trace Toolkit, which can be used for profiling.
If you send email to [email-masked], they should be able to
get you the files...

Vince Bridgers wrote:

TIA,
 
Vince