Subject: kmalloc question

From: "Finney, Steve" <[email-masked]>
Date: Wed, 8 Oct 2003 15:06:50 -1000

Is kmalloc (GFP_KERNEL) on a 32 bit HIGHMEM enabled MIPS kernel (BCM/Sibyte processor) guaranteed to allocate memory from the low, KSEG0/1 addressible region? I'm having trouble sorting through the slab.c code. On this processor, only 256 MB of DRAM is directly addressible; with more than 256 MB of RAM, there is 256 MB in zone 0, and the remainder in zone 2. Zone 1 is empty.

Thanks,
sf

---

From: Ralf Baechle <[email-masked]>
Date: Thu, 9 Oct 2003 10:09:40 +0200

> Is kmalloc (GFP_KERNEL) on a 32 bit HIGHMEM enabled MIPS kernel (BCM/Sibyte processor) guaranteed to allocate memory from the low, KSEG0/1 addressible region? I'm having trouble sorting through the…

Yes.

  Ralf