Subject: Problem with depmod

From: Tommy Tovbin <[email-masked]>
Date: Wed, 1 Oct 2003 12:18:04 +0400 (MSD)

Hi, I've recompiled whole RedHat 7.3 on MIPS. Well, when I try to startup 
my system I`m getting an error like this:

Finding module dependencies:  depmod: cannot read ELF header from 
/lib/modules/2.4.18/modules.dep
depmod: cannot read ELF header from 
/lib/modules/2.4.18/modules.generic_string
depmod: /lib/modules/2.4.18/modules.ieee1394map is not an ELF file
depmod: /lib/modules/2.4.18/modules.isapnpmap is not an ELF file
depmod: cannot read ELF header from /lib/modules/2.4.18/modules.parportmap
depmod: /lib/modules/2.4.18/modules.pcimap is not an ELF file
depmod: cannot read ELF header from /lib/modules/2.4.18/modules.pnpbiosmap
depmod: /lib/modules/2.4.18/modules.usbmap is not an ELF file
[FAILED]

Can somebody help me?

PS: I've got the NULL modules.dep, because I havn't any modules, but I 
need kernel with LKM support.

Thx.

-- 
With regards, Tommy Tovbin. tovbin at niisi dot msk dot ru.
	Zz
       zZ
    |\ z    _,,,---,,_ /,`.-'`'_ ;-;;,_
   |,4-  ) )-,_..;\ (  `'_'
  '---''(_/--'  `-'\_)

---

From: Keith Owens <[email-masked]>
Date: Wed, 01 Oct 2003 21:48:40 +1000

On Wed, 1 Oct 2003 12:18:04 +0400 (MSD), 
>/lib/modules/2.4.18/modules.dep

Short answer: 'mkdir /lib/modules/2.4.18/kernel' or 'make modules_install'.

Long answer: You can feed depmod multiple module directories, so depmod
has to look for directory 'kernel' to work out the top level of each tree.
modules.dep and the other text files are only ignored at the top level
of each tree.  You have no 'kernel' directory under /lib/modules/2.4.18
so depmod does not ignore the text files.

---

From: Tommy Tovbin <[email-masked]>
Date: Wed, 1 Oct 2003 17:34:26 +0400 (MSD)

> so depmod does not ignore the text files.

Thanks a lot!