Subject: What toolchain for vr4181

From: Jørg Ulrich Hansen <[email-masked]>
Date: Wed, 8 Oct 2003 18:49:32 +0200

Hi

I am about to start porting Linux to my hardware with an vr4181 processor.
The hardware is very close to the osprey architecture. Now my problem is
what toolchain to use.
I could do with an up to date opinion.

? gcc-2.95.3
? gcc-2.95.4
? egcs-1.1.2
? gcc-3.2
? binutils 2.13
? glibc 2.2.5
? Any patches
? http://www.ltc.com/~brad/mips/mips-cross-toolchain/index.html
? http://kegel.com/crosstool/

Where is a good starting point for a toolchain that will build and work?
I would prefere to build it my self because at a later state I might build
it under cygwin. But a prebuild does also have interest.

Kind regards Jorg

---

From: Geert Uytterhoeven <[email-masked]>
Date: Thu, 9 Oct 2003 10:30:57 +0200 (MEST)

> it under cygwin. But a prebuild does also have interest.

At work we use plain binutils 2.13.2.1 and gcc 3.2.2, which we build ourselves
(host is Solaris/SPARC).

Gr{oetje,eeting}s,

						Geert

--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- [email-masked]

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
							    -- Linus Torvalds

---

From: Jan-Benedict Glaw <[email-masked]>
Date: Thu, 9 Oct 2003 13:04:18 +0200

On Thu, 2003-10-09 10:30:57 +0200, Geert Uytterhoeven <[email-masked]>
> At work we use plain binutils 2.13.2.1 and gcc 3.2.2, which we build ourselves

Joined trees? Which configury? Unfortunately, toolchain questions are
quite FAQs, but there doesn't really exist _that_ good HOWTOs which
actually contain exactly helpful hints (eg. which versions and/or which
additional patches are needed).

If companies have some kind of scripts or the like they use, I'd really
love to see them published. That'd really help all those guys out
there:)

MfG, JBG

-- 
   Jan-Benedict Glaw       [email-masked]    . +49-172-7608481
   "Eine Freie Meinung in  einem Freien Kopf    | Gegen Zensur | Gegen Krieg
    fuer einen Freien Staat voll Freier Bürger" | im Internet! |   im Irak!
   ret = do_actions((curr | FREE_SPEECH) & ~(NEW_COPYRIGHT_LAW | DRM | TCPA));

---

From: Geert Uytterhoeven <[email-masked]>
Date: Thu, 9 Oct 2003 13:25:30 +0200 (MEST)

> love to see them published. That'd really help all those guys out

Binutils (binutils-2.13.2.1.tar.bz2):
    configure --target=mips-linux --prefix=/wherever/you/want

Gcc (gcc-core-3.2.2.tar.bz2):
    configure --target=mips-linux --prefix=/wherever/you/want --enable-languages=c --enable-shared --with-gnu-as --with-gnu-ld --with-system-zlib --enable-long-long --enable-nls --without-included-gettext

I took the development libraries and includes from Debian:
    libc6-dev_2.2.5-11.2_mips.deb
    libc6_2.2.5-11.2_mips.deb
    zlib1g-dev_1%3a1.1.4-1_mips.deb
    zlib1g_1%3a1.1.4-1_mips.deb

I wrote very simple Perl clones of dpkg and dpkg-deb with just enough
functionality to get `dpkg-cross -i' working on Solaris. I don't know whether I
can share them, though.

Gr{oetje,eeting}s,

						Geert