Subject: asm/smplock.h is dead

From: Matthew Wilcox <[email-masked]>
Date: Wed, 22 Oct 2003 00:09:32 +0100

asm/smplock.h is dead, you're the only three arches that still have it.
Can you delete next time you merge?  Thanks.

$ find -type f |xargs grep smplock.h      
./arch/mips/sibyte/sb1250/bcm1250_tbprof.c:#include <asm/smplock.h>
./include/asm-h8300/smplock.h: * <asm/smplock.h>
./include/asm-um/smplock.h:#include "asm/arch/smplock.h"
$ find -name smplock.h
./include/asm-h8300/smplock.h
./include/asm-mips/smplock.h
./include/asm-um/smplock.h

(the sibyte driver can just lose this line.  it doesn't do any SMP locking)

-- 
"It's not Hollywood.  War is real, war is primarily not about defeat or
victory, it is about death.  I've seen thousands and thousands of dead bodies.
Do you think I want to have an academic debate on this subject?" -- Robert Fisk

---

From: Ralf Baechle <[email-masked]>
Date: Wed, 22 Oct 2003 03:13:24 +0200

> (the sibyte driver can just lose this line.  it doesn't do any SMP locking)

Thanks, zapped on MIPS.

  Ralf

---

From: Yoshinori Sato <[email-masked]>
Date: Thu, 23 Oct 2003 01:11:39 +0900

At Wed, 22 Oct 2003 00:09:32 +0100,
> (the sibyte driver can just lose this line.  it doesn't do any SMP locking)

I deleted it.
Thank you.

-- 
Yoshinori Sato
<[email-masked]>