Subject: latest build - xconfig

From: David Kesselring <[email-masked]>
Date: Fri, 31 Oct 2003 14:25:16 -0500 (EST)

It seems like xconfig is broken on the code currently in cvs.
./tkparse < ../arch/mips/config.in >> kconfig.tk
arch/mips/config-shared.in: 894: can't handle
dep_bool/dep_mbool/dep_tristate condition
make[1]: *** [kconfig.tk] Error 1

Hope this helps somebody.

David Kesselring
Atmel MMC
[email-masked]
919-462-6587

---

From: "Steven J. Hill" <[email-masked]>
Date: Fri, 31 Oct 2003 14:48:53 -0500

> make[1]: *** [kconfig.tk] Error 1
I just checked in the fix. Here's the patch too for reference.

-Steve
Index: config-shared.in
===================================================================
RCS file: /home/cvs/linux/arch/mips/Attic/config-shared.in,v
retrieving revision 1.1.2.91
diff -u -r1.1.2.91 config-shared.in
--- config-shared.in	22 Oct 2003 06:58:37 -0000	1.1.2.91
+++ config-shared.in	31 Oct 2003 19:47:28 -0000
@@ -891,7 +891,7 @@
 
 if [ "$CONFIG_SGI_IP22" = "y" -o "$CONFIG_MIPS_MAGNUM_4000" = "y" -o \
      "$CONFIG_OLIVETTI_M700" = "y" -o "$CONFIG_SNI_RM200_PCI" = "y" ]; then
-   dep_bool 'EISA bus support' CONFIG_EISA
+   bool 'EISA bus support' CONFIG_EISA
 fi
 
 if [ "$CONFIG_PCI" != "y" ]; then