Subject: Relocation errors

From: David Kesselring <[email-masked]>
Date: Mon, 27 Oct 2003 08:55:19 -0500 (EST)

I'm getting the error "Unhandled relocation of type xx" on insmod. Are the
"types" documented somewhere? I am I correct that these "types" are
architecture specific?

David Kesselring
Atmel MMC
[email-masked]
919-462-6587

---

From: Daniel Jacobowitz <[email-masked]>
Date: Mon, 27 Oct 2003 09:58:03 -0500

> "types" documented somewhere? I am I correct that these "types" are

Yes.  Try an ELF specification - there's a MIPS processor supplement
(psABI) floating around.  What's the "xx"?

-- 
Daniel Jacobowitz
MontaVista Software                         Debian GNU/Linux Developer

---

From: David Kesselring <[email-masked]>
Date: Mon, 27 Oct 2003 10:06:53 -0500 (EST)

It is type 8. Any ideas? This is from an intel driver that I've cross
compiled for mips. I used these options;
-mcpu=r4600 -mips2 -mno-abicalls -fno-pic -mlong-calls -Wa,--trap -DMODULE
-pipe -O3 -fomit-frame-pointer -fno-strict-aliasing

Thanks, David

David Kesselring
Atmel MMC
[email-masked]
919-462-6587

---

From: Daniel Jacobowitz <[email-masked]>
Date: Mon, 27 Oct 2003 10:14:21 -0500

Take a look at /usr/include/elf.h:
#define R_MIPS_LITERAL          8       /* 16 bit literal entry */

In this case it's not very informative.  But the problem is probably
mismatched CFLAGS.  Take another look at the options the kernel is
built with - you lost -G 0.  See if that does it.

---

From: Ralf Baechle <[email-masked]>
Date: Mon, 27 Oct 2003 17:06:04 +0100

On Mon, Oct 27, 2003 at 10:14:21AM -0500, Daniel Jacobowitz wrote:
> Date: Mon, 27 Oct 2003 10:14:21 -0500
> From: Daniel Jacobowitz <[email-masked]>
> To: David Kesselring <[email-masked]>
> Cc: [email-masked]
> Subject: Re: Relocation errors
> Content-Type: text/plain; charset=us-ascii
> 

My gcc patches used to set this to zero because the -G optimization doesn't
work on Linux; I think HJ Lu's (?) gcc patches lost this.

  Ralf