Subject: Root fs with NFS problem...

From: Prabhakar <[email-masked]>
Date: Sat, 18 Oct 2003 19:12:30 -0000

Hi all,

I'm trying to boot through NFS using rootfs,I'm got struck like...

au1000eth.c:1.4 [email-masked]
eth0: Au1x Ethernet found at 0xb1500000, irq 28
eth0: AMD 79C874 10/100 BaseT PHY at phy address 0
eth0: Using AMD 79C874 10/100 BaseT PHY as default
eth1: Au1x Ethernet found at 0xb1510000, irq 29
eth1: AMD 79C874 10/100 BaseT PHY at phy address 0
eth1: Using AMD 79C874 10/100 BaseT PHY as default
mice: PS/2 mouse device common for all mice
NET4: Linux TCP/IP 1.0 for NET4.0
IP Protocols: ICMP, UDP, TCP
IP: routing cache hash table of 512 buckets, 4Kbytes
TCP: Hash tables configured (established 2048 bind 4096)
IP-Config: Incomplete network configuration information.
NET4: Unix domain sockets 1.0/SMP for Linux NET4.0.
Root-NFS: No NFS server available, giving up.
VFS: Unable to mount root fs via NFS, trying floppy.
kmod: failed to exec /sbin/modprobe -s -k block-major-2, errno = 2
VFS: Cannot open root device "nfs" or 02:00
Please append a correct "root=" boot option
Kernel panic: VFS: Unable to mount root fs on 02:00

I have created rootfs and configured NFS  from host end and Target but
i don't know where to put my kernel commandline parameters...

I'm doing something wrong in nfs setup, i couldn't find it out.

can anybody help me what are all configurations i have to do from host end and target end to get boot my target using rootfs by NFS.

It could be a great help for me,

Prabhakar

---

From: Jan-Benedict Glaw <[email-masked]>
Date: Sat, 18 Oct 2003 15:57:50 +0200

On Sat, 2003-10-18 19:12:30 -0000, Prabhakar <[email-masked]>
> Root-NFS: No NFS server available, giving up.

It seems you have neither compiled-in bootp or dhcp support, nor have
you given yout IP config at the command line (root=/dev/nfs
nfsroot=xx.xx.xx.aa:/path/to/root ip=xx.xx.xx.bb)

> i don't know where to put my kernel commandline parameters...

What boot loader do you use? Should be simple, though...

> I'm doing something wrong in nfs setup, i couldn't find it out.

Either you need bootp/dhcp to give an IP address (and boot config) out
to your machine, or you need to supply that data at the command line.

MfG, JBG

-- 
   Jan-Benedict Glaw       [email-masked]    . +49-172-7608481
   "Eine Freie Meinung in  einem Freien Kopf    | Gegen Zensur | Gegen Krieg
    fuer einen Freien Staat voll Freier Bürger" | im Internet! |   im Irak!
   ret = do_actions((curr | FREE_SPEECH) & ~(NEW_COPYRIGHT_LAW | DRM | TCPA));