Subject: cross debugging r3912 cpu with gdb

From: "Mark and Janice Juszczec" <[email-masked]>
Date: Sun, 07 Dec 2003 22:28:33 +0000

Hi folks

I'm trying to track down a SIGSEGV generated by kaffe on the Helio pda.  It 
uses a  Phillips R3912 cpu.

The gdb 6.0 docs say configure as follows:  configure 
--target=mips-idt-ecoff.  I did and mips shows up as an available target.

Unfortunately, when I try to connect to the pda via a USB serial connection, 
I get:

(gdb) set debug remote 2
(gdb) target mips /dev/ttyUSB0
Expected "<IDT>", got "": FAIL
Expected "<IDT>", got "": FAIL
Expected "<IDT>", got "": FAIL
Failed to initialize.
Ending remote MIPS debugging.
You can't do that without a process to debug

Further research shows there is supposed to be a target named r3900.  It 
doesn't show up under my available targets and

(gdb) target r3900 /dev/ttyUSB0

gives and error saying there is no target named r3900.

Can anyone out there give me advice about gdb and mips cross debugging?

Mark

_________________________________________________________________
Shop online for kids’ toys by age group, price range, and toy category at 
MSN Shopping. No waiting for a clerk to help you! http://shopping.msn.com

---

From: Daniel Jacobowitz <[email-masked]>
Date: Sun, 7 Dec 2003 17:54:38 -0500

> uses a  Phillips R3912 cpu.

You left out lots of details.  What operating system is the r3900
running?  From the list name, I assume it's Linux/MIPS.  So why did you
configure for mips-idt-ecoff?

If you're using gdbserver, then you want target=mips-linux and "target
remote", not "target mips".

> Unfortunately, when I try to connect to the pda via a USB serial 
> connection, I get:
> 
> (gdb) set debug remote 2
> Shop online for kids? toys by age group, price range, and toy category at 

-- 
Daniel Jacobowitz
MontaVista Software                         Debian GNU/Linux Developer