Subject: Re: gdbserver and Re: hardware questions

From: "Mark and Janice Juszczec" <[email-masked]>
Date: Mon, 29 Dec 2003 15:31:36 +0000

Kevin, et al

>
>If you want more of a "large format" mipsel platform
>to experiment with, you might be able to find an old
>"RISC PC" from Siemens or NEC with an R4000
>configured little-endian to run NT.  Maybe Ralf has
>one in his attic he'd care to sell you. ;o)
>

Ralf?

>I don't know that it's the root of your problem, but
>you should definitely get getty/shells off of whatever
>serial port you're trying to use for debug.

If I have no shell running on the serial port, how would I start gdbserver?  
Would I have to hard code it into the kernel somehow?

Mark

_________________________________________________________________
Expand your wine savvy — and get some great new recipes — at MSN Wine. 
http://wine.msn.com

---

From: Daniel Jacobowitz <[email-masked]>
Date: Mon, 29 Dec 2003 11:08:22 -0500

> Would I have to hard code it into the kernel somehow?

Try changing /etc/inittab to disable the getty, and starting gdbserver
from the system startup scripts in /etc/rc*.  I'm assuming you have
some other way than that shell on ttyS0 to modify the filesystem :)

-- 
Daniel Jacobowitz
MontaVista Software                         Debian GNU/Linux Developer