Subject: GCC 3.3.2 and Alchemy AU1100

From: "Hamilton, Ian" <[email-masked]>
Date: Tue, 9 Dec 2003 09:50:10 -0000

Hi there.

I'm trying to build software for the AMD AU1100 processor using version
3.3.2 of the gnu compiler, and I'm having trouble figuring out the -march,
-mtune, etc settings.

Version 2.95 of gcc uses something like -mcpu=r4600, but this doesn't work
with 3.3.2.

I've tried other likely-looking options (e.g. -mips32), but the compiler
fails to assembler instructions like mtc0 and cache.

Has anyone built for the AU1100 using gcc 3.3.2? If so, could you tell me
the cpu options you used please?

Thanks
Ian Hamilton.

---

From: Dirk Behme <[email-masked]>
Date: Tue, 09 Dec 2003 10:58:25 +0100

> the cpu options you used please?

For a VR41xx CPU with GCC 3.3.1 I have used

-march=r4600 -mips3 -Wa,--trap

instead of the old

-mcpu=r4600 -mips2 -Wa,--trap

Not sure whether this is correct (no test of the output on a target
yet), but it compiles.

---

From: "Lyle Bainbridge" <[email-masked]>
Date: Tue, 9 Dec 2003 04:16:19 -0600

Hi,

I am using GCC 3.3.2 to crosscompile the 2.4.22 kernel for
an Au1500 system under x86 Redhat 9.0 and I use the following
settings with success.

 -mtune=r4600 -mips2 -Wa,--trap

Cheers
Lyle

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Dirk Behme
> Sent: Tuesday, December 09, 2003 3:58 AM
> To: [email-masked]'
> Subject: Re: GCC 3.3.2 and Alchemy AU1100
> 
> 
> Hamilton, Ian wrote:
> 
> > Hi there.
> > 
> > I'm trying to build software for the AMD AU1100 processor using 
> > version 3.3.2 of the gnu compiler, and I'm having trouble 
> figuring out 
> > the -march, -mtune, etc settings.
> > 
> > Version 2.95 of gcc uses something like -mcpu=r4600, but 
> this doesn't 
> > work with 3.3.2.
> > 
> > I've tried other likely-looking options (e.g. -mips32), but the 
> > compiler fails to assembler instructions like mtc0 and cache.
> > 
> > Has anyone built for the AU1100 using gcc 3.3.2? If so, 
> could you tell 
> > me the cpu options you used please?
> 
> Not sure whether this is correct (no test of the output on a 
> target yet), but it compiles.
> 
> 
>