Subject: au1000_eth LEDs for mtx-1

From: Bruno Randolf <[email-masked]>
Date: Wed, 17 Dec 2003 10:15:37 +0100

this is also a patch i sent in a month ago:

hi again!

please also consider this small patch for enabling the traffic indication LEDs
of au1000_eth for the mtx-1 board.

thanks!

bruno

- --
4G Systeme GmbH
Am Sandtorkai 71
20457 Hamburg
fon: +49 (0)40 / 48 40 33 28
fax: +49 (0)40 / 48 40 33 30
mail: [email-masked]

--- /data/kernel/mips-2.4.23-rc5/drivers/net/au1000_eth.c	2003-11-26 10:51:55.000000000 +0100
+++ drivers/net/au1000_eth.c	2003-11-26 13:16:26.000000000 +0100
@@ -241,7 +241,11 @@
 	mdelay(1);
 
 	/* set up LEDs to correct display */
+#ifdef CONFIG_MIPS_MTX1
+	mdio_write(dev, phy_addr, 17, 0xff80);
+#else
 	mdio_write(dev, phy_addr, 17, 0xffc0);
+#endif
 
 	if (au1000_debug > 4)
 		dump_mii(dev, phy_addr);

---

From: Pete Popov <[email-masked]>
Date: 17 Dec 2003 07:59:37 -0800

Sorry, I was away for a while and Ralf was probably waiting for me to
take a look at these patches. I'll take care of them in the next couple
of days.

Pete

On Wed, 2003-12-17 at 01:15, Bruno Randolf wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 
> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.2.3 (GNU/Linux)
> 
> iD8DBQE/4B65fg2jtUL97G4RAskLAJ4o7vjuJ30wV/xnYCqebkwWqmPZpQCfc/+c
> zOVkCWZMQK7LMTWKgozboH0=
> =eKJn
> -----END PGP SIGNATURE-----