Subject: AutoNegotiation could not complete in PB1500 platform

From: "He Jin" <[email-masked]>
Date: Thu, 18 Dec 2003 11:36:59 +0800

Hi, Dear all,

I'm porting my own firmware code to PB1500, however some troubles ocurred with the Au1x NIC and LSI PHY. The dump of PHY register (the NIC initialization code is borrowed from the driver inside YAMON) is as follow:

////////////////////////////////////
 MII status: Link is up
 1th 0x3000
 2th 0x7809			=> should be 0x7829
		^^^^^^^^^^
 3th 0x16
 4th 0xf840
 5th 0x1e1
 6th 0x 0 			=> should be 0x45e1
		^^^^^^^^^^
17th 0x22
18th 0xffc0
////////////////////////////////////

It shows the MII interface couldn't finish the AutoNegotiation process. The values I think right is the output of some small probe programs using YAMON to boot the board and running those small probe programs . Besides, the LED in NIC interface could flash normally and we observed the LSI PHY chips should have been reset sucessfully in our firmware code using oscillograph device to probe the 'reset' pin in the PHY chips. 

If I use YAMON, everything OK. Could somebody tell me why ? 

Thanks a lot !

---

From: Ed Okerson <[email-masked]>
Date: Wed, 17 Dec 2003 22:55:37 -0600 (CST)

Did you set the EM bit in the mac_control register to match the endian
mode you are running the CPU in?

Ed Okerson