Subject: gdbserver and Re: hardware questions

From: "Mark and Janice Juszczec" <[email-masked]>
Date: Mon, 29 Dec 2003 14:09:17 +0000

Kevin

Good to hear from you.

Thank you to you and Geert for saving me the grief of buying the wrong 
hardware!

The whole point of buying some mipsel hardware is to better track down a 
SIGSEGV I'm having with kaffe on my mipsel pda.

People on this list have suggested I use gdbserver.  I've played around with 
it over the last month and have a feeling that it won't work.

I use busybox so its init applet can handle all the linux startup stuff I 
don't understand.  One side effect is it starts a shell on /dev/ttyS0.  No 
problem.

I can start gdbserver on the pda:  gdbserver /dev/ttyS0 ...

On my linux laptop, I can start gdb but, when I do:

target remote /dev/ttyS0

I never get connected to gdbserver on the pda.

I suspect its because there's alread a shell running on /dev/ttyS0.  Does 
this sound reasonable?

Other than debugging with gdb, any suggestions as to tracking down a SIGSEGV 
on a pda with a shell on /dev/ttyS0?

Mark

>From: "Kevin D. Kissell" <[email-masked]>
>To: "Mark and Janice Juszczec" <[email-masked]>,   
><[email-masked]>
>Subject: Re: hardware questions
>Date: Mon, 29 Dec 2003 12:39:02 +0100
>
>As Geert pointed out, the big-endian SGI hardware configuration
>and the little-endian PDA configuration mean that you'll be cross-compiling
>for "mipsel" (MIPS endian-little) on the Indigo anyway.  SGI did
>use industry-standard monitors, keyboards, and disks units of the
>period (which was 10 years ago - they could be hard to find today),
>but used non-standard NIC and memory cards. You're probably better
>off using a Linux PC as your development host.
>
>----- Original Message -----
>From: "Mark and Janice Juszczec" <[email-masked]>
>To: <[email-masked]>
>Sent: Sunday, December 21, 2003 17:20
>Subject: hardware questions
>
>
> >
> > Hi folks
> >
> > I'm the guy with the Helio pda running an r3912 chip.  In an effort to
> > create a better development environment, I'm thinking about puchasing a
> > Silicon Graphics Iris Indigo Workstation.
> >
> > But, I'm unfamiliar with MIPS hardware.
> >
> > First of all, will code developed on this machine run on the r3912 chip?
> > The r3912 is little endian mips, 16 bit I think but maybe 32 bit.
> >
> > Can off the shelf monitors, keyboards, hard drives, NICs and memory be
> > installed in this system?
> >
> > Mark
> >
> > _________________________________________________________________
> > Grab our best dial-up Internet access offer: 6 months @$9.95/month.
> > http://join.msn.com/?page=dept/dialup
> >
> >
> >

_________________________________________________________________
Working moms: Find helpful tips here on managing kids, home, work —  and 
yourself.   http://special.msn.com/msnbc/workingmom.armx

---

From: "Kevin D. Kissell" <[email-masked]>
Date: Mon, 29 Dec 2003 15:18:58 +0100

If you want more of a "large format" mipsel platform
to experiment with, you might be able to find an old
"RISC PC" from Siemens or NEC with an R4000
configured little-endian to run NT.  Maybe Ralf has
one in his attic he'd care to sell you. ;o)

I've never used gdbserver myself.  I did manage to get
some use out of the old 2.2-style kernel gdb hooks.
I don't know that it's the root of your problem, but
you should definitely get getty/shells off of whatever
serial port you're trying to use for debug.  In theory,
there are protocols to multiplex serial ports between
gdb streams and other stuff, but I've never had any
luck with them.   You may also need to make sure that
you're starting gdb and gdbserver in the right order.
Certainly, that was the case when booting with kgdb.

            Regards,

            Kevin K.

----- Original Message ----- 
From: "Mark and Janice Juszczec" <[email-masked]>
To: <[email-masked]>; <[email-masked]>
Sent: Monday, December 29, 2003 15:09
Subject: gdbserver and Re: hardware questions

> Working moms: Find helpful tips here on managing kids, home, work -  and

---

From: Ralf Baechle <[email-masked]>
Date: Mon, 29 Dec 2003 19:11:39 +0100

> one in his attic he'd care to sell you. ;o)

Unfortunately no.  Since Thomas Bogendoerfer stopped maintaining the Olivetti
support the support for MIPS Magnum 4000, MIPS Millenium, Olivetti M700-10
and Acer PICA is rotting away ...

> Certainly, that was the case when booting with kgdb.

We have a special GDB console kernel option which is meant to support
exactly that kind of gdb + console multiplexing.

  Ralf

---

From: Karsten Merker <[email-masked]>
Date: Mon, 29 Dec 2003 20:41:24 +0100

> and Acer PICA is rotting away ...

An R4000/R4400-based DECstation would be another option.  Most of the
DECstations are quite slow by today's standards, but a DECstation
5000/150 or 5000/260 is about as fast as a low-end SGI Indy
(50/100MHz R4000 in the /150, 60/120MHz R4400 in the /260).

HTH,
Karsten
-- 
#include <standard_disclaimer>
Nach Paragraph 28 Abs. 3 Bundesdatenschutzgesetz widerspreche ich der Nutzung
oder Uebermittlung meiner Daten fuer Werbezwecke oder fuer die Markt- oder
Meinungsforschung.