Subject: Indy R4000PC problems

From: Markus Dahms <[email-masked]>
Date: Mon, 2 Feb 2004 17:07:29 +0100

Hi,

I had problems getting the 2.4 kernel to work on an Indy with
a R4000PC (100MHz) processor (very old PROM, too).
The solution I found yesterday is to change an entry in
arch/mips/kernel/cpu-probe.c from CPU_R4000SC to CPU_R4000PC.
Is there a reason why only the SC version is thought to be
there, or is it believed to be compatible?
Without this change the machine locks up after loading the
kernel, linux hasn't switched to the black background, yet.

I also changed the compiler flags from -m{arch,tune}=r4600 to
*r4000, but this I also tried before without success.

greetings,

	Markus Dahms

-- 
A bug in the code is worth two in the documentation.

---

From: "Steven J. Hill" <[email-masked]>
Date: Thu, 05 Feb 2004 12:49:41 -0500

> there, or is it believed to be compatible?
The SC stands for secondary cache. So one would expect that if
your Indy only has a primary cache (PC) and you are detecting
as an Indy with SC, you will crash since there is no secondary
cache.

-Steve

---

From: Ralf Baechle <[email-masked]>
Date: Thu, 5 Feb 2004 18:51:46 +0100

> there, or is it believed to be compatible?

The PC and SC versions are basically identical except the second level
cache which is missing in the PC version.

> *r4000, but this I also tried before without success.

Do you know which version of the processor this is exactly?  IRIX's hinv
command or the "CPU revision is: ..." line of bootup messages contain
that information.

The PC version have become pretty rare, didn't recall anymore it was in
use in Indys at all.  Anyway, please try the patch below and let me know.

  Ralf

Index: arch/mips/mm/c-r4k.c
===================================================================
RCS file: /home/cvs/linux/arch/mips/mm/c-r4k.c,v
retrieving revision 1.3.2.65
diff -u -r1.3.2.65 c-r4k.c
--- arch/mips/mm/c-r4k.c	2 Feb 2004 22:24:37 -0000	1.3.2.65
+++ arch/mips/mm/c-r4k.c	5 Feb 2004 17:50:37 -0000
@@ -965,10 +965,8 @@
 	 * Linux memory managment.
 	 */
 	switch (c->cputype) {
-	case CPU_R4000PC:
 	case CPU_R4000SC:
 	case CPU_R4000MC:
-	case CPU_R4400PC:
 	case CPU_R4400SC:
 	case CPU_R4400MC:
 		probe_scache_kseg1 = (probe_func_t) (KSEG1ADDR(&probe_scache));
Index: arch/mips/kernel/cpu-probe.c
===================================================================
RCS file: /home/cvs/linux/arch/mips/kernel/cpu-probe.c,v
retrieving revision 1.1.2.31
diff -u -r1.1.2.31 cpu-probe.c
--- arch/mips/kernel/cpu-probe.c	19 Jan 2004 18:32:05 -0000	1.1.2.31
+++ arch/mips/kernel/cpu-probe.c	5 Feb 2004 17:50:39 -0000
@@ -192,10 +192,18 @@
 		c->tlbsize = 64;
 		break;
 	case PRID_IMP_R4000:
-		if ((c->processor_id & 0xff) >= PRID_REV_R4400)
-			c->cputype = CPU_R4400SC;
-		else
-			c->cputype = CPU_R4000SC;
+		if (read_c0_config() & CONF_SC) {
+			if ((c->processor_id & 0xff) >= PRID_REV_R4400)
+				c->cputype = CPU_R4400SC;
+			else
+				c->cputype = CPU_R4000SC;
+		} else {
+			if ((c->processor_id & 0xff) >= PRID_REV_R4400)
+				c->cputype = CPU_R4400SC;
+			else
+				c->cputype = CPU_R4000SC;
+		}
+
 		c->isa_level = MIPS_CPU_ISA_III;
 		c->options = R4K_OPTS | MIPS_CPU_FPU | MIPS_CPU_32FPR |
 		             MIPS_CPU_WATCH | MIPS_CPU_VCE |

---

From: Ralf Baechle <[email-masked]>
Date: Thu, 5 Feb 2004 19:10:46 +0100

> use in Indys at all.  Anyway, please try the patch below and let me know.

Argh...  Famous class of bugs when one is about to run out of the door.
The CONF_SC bit is inverted so the test for it needs to be inverted.
WIll post a new patch later.

  Ralf

---

From: Markus Dahms <[email-masked]>
Date: Fri, 6 Feb 2004 11:21:15 +0100

Hallo Ralf Baechle,

[R4000PC]
> command or the "CPU revision is: ..." line of bootup messages contain

R4000 V3.0 I believe. I'll check it, when I'm at home again.

> use in Indys at all.  Anyway, please try the patch below and let me know.

I checked the cvs version from yesterday (20040205), which contained
some changes in cpu-probe.c; it worked!

Greetings, Markus

PS: sorry for the response times, our mail system is totally overloaded
    at the moment.

-- 
Disc space -- the final frontier!

---

From: Markus Dahms <[email-masked]>
Date: Fri, 6 Feb 2004 14:46:55 +0100

> R4000 V3.0 I believe. I'll check it, when I'm at home again.

checked it:

[dmesg]
| CPU revision is: 00000430
| FPU revision is: 00000500

[/proc/cpuinfo]
| cpu model               : R4000PC V3.0  FPU V0.0

Markus

-- 
Any given program will expand to fill available memory.