Subject: IT8172 IDE support in 2.4.24

From: Adam Kiepul <[email-masked]>
Date: Thu, 19 Feb 2004 10:17:25 -0800

Hi,

Could anyone please tell me whether the 2.4.24 source actually supports the IDE HDD in the default configuration for the ITE 8172?
I have built the kernel and it boots up fine with the NFS root. However, it is unable to mount the root file system on a HDD. When I try to mount the /dev/hda1 while running with NFS root I get the "/dev/hda1 is not a valid block device" message. Am I missing something?

Thanks a lot,

-------------------
Adam Kiepul
Sr. Applications Engineer

PMC-Sierra, Microprocessor Division
Mission Towers One
3975 Freedom Circle
Santa Clara, CA 95054, USA
Direct: 408 239 8124
Fax: 408 492 9462
http://www.pmc-sierra.com/processors

---

From: Jeffrey Baitis <[email-masked]>
Date: 19 Feb 2004 17:42:28 -0800

Hi Adam:

Here's a more generic test. can you try

        for i in a b c d ; do
          echo "Trying hd$i";
          dd if=/dev/hd$i count=1 of=/dev/null;
        done

Not sure offhand if the ITE 8172 has multiple IDE channels/headers; your
HDD may also have an unreadable partition table.

Good luck
-Jeff

-- 
Jeffrey Baitis <[email-masked]>