Subject: Linux 2.6 on DDB5477?

From: [email-masked] (Kaz Sasayama)
Date: Mon, 16 Feb 2004 00:19:32 -0500

Is anyone working on DDB5477 config of Linux 2.6?  I tried to compile it 
but got many errors that I could not fix completely.  If there is a working
patch, please let me know.

Thanks in advance.

__________________________________________________________________
New! Unlimited Netscape Internet Service.
Only $9.95 a month -- Sign up today at http://isp.netscape.com/register
Act now to get a personalized email address!

Netscape. Just the Net You Need.

---

From: Jun Sun <[email-masked]>
Date: Mon, 16 Feb 2004 09:44:52 -0800

> patch, please let me know.

It basically works fine here, with a couple of known issues:

. sound driver is broken.  Just comment it out.
. if you use rockhopper baseboard, you will the following patch to access
  the ethernet on baseboard.  [Ralf, we need to fix origin and apply this
  patch somehow]
. under long time stress test, ether driver may go down.

Jun

diff -u -r1.25 pci.c
--- arch/mips/pci/pci.c 19 Jan 2004 16:28:13 -0000      1.25
+++ arch/mips/pci/pci.c 16 Feb 2004 17:41:38 -0000
@@ -166,7 +166,7 @@
 
        pci_read_config_word(dev, PCI_COMMAND, &cmd);
        old_cmd = cmd;
-       for(idx=0; idx<6; idx++) {
+       for(idx=0; idx< PCI_NUM_RESOURCES; idx++) {
                /* Only set up the requested stuff */
                if (!(mask & (1<<idx)))
                        continue;