Subject: RE: questions about making a script file for YAMON command

From: "Ren, Manling" <[email-masked]>
Date: Thu, 12 Feb 2004 13:45:25 -0000

Dear the technical support team,
 
I am running YAMON on pb1100 board in Linux.  At the YAMON prompt, I need to
change some registers by using the command "edit -32 0x########"  several
times.  I wonder if I can put all these "edit" commands into a script file
then run this file without typing any more commands?  How can I achieve this
if it is possible.  It seems that the "load" command in YAMON is only
supported srec file.  Could you give me some clues please.  Thanks a lot.
 
Regards,
Manling
 
____________________________ 
Manling Ren  :-)* ******* *****                

Welwyn OPDU Software Architecture Team 
OPDU                    
Xerox Limited Technical Centre 
DP2         
Bessemer Road               
Welwyn Garden City  AL7 1HE         
Hertfordshire               
UK                          
%    +44 (0)1707 35 2704                  
*     8 668 2704 (xerox intranet)         
*     +44 (0)1707 35 3947         
*    [email-masked]  
_________________________________

---

From: Jan-Benedict Glaw <[email-masked]>
Date: Thu, 12 Feb 2004 15:08:21 +0100

On Thu, 2004-02-12 13:45:25 -0000, Ren, Manling <[email-masked]>
> Dear the technical support team,

No technical support team here, just a number of hackers...

> times.  I wonder if I can put all these "edit" commands into a script file

Personally, I don't know yamon since nobody offered a board using it to
me, but if it uses serial console, just prepare a text file containing
all the lines you need to type. Then, cut'n'paste the commands to
minicom or whatever you use...

MfG, JBG

-- 
   Jan-Benedict Glaw       [email-masked]    . +49-172-7608481
   "Eine Freie Meinung in  einem Freien Kopf    | Gegen Zensur | Gegen Krieg
    fuer einen Freien Staat voll Freier Bürger" | im Internet! |   im Irak!
   ret = do_actions((curr | FREE_SPEECH) & ~(NEW_COPYRIGHT_LAW | DRM | TCPA));

---

From: Wolfgang Denk <[email-masked]>
Date: Thu, 12 Feb 2004 15:20:02 +0100

> Dear the technical support team,

Did you pay a support contract? ;-)

> then run this file without typing any more commands?  How can I achieve this

Use the standard tools you can find in your Unix environment. In this
case, use expect.

Best regards,

Wolfgang Denk

-- 
See us @ Embedded World, Nuremberg, Feb 17 - 19,  Hall 12.0 Booth 440
Phone: (+49)-8142-4596-87  Fax: (+49)-8142-4596-88  Email: [email-masked]
"No matter where you go, there you are..."          - Buckaroo Banzai

---

From: Goswin von Brederlow <[email-masked]>
Date: 12 Feb 2004 18:21:45 +0100

> Use the standard tools you can find in your Unix environment. In this

Or rebuild yamon to your likeing.

MfG
        Goswin