Subject: [ANNOUNCE] "cvs explorer" for linux-mips CVS tree

From: Jun Sun <[email-masked]>
Date: Wed, 4 Feb 2004 15:08:20 -0800

I wrote a CVS tracking tool that tracks CVS changes in patch format
and present them with a web interface.  It is now set up to track
linux-mips.org tree at the following place.  Enjoy.

http://www.linux-mips.org/xcvs/linux-mips

BTW, if you use this tool for tracking other trees, please drop me a
note.  Of course, I also like to have more developers to participate.  
Please join us at

http://xcvs.sf.net

Jun

---

From: Geert Uytterhoeven <[email-masked]>
Date: Thu, 5 Feb 2004 12:19:34 +0100 (MET)

> http://www.linux-mips.org/xcvs/linux-mips

http://www.linux-mips.org/xcvs/html/select.php
| Warning: Assertion failed in /var/www/www.linux-mips.org/xcvs/html/db.inc.php on line 36
| Warning: readfile("/LAST_UPDATE") - No such file or directory in /var/www/www.linux-mips.org/xcvs/html/select.inc.php on line 47

Gr{oetje,eeting}s,

						Geert

--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- [email-masked]

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
							    -- Linus Torvalds

---

From: Jun Sun <[email-masked]>
Date: Thu, 5 Feb 2004 10:05:25 -0800

> | Warning: readfile("/LAST_UPDATE") - No such file or directory in /var/www/www.linux-mips.org/xcvs/html/select.inc.php on line 47

It appears session somehow does not work on your web viewer.  What is 
your web browser anyway?

Immediately after you hit above link, please redirect URL to

http://www.linux-mips.org/xcvs/test.php

If you don't see following, that means sessions do not work.

------------------------------------------------
dbname : xcvs_linux_mips
patchdir : ../linux-mips/patches
branch : MAIN
author : all authors
starting-date :
ending-date :
-----------------------------------------------

Anybody else has similar problems?

Jun

---

From: Johannes Stezenbach <[email-masked]>
Date: Thu, 5 Feb 2004 19:40:08 +0100

> note.  Of course, I also like to have more developers to participate.  

Very good!

I played with cvsps a few times, but didn't dare to use it
on such a large tree like the Linux kernel.

A few nits:
- I would prefer a "latest first" sort order in the patchset listing
- IMHO 'diff -up' would make the patchsets much easier to read
- could you please add a <title> tag for the query page? (For
  easier bookmarking.)

The README from the sources mentions some constraints:

 ". Branching is always a complete branching of the whole tree."

What happens when only a part of a tree is branched?

 ". Commitment only modifies the head of a given branch."

I don't understand this. CVS commits will always change the head
of a branch (or the trunk) only, no?

How would one use xcvs on a repository with many different, but
interdependent CVS modules (e.g. gnome CVS http://cvs.gnome.org/)?

Johannes

---

From: "Gleb O. Raiko" <[email-masked]>
Date: Thu, 05 Feb 2004 21:15:15 +0300

> Anybody else has similar problems?

Sure, IE6 w/ high security settings. Had to accept all cookies from
linux-mips.org in order to fix the problem.

Regards,
Gleb.

---

From: Jun Sun <[email-masked]>
Date: Thu, 5 Feb 2004 11:39:40 -0800

> linux-mips.org in order to fix the problem.

I thought if a browser refuses to accept cookies, PHP would
fall back to use explicit SID get variable in URL.  Strange.

Jun

---

From: Jun Sun <[email-masked]>
Date: Thu, 5 Feb 2004 11:43:16 -0800

> - could you please add a <title> tag for the query page? (For

Good suggestions.  Patches are even more welcome. :)

> What happens when only a part of a tree is branched?

Probably does not hurt.

> of a branch (or the trunk) only, no?

These statements are over paranoid.

> interdependent CVS modules (e.g. gnome CVS http://cvs.gnome.org/)?

Don't know yet.  Have not given a thought.

BTW, this kind of discussions probably should go to xcvs list.  Pretty
soon I think Ralf will revoke our posting previledges. :)

Jun

---

From: Geert Uytterhoeven <[email-masked]>
Date: Thu, 5 Feb 2004 21:22:20 +0100 (MET)

> It appears session somehow does not work on your web viewer.  What is

Galeon (from Debian testing or unstable on ia32).

> If you don't see following, that means sessions do not work.

... and all I see is the two lines with hyphens.

> Anybody else has similar problems?

OK, if I enable cookies, it works fine! Nice!

Gr{oetje,eeting}s,

						Geert

---

From: Ralf Baechle <[email-masked]>
Date: Thu, 5 Feb 2004 22:51:26 +0100

> soon I think Ralf will revoke our posting previledges. :)

Hey, if I'd be consequent I'd then have to revoke posting priviledges
for myself fi...

DISCONNECT