Subject: configuring console to use a different UART

From: Prashant Viswanathan <[email-masked]>
Date: Wed, 4 Feb 2004 14:42:13 -0800

Hi,

How can I change the kernel so that it uses the UART I specify for the
console instead of the first available one? I dont want to pass this on the
bootline but want to compile this into vmlinux.

Thanks
Prashant

---

From: Jun Sun <[email-masked]>
Date: Wed, 4 Feb 2004 15:01:04 -0800

> bootline but want to compile this into vmlinux.

With 2.6, set CONFIG_CMDLINE with something like:

console=ttyS1,38400

With 2.4, add (strcpy or strcat) the above string to your arcs_cmdline 
defined by your specific board code.

Jun