Subject: indy r4000FPC kernel?

From: Joost <[email-masked]>
Date: Thu, 12 Feb 2004 17:12:58 +0100 (CET)

Hello,

Is this the correct list to be asking about kernel trouble?
If not, i apologize for this lengthy piece of offtopic ranting :-)

  I'm trying to get a working kernel on my indy, but 2.4.16
seems to be as far as it will go. The 2.4.22 that comes with
debian testing gives an error while booting so i decided
to try and be adventurous and downloaded the 2.6 sources
via cvs. The PROM in this beast is old i gues, it won't
boot elf kernels, so i used the 'ecoff' tip on linux-mips.com.
  Going from elf to ecoff gives out a warning:
arch/mips/boot/elf2ecoff vmlinux vmlinux.ecoff
wrote 20 byte file header.
wrote 56 byte a.out header.
wrote 120 bytes of section headers.
wrote 12 byte pad.
writing 3685492 bytes...
Warning: 908 byte intersegment gap.
writing 499845 bytes...
  Is this warning about the 'intersegment gap' something I
can safely ignore?
  After booting this kernel it panics, complaining about
'unaligned instruction access in arch/mips/kernel/unaligned.c::do_ade,
line 544[#1]: cpu 0' followd by lots of yukkie numbers and a call trace:
[<883e558c>] mem_init+0x6c/0x1e4
[<883ef580>] start_kernel+0x114/0x238
[<883ef588>] start_kernel+0x17c/0x238
[<883ef30c>] unknown_bootoption+0x0/0x130
[<883ef08c>] no_smp+0x0/0x10
Kernel Panic! Attempted to kill the idle task!

  Am I doing something obvious wrong? The compiler in use is
gcc-2.95.4, the machine is an indy with r4000FPC. I'm doing
a native compile (yes, my time is cheap :-).

Thank you for your time!

Joost.
--
I have spent most of my money on women and beer. The rest I just wasted...

---

From: "Dominik 'Rathann' Mierzejewski" <[email-masked]>
Date: Thu, 12 Feb 2004 17:42:05 +0100

> boot elf kernels, so i used the 'ecoff' tip on linux-mips.com.

Get a current version (branch linux_2_4) from linux-mips.org's CVS
and try that one. There have been some trouble with r4k processors
lately, but they seem to be resolved now. I'm running 2.4.25-pre6
at the moment. Oh, and use arcboot - it saves a lot of hassle.
You don't have to upload your kernel to volume header and you can
boot any ELF kernel image that is on any ext2/3 partition on your
system.

HTH

-- 
Dominik 'Rathann' Mierzejewski <[email-masked]>                                                 
Interdisciplinary Centre for Mathematical and Computational Modelling                               
Warsaw University  |  http://www.icm.edu.pl  |  tel. +48 (22) 5540810

---

From: Joost <[email-masked]>
Date: Thu, 12 Feb 2004 18:03:35 +0100 (CET)

> boot any ELF kernel image that is on any ext2/3 partition on your
Thank you!
I will give it a try right now, should be finished by dawn :-)

Joost.
-- 
When I was a child I could remember anything...
Whether it happened or not. -- Mark Twain

---

From: Guido Guenther <[email-masked]>
Date: Thu, 12 Feb 2004 18:48:22 +0100

> debian testing gives an error while booting so i decided
What kind of error?
 -- Guido

---

From: Joost <[email-masked]>
Date: Thu, 12 Feb 2004 19:46:36 +0100 (CET)

> > debian testing gives an error while booting so i decided
It might have been the "can't load elf" problem. I'm very new
to all of this so at the time (yesterday :-) I didn't know a
solution existed. If it's important to you I could check again
tomorow?

Joost.
-- 
"I distrust camels, and anyone else who can go for a week without a drink."
-- Joe E Lewis

---

From: Guido Guenther <[email-masked]>
Date: Thu, 12 Feb 2004 21:10:20 +0100

> solution existed. If it's important to you I could check again
Yes please do. Thanks.
 -- Guido

---

From: Joost <[email-masked]>
Date: Fri, 13 Feb 2004 09:37:00 +0100 (CET)

> > solution existed. If it's important to you I could check again
After running elf2ecoff on it, the kernel from debian testing
(kernel-image-2.4.22-r4k-ip22) seems to run just fine.
The linux_2_4 cvs that compiled this night also works ok.

Many thanks for all your help!

Joost.
-- 
"Love is the delusion that one woman differs from another." -- HL Mencken

---

From: Guido Guenther <[email-masked]>
Date: Fri, 13 Feb 2004 15:17:07 +0100

> The linux_2_4 cvs that compiled this night also works ok.
Thanks a lot for testing this. BTW you can avoid elf2ecoff by using
arcboot.
Cheers,
 -- Guido