Subject: CONFIG_XIP_ROM vs. CONFIG_XIP_KERNEL

From: Tim Bird <[email-masked]>
Date: Thu, 29 Apr 2004 12:07:17 -0700

I'm looking at some sources for kernel Execute-in-place (XIP).

I see references to CONFIG_XIP_ROM and CONFIG_XIP_KERNEL,
in different architecture branches of the same kernel
source tree.

Is this difference merely the result of inconsistent
usage, or is there a functional difference between
these two options?

I can imagine that CONFIG_XIP_ROM is intended only to
handle XIP in ROM, and that CONFIG_XIP_KERNEL possibly
handles additional cases like XIP in flash.  However,
before jumping to that conclusion I thought I would
ask if there is some intention behind the different
config names.

Thanks,

=============================
Tim Bird
Architecture Group Co-Chair
CE Linux Forum
Senior Staff Engineer
Sony Electronics
E-mail: Tim.Bird (at) am.sony.com
=============================

---

From: Ralf Baechle <[email-masked]>
Date: Thu, 29 Apr 2004 22:09:27 +0200

> ask if there is some intention behind the different

Since you copied linux-mips - neither option is implemented for MIPS ...

  Ralf

---

From: Nicolas Pitre <[email-masked]>
Date: Thu, 29 Apr 2004 16:49:45 -0400 (EDT)

> usage, or is there a functional difference between

It's the result of me deciding CONFIG_XIP_ROM wasn't totally appropriate ...  

> ask if there is some intention behind the different

... so I renamed it to CONFIG_XIP_KERNEL.  Especially since there is also 
XIPable user space which also can be stored in ROM (or flash).  So please 
disregard CONFIG_XIP_ROM and use CONFIG_XIP_KERNEL.  Whether ROM or Flash is 
used is rather irrelevant to the code this option is linked to.

Nicolas

---

From: Ralf Baechle <[email-masked]>
Date: Fri, 30 Apr 2004 03:34:10 +0200

On Thu, Apr 29, 2004 at 01:56:53PM -0700, Tim Bird wrote:

> Well this is interesting.  One the architectures where this is supported
> in my tree is MIPS.  I'm looking at the CELF source tree. The patch for
> this was submitted to me by Toshiba.  I had assumed (based on some other
> indications) that they were submitting stuff to me that they had already
> submitted to kernel.org or to the MIPS list.  This appears not to be
> the case.
> 
> We should discuss this.  I have some patches for MIPS stuff in the
> CELF tree from MontaVista, Toshiba, and NEC.   Unfortunately, the
> CELF tree is based on Linux 2.4.20, so I don't know how much of it,
> if any, would be useful to you.

Depends.  The linux-mips.org tree is at 2.4.26.  Some areas have changed
significantly since 2.4.20, some not at all.  If you want to send patches
please make sure they still apply to the latest kernel.

> How do I proceed with finding out what's interesting, and how to get
> it to you?  Just post some stuff (even if old) to the mips mailing
> list?  Request the originator to do such a post?  Do things need to
> be migrated to 2.6?

Preferably yes.  I don't really care who sends the patch as long as the
sender takes responsibility also after the initial submission.

Any new features preferably for 2.6.

>  Could we bypass that for a casual "is this interesting" review?  Etc.

If all you need is a comment, sure.

> The questions are endless.
> Let me know what you think.
> 
> And, BTW, in my tree the variable used for MIPS is CONFIG_XIP_ROM.
> For SH, it's CONFIG_XIP_KERNEL, and for ARM, it has conditionals
> for both, but only defines CONFIG_XIP_ROM in the config.in!

In the kernel.org kernel the only references to these symbols are to
CONFIG_XIP_KERNEL in a few files under arch/arm26.

  Ralf