Subject: relocation overflow of type 4 __copy_user

From: santosh khare <[email-masked]>
Date: Fri, 23 Apr 2004 11:44:52 -0700 (PDT)

Hi
When I am trying to insmod iptables.o I am getting this error multiple times.
 
relocation overflow of type 4 __copy_user
relocation overflow of type 4 __copy_user
relocation overflow of type 4 __copy_user
.........
 
I was getting similar errors for printk etc but they disappeared after I changed the CFLAGS  for arch/mips/Makefile and included -mno-abicalls.
 
Please let me know how can I get rid of this relocation overflow.
 
Looking at /proc/ksyms I see following.
 
#cat /proc/ksyms | grep __copy_user
802e0144 __copy_user
 
Santosh

---------------------------------
Do you Yahoo!?
Yahoo! Photos: High-quality 4x6 digital prints for 25¢

---

From: santosh khare <[email-masked]>
Date: Fri, 23 Apr 2004 14:29:46 -0700 (PDT)

I have changed 
CONFIG_IP_TABLES=y to 
CONFIG_IP_TABLES=m
 in .config file.
make modules now building ip_tables.o and I do not have this error any more.
Although, executing iptables utility is giving following error.
 
ip_tables: applet not found
can't initialize iptables table 'filter': table does not exist
perhaps iptables or your kernel needs to be upgraded.
 
Any ideas?
 
Santosh

"Steven J. Hill" <[email-masked]> wrote:
santosh khare wrote:
> I was getting similar errors for printk etc but they disappeared after I 
> changed the CFLAGS for arch/mips/Makefile and included -mno-abicalls.
>
This flag is already included by default in both 2.4 and 2.6 kernels. How
did you compile your module?

-Steve

Santosh Khare
425 556 0845 (H)
425 241 3566 (C)

Santosh Khare
425 556 0845 (H)
425 241 3566 (C)