Subject: few questions about linux on sgi machines

From: Alex Deucher <[email-masked]>
Date: Thu, 22 Apr 2004 10:49:16 -0700 (PDT)

Is the PCI slot supported on the o2 (i.e., could I put a linux
supported pci card in and use it)?  Also is the o2 AV IO board
supported?  Is that encompassed by VICE or is that separate?

What about the PCI slots on o200?  Are they supported?

Also, out of curiosity, is there a list somewhere of all the asics in
the Octane?  e.g., sound chip(s), ethernet, parallel/serial, etc.

Thanks,

Alex

		
__________________________________
Do you Yahoo!?
Yahoo! Photos: High-quality 4x6 digital prints for 25¢
http://photos.yahoo.com/ph/print_splash

---

From: Stanislaw Skowronek <[email-masked]>
Date: Thu, 22 Apr 2004 20:28:46 +0200 (MET DST)

> the Octane?  e.g., sound chip(s), ethernet, parallel/serial, etc.

Yes! (It depends what do you call an ASIC. I use it for a SGI-specific
chip with no docs at all.)

-- Base I/O --
HEART	memory controller, Xtalk bridge
IOC3	multi-I/O
RAD1	audio
BRIDGE	Xtalk-PCI bridge?
-- Frontplane --
XBOW	Xtalk router
-- PCI card cage (correct this) --
BRIDGE	Xtalk-PCI bridge
-- MardiGras (this is one big mystery) --
HQ4	Xtalk bridge
GE11	geometry engine
RE4	raster engine
PP1	?
VC3	video controller?
CMAP	colormap?

I'm writing this from memory, so correct me please.

Stanislaw Skowronek

---

From: Christoph Hellwig <[email-masked]>
Date: Thu, 22 Apr 2004 22:29:07 +0200

> chip with no docs at all.)

Yes.  The same as used in the IP27 btw.

> XBOW	Xtalk router

Also shared witg IP27.

---

From: Christoph Hellwig <[email-masked]>
Date: Fri, 23 Apr 2004 15:17:06 +0200

> What about the PCI slots on o200?  Are they supported?

There's is PCI support but there's some problems, mosty because the
Linux support code isn't as nice as it should and we support only
glogic fibre channels and scsi cards and the SGI ioc3 currently.

Fixing that is in-progress but even then you could have problems with
most standard linux drivers because the pci hardware on all systems
using the bridge ASIC and it's sucessors (xbridge, pic) violate some
ordering contraints in the PCI spec.  The SGI folks doing the SN1/SN2
IA64 port have come up with workaround for xbride and pic but I'm not
sure they're applicable to IP27.

---

From: Alex Deucher <[email-masked]>
Date: Fri, 23 Apr 2004 06:29:01 -0700 (PDT)

> sure they're applicable to IP27.

I assume IP30 has the same problems since they are similarly
architected?  What about IP32?

Thanks,

Alex

---

From: Christoph Hellwig <[email-masked]>
Date: Fri, 23 Apr 2004 15:31:06 +0200

On Fri, Apr 23, 2004 at 06:29:01AM -0700, Alex Deucher wrote:
> architected?

I guess it has the same problems as it's using the bridge ASIC, too.

> What about IP32?

It uses a completely different pci subsystem that should be okay.

---

From: Ralf Baechle <[email-masked]>
Date: Mon, 26 Apr 2004 14:52:53 +0200

> It uses a completely different pci subsystem that should be okay.

It's not fully PCI compliant either ...

  Ralf