Subject: MIPS status in 2.6

From: Tim Bird <[email-masked]>
Date: Fri, 07 May 2004 15:10:40 -0700

Anyone know what the status is of MIPS support in 2.6?

=============================
Tim Bird
Architecture Group Co-Chair
CE Linux Forum
Senior Staff Engineer
Sony Electronics
E-mail: [email-masked]
=============================

---

From: Jun Sun <[email-masked]>
Date: Fri, 7 May 2004 15:58:11 -0700

> Anyone know what the status is of MIPS support in 2.6?

32bit has been working pretty well, including preemption, kgdb,
SMP, etc.  IO subsystems have not been thoroughly tested.  Board support
varies.

64bit needs some work.

Jun

---

From: Pete Popov <[email-masked]>
Date: Fri, 07 May 2004 16:04:17 -0700

>SMP, etc.  IO subsystems have not been thoroughly tested.  Board support
AMD Alchemy boards:
- serial driver was updated
- ethernet driver works, but seens some minor updates
- kind of a beta version of the 36bit address support was sent to Ralf
- pcmcia driver was rewritten for 2.6, but only for db1x00 right now. 
The rest of the boards need to be updated.
- usb host needs work
- pci bus seems to work (with the 36bit patch)
- sound driver needs update from OSS to ALSA
- Au1100 FB driver needs to be updated to 2.6
- Epson FB driver too (I won't work on that one)
- usb gadget support is needed

I may be forgetting something. I'm working on it part time.

Pete