Subject: gp_disp

From: "Nilanjan Roychowdhury" <[email-masked]>
Date: Thu, 27 May 2004 14:26:54 +0530

Hi,
I have a kernel module which works fine with linux X86 combo.
But when I try to compile it with mips cross toll chain it compiles well but insmod gives me error on "_gp_disp" unknown symbol.
 
How do I get rid of that ??? Do I need to do anything special with my compiler flags.

---

From: Ralf Baechle <[email-masked]>
Date: Thu, 27 May 2004 11:25:15 +0200

> I have a kernel module which works fine with linux X86 combo.

Which provides aproximately zero proof for the correctness of your code,
sorry ...

> But when I try to compile it with mips cross toll chain it compiles well
> but insmod gives me error on "_gp_disp" unknown symbol.
>  

Read the FAQ, it's described there.

  Ralf