Subject: setup X11 on MIPS64/MALTA

From: "Ratin Kumar" <[email-masked]>
Date: Mon, 17 May 2004 17:00:53 -0700

Hi,

I am trying to get X11 up on my MALTA (MIPS 64, little endian board). I have
the frame buffer working (using Matrox Mill - II PCI card). I also have the
Red Hat 7.3 installation going but I am not able to get X to work. Has any
one tried this combination OR if there is any advice on this ??

Thanks in advance.

-Ratin.

---

From: Stuart Longland <[email-masked]>
Date: Tue, 18 May 2004 13:13:05 +1000

Ratin Kumar wrote:

> I am trying to get X11 up on my MALTA (MIPS 64, little endian board). I 
> have the frame buffer working (using Matrox Mill – II PCI card). I also 
> have the Red Hat 7.3 installation going but I am not able to get X to 
> work. Has any one tried this combination OR if there is any advice on 
> this ??

How have you tried configuring XFree86?  Did you use the matrox driver 
or fbdev?  If the framebuffer works, then I'd suggest trying fbdev.

Beyond that, I wouldn't have a clue.
-- 
+-------------------------------------------------------------+
| Stuart Longland           stuartl at longlandclan.hopto.org |
| Brisbane Mesh Node: 719             http://stuartl.cjb.net/ |
| I haven't lost my mind - it's backed up on a tape somewhere |
| Atomic Linux Project    <--->    http://atomicl.berlios.de/ |
+-------------------------------------------------------------+

---

From: "Kevin D. Kissell" <[email-masked]>
Date: Tue, 18 May 2004 08:39:03 +0200

I managed to make X11 work on a 5Kc/Malta configuration by overlaying part of the MIPS port
of RH 7.1 with the "zhang tarball" (ftp://ftp.paralogos.com/pub/linux/mips/tarballs/X11R6.mipsel.tar.gz ) 
and overlaying part of the linux-mips.org source tree with Matrox fixes from kernel.org.

Earl Mitchell of MIPS went through this exercise last year and came up with a revised procdeure
which I've bundled into a 33MB tarball and put up at 
ftp://ftp.paralogos.com/pub/linux/mips/tarballs/earlm_xfree86_malta.tgz 
I haven't actually used it yet, but it contains a revised X11 subtree, sample configuration files, and
a README.
  ----- Original Message ----- 
  From: Ratin Kumar 
  To: [email-masked] 
  Sent: Tuesday, May 18, 2004 2:00
  Subject: setup X11 on MIPS64/MALTA

  Hi,

  I am trying to get X11 up on my MALTA (MIPS 64, little endian board). I have the frame buffer working (using Matrox Mill - II PCI card). I also have the Red Hat 7.3 installation going but I am not able to get X to work. Has any one tried this combination OR if there is any advice on this ??

  Thanks in advance.

  -Ratin.