Subject: RE: titan ethernet driver

From: Manish Lachwani <[email-masked]>
Date: Thu, 13 May 2004 09:26:50 -0700

Are you referring to 2.4 or 2.6? You have already downloaded 2.4.26 and 2.4.21 versions (with source code) from the PMC-Sierra ftp site. These are fully functional and several customers are using it from the last 3-4 months now. The patches for 2.4 have been sent out to Ralf. 

As far as 2.6 goes, when it is ready, we will let you know

-----Original Message-----
From: Thomas Koeller [mailto:[email-masked]]
Sent: Thursday, May 13, 2004 7:44 AM
To: [email-masked]
Cc: Ralf Baechle; Manish Lachwani
Subject: Re: titan ethernet driver

On Friday, March 26th, 2004 Ralf Baechle wrote:
> On Fri, Mar 26, 2004 at 03:12:06PM +0100, Thomas Koeller wrote:
> > I am trying to use your titan ethernet driver. I
> > found that I could not compile it for a 2.6.4
> > kernel, because it uses 2.4 kernel APIs. When
> > fixing that I found that the code contains
> > obvious errors; it does not even compile unchanged.
> > This makes me a bit uneasy. Would you mind
> > commenting on the state of this driver? Are there
> > any newer sources than those contained in CVS at
> > linux-mips.org?
>
> I'm going to fix Yosemite / Titan support in 2.6 asap - as soon as I get
> the board which should be somewhen next week.
>
>   Ralf

I see work going on for the titan ge driver, but AFAIK the only
platform supporting this hardware is the yosemite board, and the
board support has not been updated for months and is still
non-functional. So I wonder how these changes are tested - or
am I missing something?

tk
-- 
--------------------------------------------------

Thomas Koeller, Software Development
Basler Vision Technologies

thomas dot koeller at baslerweb dot com
http://www.baslerweb.com

==============================

---

From: Thomas Koeller <[email-masked]>
Date: Fri, 14 May 2004 14:58:01 +0200

Manish Lachwani wrote:

> Are you referring to 2.4 or 2.6? You have already downloaded 2.4.26 and
> 2.4.21 versions (with source code) from the PMC-Sierra ftp site. These are
> fully functional and several customers are using it from the last 3-4
> months now. The patches for 2.4 have been sent out to Ralf.

This is all about 2.6. From the CVS change logs I see that Ralf is
applying 2.6-specific changes to the driver. Now that there is no
working support for 2.6 on the yosemite, the only platform I know of
that has this H/W, I just wondered how these changes are tested.

tk

An der Strusbek 60-62
22926 Ahrensburg
Germany

Tel +49 (4102) 463-390
Fax +49 (4102) 463-46390

mailto:[email-masked]
http://www.baslerweb.com

---

From: Ralf Baechle <[email-masked]>
Date: Fri, 14 May 2004 16:07:20 +0200

> that has this H/W, I just wondered how these changes are tested.

On Yosemite, of course :-)  The reason why I put this driver already into
CVS before the remainder of the Yosemite port is to make it accessible
for outside review by one of the Linux networking gods.

  Ralf