Subject: RaQ2: Installation stops at "loading debian installer"

From: Joerg Rossdeutscher <[email-masked]>
Date: Thu, 13 May 2004 19:31:05 +0200

Hi,
step by step... :-)

The RaQ2 boots the debian-installer-b4 via tftp and nfs until the 
display shows "Loading debian installer". Then it stops.
I now have found an old Laptop that still has a serial port.

The last lines say:

 >execute initrd={initrd-size}@{initrd-start} 
console=ttyS0,{console-speed}
elf: 80080000 <-- 00001000 1916928t+176112t
elf: entry 801fc040
net: interface down

(I type this by hand, so excuse possibly errors)

That's it. Ethereal shows no more net traffic and no remarkable errors 
before the installation stops. Nothings happens. And nothing at google 
for this message. Hm.

Any ideas someone?

Bye, Ratti

-- 
_____________________________
Joerg Rossdeutscher

Factor Design AG
Schulterblatt 58
20357 Hamburg
Germany

T +49.40.432 571-43
F +49.40.432 571-99
E-mail: [email-masked]

http://www.factordesign.com

---

From: Martin Michlmayr <[email-masked]>
Date: Thu, 13 May 2004 19:47:24 +0100

That's the same as I get:

> -script
> lcd 'Loading' 'debian-installer'
> tftp {dhcp-next-server} vmlinux-2.4.25-r5k-cobalt initrd.gz
arp: request from 192.168.1.1
...
> execute initrd={initrd-size}@{initrd-start} console=ttyS0,{console-speed}
elf: 80080000 <-- 00001000 1916928t + 176112t
elf: entry 801fc040
net: interface down
CPU revision is: 000028a0
FPU revision is: 000028a0
Primary instruction cache 32kB, physically tagged, 2-way, linesize 32 bytes.
Primary data cache 32kB 2-way, linesize 32 bytes.
Linux version 2.4.25-r5k-cobalt ([email-masked]) (gcc version 3.3.3 (Debian 20040321)) #1 Thu Apr 15 15:17:00 BST 2004

Well, immediately after the message you saw, control should be passed to the
kernel and you should see kernel message.  I don't really know why that
wouldn't work in your case.

-- 
Martin Michlmayr
[email-masked]

---

From: Peter Horton <[email-masked]>
Date: Thu, 13 May 2004 20:37:35 +0100

> before the installation stops. Nothings happens. And nothing at google 

The messages are just debugging output, nothing wrong there. The next
thing to be displayed should be kernel messages :-(

Can you post all the boot messages (off list).

P.

---

From: Joerg Rossdeutscher <[email-masked]>
Date: Mon, 17 May 2004 12:27:38 +0200

Hi,

> before the installation stops. Nothings happens. And nothing at google 

Thanks to everyone who tried to help. Peter Horton guided me to the
solution. The kernel was broken, the md5sum did not match. I quote
his PM how to find out:

 >It's possible the kernel is not booting because of a problem with the
 >initrd code. What happens if you type the following at the boot shell
 >prompt :-
 >
 >	net
 >	tftp {dhcp-next-server} vmlinux-2.4.25-r5k-cobalt
 >	md5sum
 >	execute console=ttyS0,{console-speed}
 >
 >You can also check that the MD5 sum displayed matches that of the 
kernel
 >file on the TFTP server.

That md5 differed fronm the one on the debian server.
Re-downloaded, now installing. :-)

Yipiiie!

Bye, Ratti

Factor Design AG
Schulterblatt 58
20357 Hamburg
Germany

T +49.40.432 571-43
F +49.40.432 571-99