Subject: "No such device" with PCI card

From: jospehchan <[email-masked]>
Date: Mon, 14 Jun 2004 19:56:31 +0800 (CST)

Hi all,
  I'm new in MIPS. 
  Recently, I encountered a strange problem. 
  That is when I plugged in a USB1.1 PCI card on my
MIPS machine.
  When I load "usb-uhci" modules, the system returns
"Init_modules: No such device".
  But checking "lspci", I can see the device's ID of
the USB PCI card.
  Is there anything I missed? Any suggestion or advice
is appreciated. 
  Thanks.

-----------------------------------------------------------------
Yahoo!奇摩Messenger6.0
信箱搭配即時通, 溝通樂趣無窮! 
http://tw.messenger.yahoo.com/

---

From: Jan-Benedict Glaw <[email-masked]>
Date: Mon, 14 Jun 2004 16:27:30 +0200

On Mon, 2004-06-14 19:56:31 +0800, jospehchan <[email-masked]>
>   Is there anything I missed? Any suggestion or advice

lspci tells you vendor and device id. These IDs need to be told to the
driver. Because the uhci driver uses:

static const struct pci_device_id uhci_pci_ids[] = { {
        /* handle any USB UHCI controller */
        PCI_DEVICE_CLASS(((PCI_CLASS_SERIAL_USB << 8) | 0x00), ~0),
        .driver_data =  (unsigned long) &uhci_driver,
        }, { /* end: all zeroes */ }
};

I think your device is just broken (and doesn't tell it's a USB host).
If you think it's really driven by uhci (and not by ohci), then stick
your device IDs into that table, or add those dynamically by echo'ing
them to /sys/bus/pci/drivers/uhci_hcd/new_id. You need sysfs mounted to
/sys, though.

MfG, JBG

-- 
   Jan-Benedict Glaw       [email-masked]    . +49-172-7608481
   "Eine Freie Meinung in  einem Freien Kopf    | Gegen Zensur | Gegen Krieg
    fuer einen Freien Staat voll Freier Bürger" | im Internet! |   im Irak!
   ret = do_actions((curr | FREE_SPEECH) & ~(NEW_COPYRIGHT_LAW | DRM | TCPA));