Subject: shared mem problem

From: Sujith Nayak <[email-masked]>
Date: Thu, 3 Jun 2004 15:31:53 +0100 (BST)

Hi,
I am currently working on a board powered by a MIPS
processor, using Linux kernel 2.4.2. The problem that
I am facing is, whenever I create a shared memory
using shmget(), shmat(), etc. APIs, I always see that
the shared mem is created with 0 bytes. As a result
any access to it bombs the process.

Anyone has any idea, I will be grateful for your
response. I had a look at the patch-2.4.2-ac23, which
talks about the some shared mem lock up problem. But I
cannot apply the patch as it is because my customer
has pruned the kernel so much that the patch does not
apply right away.

Pl. help (by CCing your response to my mail id also).

Regards,

Sujeet

____________________________________________________________
Yahoo! Messenger - Communicate instantly..."Ping" 
your friends today! Download Messenger Now 
http://uk.messenger.yahoo.com/download/index.html

---

From: Jan-Benedict Glaw <[email-masked]>
Date: Thu, 3 Jun 2004 22:30:07 +0200

On Thu, 2004-06-03 15:31:53 +0100, Sujith Nayak <[email-masked]>
> processor, using Linux kernel 2.4.2. The problem that

Before doing anything else, you'd consider moving forward to current
2.4.x or even 2.6.x...

> has pruned the kernel so much that the patch does not

Then talk your customer (isn't that actually your vendor?) into putting
work into a newer kernel. Maybe you can diff you their changes agains a
2.4.2 from either linux-mips.org or 2.4.2 from Linus and try to
forward-port the changes to current 2.4.x or 2.6.x ...

MfG, JBG

-- 
   Jan-Benedict Glaw       [email-masked]    . +49-172-7608481
   "Eine Freie Meinung in  einem Freien Kopf    | Gegen Zensur | Gegen Krieg
    fuer einen Freien Staat voll Freier Bürger" | im Internet! |   im Irak!
   ret = do_actions((curr | FREE_SPEECH) & ~(NEW_COPYRIGHT_LAW | DRM | TCPA));

---

From: Ralf Baechle <[email-masked]>
Date: Fri, 4 Jun 2004 02:50:01 +0200

> has pruned the kernel so much that the patch does not

This doesn't look like the fingerprint of any known problem.  Anyway,
discussing 2.4.2 bugs is pointless - you're missing over three years
worth of bugfixes.

  Ralf