Subject: MIPS assembly document...

From: "Steven J. Hill" <[email-masked]>
Date: Tue, 22 Jun 2004 22:30:24 -0500

Hey guys.

Is there a nice little pocket MIPS assembly reference card
with R3000 and/or R4000 instructions on it? I know the ARM
architecture has something like this, but I have never seen
(or I missed) anything on MIPS or SGI ftp sites anywhere.
Anything?

-Steve

---

From: Ralf Baechle <[email-masked]>
Date: Wed, 23 Jun 2004 11:59:15 +0200

> (or I missed) anything on MIPS or SGI ftp sites anywhere.

See MIPS Run has a pretty complete listing of all instructions of even
the most exotic MIPS variants but I guess that's a little to long to
qualify as pocket reference.

  Ralf

---

From: "Alexander Voropay" <[email-masked]>
Date: Wed, 23 Jun 2004 14:00:42 +0400

Steven J. Hill wrote:

>with R3000 and/or R4000 instructions on it?

 The MIPS instructions is very simply, so it is possible
to tead it in hex without reference card ;-)

* IDT Assembler Software Reference Guide Vol. 2
3. CPU Instruction Reference
4. CPU Instructions Encoding
http://www1.idt.com/pcms/documents.taf?catID=121&docTypeID=25&mode=byTit
le
http://www1.idt.com/pcms/tempDocs/79RC32355_MA_92629.pdf

P.S. See:
http://chortle.ccsu.edu/AssemblyTutorial/tutorialContents.html
http://myrkraverk.afraid.org/PlayStation/EmotionEngine/

--
-=AV=-