Subject: bootloader

From: Dmitriy Tochansky <[email-masked]>
Date: Fri, 04 Jun 2004 11:51:17 +0400

Hi!
Does anybody can advice me some bootloader for my Zinfandel(Db1500) board?

CU.

---

From: "Tiemo Krueger - mycable.de" <[email-masked]>
Date: Fri, 04 Jun 2004 09:53:14 +0200

Yamon should be in Flash of that board and start automatically...
If it doesn't start check the DIP Switches on the board for correct 
settings.
(little/big endian, and I think you can switch between the flashes)

Tiemo

---

From: Dmitriy Tochansky <[email-masked]>
Date: Fri, 04 Jun 2004 12:09:05 +0400

> Does anybody can advice me some bootloader for my Zinfandel(Db1500) 
Oops! Sorry. :) I mean another bootloader insted YAMON. I need to load 
kernel from flash but not from LAN(tftp and etc). Can YAMON to do that?

CU

---

From: "Tiemo Krueger - mycable.de" <[email-masked]>
Date: Fri, 04 Jun 2004 10:17:44 +0200

Yes, it can!
There are two options, use a kernel simply compiled for ram,
load it via tftp, cp it to an erased flashed area.
then you can start it by copying it to ram and jump to the start address 
inside the kernel.
the second more simple solution is to build a compressed kernel,
flash it e.g. to 0xbfd00000 and then simply go there for start.

Pls refer the Yamon help for any details, you can add a start variable 
to the Yamon
config which is executed after two seconds if you don't stop this with 
Ctrl-c via serial.

(set start 'go 0xbfd00000 root=/dev/mtdblock1' or whatever...)

Tiemo

---

From: Dmitriy Tochansky <[email-masked]>
Date: Fri, 04 Jun 2004 12:32:15 +0400

Tiemo Krueger - mycable.de wrote:

> then you can start it by copying it to ram and jump to the start 
> address inside the kernel.
Yes I did it that way. :) Thanks.
So is there other nice loaders for this board?

CU

---

From: Wolfgang Denk <[email-masked]>
Date: Fri, 04 Jun 2004 10:31:56 +0200

> Does anybody can advice me some bootloader for my Zinfandel(Db1500) board?

U-Boot?

Best regards,

Wolfgang Denk

-- 
Software Engineering:  Embedded and Realtime Systems,  Embedded Linux
Phone: (+49)-8142-4596-87  Fax: (+49)-8142-4596-88  Email: [email-masked]
Men don't talk peace unless they're ready to back it up with war.
	-- Col. Green, "The Savage Curtain", stardate 5906.4

---

From: Ed Okerson <[email-masked]>
Date: Fri, 4 Jun 2004 10:39:31 -0500 (CDT)

I have the same board and I use U-Boot.

Ed

---

From: Dmitriy Tochansky <[email-masked]>
Date: Mon, 07 Jun 2004 15:31:23 +0400

>>Does anybody can advice me some bootloader for my Zinfandel(Db1500) board?
Had you any problems in compile it?

---

From: Ed Okerson <[email-masked]>
Date: Mon, 7 Jun 2004 12:44:48 -0500 (CDT)

> Had you any problems in compile it?

It was somewhat difficult to get it working in little endian mode, but
once I did I submitted patches back to U-Boot and it should work fine now.

Ed Okerson