Subject: bootimage for RM300E ?

From: Thomas Kunze <[email-masked]>
Date: Tue, 06 Jul 2004 07:11:53 -0800

Quoting Alexander Voropay <[email-masked]>:

> 
> >OK. what are the next steps to get a bigendian bootimage for the
> RM300E? 
> >are there any sources available to compile for the RM300? 
> >is there a bootimage for the RM200C that i can give a try?
> 
> 1) Install a bigendian toolchain at the x86 host box and recompile the
> Linux kernel.
> P.5  http://howto.linux-mips.org/mips-howto.html

ok i downloaded toolchain. 
which kernel should i use? that one from kernel.org or from linux-mips.org ?
what should be done next, after create a kernel ? 
what do i need to create a bootimage for the RM300 ?
how must this bootimage looks like ?
any howto's ?

with best regards
thomas
-------------------------------------------------------------------------------------------
***Protect your PC from local E-Mail Application security holes***
***Maintain your Privacy - MS Passport Free***
***Anti SPAM "Whitelist" feature***

http://www.xmail.net Web E-Mail, accessible anywhere, 128 bit SSL Secure

Voice Messages, Voice Calls (VoIP), Video Conferencing,  
XMail Messenger, Personal Web Hosting, Private Disk Storage,  
Calendar, Bookmarks, Forwarding, Virtual Mail Map Aliasing

XMail Premium: 20 - 250MB Storage, 20MB Messages, SMTP, POP3, Ad Free
Starting at $9.95 per year
-------------------------------------------------------------------------------------------
Anonymous Web Surfing http://www.snoopblocker.com
Search http://www.teradex.com

---

From: Jan-Benedict Glaw <[email-masked]>
Date: Tue, 6 Jul 2004 17:16:07 +0200

On Tue, 2004-07-06 07:11:53 -0800, Thomas Kunze <[email-masked]>
> which kernel should i use? that one from kernel.org or from linux-mips.org ?

linux-mips.org, current CVS checkout. However, I can't tell you if
you're better off using HEAD or the linux_2_4 branch (probably HEAD,
though...).

> how must this bootimage looks like ?

Try to feed the kernel image either as ELF or ECOFF via network. The
first step is to make the machine actually *accept* the image (let alone
properly executing it).

MfG, JBG

-- 
   Jan-Benedict Glaw       [email-masked]    . +49-172-7608481
   "Eine Freie Meinung in  einem Freien Kopf    | Gegen Zensur | Gegen Krieg
    fuer einen Freien Staat voll Freier Bürger" | im Internet! |   im Irak!
   ret = do_actions((curr | FREE_SPEECH) & ~(NEW_COPYRIGHT_LAW | DRM | TCPA));

---

From: Ralf Baechle <[email-masked]>
Date: Tue, 6 Jul 2004 21:38:48 +0200

> which kernel should i use? that one from kernel.org or from linux-mips.org ?

Wipe the word kernel.org from your brain ;-)

> how must this bootimage looks like ?

Just "make rm200_defconfig; make" which will build vmlinux.ecoff which is
the file which can be netbooted via bootp/tftp.  Same procedure as with
SGI machines basically so the usual howtos for SGI IP22 netbooting Linux
apply.

> any howto's ?

In the back of my brain.

  Ralf