Subject: ABI question

From: Thomas Koeller <[email-masked]>
Date: Tue, 27 Jul 2004 10:57:52 +0200

Hi,

for 2.6 kernels, arch/mips/Makefile contains the following lines:

ifdef CONFIG_MIPS64
gcc-abi			= 64
gas-abi			= 32
tool-prefix		= $(64bit-tool-prefix)
UTS_MACHINE		:= mips64
endif

Is it intentional that gcc-abi and gas-abi are different? This
results in '-Wa,-32' appearing on gcc's command line, causing
the asembler to complain:

Error: -mgp64 used with a 32-bit ABI

If I change gas-abi to 64, this error goes away.

tk
-- 
--------------------------------------------------

Thomas Koeller, Software Development
Basler Vision Technologies

thomas dot koeller at baslerweb dot com
http://www.baslerweb.com

==============================

---

From: "Maciej W. Rozycki" <[email-masked]>
Date: Tue, 27 Jul 2004 15:05:02 +0200 (CEST)

> Is it intentional that gcc-abi and gas-abi are different? This

 It is -- some people want to use 32-bit pointers within Linux, to 
conserve memory.  It seems to work with older tools, but I've never tried 
that.

> If I change gas-abi to 64, this error goes away.

 You may run `make "gas-abi=64" <whatever>' as a workaround.  I'm going to 
make it selectable in the configuration one day.

  Maciej