Subject: sharp mobilon hc-4100

From: "Volker Jahns" <[email-masked]>
Date: Thu, 8 Jul 2004 14:52:44 +0200 (CEST)

Linux on Sharp Mobilon HC-4100

I would like to have Linux boot on the Sharp HC-4100 and have tried a
couple of suitable kernels with the following outcome:

Booting
-------
netbsd tx3912               - netbsd 1.5.3 , keyboard functional
linux for philips velo      - vmlinux-2.4.0-test4-pre3 , keyboard not
functional

Booting, but framebuffer scrambled
----------------------------------
linux nino                  - vmlinux-2.4.17
linux sharp HC-4500/HC-4600 - vmlinux-2.3.21. vmlinux-2.3.47

I have tried to compile a kernel from versions - 2.4.20 and 2.4.0-test9 -
( sharp mobilon, philips velo, philips nino) which all boot but have the
framebuffer device scrambled.

Which kernel version is good to start from, and where would I find its code ?
Has somebody a working .config vor the Velo 500 available, so that I get
the correct options to have this damn framebuffer device working?

Please redirect, in case this should be the wrong place to post.
-- 
Volker Jahns, [email-masked], http://thalreit.de, DG7PM

---

From: Ricardo Mendoza <[email-masked]>
Date: Thu, 08 Jul 2004 14:21:11 -0400

> Booting, but framebuffer scrambled

Hi, sometimes the scrambled problem happens when you are using a linked 
inside ramdisk image and it corrupts the kernel itself in some way, it 
has happened to me quite many times with the nino kernel.

It would help to check your config, I can assure you that the 2.4.17 
nino code is working, I use it myself but on the nino, it might require 
some modifications for the Mobilon.

-- 
Ricardo Mendoza Meinhardt
[email-masked]

.knxTech
Administrador Linux
Programador/PHP

"get ready for a bit of the old Ultra Violence"

---

From: Volker Jahns <[email-masked]>
Date: Thu, 8 Jul 2004 21:26:25 +0200

> >couple of suitable kernels with the following outcome:

...

> some modifications for the Mobilon.

Modifications are certainly a must:

e.g. 2.4.20 in drivers/video/tx3912fb.h thereis _only_  framebuffer definitions for the nino:
<pre>
#if defined(CONFIG_NINO_4MB) || defined(CONFIG_NINO_8MB)
#define FB_X_RES       240 
#define FB_Y_RES       320
#if defined(CONFIG_FBCON_CFB4)
#define FB_BPP         4
</pre>

while 2.4.0-test9 carries the _good_ information for the velo 1, velo 500 and for the helio ( the code for the nino is missing here). In drivers/video/r3912fb.h ( which seems to be the historic version of tx3912fb.h, ouch what a chaos :-(
<pre>
#ifdef CONFIG_PHILIPS_VELO
#       ifdef CONFIG_PHILIPS_VELO1
#               define FB_X_RES         480
#       elif defined(CONFIG_PHILIPS_VELO500)
#               define FB_X_RES         640
#       endif
#       define  FB_Y_RES        240
#       ifdef CONFIG_PHILIPS_VELO_4GRAY
#               define FB_BPP   2
#       else /* CONFIG_PHILIPS_VELO_16GRAY */
#               define FB_BPP   4
#       endif
#       define FB_IS_GREY     1
#       define FB_IS_INVERSE  0
#       define VIDEORAM_SIZE  (FB_X_RES * FB_Y_RES * FB_BPP / 8)
</pre>

On the other hand the mobilon needs 
<pre>
#               define FB_X_RES         640
#               define FB_X_RES         240
#               define FB_BPP           4
</pre>

This information ( and what else which might be of interest to make the LCD working on this thing) must have get lost on the kernel's way. I really wonder where to find a more or less functional version of the kernel code to start with.

-- 
Volker Jahns, [email-masked], http://thalreit.de, DG7PM

---

From: Martin Michlmayr <[email-masked]>
Date: Thu, 8 Jul 2004 21:48:21 +0200

> On the other hand the mobilon needs 

I thought it was 800x480.  BTW, how do you boot this thing?  From
WinCE or can you override the ROM?

-- 
Martin Michlmayr
[email-masked]

---

From: "Volker Jahns" <[email-masked]>
Date: Fri, 9 Jul 2004 08:56:26 +0200 (CEST)

>> On the other hand the mobilon needs
that is correct.
> WinCE or can you override the ROM?
pbsdboot :-( But if you have an idea on how to write the ROM, please let
me know.