Subject: [Fwd: Re: sharp mobilon hc-4100]

From: Ricardo Mendoza <[email-masked]>
Date: Thu, 08 Jul 2004 16:03:10 -0400

Volker Jahns wrote:

> 
> Modifications are certainly a must:
> 
> e.g. 2.4.20 in drivers/video/tx3912fb.h thereis _only_  framebuffer definitions for the nino:
> <pre>
> #if defined(CONFIG_NINO_4MB) || defined(CONFIG_NINO_8MB)
> #define FB_X_RES       240 
> #define FB_Y_RES       320
> #if defined(CONFIG_FBCON_CFB4)
> #define FB_BPP         4
> </pre>
> 
> while 2.4.0-test9 carries the _good_ information for the velo 1, velo 500 and for the helio ( the code for the nino is missing here). In drivers/video/r3912fb.h ( which seems to be the historic version of tx3912fb.h, ouch what a chaos :-(
> <pre>
> #ifdef CONFIG_PHILIPS_VELO
> #       ifdef CONFIG_PHILIPS_VELO1
> #               define FB_X_RES         480
> #       elif defined(CONFIG_PHILIPS_VELO500)
> #               define FB_X_RES         640
> #       endif
> #       define  FB_Y_RES        240
> #       ifdef CONFIG_PHILIPS_VELO_4GRAY
> #               define FB_BPP   2
> #       else /* CONFIG_PHILIPS_VELO_16GRAY */
> #               define FB_BPP   4
> #       endif
> #       define FB_IS_GREY     1
> #       define FB_IS_INVERSE  0
> #       define VIDEORAM_SIZE  (FB_X_RES * FB_Y_RES * FB_BPP / 8)
> </pre>
> 
> On the other hand the mobilon needs 
> <pre>
> #               define FB_X_RES         640
> #               define FB_X_RES         240
> #               define FB_BPP           4
> </pre>
> 
> This information ( and what else which might be of interest to make the LCD working on this thing) must have get lost on the kernel's way. I really wonder where to find a more or less functional version of the kernel code to start with.
> 

The 2.4.17 tree on Steven J. Hill's website is functional, I can give it
  to you if you cant find it, just let me know.

By the way, when I refer to functional is for the TX3912 generic stuff,
one thing for sure is that you _WILL_ need to make an specific machine
directory for the mobilon, and you can use the same code for it, after
removing the non-generic tx3912 stuff and perhaps changing some stuff
that matters only to the mobilon.

You can also try hacking on the nino files as if you were using a nino.

P.D. Remove the html tags

-- 
Ricardo Mendoza Meinhardt
[email-masked]

.knxTech
Administrador Linux
Programador/PHP

"get ready for a bit of the old Ultra Violence"

---

From: Ralf Baechle <[email-masked]>
Date: Fri, 9 Jul 2004 13:21:47 +0200

>  to you if you cant find it, just let me know.

Would be nice if somebody can resurrect this platform.  It's rotting
for too long and Steven even convinced me to remove it from 2.6.  I
hope we can add functional code back somewhen.

  Ralf

---

From: Ricardo Mendoza <[email-masked]>
Date: Fri, 09 Jul 2004 11:46:38 -0400

> hope we can add functional code back somewhen.

Hey Ralf, well as you know I have been getting involved in that, as far 
as today PCMCIA IDE kind of works, but the real plan is to develop a 
PCMCIA driver for the controller.

Im ricmm, perhaps now that vacations started for me I can really get 
into the stuff, I will let you know if I get into porting it to the 2.6 
kernel.

.knxTech
Administrador Linux
Programador/PHP