Subject: RE: Linux on SNI RM300E ?

From: Thomas Kunze <[email-masked]>
Date: Tue, 06 Jul 2004 02:14:20 -0800

Quoting Alexander Voropay <[email-masked]>:

>  AFAIK, the RM300E is an ARC compatible. (?)
i don't no. i saw something like that on the net. but nothing about that in the manuals
that i have.
> 
>  So, try to load "arcdiag" utility instead of kernel :
> 
> ftp://ftp.sra.co.jp/pub/os/NetBSD/misc/arc/
> 
i've downloaded the arcdiag-0.2 and served it via tftp. but the RM300E don't like that
file. it only says "Bad magic number". what does this mean (little/bigendian)? 

the same error-message appears when the to load mipsel boot-images.

with best regards
thomas

-------------------------------------------------------------------------------------------
***Protect your PC from local E-Mail Application security holes***
***Maintain your Privacy - MS Passport Free***
***Anti SPAM "Whitelist" feature***

http://www.xmail.net Web E-Mail, accessible anywhere, 128 bit SSL Secure

Voice Messages, Voice Calls (VoIP), Video Conferencing,  
XMail Messenger, Personal Web Hosting, Private Disk Storage,  
Calendar, Bookmarks, Forwarding, Virtual Mail Map Aliasing

XMail Premium: 20 - 250MB Storage, 20MB Messages, SMTP, POP3, Ad Free
Starting at $9.95 per year
-------------------------------------------------------------------------------------------
Anonymous Web Surfing http://www.snoopblocker.com
Search http://www.teradex.com

---

From: Thiemo Seufer <[email-masked]>
Date: Tue, 6 Jul 2004 12:06:47 +0200

> i don't no. i saw something like that on the net. but nothing about that in the manuals

It is, AFAIK. But the woody kernel is for a SGI Indy/Indigo2, not for
RM300E. The linux-mips.org tree has only support for RM200C, adding
support for RM300E is probably not that complicated if it is similiar
enough.

> file. it only says "Bad magic number". what does this mean (little/bigendian)? 

Wrong endianness. Your machine apparently has big endian firmware.

Thiemo

---

From: "Alexander Voropay" <[email-masked]>
Date: Tue, 6 Jul 2004 14:18:01 +0400

>i've downloaded the arcdiag-0.2 and served it via tftp. but the RM300E
don't like that file.
>it only says "Bad magic number". what does this mean
(little/bigendian)? 

>the same error-message appears when the to load mipsel boot-images.

 Do you have an originas OS (SINIX ?) supplied with this server ?
Try a `file` GNU utility:
$ file <ANY_BINARIES_FROM_THE_ORIGINAL_OS>
or
$ file <KERNEL_IMAGE_FROM_THE_ORIGINAL_OS>

 Some modern loaders requires ELF binaries (not COFF) so you should
know a full binary file format to load (ELF/COFF/little/bigendian).

--
-=AV=-

---

From: Thomas Kunze <[email-masked]>
Date: Tue, 06 Jul 2004 03:41:17 -0800

> know a full binary file format to load (ELF/COFF/little/bigendian).

yepp, sinix reliant 5.44 is installed and boots up. BUT, i have no login no password.
and the previous owner can't remember any login or password. also, i don't have any
orig. CD's for the RM300E. it seems that the machine is running in bigendian mode.

with best regards
thomas

---

From: Jan-Benedict Glaw <[email-masked]>
Date: Tue, 6 Jul 2004 12:45:52 +0200

On Tue, 2004-07-06 03:41:17 -0800, Thomas Kunze <[email-masked]>
> orig. CD's for the RM300E. it seems that the machine is running in bigendian mode.

I don't know what filesystem Sinix used, maybe you can rip off the
disks and attach them to any other Linux box. Possibly you can mount the
filesystem(s), but even if not, you can use a hex editor to zero out
root's password on the raw disk :-)

MfG, JBG

-- 
   Jan-Benedict Glaw       [email-masked]    . +49-172-7608481
   "Eine Freie Meinung in  einem Freien Kopf    | Gegen Zensur | Gegen Krieg
    fuer einen Freien Staat voll Freier Bürger" | im Internet! |   im Irak!
   ret = do_actions((curr | FREE_SPEECH) & ~(NEW_COPYRIGHT_LAW | DRM | TCPA));

---

From: Thomas Kunze <[email-masked]>
Date: Tue, 06 Jul 2004 03:48:07 -0800

> support for RM300E is probably not that complicated if it is similiar

OK. what are the next steps to get a bigendian bootimage for the RM300E? 
are there any sources available to compile for the RM300? 
is there a bootimage for the RM200C that i can give a try?

with best regards
thomas

---

From: Thiemo Seufer <[email-masked]>
Date: Tue, 6 Jul 2004 13:41:02 +0200

> is there a bootimage for the RM200C that i can give a try?

I would try current CVS HEAD, compile the RM200C configuration and
see where it dies. No need to bother about a complete boot image
at this stage. Welcome to the world of kernel porting. :-)

(You need a kernel converted to ECOFF for this, like it is done
for some other machines via elf2ecoff.)

Thiemo