Subject: DECstation 5000/20

From: havner <[email-masked]>
Date: Mon, 19 Jul 2004 21:02:14 +0200

What's the recommended kernel for this machine?
I've only managed to boot 2.4.17 from debian and 2.4.18
http://www.xs4all.nl/~vhouten/mipsel/vmlinux-2.4.18-decR3k.ecoff.tgz
Unfortunately both of them freezes system (RH7.1/RH7.3) f.e. when trying to 
cat /proc/cpuinfo. No oops, no message on serial, just hard freeze.
using rpm also likes to freeze this machine. I've tried co cross compile 
kernel from cvs at linux-mips.org, but it stop at boot time just after 
setting high precission timer. vanila kernel (2.6.7) ends with kernel panic.
cross tools used:

1. the newest versions from:
ftp://ftp.linux-mips.org/pub/linux/mips/crossdev/i386-linux/mipsel-linux

2. self compiled:
$ mipsel-pld-linux-gcc -v
Reading specs from /usr/lib/gcc-lib/mipsel-pld-linux/3.3.4/specs
Configured with: ../configure --prefix=/usr --infodir=/usr/share/info 
- --mandir=/usr/share/man --bindir=/usr/bin --libdir=/usr/lib 
- --libexecdir=/usr/lib --includedir=/usr/mipsel-pld-linux/include 
- --disable-shared --disable-threads --enable-languages=c --with-gnu-as 
- --with-gnu-ld --with-system-zlib --with-multilib --without-x 
- --build=athlon-pld-linux --host=athlon-pld-linux --target=mipsel-pld-linux
Thread model: single
gcc version 3.3.4
$ mipsel-pld-linux-ld -v 
GNU ld version 2.15.91.0.1 20040527

The same effect on both.
I cannot find any patches for decstation on the net
Are there any more mips kernel repositories over the net?

I've got this machine two days ago and I'm trying to make small PLD port 
there.
I would be gratefull for any help.

- -- 
Regards       Havner                          http://livecd.pld-linux.org
GG: 2846839                             jid,mail: havner(at)pld-linux.org
          "We live as we dream, alone"   - Joseph Conrad

---

From: Thiemo Seufer <[email-masked]>
Date: Tue, 20 Jul 2004 01:24:49 +0200

havner wrote:
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: SHA1
> 

This is very old.

> cat /proc/cpuinfo. No oops, no message on serial, just hard freeze.

Fixed in newer 2.4 kernels from linux-mips.org.

> setting high precission timer. vanila kernel (2.6.7) ends with kernel panic.

linux-mips.org CVS, -r linux_2_4, should work for serial console. Debian
has a r3k-kn02 kernel package for mipsel which is supposed to work as
well.

Thiemo

---

From: havner <[email-masked]>
Date: Tue, 20 Jul 2004 02:02:07 +0200

On Tuesday 20 July 2004 01:24, Thiemo Seufer wrote:
> > Unfortunately both of them freezes system (RH7.1/RH7.3) f.e. when trying
> > to cat /proc/cpuinfo. No oops, no message on serial, just hard freeze.
>
I've already found, but it doesn't build (my previous post)

> has a r3k-kn02 kernel package for mipsel which is supposed to work as
The only debian image I've managed to find was 2.4.17 and it freezes the same
way like 2.4.18 quoted previously :-(

- --

---

From: Martin Michlmayr <[email-masked]>
Date: Tue, 20 Jul 2004 01:09:09 +0100

> way like 2.4.18 quoted previously :-(

http://ftp.debian.org/debian/pool/main/k/kernel-patch-2.4.26-mips/kernel-image-2.4.26-r3k-kn02_2.4.26-0.040505.1_mipsel.deb

-- 
Martin Michlmayr
[email-masked]

---

From: havner <[email-masked]>
Date: Tue, 20 Jul 2004 02:26:00 +0200

On Tuesday 20 July 2004 02:09, Martin Michlmayr wrote:
> > The only debian image I've managed to find was 2.4.17 and it freezes the
> > same way like 2.4.18 quoted previously :-(
>
> http://ftp.debian.org/debian/pool/main/k/kernel-patch-2.4.26-mips/kernel-im
>age-2.4.26-r3k-kn02_2.4.26-0.040505.1_mipsel.deb

Thank's. I wasn't looking in packages, but around boot images. It seems thay 
have outdated files there.

- --

---

From: havner <[email-masked]>
Date: Tue, 20 Jul 2004 02:47:36 +0200

>age-2.4.26-r3k-kn02_2.4.26-0.040505.1_mipsel.deb

It almost works properly. I get oopses all the time (mainly with modules 
operations, but not only). Maybe to old modutils and rest of the system. I'll 
check it tommorrow. Thank for help. I must have a look at debian patches too.

- --