Subject: Re: [PATCH] MIPS getdomainname() off by 1;

From: Ralf Baechle <[email-masked]>
Date: Thu, 8 Jul 2004 02:49:51 +0200

On Mon, May 31, 2004 at 08:21:01PM -0700, Randy.Dunlap wrote:

> irix_getdomainname() max size appears to be off by 1;
> other similar code in kernel uses __NEW_UTS_LEN as the max size,
> and <domainname> includes an extra byte for the terminating
> null character.
> 
> Does sysirix.c need to limit <len> to 63 instead of 64 for some
> reason?

I would know why - and it has other bugs also, so I removed it by the
normal Linux getdomainname(2) for SysV flavour syscalls, too.

  Ralf

---

From: Geert Uytterhoeven <[email-masked]>
Date: Thu, 8 Jul 2004 10:46:19 +0200 (MEST)

> normal Linux getdomainname(2) for SysV flavour syscalls, too.

I saw you even removed it from 2.0. Woow! ;-)

Gr{oetje,eeting}s,

						Geert

--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- [email-masked]

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
							    -- Linus Torvalds

---

From: Ralf Baechle <[email-masked]>
Date: Thu, 8 Jul 2004 12:56:50 +0200

> I saw you even removed it from 2.0. Woow! ;-)

Yep :-)  But whoever is still runing 2.0 on MIPS must be suffering from a
suicidal tendences.  Too many bugs left unfixed.

  Ralf