Subject: Re: Should #ifdef __KERNEL__ be added before #include <spaces.h> in asm-mips/addrspace.h ?

From: Ralf Baechle <[email-masked]>
Date: Fri, 20 Aug 2004 14:05:26 +0200

On Tue, Jul 20, 2004 at 05:03:56PM -0700, Song Wang wrote:

> Should #ifdef _KERNEL__ be added before #include
> <spaces.h> in asm-mips/addrspace.h?
> 
> I think the reason is the same as when you added
> the #ifdef __KERNEL__ before #include <spaces.h>
> for asm-mips/page.h.

Some userspace software is expecting to get PAGE_SHIFT, PAGE_SIZE and
PAGE_MASK to be available in userspace via <asm/page.h>, so I
protected the inclusion of <asm/spaces.h> with __KERNEL__ but left
the definitions of these symbols unprotected.

  Ralf

---

From: Song Wang <[email-masked]>
Date: Wed, 25 Aug 2004 12:34:58 -0700 (PDT)

Ralf,

The problem in asm-mips/addrspace.h when including
<spaces.h> is different. The problem is the path.

spaces.h lives in asm-mips/mach-generic,

Only when compiling kernel, asm-mips/mach-generic
is in the include path, because arch/mips/Makefile
defines it.

However, when compiling the user-space apps, they
don't know how to find spaces.h when they indirectly
include <asm/addrspace.h>

-Song

> the definitions of these symbols unprotected.

		
__________________________________
Do you Yahoo!?
New and Improved Yahoo! Mail - 100MB free storage!
http://promotions.yahoo.com/new_mail