Subject: pthread uClibc

From: "akshay" <[email-masked]>
Date: Fri, 6 Aug 2004 09:43:03 +0530

Hi,

I am trying to use pthread on mips based platform.

I have simple program to just create pthreads and when I run my program, it
goes in infinite loop and never comes back.
Though when I hit enter on console, I see following message on console.

pt: assertion failed in manager.c:154.

pt: assertion failed in manager.c:193.

Can someone plz help me here .

Here is the code for my program.
==============================================================
#include <stdio.h>
#include <pthread.h>

void print_message_function( void *ptr );

     pthread_t thread1;
     char *message1 = "Thread 1";

main()
{
     int  iret1, iret2;

    /* Create independant threads each of which will execute function */

     iret1 = pthread_create( &thread1, NULL, (void*)&print_message_function,
(v
oid*) message1);

printf("threads created ....\n");
     /* Wait till threads are complete before main continues. Unless we  */
     /* wait we run the risk of executing an exit which will terminate   */
     /* the process and all threads before the threads have completed.   */

     pthread_join( thread1, NULL);

     printf("Thread 1 returns: %d\n",iret1);
     exit(0);
}

void print_message_function( void *ptr )
{
     char *message;
     message = (char *) ptr;
     printf("%s \n", message);
}

Thanks,
Akshay

---

From: "Ratin Kumar" <[email-masked]>
Date: Thu, 5 Aug 2004 23:30:22 -0700

It might make a bit more sense if you talk a bit about your setup/toolchain
(cross??) and version of libraries used....

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of akshay
Sent: Thursday, August 05, 2004 9:13 PM
To: [email-masked]
Subject: pthread uClibc

Hi,

     pthread_t thread1;

main()
{
     int  iret1, iret2;

Thanks,
Akshay