Subject: Re: Yamon compiling and linking

From: [email-masked]
Date: Tue, 17 Aug 2004 09:58:57 -0700

Reset code (reset.S) IS compiled and linked (at bfc00000 like it should
be), and pretty early on in there YAMON detects endianness and jumps to the
location of the appropriate endian image. Dump the output of make to a log
file and look for the compilation of reset.S.

 Hope that helps,
-Saugata.

                      "Roman Mashak"                                                                                                       
                      <[email-masked]>               To:       <[email-masked]>                                                   
                      Sent by:                     cc:                                                                                     
                      linux-mips-bounce@lin        Subject:  Yamon compiling and linking                                                   
                      ux-mips.org                                                                                                          

                      08/16/2004 06:57 PM                                                                                                  

Hello!

I solved the problem with Yamon compiling I asked recently, but still have
technical related questions about Yamon linking & code allocating in
memory.

Here it is.

When I compile little-endian only image, as far as I understood, I got
image
without RESET code at the beginning, so according to the memory map and
link
script (link_el.xn) - starting entry point is __RESET_HANDLER_END (locating
in init.S) and its address is 0x9fc10000.
So, I don't quite understand, how will be going after CPU reset? As
documentation's saying "following a reset, hardware fetches instructions
starting at the reset exception vector 0xBFC00000". But what is waiting at
this address, because reset code (reset.S) is not compiled and is not
linked?

Could you please make it clear to me?

Thanks in advance!

With best regards, Roman Mashak.  E-mail: [email-masked]

---

From: "Roman Mashak" <[email-masked]>
Date: Wed, 18 Aug 2004 14:53:18 +0900

Hello, [email-masked]!
You wrote to "Roman Mashak" <[email-masked]> on Tue, 17 Aug 2004
09:58:57 -0700:

SC> Reset code (reset.S) IS compiled and linked (at bfc00000 like it should
SC> be), and pretty early on in there YAMON detects endianness and jumps to
the
SC> location of the appropriate endian image. Dump the output of make to a
log
SC> file and look for the compilation of reset.S.

I have already investigated the 'makefile' and 'make' dump - and I've found
that reset code is compiled only in one case - when I compile both LE and BE
images.

Yes, I'm using AMD modified code and perhaps this is the reason, but their
support didn't answer yet.

Anyway - thank you for spending time for me.