Subject: Re: Doubt on rootfs

From: "bel racu" <[email-masked]>
Date: 18 Aug 2004 06:15:28 -0000

On Tue, 17 Aug 2004 Arravind babu wrote :
>Hi all,
>
>          I am cross-compiling linux 2.4.20 onto MIPS .I compiled and i booted the system.When i gave the command mount at the prompt it gave the following things.
>
>$mount
>
>rootfs on / type rootfs (rw)

meen your Root filesystem is in memory

>/dev/rom0 on / type romfs (ro)
>/dev/ram0 on /var type ext2 (rw)

Ramdisk  mounted for /var with ext2 filesystem

>/proc on /proc type proc (rw)

Procfs

>/dev/mtdblock6 on /flash type jffs2 (rw)

Flash device with jffs2 filesystem

>/dev/ram1 on /upgrade type sramfs (rw)
>/dev/mtdblock5 on /apps type cramfs (ro)

flash device holding ur filesystm and image

>devpts on /dev/pts type devpts (rw)
>
>
>When i gave the same command on a normal linux 2.4.20 machine i got the following.
>
>$mount
>
>/dev/sda1 on / type ext3 (rw)
>none on /proc type proc (rw)
>usbdevfs on /proc/bus/usb type usbdevfs (rw)
>none on /dev/pts type devpts (rw,gid=5,mode=620)
>/dev/sda5 on /home type ext3 (rw)
>/dev/sdb1 on /home1 type ext3 (rw)
>none on /dev/shm type tmpfs (rw)
>none on /proc/sys/fs/binfmt_misc type binfmt_misc (rw)
>

when u issue the Mount command it will display all the mounted
devices. U can also "cat /etc/mout" file to check the mounted devices
in your system.

>
>Why rootfs is not showing any device like in linux machine( /dev/sda1 on / type ext3)  ?
>  I checked the files

>usr/src/linux/init/main.c
>usr/src/linux/fs/ramfs/inode.c
>usr/src/linux/fs/namespace.c
>
>But i didnot got the point.Any idea is highly appreciated.My project is stopped due to this.Pls help me regarding this.
>
>Thanks in advance,
>Aravind.
>
>Yahoo! India Matrimony: Find your life partneronline.

---

From: Geert Uytterhoeven <[email-masked]>
Date: Wed, 18 Aug 2004 10:36:53 +0200 (MEST)

> devices. U can also "cat /etc/mout" file to check the mounted devices

Or better, `cat /proc/mount', since /etc/mount may be out-of-date.

Gr{oetje,eeting}s,

						Geert

--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- [email-masked]

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
							    -- Linus Torvalds