Subject: Q: PCI VGA on Meshcube - any progress?

From: Ralf Ackermann <[email-masked]>
Date: Tue, 10 Aug 2004 22:09:28 +0200 (CEST)

Hello,

today my MS-9513 miniPCI VGA card arrived and I started trying to use it.
The card is identified in the /proc filesystem:

---------------
[root@meshcube01 root]# cat /proc/pci
PCI devices found:
  Bus  0, device   3, function  0:
    VGA compatible controller: ATI Technologies Inc Rage XL (rev 39).
      IRQ 5.
      Master Capable.  Latency=128.  Min Gnt=8.
      Non-prefetchable 32 bit memory at 0x40000000 [0x40ffffff].
      I/O at 0x300 [0x3ff].
      Non-prefetchable 32 bit memory at 0x41000000 [0x41000fff].
----------------

Nevertheless - it does not output any signal - which is probably / as 
expected due to the missing initialization (that is done by the BIOS on 
x86 systems).

Did anybody have any more practical success/experiences so far? If so:
 - Did you try to use the card with the fbdev code (and with which 
	kernel)?
 - Did somebody suceed in using an XFree X server (which?, any special 
	hints?)

In addition to a cross-compile environment I'm using a chrooted 
Redhat/MIPS installation. It does have the development tools and 
infrastructure to compile an XFree X server on my own - nevertheless, I'd 
like to share/wait for the experiences that others made before I spend 
more time on it right now.

Any hints are welcome!

Best regards
 Ralf

---------------------------------------------------------------
Dr. Ralf Ackermann            _         [email-masked]
Multimedia Communications |/ | | |\/|           Merckstrasse 25
                          |\ |_| |  |  64283 Darmstadt, Germany
Tel.: (+49) 6151 16-6138                Fax: (+49) 6151 16-6152
---------------------------------------------------------------
             http://www.kom.tu-darmstadt.de/~rac
---------------------------------------------------------------

---

From: Ralf Ackermann <[email-masked]>
Date: Tue, 10 Aug 2004 22:31:37 +0200 (CEST)

Hello,

since a few people (e.g. Thiemo Seufer <[email-masked]>) 
already earlier suggested to use a full-featured Debian/MIPS with the 
Meshcube - here are my 2 questions concerning that topic:
	1. Is there a step-by-step instruction list on how
		to bootstrap such an environment (with just the
		MeshCube and i386 Linux systems but no further MIPS system
		available)
	2. Could somebody provide a snapshot of a (basic) Debian/MIPS
		filesystem that can be mounted via NFS and chrooted to?
		(this would then let me start apt-get upgrading / 
		installing in it)
	(I could provide the storage space / connectivity to also host
		such a FS snapshot for others)

Many thanks for your help and best regards
 Ralf

---

From: Goswin von Brederlow <[email-masked]>
Date: Tue, 10 Aug 2004 23:18:29 +0200

> 		MeshCube and i386 Linux systems but no further MIPS system

nfs-root? Debian (on that i386)?

cdebootstrap -amips sarge /tftpboot/<ip>/ http://ftp.de.debian.org/debian

That will fail after a while leaving you with a skeleton to boot from:

- create etc/fstab hosts resolv.conf apt/sources.list
- boot with init=/bin/sh
  - cd /var/cache/apt/archive/
  - dpkg --force-all -i libc6*deb
  - dpkg --force-all -i dpkg*deb
  - dpkg --force-all -i libc6*deb
  - dpkg -iGREB /var/cache/apt/archive/
  - dpkg -iGREB /var/cache/apt/archive/
  - dpkg -iGREB /var/cache/apt/archive/
  - check remaining dpkg errors if any
  - /usr/sbin/base-config
- adjust etc/inittab for serial console if you need
- reboot with normal init
- run dselect once going through all the top menu items to get all the
  standard packages added. You don't need to select any packages, just
  go into select once.

If you already have a unix on the meshcube run cdeboostrap there
(build it from source). Much easier.

> 		such a FS snapshot for others)

Again use cdebootstrap or debootstrap.

> Many thanks for your help and best regards

MfG
        Goswin

PS: You can ask your local DAluk for help if you get stuck too.