Subject: Q: XFree86 (on MeshCube) from Debian?

From: Ralf Ackermann <[email-masked]>
Date: Wed, 11 Aug 2004 09:35:35 +0200 (CEST)

Hello,

thanks a lot to the persons who helped me setting up a Debian/Sarge 
environment for the MeshCube (using cdebootstrap worked like a charm).

I may go on with an XFree86 server now (I tried using the ati module):
...
XFree86 Version 4.3.0.1 (Debian 4.3.0.dfsg.1-6 20040709164028 
[email-masked]
.org)
Release Date: 15 August 2003
X Protocol Version 11, Revision 0, Release 6.6
Build Operating System: Linux 2.4.25 mips [ELF]
Build Date: 10 July 2004
...

Nevertheless - the server refuses to start because of:
Fatal server error:
xf86OpenConsole: Cannot open /dev/tty0 (No such file or directory)

Can this be fixed without having to install an alternative kernel on the 
cube? (e.g. by loading an additional / which? kernel module?)

best regards and thanks for your help
 Ralf

---

From: Tiemo Krüger - mycable GmbH <[email-masked]>
Date: Wed, 11 Aug 2004 10:07:21 +0200

Hi,

> xf86OpenConsole: Cannot open /dev/tty0 (No such file or directory)

perhaps there is simply no /dev/tty0 ???

Maybe this will help:

http://mycable.de/xxs1500/cms/index.php?Linux:Graphics:Console

Tiemo

---

From: Michael Stickel <[email-masked]>
Date: Wed, 11 Aug 2004 11:05:49 +0200

Do you have an nfs-rootfs?
If you have a serial cable you can load an alternate kernel from tftp.
It has to be in srec format.

---

From: Goswin von Brederlow <[email-masked]>
Date: Wed, 11 Aug 2004 20:45:57 +0200

> cube? (e.g. by loading an additional / which? kernel module?)

cdebootstrap only creates the absolutely essential device nodes for a
chroot. You need more device nodes, udev or devfs.

cd /dev
MAKEDEV generic

> best regards and thanks for your help

MfG
        Goswin