Subject: Reset of USB

From: [email-masked]
Date: Tue, 31 Aug 2004 23:49:31 +0900

Hello ,

I invoked the Linux kernel on ALCHEMY DBAU1100 by U-BOOT.

The processing which resets USB-OHCI of the head of a kernel is not 
completed. (refer to *)

Au1100 does not indicate "reset is completed."
Is this phenomenon experienced?

In addition,
this phenomenon is not encountered when starting a kernel by YAMON.

*:
arch/mips/au1000/common/setup.c

#ifdef CONFIG_USB_OHCI
	// enable host controller and wait for reset done
	au_writel(0x08, USB_HOST_CONFIG);
	udelay(1000);
	au_writel(0x0E, USB_HOST_CONFIG);
	udelay(1000);
	au_readl(USB_HOST_CONFIG); // throw away first read
	while (!(au_readl(USB_HOST_CONFIG) & 0x10))
		au_readl(USB_HOST_CONFIG);
#endif

Best regards,
Nyauyama

---

From: Pete Popov <[email-masked]>
Date: Tue, 31 Aug 2004 14:40:49 -0700

> this phenomenon is not encountered when starting a kernel by YAMON.

Yamon initializes the CPU and then Linux doesn't have to touch too many 
registers. I'm guessing u-boot doesn't setup the clocking correctly, or 
at all, and that might be your problem. The Yamon code for these boards 
is available and it's easy to read the initialization code.  Take a look 
at it and that should solve your problem.

Pete