Subject: RE: Busybox v0.60.2 insmod gives segmentation fault without any m essages when trying to load a loadable module

From: Marcus Gustafsson <[email-masked]>
Date: Tue, 17 Aug 2004 09:24:49 +0200

> Manish Lohani wrote:
> > I have a driver loadable module which i am compiling with 
> the same gcc
> > flags as used to compile a kernel for a MIPS R5432 based NEC board.
> > 
> > On the development machine, to compile files driver1.c and 
> driver2.c:
> > $ mips_fp_le-gcc -fomit-frame-pointer -fno-strict-aliasing -G 0
> > -mno-abicalls -fno-pic -pipe -mtune=r5000 -mlong-calls 
> -mips2 -Wall -c
> > driver1.c
> > 
> > $mips_fp_le-ld -r -o driver --printmap --cref driver1.o driver2.o
> > 
> > mips_fp_le-gcc (GCC) version 3.3.1
> > mips_fp_le-ld (GNU ld) version 2.14
> > 
> > I have Busybox v0.60.2 on the target.
> > 
> > On the target:
> > # insmod ./driver
> > Using driver
> > Segmentation fault
> > #
> > 
> > Does anybody have any suggestions as to what could be wrong?
> > 
> 
> BusyBox0.60.x's insmod does not work with gcc-3.3 and above.
> 
> I use a patched version of the real insmod:
> 
> # insmod --version
> insmod version 2.4.25
> 
> I forget where I put the patch, but the insmod author told me that the
> patches were in a later version.  So if I were you, I would 
> use version
> 2.4.26 or higher.
> 
> David Daney.

Im using gcc-3.3.3 and busybox-0.60.5 and insmod works if I strip the debug
symbols from the module.

/Marcus Gustafsson

---

From: Ralf Baechle <[email-masked]>
Date: Tue, 17 Aug 2004 20:08:06 +0200

> Im using gcc-3.3.3 and busybox-0.60.5 and insmod works if I strip the debug

Seems that insmod is derived from an awfully old version from kernel.org;
this bug was fixed years ago.

  Ralf

---

From: David Daney <[email-masked]>
Date: Tue, 17 Aug 2004 12:49:08 -0700

> this bug was fixed years ago.

GCC 3.3 introduced several new debugging information sections.  The
ability of insmod to handle these new sections was not added until
around October 2003 (to my best recollection).

David Daney.

---

From: Ralf Baechle <[email-masked]>
Date: Wed, 18 Aug 2004 00:24:47 +0200

> around October 2003 (to my best recollection).

I know, around '97 I wrote the code that did reject the DWARF sections :-)

  Ralf