Subject: Re: PCMCIA genric sreail or modem support for db1100 bord

From: "safiudeen Ts" <[email-masked]>
Date: Fri, 20 Aug 2004 08:51:39 +0000

built in serial ports are working fine in DB1100 with linux-2.4.20 kernel
When we use a pcmcia serial card or modem, for most of the card, cardmaneger 
load serial_cs.o (actualy it uses the serial.o  fetures for registering the 
module).
This method work fine in my laptop.
same think hepens in db1100 bord also. I gues serial.o in bord db110 does'nt 
support well for serial_cs
.
If there is a stand alon serial_cs.o module for this board It may work 
without any problem.
if it is os where  can I get the seria_cs or any generic serial pcmcia 
driver for db1100 bord, or  otherwise is any serial.c available for db1100 
that can support pcmcia and inbuild serial as it works in labtop.

There is important think, when we connected in the laptop this pcmcia serial 
card detect is detected as 65550A but in the board it detected as 65550. I 
checked the serial.c code of db1100 there is no entry for this 65550A.

if any one worked with this DB1100 please help me to solve this problem

thanx
safiudeen

&gt;From: Michael Stickel &lt;[email-masked]&gt;
&gt;To: &quot;safiudeen Ts&quot; &lt;[email-masked]&gt;
&gt;Subject: Re: PCMCIA genric sreail or modem support for db1100 bord
&gt;Date: Fri, 20 Aug 2004 10:07:40 +0200
&gt;
&gt;
&gt;Do you use the buildin serial ports?
&gt;
&gt;My last information is that the au1x00-serial module does not work
&gt;in parallel with the serial module because au1x00-serial.c is just a
&gt;modified copy of serial.c.
&gt;
&gt;Michael
&gt;

_________________________________________________________________
Add photos to your messages with MSN 8. Get 2 months FREE*. 
http://join.msn.com/?page=features/featuredemail

---

From: Michael Kelly <[email-masked]>
Date: Fri, 20 Aug 2004 08:59:12 -0400

Safiudeen,

There is a known problem with some 8-bit cards and the Au1xxx family.
The following is from the FAQ for Linux that comes with the DB1100 CD:

============================================================

25) Which PCMCIA cards work with Au1x00/Pb1x00 Linux?

The Au1x00/Pb1x00 Linux PCMCIA cardmgr has been tested and known to
work with the following PC Cards.  The Linux PCMCIA driver module is
listed to the left:

   ide_cs.o Ritek Corporation, ATA DISK drive (3.3V Compact Flash Adapter)
   ide_cs.o Butterfly Group 64M ATA disk drive (3.3V)
   ide_cs.o SanDisk 192MB FlashDisk ATA (3.3/5V)
   ide_cs.o SanDisk 10MB FlashDisk ATA (5V)
   ide_cs.o Hitach 64MB flash card (3.3/5V)
   ide_cs.o IO Data 256MB flash card (3.3/5V)
   ide_cs.o Toshiba 2GB hard drive (actual tiny drive, like the IBM 
MicroDrive) (3.3V/5V)
   ide_cs.o IBM Microdrive
   3c589.o  3COM 589 Ethernet card (5V)
   pcnet_cs.o Linksys Network Everywhere NP10T
   pcnet_cs.o Corega Ether PCC-TD
   pcnet_cs.o Corega FEther PCC-TXD
   pcnet_cs.o Laneed LD-CDL/T
   axnet_cs.o Buffalo Tough Connect LPC3-CLX

NOTE: The Au1000 and Au1500 require an 8-bit PCMCIA HBA work around
be implemented on the board in order for 8-bit cards (i.e. pcnet_cs.o)
to work properly. See app note "Au1000 8-bit PCMCIA HBA".

============================================================\

IIRC most serial cards are 8-bit.

Hope this helps,

Michael

At 04:51 AM 8/20/2004, safiudeen Ts wrote:
>When we use a pcmcia serial card or modem, for most of the card, 
>cardmaneger load serial_cs.o (actualy it uses the serial.o  fetures for 
>registering the module).
>same think hepens in db1100 bord also. I gues serial.o in bord db110 
>does'nt support well for serial_cs
>.
>There is important think, when we connected in the laptop this pcmcia 
>serial card detect is detected as 65550A but in the board it detected as 
>65550. I checked the serial.c code of db1100 there is no entry for this 65550A.
>

Michael J. Kelly
VP Engineering/Marketing
Cogent Computer Systems, Inc.
1130 Ten Rod Road
Suite A-201
North Kingstown, RI 02852
tel:401-295-6505 fax:401-295-6507
www.cogcomp.com
alternate email: [email-masked]