Subject: why gcc 2.95.3 generate different result with option -mips2 and -mips3 for the same code

From: "glame" <[email-masked]>
Date: Tue, 14 Sep 2004 17:29:59 +0800

hi,
when i disassemble the code, the result is as the following

-ffffffff80010b8c:  01001021    move    $v0,$t0  (-mips2)
+ffffffff80010b8c:  0100102d    move    $v0,$t0  (-mips3)

why? 

best regards
　　　　　　　　glame

---

From: Thiemo Seufer <[email-masked]>
Date: Tue, 14 Sep 2004 14:06:40 +0200

> +ffffffff80010b8c:  0100102d    move    $v0,$t0  (-mips3)

Because you told it to do so. :-)
The 32bit move is "addu v0, $0, t0", the 64bit move "daddu ...".

Thiemo