Subject: Re:

From: "xuhaoz" <[email-masked]>
Date: Fri, 3 Sep 2004 16:57:16 +0800

hi:

	does somebody meet a problem like this?

	static void __init init_mount_tree(void)
	{
		mnt=do_kern_mount("rootfs",0,"rootfs",NULL);
		if(IS_ERR(mnt))
			panic("can't creat rootfs");
	}

	when uclinux run here, it report panic, and i wonder which cause this problem?
	would you please give a hint? any suggestion will appreciated!! 
	thank you !!

---

From: Fuxin Zhang <[email-masked]>
Date: Sat, 04 Sep 2004 05:47:48 +0800

This is probably nothing to do with mips thus not so suitable to appear
here:)

>			panic("can't creat rootfs");

And I think you should really do a little more before ask for such questions
(I will attach you a copy of the famous "How To Ask Questions The Smart Way"
,hope that helps:)

You can use ctags or some other code reading tools(e.g. source insight) to
dig in the code, it is not hard to find out where are the possible
failing reasons
then you can insert printks to test your thoughts.

Maybe you can use remote debug to trace the code too.