Subject: gcc 2.95 patch for IP28

From: Peter Fuerst <[email-masked]>
Date: Thu, 2 Sep 2004 04:11:25 +0200 (CEST)

Hello !

A patch to gcc 2.95.4 to make it insert the necessary cache barriers
in (kernel-)code for SGI Indigo2 R10k (IP28) is available at
http://home.alphastar.de/fuerst/download.html

with kind regards...

---

From: Florian Lohoff <[email-masked]>
Date: Tue, 14 Sep 2004 14:03:47 +0200

Hi Peter,

> http://home.alphastar.de/fuerst/download.html

I could build all the stuff.

I see the mentioned problem about 2.6 grinding to a halt too. Also i
have problems getting output on the serial console. its compiled in and
i see all kernel messages. Once into userspace i only see error messages
like this:

[...]
NET: Registered protocol family 2
IP: routing cache hash table of 1024 buckets, 16Kbytes
TCP: Hash tables configured (established 8192 bind 8192)
NET: Registered protocol family 1
NET: Registered protocol family 17
NET: Registered protocol family 15
Sending BOOTP requests . OK
IP-Config: Got BOOTP answer from 195.71.97.193, my address is 195.71.97.214
IP-Config: Complete:
      device=eth0, addr=195.71.97.214, mask=255.255.255.224, gw=195.71.97.193,
     host=195.71.97.214, domain=home.rfc822.org, nis-domain=(none),
     bootserver=195.71.97.193, rootserver=195.71.97.193, rootpath=/data/nfsroot/mips
Looking up port of RPC 100003/2 on 195.71.97.193
Looking up port of RPC 100005/1 on 195.71.97.193
VFS: Mounted root (nfs filesystem) readonly.
Freeing unused kernel memory: 148k freed
Ivemount: wrong fs type, bad option, bad superblock on tmpfs,
       or

the I looks like "INIT:". I cant explain the "ve" which comes some seconds

Flo
-- 
Florian Lohoff                  [email-masked]             +49-171-2280134
                        Heisenberg may have been here.

---

From: Peter Fuerst <[email-masked]>
Date: Wed, 15 Sep 2004 14:37:18 +0000 (GMT)

Hi !

> I could build all the stuff.

Hopefully with the updated gcc-patch from Sep 8th, which takes .reorder/
.noreorder settings into account, and seems to do the right thing:
meanwhile i build the kernels only on the I2 itself, and the 2.4-kernel
works flawlessly (as far as i can see).

> the I looks like "INIT:". I cant explain the "ve" which ...

This is most probably "INIT: version..." (Saw "Ive" last in June ;-)

> I see the mentioned problem about 2.6 grinding to a halt too...

Recently i traced this a bit further: from /sbin/init over sys32_execve,
open_exec,... finally an infinite loop in __d_lookup (dcache.c) showed up.
After changing the `hlist_for_each..' macros and local changes it looks like
we get over this place now.  Now, the last output i see, says that a syscall
4085 (__NR_readlink) is started (not the first 4085), some `execve's and
`open's later.
When the frustration has faded, i shall go on tracing.
The strange thing about the halt is, that it happens at an architecture-
independent place and not yet happened on other machines.

with kind regards

pf

On Tue, 14 Sep 2004, Florian Lohoff wrote:

> Date: Tue, 14 Sep 2004 14:03:47 +0200
> From: Florian Lohoff <[email-masked]>
> To: Peter Fuerst <[email-masked]>
> Cc: [email-masked]
> Subject: Re: gcc 2.95 patch for IP28
> 
> 
> Hi Peter,
>