Subject: Why the program complied by mips-linux-g++ cann't run on the target machine

From: "Li Shishan" <[email-masked]>
Date: Sat, 4 Sep 2004 13:06:39 +0800

Hi, all:

               I  use the   mips-linux-g++  complie a program.  and I excuted it on the target machine , but cann't, what's wrong?
     
              For example:

               For PC, I use g++  -c -o ccgame.o ccgame.cpp
		                    g++  -o ccgame ./ccgame.o
		execute it will give: Hello, world!

		For the target board, I use mips-linux-g++  -c -o ccgame.o ccgame.cpp 
		                             mips-linux-g++  -o ccgame ./ccgame.o
		excute it will give " /bin/sh: ./ccgame: not found". 

		Is there something wrong? 

		the mips-linux-gcc work is well!!!

		looking forward for anybody send me the question answer,very thanks!!!

		your sincerely liss

		2004.09.04  13:06

---

From: Geert Uytterhoeven <[email-masked]>
Date: Sat, 4 Sep 2004 22:43:54 +0200 (MEST)

> 		Is there something wrong?

Look like you didn't install the C++ runtime libraries on the target.
What does `ldd ./ccgame' say?

Gr{oetje,eeting}s,

						Geert

--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- [email-masked]

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
							    -- Linus Torvalds