Subject: __stq_u parameter

From: Pavel Kiryukhin <[email-masked]>
Date: Thu, 23 Sep 2004 19:24:47 +0400

Sorry,
 does this make sense for 2.4.x kernels?
----
Regards,
Pavel Kiryukhin
--- linux/include/asm-mips/unaligned.h_org	2004-09-23 15:54:37.000000000 +0400
+++ linux/include/asm-mips/unaligned.h	2004-09-23 18:32:48.000000000 +0400
@@ -61,7 +61,7 @@
 /*
  * Store doubleword ununaligned.
  */
-static inline void __stq_u(unsigned long __val, unsigned long long * __addr)
+static inline void __stq_u(unsigned long long __val, unsigned long long * __addr)
 {
 	__asm__("usw\t%1, %0\n\t"
 		"usw\t%D1, 4+%0"

---

From: Ralf Baechle <[email-masked]>
Date: Thu, 23 Sep 2004 22:59:46 +0200

> does this make sense for 2.4.x kernels?

Once uppon a time it made ...

The file has been rewritten completly since then.

Thanks anyway,

  Ralf

---

From: Pavel Kiryukhin <[email-masked]>
Date: Fri, 24 Sep 2004 18:19:51 +0400

Just in case it may help somebody..
This patch  is necessary for normal 1.3 and 1.3.1 XFS filesystem  
operations on  mips targets (LE especially) with  old (2.4) kernels.
----
Pavel