Subject: [patch 1/1] minmax-removal arch/mips/au1000/common/usbdev.c

From: [email-masked]
Date: Wed, 01 Sep 2004 23:28:17 +0200

Patch (against 2.6.8.1) removes unnecessary min/max macros and changes
calls to use kernel.h macros instead.

Since I dont have the hardware those patches are not tested.

Best regards
Veeck

Signed-off-by: Michael Veeck <[email-masked]>
Signed-off-by: Maximilian Attems <[email-masked]>

---

 linux-2.6.9-rc1-bk7-max/arch/mips/au1000/common/usbdev.c |    2 --
 1 files changed, 2 deletions(-)

diff -puN arch/mips/au1000/common/usbdev.c~min-max-arch_mips_au1000_common_usbdev arch/mips/au1000/common/usbdev.c
--- linux-2.6.9-rc1-bk7/arch/mips/au1000/common/usbdev.c~min-max-arch_mips_au1000_common_usbdev	2004-09-01 19:38:23.000000000 +0200
+++ linux-2.6.9-rc1-bk7-max/arch/mips/au1000/common/usbdev.c	2004-09-01 19:38:23.000000000 +0200
@@ -61,8 +61,6 @@
 #define vdbg(fmt, arg...) do {} while (0)
 #endif
 
-#define MAX(a,b)	(((a)>(b))?(a):(b))
-
 #define ALLOC_FLAGS (in_interrupt () ? GFP_ATOMIC : GFP_KERNEL)
 
 #define EP_FIFO_DEPTH 8

_

---

From: maximilian attems <[email-masked]>
Date: Thu, 2 Sep 2004 21:27:29 +0200

On Thu, 02 Sep 2004, Ralf Baechle wrote:

> On Wed, Sep 01, 2004 at 11:28:17PM +0200, [email-masked] wrote:
> 
> The patch description isn't really right here; the MAX macro in
> arch/mips/au1000/common/usbdev.c was unused so removing it was a
> nobrainer.

you are right,
sorry it was one of a bigger list of MIN/MAX conversions.
that's no excuse, i'll better double check next time.
 
> I guess that's excusable in this case ;-)

thanks.

--
maks
kernel janitor  	http://janitor.kernelnewbies.org/