Subject: Routing Performance Comparison between 2.4 and 2.6 kernel

From: Song Wang <[email-masked]>
Date: Fri, 10 Sep 2004 16:17:28 -0700 (PDT)

Hi,

I'm looking for the network packet routing
performance comparison between the latest 2.4
and 2.6 kernel.

I did some initial testing on my mips-based router.
2.6 kernel performed way below 2.4 kernel. It sucks.
Turning on preemption on 2.6 kernel even makes
routing performance worse.

Anybody did a comprehensive study on the routing
performance for 2.6 and 2.4 kernel?

Thanks.

_______________________________
Do you Yahoo!?
Shop for Back-to-School deals on Yahoo! Shopping.
http://shopping.yahoo.com/backtoschool

---

From: "David S. Miller" <[email-masked]>
Date: Fri, 10 Sep 2004 16:35:36 -0700

You might reach a more knowledgable and interested
audience at [email-masked] which is where the
networking developers are subscribed.