Subject: [PATCH 2.6] fix build error about NEC VR4100 series.

From: Yoichi Yuasa <[email-masked]>
Date: Thu, 2 Dec 2004 00:05:30 +0900

Hi Ralf,

This patch had fixed build error about NEC VR4100 series.
Please apply this patch to 2.6.

Yoichi

Signed-off-by: Yoichi Yuasa <[email-masked]>

diff -urN -X dontdiff a-orig/arch/mips/vr41xx/common/bcu.c a/arch/mips/vr41xx/common/bcu.c
--- a-orig/arch/mips/vr41xx/common/bcu.c	Thu May 27 02:11:11 2004
+++ a/arch/mips/vr41xx/common/bcu.c	Wed Dec  1 23:50:40 2004
@@ -30,6 +30,7 @@
  */
 #include <linux/init.h>
 #include <linux/ioport.h>
+#include <linux/kernel.h>
 #include <linux/smp.h>
 #include <linux/types.h>
 
diff -urN -X dontdiff a-orig/arch/mips/vr41xx/common/pmu.c a/arch/mips/vr41xx/common/pmu.c
--- a-orig/arch/mips/vr41xx/common/pmu.c	Thu May 27 02:11:11 2004
+++ a/arch/mips/vr41xx/common/pmu.c	Wed Dec  1 23:50:40 2004
@@ -18,6 +18,7 @@
  *  Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
  */
 #include <linux/init.h>
+#include <linux/kernel.h>
 #include <linux/smp.h>
 #include <linux/types.h>

---

From: Ralf Baechle <[email-masked]>
Date: Wed, 1 Dec 2004 16:44:23 +0100

> Please apply this patch to 2.6.

Applied,

  Ralf