Subject: About task->used_math and TIF_USEDFPU

From: zhan rongkai <[email-masked]>
Date: Thu, 16 Dec 2004 16:06:12 +0800

hi all,

I am a little confused about the task_struct member 'used_math', and
thread_info flag TIF_USEDFPU.

What are their meaning, and what is the difference between them?

thanks.

---

From: Jun Sun <[email-masked]>
Date: Thu, 16 Dec 2004 09:33:06 -0800

> What are their meaning, and what is the difference between them?

used_math is used to indicate whether a process has ever used FPU since
it is created (which typically is true due to the glibc using FPU at the
beginning of each program).

TIF_USEDFPU indicates whether a _running_ process has used FPU since
it is context-switched on.

Jun