Subject: arcboot initrd+iso9660+shell patch

From: "Kaj-Michael Lang" <[email-masked]>
Date: Fri, 3 Dec 2004 19:47:53 +0200

Hi

The patch is kinda large so I won't send it to the list, unless
it's ok? It is about 73k.

The patch does:
- Add initrd support (arcboot.conf: initrd=/ramdisk.gz)
- Add interactive/shell mode
  - Load kernel
  - Load ramdisk
  - Edit kernel cmdline arguments
  - ls
  - help for list of commands
- Add working iso9660 support
- Unfinished romfs support
- It's probably a mess
- Probably has many bugs here and there
- To start interactive mode boot with -i as parameter:
  "arcboot -i"
- Tested on IP32 only (and patch changes default to IP32 :)

http://home.tal.org/~milang/o2/patches/arcboot_onion_iso_shell_initrd-1.patch

A binary for IP32 is also available:
http://home.tal.org/~milang/o2/patches/arcboot-patched-1.ip32

Enjoy!

-- 
Kaj-Michael Lang , [email-masked]

---

From: Thiemo Seufer <[email-masked]>
Date: Sat, 4 Dec 2004 04:49:26 +0100

> http://home.tal.org/~milang/o2/patches/arcboot_onion_iso_shell_initrd-1.patch

Great! A few comments, though:

 - About CFLAGS: Using -g is almost always a good idea, even if you strip
   the binaries afterwards. Using -march=mips3 is a bad idea if we ever
   want to support Indigo1 etc. It also breaks build with older compilers,
   and doesn't provide any relevant performance gain.
 - _PARM_LIMIT was 32 to match the kernel param limit. If you change it to
   allow more for arcboot, make sure it complains if more than 32 params
   are passed to the kernel.
 - ARC_CDROM/ARC_DISK shouldn't have a leading pci(0) for ip22, PROMPT
   should be arcboot@ip22 in that case.
 - Default SUBARCH should remain ip22. Better: Build both unconditionally
   unless overridden by a SUBARCH setting.
 - The tip22 stuff is broken (at least: doesn't match what's in CVS).

Thiemo