Subject: [PATCH] add iomap functions

From: Sébastien Vajda <[email-masked]>
Date: Sat, 11 Dec 2004 21:34:06 +0100 (CET)

Dear all,

I tried compiling CVS from 3~4 days ago for a Cobalt
Qube2. This box has two tulip NIC. The tulip driver
has been changed in the 2.6.10-rcx timeframe. It now
uses iowrite32, ioread32 and assorted functions.

Those are currently not implemented in linux-mips.

In Novemember, Yoichi Yuasa submitted a patch for
iomap functions. On this submission Ralf Baechle asked
why not use the generic iomap implementation instead?

I've tried both. With the generic iomap the kernel
compiles fine, but the tulip driver is not working.
With Yoichi Yuasa's patch everything works as it
should.

As Yoichi's patch is needed for the Qube2 boxen, could
I ask if the patch is going to be applied in CVS. And
if not, what needs to be done?

ps.: I'm not on the list, so please CC me when
replying.

Best regards,
Seb.

		
Découvrez le nouveau Yahoo! Mail : 250 Mo d'espace de stockage pour vos mails ! 
Créez votre Yahoo! Mail sur http://fr.mail.yahoo.com/ 
 
Avec Yahoo! faites un don et soutenez le Téléthon en cliquant sur http://www.telethon.fr/030-Don/10-10_Don.asp

---

From: Yoichi Yuasa <[email-masked]>
Date: Sun, 12 Dec 2004 23:38:17 +0900

Hi,

On Sat, 11 Dec 2004 21:34:06 +0100 (CET)

> why not use the generic iomap implementation instead?

Some MIPS systems are unable to define PIO space by PIO_MASK/PIO_RESERVED.
This is the reason I didn't use the general iomap implementation.

Yoichi