Subject: kernel 2.6.9 patch

From: "Tatsuya Koseki" <[email-masked]>
Date: Tue, 14 Dec 2004 17:53:02 +0900

Please review 

--- linux/include/asm/stackframe.h.old Tue Dec 14 17:49:38 2004
+++ linux/include/asm/stackframe.h Tue Dec 14 17:50:35 2004
@@ -244,6 +244,10 @@
   nor v1, $0, v1
   and v0, v1
   or v0, a0
+
+  li v1,2
+  or v0,v1
+
   mtc0 v0, CP0_STATUS
   LONG_L v1, PT_EPC(sp)
   MTC0 v1, CP0_EPC

---

From: Ralf Baechle <[email-masked]>
Date: Wed, 15 Dec 2004 14:17:53 +0100

On Tue, Dec 14, 2004 at 05:53:02PM +0900, Tatsuya Koseki wrote:

> Subject: kernel 2.6.9 patch
> Date: Tue, 14 Dec 2004 17:53:02 +0900
> Content-Type: text/plain;
> 	charset="iso-2022-jp"
> 
> Please review 
> 
> 

 o Your patch got corrupted by using a differnet indentation so couldn't be
   applied anyway
 o When posting a patch, post an explanation.  If the purpose of a patch
   isn't obvious it'll likely be ignroed.
 o This bug was already fixed in CVS.
 o The issue only affected new-born processes, so there is no reason to
   burden the fix on every exception taken.
 o Why using two instruction if one would be sufficient.

  Ralf

---

From: "Tatsuya Koseki" <[email-masked]>
Date: Thu, 16 Dec 2004 11:53:41 +0900

I find this message,
  http://www.linux-mips.org/archives/linux-mips/2004-10/msg00256.html

Thank you  for reply.