Subject: minor asm-mips/sigcontext.h fix

From: Atsushi Nemoto <[email-masked]>
Date: Thu, 16 Dec 2004 19:37:58 +0900 (JST)

The asm-mips/sigcontext.h uses '#ifdef __KERNEL__' to not export
sigcontext32 to userland.  It includes linux/types.h but it is needed
just for sigcontext32, so it would be better to hide from userland
too.

Here is a patch.  Could you apply?

--- linux-mips/include/asm-mips/sigcontext.h	2004-08-14 19:56:24.000000000 +0900
+++ linux/include/asm-mips/sigcontext.h	2004-12-16 19:02:43.922237317 +0900
@@ -41,8 +41,6 @@
                                                                                 
 #if _MIPS_SIM == _MIPS_SIM_ABI64 || _MIPS_SIM == _MIPS_SIM_NABI32
 
-#include <linux/types.h>
-
 /*
  * Keep this struct definition in sync with the sigcontext fragment
  * in arch/mips/tools/offset.c
@@ -66,6 +64,8 @@
 };
 
 #ifdef __KERNEL__
+#include <linux/types.h>
+
 struct sigcontext32 {
 	__u32	sc_regmask;		/* Unused */
 	__u32	sc_status;

---
Atsushi Nemoto

---

From: Ralf Baechle <[email-masked]>
Date: Thu, 16 Dec 2004 14:21:49 +0100

> Here is a patch.  Could you apply?

Applied but changed to include <linux/posix_types.h> only.

  Ralf