Subject: Re: fyi, syscall() somehow broken...

From: Pete Popov <[email-masked]>
Date: Thu, 09 Dec 2004 07:25:49 -0800

> jfyi, something broke w/ the following commit... most notably 'ls -l'
> doesn't work anymore... reverting to yesterdays cvs state fixes the
> issues... ;-)
> 
> Working file: arch/mips/kernel/scall32-o32.S
> head: 1.18
> revision 1.18
> date: 2004/12/08 14:32:30;  author: ths;  state: Exp;  lines: +85 -102
> Fix indirect syscalls for o32, improve syscall performance a bit,
> and general code cleanup.

Someone reported this problem on the Au1x boards. Anyone else seeing 
the problem on other MIPS32 boards?

Pete

---

From: Thiemo Seufer <[email-masked]>
Date: Thu, 9 Dec 2004 16:44:05 +0100

> >doesn't work anymore... reverting to yesterdays cvs state fixes the

Confirmed on a SGI Indy with 32bit kernel. sys_quotactl seems to be
broken, while the rest of the system appears to work well.
I'll have a look.

> the problem on other MIPS32 boards?

The changed code is fairly hardware independent.

Thiemo

---

From: Thiemo Seufer <[email-masked]>
Date: Fri, 10 Dec 2004 07:25:23 +0100

> broken, while the rest of the system appears to work well.

I just committed a fix.

Thiemo