Subject: [PATCH] Ocelot-3 supports 256 MB memory

From: Manish Lachwani <[email-masked]>
Date: Mon, 6 Dec 2004 13:27:20 -0800

Hi Ralf,

Small patch for Ocelot-3 to support 256 MB memory. Please apply ...

Thanks
Manish Lachwani

--- arch/mips/momentum/ocelot_3/setup.c.orig	2004-12-06 13:18:44.000000000 -0800
+++ arch/mips/momentum/ocelot_3/setup.c	2004-12-06 13:18:57.000000000 -0800
@@ -390,8 +390,8 @@
 	printk("  - Boot flash write jumper: %s\n", (tmpword&0x40)?"installed":"absent");
 	printk("  - L3 cache size: %d MB\n", (1<<((tmpword&12) >> 2))&~1);
 
-	/* Support for 128 MB memory */
-	add_memory_region(0x0, 0x08000000, BOOT_MEM_RAM);
+	/* Support for 256 MB memory */
+	add_memory_region(0x0, 0x10000000, BOOT_MEM_RAM);
 
 	return 0;
 }

---

From: Ralf Baechle <[email-masked]>
Date: Mon, 6 Dec 2004 22:43:46 +0100

> Small patch for Ocelot-3 to support 256 MB memory. Please apply ...

Does this board really have a fixed memory configuration?  If not we should
use a safe default, the minimum configuration.  Or probe which obviously
is the right thing to do.

  Ralf

---

From: Manish Lachwani <[email-masked]>
Date: Mon, 06 Dec 2004 13:52:53 -0800

> is the right thing to do.

Probing is a better idea. Let me put that together and send another patch

Thanks
Manish Lachwani