Subject: Re: Forcing IDE to work in PIO mode

From: "Muruga Ganapathy" <[email-masked]>
Date: Thu, 9 Dec 2004 13:02:36 -0800

Manish, 

Thanks for the pointer.

I am looking for the PCMCIA-IDE driver for the SWARM board in 2.6.x
I did see this driver in 2.4.26/27 but not in 2.6.10.

Do you have any suggestions on porting the PCMCIA-IDE driver from 2.4.27
to 2.6.x?

Regards
G.Muruganandam

> I had posted a patch to this mailing list a few days back. The patch 
> applies cleanly to the current tree and is currently checked in: 
> drivers/ide/mips/swarm.c
> 
> Using this patch, Broadcom SWARM IDE works well
> 
> Thanks
> Manish Lachwani
> 
> Muruga Ganapathy wrote:
> > Thanks Manish for the information.  
> >  
> > BTW, do you have patch to make the swarm IDE work in 2.6.6-rc3 
> >  
> > Regards 
> > G.Muruganandam 
> >  
> >  
> > 
> >>Muruga Ganapathy wrote: 
> >>
> >>>Hello,  
> >>> 
> >>>How do I force the IDE to work in the PIO mode by including the  
> >>>option like "hdb=noprobe" in the setup.c? 
> >>> 
> >>> 
> >>>My kernel version is 2.6.6 
> >>> 
> >>>Thanks 
> >>>G.Muruganandam 
> >>> 
> >>
> >> 
> >>Hello ! 
> >> 
> >>I would have thought "ide=nodma" at the command line would have 
> > 
> > worked 
> > 
> >> 
> >>Thanks 
> >>Manish Lachwani 
> >> 
> >> 
> > 
> >  
> > ************************************************************* 
> > GDA Technologies, Inc.		 
> > 1010 Rincon Circle  
> > San Jose CA, 95131 
> > Phone	(408) 432-3090 
> > Fax	(408) 432-3091 
> >  
> > Accelerate Your Innovation	 
> > ************************************************************** 
> 
> 

*************************************************************
GDA Technologies, Inc.		
1010 Rincon Circle 
San Jose CA, 95131
Phone	(408) 432-3090
Fax	(408) 432-3091

Accelerate Your Innovation	
**************************************************************

---

From: Manish Lachwani <[email-masked]>
Date: Thu, 09 Dec 2004 13:29:33 -0800

Please point me to the 2.4.26 or 2.4.27 code that you are referring to

Thanks
Manish Lachwani