Subject: Re: Forcing IDE to work in PIO mode

From: "Muruga Ganapathy" <[email-masked]>
Date: Thu, 9 Dec 2004 10:14:01 -0800

Thanks Manish for the information.  
 
BTW, do you have patch to make the swarm IDE work in 2.6.6-rc3 
 
Regards 
G.Muruganandam 

> Muruga Ganapathy wrote: 
> > Hello,  
> >  
> > How do I force the IDE to work in the PIO mode by including the  
> > option like "hdb=noprobe" in the setup.c? 
> >  
> >  
> > My kernel version is 2.6.6 
> >  
> > Thanks 
> > G.Muruganandam 
> >  
>  
> Hello ! 
>  
> I would have thought "ide=nodma" at the command line would have 
worked 
> Thanks 
> Manish Lachwani 
 
************************************************************* 
GDA Technologies, Inc.		 
1010 Rincon Circle  
San Jose CA, 95131 
Phone	(408) 432-3090 
Fax	(408) 432-3091 
 
Accelerate Your Innovation	 
**************************************************************

---

From: Manish Lachwani <[email-masked]>
Date: Thu, 09 Dec 2004 11:30:46 -0800

I had posted a patch to this mailing list a few days back. The patch 
applies cleanly to the current tree and is currently checked in: 
drivers/ide/mips/swarm.c

Using this patch, Broadcom SWARM IDE works well

Thanks
Manish Lachwani