Subject: Titan ethernet and little endian

From: Rojhalat Ibrahim <[email-masked]>
Date: Thu, 03 Feb 2005 15:59:32 +0100

Hi,
a while ago I posted the attached patch,
which makes the titan_ge driver work in
little-endian mode. I got no reaction
whatsoever. What did I do wrong?
Rojhalat Ibrahim

Index: titan_ge.h
===================================================================
RCS file: /home/cvs/linux/drivers/net/titan_ge.h,v
retrieving revision 1.17
diff -u -r1.17 titan_ge.h
--- titan_ge.h	4 Dec 2004 23:42:53 -0000	1.17
+++ titan_ge.h	10 Jan 2005 12:59:20 -0000
@@ -153,8 +153,10 @@
 
 /* Define the Rx descriptor */
 typedef struct eth_rx_desc {
-	u32	buffer_addr;	/* Buffer address inclusive of checksum */
-	u32     cmd_sts;	/* Command and Status info */
+	u32     buffer_addr;	/* CPU buffer address 	*/
+	u32     reserved;	/* Unused 		*/
+	u32	buffer;		/* XDMA buffer address	*/
+	u32	cmd_sts;	/* Command and Status	*/
 } titan_ge_rx_desc;
 
 /* Define the Tx descriptor */

---

From: Manish Lachwani <[email-masked]>
Date: Thu, 03 Feb 2005 10:13:21 -0800

Rojhalat Ibrahim wrote:

>------------------------------------------------------------------------
>
>Index: titan_ge.h
Hi !

So, have you got the titan to work in the LE mode? Are you using the 
Yosemite board? Does this patch break BE?

Please do let us know.

Thanks
Manish Lachwani

---

From: Rojhalat Ibrahim <[email-masked]>
Date: Mon, 07 Feb 2005 08:43:37 +0100

> Yosemite board? Does this patch break BE?

Hi!

Yes I have got the titan work in LE mode. And yes I am using the
Yosemite board. And no this patch does not break BE. I haven't
actually tested that but all the changes I made are between
#ifdef LITTLE_ENDIAN and #endif.

Thanks
Rojhalat Ibrahim

---

From: Manish Lachwani <[email-masked]>
Date: Mon, 07 Feb 2005 09:30:21 -0800

> #ifdef LITTLE_ENDIAN and #endif.
Ok, as long as the changes are in #ifdef. Although, your patch did not 
indicate the "#ifdef LITTLE_ENDIAN"

Thanks
Manish Lachwani

---

From: Rojhalat Ibrahim <[email-masked]>
Date: Tue, 08 Feb 2005 08:30:26 +0100

> indicate the "#ifdef LITTLE_ENDIAN"

That's because the #ifdef was already there. The code inbetween
was just not entirely correct.

Thanks
Rojhalat Ibrahim

---

From: Rojhalat Ibrahim <[email-masked]>
Date: Thu, 10 Feb 2005 09:43:11 +0100

> indicate the "#ifdef LITTLE_ENDIAN"

I have actually tested it also in BE mode now.
Is there any remaining reason not to apply this patch?

Thanks
Rojhalat Ibrahim