Subject: Re: CVS [email-masked]: linux

From: "Maciej W. Rozycki" <[email-masked]>
Date: Sun, 13 Feb 2005 21:33:48 +0000 (GMT)

On Sun, 13 Feb 2005 [email-masked] wrote:

> Modified files:
> 	arch/mips      : Kconfig 
> 
> Log message:
> 	If you want RM7000 better fix it to build first ...

 It works for me -- if you want a fix, then tell me what exactly is wrong.  
Perhaps your compiler is broken.

  Maciej

---

From: "Maciej W. Rozycki" <[email-masked]>
Date: Fri, 25 Feb 2005 16:48:06 +0000 (GMT)

On Fri, 25 Feb 2005 [email-masked] wrote:

> Modified files:
> 	arch/mips/mm   : pg-sb1.c 
> 
> Log message:
> 	Fix initialization. Unbreak the wait-for-completion loops. Code cleanup.

 Don't use a cast on IOADDR() -- it already returns "void *".  The casts 
obfuscate code and make it difficult to spot incorrect use if the API ever 
changes.

  Maciej

---

From: "Maciej W. Rozycki" <[email-masked]>
Date: Fri, 25 Feb 2005 16:50:29 +0000 (GMT)

On Fri, 25 Feb 2005 [email-masked] wrote:

> Modified files:
> 	drivers/i2c/busses: i2c-sibyte.c 
> 
> Log message:
> 	Fix 64bit builds.

 Well, these should actually be converted to ioremap()...

  Maciej