Subject: HIGHMEM Query

From: <[email-masked]>
Date: Thu, 17 Feb 2005 10:40:22 +0530

hi,

I have been working on HIGHMEM fixation for 2.4.20 linux MVL kernel for
MIPS architecture.
I am getting DATA BUS ERROR(ADDR: 0xffffd000) exception when loading
(copying the data received from ethernet to the kernel space in FIXADDR
SPACE) "/sbin/init" from TARGET ROOT DIR (through NFS). I figured out
that this is because there is no corresponding page table entry for the
same.

I checked that the virtual address is generated by making a call to
kmap_atomic(). Which internally calls set_pte() and then
local_flush_tlb_all(). Virtual Address is generated by making a call to

vaddr = __fix_to_virt(FIX_KMAP_BEGIN + idx);
1> Where is the page table entries updated?
2> When are they updated with the processor?

Regards,

Rishabh

The information contained in this e-mail message and in any annexure is
confidential to the  recipient and may contain privileged information. If you are not
the intended recipient, please notify the sender and delete the message along with
any annexure. You should not disclose, copy or otherwise use the information contained
in the message or any annexure. Any views expressed in this e-mail are those of the
individual sender except where the sender specifically states them to be the views of
SoCrates Software India Pvt Ltd., Bangalore.

---

From: Ralf Baechle <[email-masked]>
Date: Thu, 17 Feb 2005 20:36:54 +0000

On Thu, Feb 17, 2005 at 10:40:22AM +0530, [email-masked] wrote:

First, fix your mailer setup, it's littering emails with extra carriage
returns.

> that this is because there is no corresponding page table entry for the

That does not make sense.  If you don't have a pagetable entry the CPU will
take a TLB reload exception.  If the entry is invalid, the kernel will
die with an oops.  A bus error has different causes.

  Ralf