Subject: error:Unhandled relocation of type 7 for

From: "李建坤" <[email-masked]>
Date: Thu, 17 Feb 2005 11:23:06 +0800

Hi everyone,

  I has been developing drivers for AMD MIPS CPU Au1x00, but I encounted some problems, maybe you could help me!

  I cross-complile my kernel with options:
  make CFLAGS="-D__KERNEL__ -I/work/opt/target/root/ljk/pda_linux/include -Wall -Wstrict-prototypes -Wno-trigraphs -O2 -fno-strict-aliasing -fno-common -pipe -fno-pic -mno-abicalls -mlong-calls -fomit-frame-pointer -I /work/opt/target/root/ljk/pda_linux/include/asm/gcc -G 0 -mno-abicalls -fno-pic -pipe -mcpu=r4600 -mips2 -Wa,--trap " -C  arch/mips/lib

  and then I compile my driver modules with following options:
  mips_fp_le-gcc  -D__KERNEL__ -DMODULE=1 -I/opt/target/root/ljk/pda_linux/include -O2  -DLINUX -Wall -Wstrict-prototypes -fomit-frame-pointer -Wno-trigraphs -O2 -fno-strict-aliasing -fno-common -pipe -DALSA_BUILD -nostdinc -iwithprefix include -fno-pic -mno-abicalls -mlong-calls

  but when I want to insmod this modules, the errors come:
  insmod snd-page-alloc.o
  snd-page-alloc.o: Unhandled relocation of type 7 for
  snd-page-alloc.o: Unhandled relocation of type 7 for
  snd-page-alloc.o: Unhandled relocation of type 7 for
  snd-page-alloc.o: Unhandled relocation of type 7 for
  snd-page-alloc.o: Unhandled relocation of type 7 for
  snd-page-alloc.o: Unhandled relocation of type 7 for
  snd-page-alloc.o: Unhandled relocation of type 7 for
  snd-page-alloc.o: Unhandled relocation of type 7 for
  snd-page-alloc.o: Unhandled relocation of type 7 for
  snd-page-alloc.o: Unhandled relocation of type 7 for
  
  Have you come up with these problems? and Could you help me or give me some suggestions?
  Thank you in advance!	

　            [email-masked]
　　　　　　　　　　2005-02-17
�鳕殮,穽点@烹灨鉢痡3角

---

From: Thiemo Seufer <[email-masked]>
Date: Mon, 21 Feb 2005 13:34:45 +0100

>   mips_fp_le-gcc  -D__KERNEL__ -DMODULE=1 -I/opt/target/root/ljk/pda_linux/include -O2  -DLINUX -Wall -Wstrict-prototypes -fomit-frame-pointer -Wno-trigraphs -O2 -fno-strict-aliasing -fno-common -p…

"-G 0 -mcpu=r4600 -mips2 -Wa,--trap" went missing.

>   snd-page-alloc.o: Unhandled relocation of type 7 for

And that's the result of it (missing -G 0, specifically).

Thiemo

---

From: Ralf Baechle <[email-masked]>
Date: Mon, 21 Feb 2005 13:59:26 +0000

On Mon, Feb 21, 2005 at 01:34:45PM +0100, Thiemo Seufer wrote:
> Date:	Mon, 21 Feb 2005 13:34:45 +0100
> To:	?????? <[email-masked]>
> Cc:	linux-mips <[email-masked]>
> Subject: Re: error:Unhandled relocation of type 7 for
> Content-Type: text/plain; charset=us-ascii
> From:	Thiemo Seufer <[email-masked]>
> 
> ?????? wrote:
> > Hi everyone,
> > 

GP Optimization has _never_ done anything useful on Linux as such I blame
the person who put that -G 8 crap into gcc.

  Ralf