Subject: configuration of yosemite board with titan 1.2

From: TheNop <[email-masked]>
Date: Thu, 17 Feb 2005 11:04:23 +0100

Hello,

today i got the yosemite board with titan 1.2.
Currently I have problems to get the kernel 2.6.10.rc1 running (it runs 
on the old yosemite quite well).
The first thing I noticed is that after starting the kernel no output on 
the console is printed.
On the new yosemite board I got, the external UART chip (U36) is not 
mounted anymore. Could that cause my problems?

Is there anybody how can send my a .config file to get the yosemite working?

Best regards
TheNop

---

From: Rojhalat Ibrahim <[email-masked]>
Date: Thu, 17 Feb 2005 13:08:06 +0100

Hi,

if you want to use the internal UART, you need an adapted
kernel from PMC. The kernel from linux-mips.org only supports
the external UART chip. You can download an adapted source
archive from the PMC-Sierra ftp site.

Rojhalat Ibrahim

---

From: TheNop <[email-masked]>
Date: Thu, 17 Feb 2005 13:42:34 +0100

Hi,

on the ftp site of PMC I only found kernel 2.4.26 sources supporting
internal UART.
I need kernel 2.6.
Is it planed to integrate internal UART support to linux-mips.org 2.6
sources?

Why PMC-Sierra removed the external UART chip?
So it is not possible to use current yosemite boards with linux-mips.org :-(

Beste regards
TheNop

Rojhalat Ibrahim wrote:

>> Currently I have problems to get the kernel 2.6.10.rc1 running (it 
>> runs on the old yosemite quite well).
>> The first thing I noticed is that after starting the kernel no output 
>> on the console is printed.

---

From: Rojhalat Ibrahim <[email-masked]>
Date: Thu, 17 Feb 2005 17:00:10 +0100

> on the ftp site of PMC I only found kernel 2.4.26 sources supporting

They have recently (about one week ago) uploaded a kernel 2.6
that supports the internal UART.

> So it is not possible to use current yosemite boards with linux-mips.org 

Not without the external UART chip. On my board with chip revision 1.2
the external UART chip is still present. I just had to change some
resistor stuffing option to make it work.

---

From: TheNop <[email-masked]>
Date: Thu, 17 Feb 2005 17:17:05 +0100

Hi, 

thanx, now I found the 2.6 sources with internal UART support.
I was probably blind. :-)

Best regards