Subject: [PATCH] Fix Kconfig for Broadcom SWARM

From: Manish Lachwani <[email-masked]>
Date: Tue, 1 Feb 2005 12:28:35 -0800

Hi Ralf,

Attached patch adds necessary options for Broadcom SWARM. 

Thanks
Manish Lachwani
Index: linux/arch/mips/Kconfig
===================================================================
--- linux.orig/arch/mips/Kconfig
+++ linux/arch/mips/Kconfig
@@ -498,6 +498,8 @@
 	select SWAP_IO_SPACE
 	select SYS_SUPPORTS_BIG_ENDIAN
 	select SYS_SUPPORTS_LITTLE_ENDIAN
+	select SIBYTE_CFE
+	select SIBYTE_HAS_LDT
 
 config SIBYTE_SENTOSA
 	bool "Support for Sibyte BCM91250E-Sentosa"

---

From: "Maciej W. Rozycki" <[email-masked]>
Date: Tue, 1 Feb 2005 22:42:27 +0000 (GMT)

> Attached patch adds necessary options for Broadcom SWARM. 

 What is it supposed to do?

  Maciej

---

From: Manish Lachwani <[email-masked]>
Date: Tue, 01 Feb 2005 14:54:50 -0800

> What is it supposed to do?
libs-$(CONFIG_SIBYTE_CFE)       += arch/mips/sibyte/cfe/

in arch/mips/Makefile

So, without the above, contents of arch/mips/sibyte/cfe/ are not compiled.

SIBYTE_HAS_LDT is needed for the LDT specific stuff in 
arch/mips/pci/pci-sb1250.c

Btw, there are other issues as well. More options need to be defined to 
compile in the serial driver, ethernet driver and to compile for a PASS 
2 CPU. For example, the ethernet driver drivers/net/sb1250-mac.c 
compiles only if SIBYTE_SB1xxx_SOC is defined. And SIBYTE_SB1xxx_SOC no 
longer exists in arch/mips/Kconfig.

Thanks
Manish Lachwani

---

From: "Maciej W. Rozycki" <[email-masked]>
Date: Tue, 1 Feb 2005 23:27:11 +0000 (GMT)

> arch/mips/pci/pci-sb1250.c

 Both options are taken care of in arch/mips/sibyte/Kconfig, thus any fix 
should be sought there.

> compile in the serial driver, ethernet driver and to compile for a PASS 2 CPU.

 Likewise.

> For example, the ethernet driver drivers/net/sb1250-mac.c compiles only if
> SIBYTE_SB1xxx_SOC is defined. And SIBYTE_SB1xxx_SOC no longer exists in
> arch/mips/Kconfig.

 This one is missing indeed.

 I'll have a look at how to get the mess resolved.

  Maciej

---

From: Ralf Baechle <[email-masked]>
Date: Thu, 3 Feb 2005 15:29:19 +0100

> Attached patch adds necessary options for Broadcom SWARM. 

And forgets about all other Sibyte boards ...

  Ralf

---

From: Manish Lachwani <[email-masked]>
Date: Thu, 03 Feb 2005 09:36:26 -0800

>And forgets about all other Sibyte boards ...
The problem is that SIBYTE_SB1xxx_SOC is undefined. We need a small 
change in arch/mips/sibyte/Kconfig:

config SIBYTE_SB1xxx_SOC
        bool "Support for Broadcom BCM1xxx SOCs "

Since the ethernet driver, the serial driver and the CFE depend on this 
option to be selected else they wont be compiled in.

Thanks
Manish Lachwani

---

From: Ralf Baechle <[email-masked]>
Date: Fri, 4 Feb 2005 00:57:02 +0100

> option to be selected else they wont be compiled in.

The fix for this is already in CVS since a few hours.

  Ralf