Subject: Linux 2.6 support for Brecis MSP2100 processor !

From: Linux Mailinglist <[email-masked]>
Date: Tue, 8 Mar 2005 20:26:40 -0800

Hi all !

Is anybody have a port of Linux 2.6 kernel on Brecis MSP2100 processor ? 

Thanks 
Srinivasan

---

From: Ralf Baechle <[email-masked]>
Date: Wed, 9 Mar 2005 17:30:44 +0000

> Is anybody have a port of Linux 2.6 kernel on Brecis MSP2100 processor ? 

That's not a processor but a whole SOC and the processor is a 4Km which
is supported.

  Ralf

---

From: [email-masked]
Date: Wed, 9 Mar 2005 20:20:02 +0200 (EET)

> That's not a processor but a whole SOC and the processor is a 4Km which

Hi,

Brecis will support it if you buy more than 100 devices.

Best regards,
Ruijinschi Remus
[email-masked]

---

From: Linux Mailinglist <[email-masked]>
Date: Thu, 10 Mar 2005 17:46:23 -0800

Hi Ralf !

Thanks, but the problem with this SOC is that it does not have MMU. I
would like to know wheather we have the port for Mips 4Km processor
without MMU ?

Thanks in advance. 
Srinivasan

---

From: Pete Popov <[email-masked]>
Date: Thu, 10 Mar 2005 17:56:25 -0800

> would like to know wheather we have the port for Mips 4Km processor

Take a look at uclinux.org. That's the MMU-less project. I don't 
know what the MIPS statis is though.

Pete

---

From: Manish Lachwani <[email-masked]>
Date: Thu, 10 Mar 2005 18:14:05 -0800

Hello !

4Km is a 4Kc without TLB. I think this is supported.

Thanks
Manish Lachwani

Pete Popov wrote:

> Take a look at uclinux.org. That's the MMU-less project. I don't know 
> what the MIPS statis is though.
>
> Pete
>
>>
>> Thanks in advance. Srinivasan
>>
>>

---

From: Ralf Baechle <[email-masked]>
Date: Fri, 11 Mar 2005 14:35:02 +0000

> 4Km is a 4Kc without TLB. I think this is supported.

Maybe at uclinux.org but certainly not on linux-mips.org.  There have never
been many requests for Linux on TLB-less processors and in recent years
the interest that low interest seems to have fallen even further.

That said, if anybody wants to working on supporting MIPS with
CONFIG_MMU=n by all means, go ahead.

  Ralf

---

From: Linux Mailinglist <[email-masked]>
Date: Fri, 11 Mar 2005 10:26:11 -0800

Thanks everiybody. I think I should go ahead and start doing it myself. 

Srinivasan