Subject: Some questions about kernel tailoring

From: dfsd df <[email-masked]>
Date: Wed, 30 Mar 2005 15:37:42 +0800 (CST)

Hello, everybody:
     Now, I participate to porting linux to MIPS platform. I'm a newbie.
 
     I met some questions, I hope somebody can tell me why or give me some hints! thanks!
 
The board is Malta, CPU is MIPS4kc. I downloaded kernel src from ftp.mips.com
 
    1. I use "make zImage" for kernel-2.4.3, everything is ok!
 But using "make zImage" for kernel-2.4.18, I failed, It could only build a vmlinux file. 
I  find it's because of no rules in arch/mips/boot/Makefile to build zImage. 
So I modified the arch/mips/boot/Makefile, It worked fine.
 but when excuted "./mkboot zImage.tmp zImage", It generated a very big zImage file. After noticing "file size exceed", the system delete the zImage file automatically!
 
what's wrong about it? It's ok for kernel-2.4.3. and I can make sure that the mkboot is no problem.
 
2. I only selectd board and cpu type when compiling the kernel-2.4.3. 
If using make ,the vmlinux size is about 780k. If using "make zImage", the zImage file is about 580k.
I think that's a minimun size by using "make menuconfig". 
but I use gzip to compress this two files, its size became only 1/3 of their original size.
 
So I'm puzzled why "make zImage" don't use gzip compress method? If so , we can get a more small kernel, isn't it?
 
thanks again!

---------------------------------
Do You Yahoo!?
150万曲MP3疯狂搜，带您闯入音乐殿堂
美女明星应有尽有，搜遍美图、艳图和酷图
1G就是1000兆，雅虎电邮自助扩容！

---

From: Stuart Longland <[email-masked]>
Date: Thu, 31 Mar 2005 08:20:17 +1000

dfsd df wrote:
> The board is Malta, CPU is MIPS4kc. I downloaded kernel src from
> ftp.mips.com <ftp://ftp.mips.com>
>  

That's correct... 'vmlinux' is your kernel.  mips doesn't use zImages.

>  but when excuted "./mkboot zImage.tmp zImage", It generated a very big
> zImage file. After noticing "file size exceed", the system delete the
> zImage file automatically!
> 

Try running mkboot on the vmlinux file.

> that the mkboot is no problem.

A newer kernel mightn't be a bad idea either... 2.4.3 is very old now.

> So I'm puzzled why "make zImage" don't use gzip compress method? If so ,
> we can get a more small kernel, isn't it?
>  
> thanks again!

I'll let the guru's chime in here :-)

(PS... Please refrain from HTML email on this list)

-- 
+-------------------------------------------------------------+
| Stuart Longland -oOo- http://stuartl.longlandclan.hopto.org |
| Atomic Linux Project     -oOo-    http://atomicl.berlios.de |
| - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - |
| I haven't lost my mind - it's backed up on a tape somewhere |
+-------------------------------------------------------------+

---

From: Ralf Baechle DL5RB <[email-masked]>
Date: Thu, 31 Mar 2005 17:09:42 +0100

> (PS... Please refrain from HTML email on this list)

The list is configured to reject HTML email.  But - the filter didn't
detect this broken use of HTML.

  Ralf