Subject: [patch] fix structure declarations

From: Ulrich Eckhardt <[email-masked]>
Date: Tue, 15 Mar 2005 08:30:23 +0100

Hi!

Seems someone went about adding C99 initialisers, but accidentally 'fixed' 
these structure definitions containing bitfields...

Uli

Index: drivers/pcmcia/au1000_generic.h
===================================================================
RCS file: /home/cvs/linux/drivers/pcmcia/au1000_generic.h,v
retrieving revision 1.5
diff -u -r1.5 au1000_generic.h
--- drivers/pcmcia/au1000_generic.h 28 Feb 2005 13:35:57 -0000 1.5
+++ drivers/pcmcia/au1000_generic.h 15 Mar 2005 07:27:41 -0000
@@ -61,21 +61,21 @@
 
 struct pcmcia_state {
   unsigned detect: 1,
-            .ready = 1,
-           .wrprot = 1,
-      bvd1: 1,
-      bvd2: 1,
+            ready: 1,
+           wrprot: 1,
+             bvd1: 1,
+             bvd2: 1,
             vs_3v: 1,
             vs_Xv: 1;
 };
 
 struct pcmcia_configure {
   unsigned sock: 8,
-            .vcc = 8,
-            .vpp = 8,
-         .output = 1,
-        .speaker = 1,
-          .reset = 1;
+            vcc: 8,
+            vpp: 8,
+         output: 1,
+        speaker: 1,
+          reset: 1;
 };
 
 struct pcmcia_irqs {

---

From: Ralf Baechle <[email-masked]>
Date: Tue, 15 Mar 2005 12:55:17 +0000

> these structure definitions containing bitfields...

Your mailer converted the tabs in the patch into spaces ..