Subject: Re: Some questions about kernel tailoring

From: dfsd df <[email-masked]>
Date: Thu, 31 Mar 2005 09:49:35 +0800 (CST)

Thanks for your reply!

> That's correct... 'vmlinux' is your kernel.  mips
> doesn't use zImages.

But , the vmlinux is too big, Waht should I do? Is the
vmlinux already compressed?

> (PS... Please refrain from HTML email on this list)

Sorry, I'm a newbie, I really don't know what you
mean. :-)

--- Stuart Longland <[email-masked]>
wrote:
> dfsd df wrote:
> > Hello, everybody:
> >      Now, I participate to porting linux to MIPS
> platform. I'm a newbie.
> >  
> >      I met some questions, I hope somebody can
> tell me why or give me
> > some hints! thanks!
> >  
> > The board is Malta, CPU is MIPS4kc. I downloaded
> kernel src from
> > ftp.mips.com <ftp://ftp.mips.com>
> >  
> > 1. I use "make zImage" for kernel-2.4.3,
> everything is ok!
> > But using "make zImage" for kernel-2.4.18, I
> failed, It could only
> > build a vmlinux file.
> 
> That's correct... 'vmlinux' is your kernel.  mips
> doesn't use zImages.
> 
> > I find it's because of no rules in
> arch/mips/boot/Makefile to build
> > zImage.
> > So I modified the arch/mips/boot/Makefile, It
> worked fine.
> >  but when excuted "./mkboot zImage.tmp zImage", It
> generated a very big
> > zImage file. After noticing "file size exceed",
> the system delete the
> > zImage file automatically!
> > 
> 
> Try running mkboot on the vmlinux file.
> 
> > what's wrong about it? It's ok for kernel-2.4.3.
> and I can make sure
> > that the mkboot is no problem.
> 
> A newer kernel mightn't be a bad idea either...
> 2.4.3 is very old now.
> 
> > 2. I only selectd board and cpu type when
> compiling the kernel-2.4.3.
> > If using make ,the vmlinux size is about 780k. If
> using "make zImage",
> > the zImage file is about 580k.
> > I think that's a minimun size by using "make
> menuconfig".
> > but I use gzip to compress this two files, its
> size became only 1/3 of
> > their original size.
> >  
> > So I'm puzzled why "make zImage" don't use gzip
> compress method? If so ,
> > we can get a more small kernel, isn't it?
> >  
> > thanks again!
> 
> I'll let the guru's chime in here :-)
> 
> (PS... Please refrain from HTML email on this list)
> 
> -- 
>
+-------------------------------------------------------------+
> | Stuart Longland -oOo-
> http://stuartl.longlandclan.hopto.org |
> | Atomic Linux Project     -oOo-   
> http://atomicl.berlios.de |
> | - - - - - - - - - - - - - - - - - - - - - - - - -
> - - - - - |
> | I haven't lost my mind - it's backed up on a tape
> somewhere |
>
+-------------------------------------------------------------+

_________________________________________________________
Do You Yahoo!?
注册世界一流品质的雅虎免费电邮
http://cn.rd.yahoo.com/mail_cn/tag/1g/*http://cn.mail.yahoo.com/

---

From: Stuart Longland <[email-masked]>
Date: Thu, 31 Mar 2005 13:49:15 +1000

> vmlinux already compressed?

Normally you manually gzip it -- but it will largely depend on what the
bootloader for your device expects.  Incidentally, are you trying to
boot the kernel directly, or via something like U-boot or YAMON?
AFAIK these evaluation boards are not designed to directly boot a kernel.

> Sorry, I'm a newbie, I really don't know what you

Rich text emails -- in layman's terms.  Couple of reasons for this:
* They do make the email slightly larger
* Not everyone can see HTML
* SPAM and Viruses commonly exploit HTML

Never mind though, as it seems your mail client has figured to use
plaintext already. ;-)

-- 
+-------------------------------------------------------------+
| Stuart Longland -oOo- http://stuartl.longlandclan.hopto.org |
| Atomic Linux Project     -oOo-    http://atomicl.berlios.de |
| - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - |
| I haven't lost my mind - it's backed up on a tape somewhere |
+-------------------------------------------------------------+