Subject: Build 64bit on RaQ2

From: Jim Gifford <[email-masked]>
Date: Fri, 25 Mar 2005 15:31:19 -0800

Has anyone had any luck compiling a 64 bit version on the RaQ2. I can 
get it to compile but, it locks up during boot up.

elf64: 00080000 - 0042fd3f (ffffffff,803e6000) (ffffffff,8000000)
elf64: ffffffff,80080000 (8008000) 3731589t + 134331t

That's all I got during bootup, no error messages or anything.

-- 
----
Jim Gifford
[email-masked]

---

From: Kumba <[email-masked]>
Date: Fri, 25 Mar 2005 19:38:11 -0500

> That's all I got during bootup, no error messages or anything.

Peter Horton had some experimental code in the kernel at one point to try 
this.  I managed to get a 2.6.9 (I think, maybe 2.6.10) mips64 kernel to boot 
on cobalt, but it was pretty useless.  Poor machine was slower than molasses 
uphill in winter.

I believe cobalt would run better using the o64 kernel hack than pure n64 
kernel (-mabi=64), but cobalt needs some fixups to its spaces.h before an o64 
kernel will build on it.

--Kumba

-- 
"Such is oft the course of deeds that move the wheels of the world: small 
hands do them because they must, while the eyes of the great are elsewhere." 
--Elrond

---

From: Peter Horton <[email-masked]>
Date: Sat, 26 Mar 2005 09:12:18 +0000

> That's all I got during bootup, no error messages or anything.

As a starting point you need to ensure the "cpu_has_llsc" is false for
64-bit Cobalt kernels. LLD/SCD is broken on RM5230/5231. There is an
experimental patch for 2.6.9 on
http://www.colonel-panic.org/cobalt-mips.

P.

---

From: Jim Gifford <[email-masked]>
Date: Mon, 28 Mar 2005 15:06:36 -0800

>http://www.colonel-panic.org/cobalt-mips.
Peter,
    Got it to compile, but the tulip driver is giving me fits. I built 
it as a module and into the kernel

0000:00:07.0: tulip_stop_rxtx() failed
0000:00:07.0: tulip_stop_rxtx() failed
0000:00:07.0: tulip_stop_rxtx() failed
0000:00:07.0: tulip_stop_rxtx() failed
0000:00:07.0: tulip_stop_rxtx() failed
0000:00:07.0: tulip_stop_rxtx() failed
0000:00:07.0: tulip_stop_rxtx() failed
0000:00:07.0: tulip_stop_rxtx() failed
0000:00:07.0: tulip_stop_rxtx() failed
0000:00:07.0: tulip_stop_rxtx() failed
0000:00:07.0: tulip_stop_rxtx() failed
0000:00:07.0: tulip_stop_rxtx() failed
0000:00:07.0: tulip_stop_rxtx() failed
0000:00:07.0: tulip_stop_rxtx() failed
0000:00:07.0: tulip_stop_rxtx() failed
0000:00:07.0: tulip_stop_rxtx() failed
0000:00:07.0: tulip_stop_rxtx() failed
0000:00:07.0: tulip_stop_rxtx() failed
0000:00:07.0: tulip_stop_rxtx() failed
0000:00:07.0: tulip_stop_rxtx() failed
0000:00:07.0: tulip_stop_rxtx() failed

-- 
----
Jim Gifford
[email-masked]

---

From: Peter Horton <[email-masked]>
Date: Tue, 29 Mar 2005 22:46:41 +0100

> 0000:00:07.0: tulip_stop_rxtx() failed

Tulip driver gave me problems also. I landed up inserting a printk()
which made it work, see the patch. I didn't get round to debugging it
any further, sorry.

P.

---

From: Jim Gifford <[email-masked]>
Date: Tue, 29 Mar 2005 14:11:09 -0800

>which made it work, see the patch. I didn't get round to debugging it
I posted a simliar question to the linux-net list, a lot of people don't 
understand why the driver doesn't work in 64 bit, but works perfectly in 
32 bit.

-- 
----
Jim Gifford
[email-masked]