Subject: Re: Some questions about kernel tailoring

From: dfsd df <[email-masked]>
Date: Thu, 31 Mar 2005 17:41:15 +0800 (CST)

Thanks again!
 
Because of the limitation of memory, I don't want to use YAMON. 
Using gzip -9, I can get a kernel more small than the kernel made by "make zImage". 
So I want to write a very simple bootloader and make a self-decompressed kernel.
 
But why everyone use "make zImage" instead of my method? That's what puzzles me? 

Stuart Longland <[email-masked]> wrote:
dfsd df wrote:
> Thanks for your reply!
> 
>>That's correct... 'vmlinux' is your kernel. mips
>>doesn't use zImages.
> 
> But , the vmlinux is too big, Waht should I do? Is the
> vmlinux already compressed?

Normally you manually gzip it -- but it will largely depend on what the
bootloader for your device expects. Incidentally, are you trying to
boot the kernel directly, or via something like U-boot or YAMON?
AFAIK these evaluation boards are not designed to directly boot a kernel.

>>(PS... Please refrain from HTML email on this list)
> Sorry, I'm a newbie, I really don't know what you
> mean. :-)

Rich text emails -- in layman's terms. Couple of reasons for this:
* They do make the email slightly larger
* Not everyone can see HTML
* SPAM and Viruses commonly exploit HTML

Never mind though, as it seems your mail client has figured to use
plaintext already. ;-)

-- 
+-------------------------------------------------------------+
| Stuart Longland -oOo- http://stuartl.longlandclan.hopto.org |
| Atomic Linux Project -oOo- http://atomicl.berlios.de |
| - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - |
| I haven't lost my mind - it's backed up on a tape somewhere |
+-------------------------------------------------------------+

---------------------------------
Do You Yahoo!?
150万曲MP3疯狂搜，带您闯入音乐殿堂
美女明星应有尽有，搜遍美图、艳图和酷图
1G就是1000兆，雅虎电邮自助扩容！

---

From: Stuart Longland <[email-masked]>
Date: Fri, 01 Apr 2005 08:06:23 +1000

> Thanks again!

BTW: Your mail client has just switched back to its fixation on HTML.
Could you please have a close look at the settings and disable HTML mail
composition?  (at least for this email address/domain)

> So I want to write a very simple bootloader and make a self-decompressed

AFAIK the bootloader is only resident during the initial bootup, and is
normally gone by the time userland kicks in.  (Think about it -- what's
 the point in it sticking around, its job is done ;-)

If you've got at least 8MB RAM you should be okay.  (And lets face it --
Linux on 4MB *IS NOT PRETTY* -- Been there, done that)  How much RAM are
you working with?
-- 
+-------------------------------------------------------------+
| Stuart Longland -oOo- http://stuartl.longlandclan.hopto.org |
| Atomic Linux Project     -oOo-    http://atomicl.berlios.de |
| - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - |
| I haven't lost my mind - it's backed up on a tape somewhere |
+-------------------------------------------------------------+