Subject: Au1500 and 1Gbps

From: Gilad Rom <[email-masked]>
Date: Tue, 22 Mar 2005 20:42:14 +0200

Hello,

As a follow up to my last posting, I was wondering if anyone
ever actually benchmarked the Au1500 in terms of networking
throughput.

We make a custom board, based on the Au1500. 100Mbps
performance is 100% (100Mbps FTP transfers when using brctl to bridge
both ethernet MAC's), but What we would like to do, ultimately,
is build a board with two Gigabit MAC/PHY's and use our board
to construct a much more powerful gateway.

Any insight? can the Au1500 even try to handle 1000Mbps?

Thanks,
Gilad.

---

From: Pete Popov <[email-masked]>
Date: Tue, 22 Mar 2005 10:47:02 -0800

> Any insight? can the Au1500 even try to handle 1000Mbps?

Should be easy to get up and running the benchmarked. The Intel 1G driver 
(e100?) should run fine on mips with, hopefully, little or no modifications.

Pete

---

From: Gilad Rom <[email-masked]>
Date: Tue, 22 Mar 2005 20:51:42 +0200

> Should be easy to get up and running the benchmarked. The Intel 1G 
> driver (e100?) should run fine on mips with, hopefully, little or no 
> modifications.
> 
> Pete

Do you see any theoretical limitation on the Au1500 which
would prevent it from utilizing the full 1000Mbps bandwidth?

Gilad.

---

From: Pete Popov <[email-masked]>
Date: Tue, 22 Mar 2005 10:55:41 -0800

> would prevent it from utilizing the full 1000Mbps bandwidth?

I haven't done any paper napkin calculations on what it takes to handle the 
smallest packets, worst case, at 1G.  It also depends on what else your CPU is 
doing. If you're just routing packets you'll get a lot better performance then 
you would if you're busy doing something else.

Pete