Subject: [PATCH] R43XX tlb write entry missing

From: Brian Murphy <[email-masked]>
Date: Sun, 20 Mar 2005 20:44:36 +0100

Hi Ralf,
	the R43XX is missing an entry in the tlbw synthesizer.
Here is a patch.

/Brian

Index: arch/mips/mm/tlbex.c
===================================================================
RCS file: /cvs/linux/arch/mips/mm/tlbex.c,v
retrieving revision 1.17
diff -u -r1.17 tlbex.c
--- arch/mips/mm/tlbex.c	1 Mar 2005 06:33:17 -0000	1.17
+++ arch/mips/mm/tlbex.c	17 Mar 2005 23:14:44 -0000
@@ -830,6 +830,7 @@
 		i_nop(p);
 		break;
 
+	case CPU_R4300:
 	case CPU_R4600:
 	case CPU_R4700:
 	case CPU_R5000:

---

From: Ralf Baechle <[email-masked]>
Date: Sun, 20 Mar 2005 22:42:05 +0000

> 	the R43XX is missing an entry in the tlbw synthesizer.

Are you testing on a R4300 series processor?  I think I've not had any
test reports in years.

  Ralf