Subject: Current Build Warning Message

From: Jim Gifford <[email-masked]>
Date: Tue, 15 Mar 2005 13:39:35 -0800

I just tried doing a current build on a 2.6.11 systems. I get the 
following warnings.

*** Warning: "pci_iounmap" [drivers/net/tulip/tulip.ko] undefined!
*** Warning: "pci_iomap" [drivers/net/tulip/tulip.ko] undefined!

Any ideas on how to correct this?

-- 
----
Jim Gifford
[email-masked]

---

From: Ralf Baechle <[email-masked]>
Date: Tue, 15 Mar 2005 21:55:39 +0000

On Tue, Mar 15, 2005 at 01:39:35PM -0800, Jim Gifford wrote:
> Date:	Tue, 15 Mar 2005 13:39:35 -0800
> From:	Jim Gifford <[email-masked]>
> To:	Linux MIPS List <[email-masked]>
> Subject: Current Build Warning Message
> Content-Type: text/plain; charset=ISO-8859-1; format=flowed
> 

Write pci_iounmap and pci_iomap :-)

(Recently an implementation was posted here but it's been broken as it
only did support a single PCI bus and will fail silently for additional
busses.)

  Ralf

---

From: Jim Gifford <[email-masked]>
Date: Mon, 21 Mar 2005 08:33:40 -0800

Jim Gifford wrote:

FYI for the list. Didn't mean to send to you excusively Ralf, sorry.

 Ralf,
    Got that one fixed, everything compiles ok. But now on bootup I get 
this.
      If you need it, I can give you ssh access to a RaQ2 to work with. 
Let me know.

 Cobalt Microserver Diagnostics - 'We serve it, you surf it'
 Built Wed Mar  3 21:26:25 PST 1999

 1.LCD Test................................PASS
 2.Controller Test.........................PASS
 5.Bank 0:.................................64M
6.Bank 1:.................................64M
 7.Bank 2:.................................64M
 8.Bank 3:.................................64M
 9.Serial Test.............................PASS
 10.PCI Expansion Slot....................**EMPTY**
 12.IDE Test................................PASS
 13.Ethernet Test...........................PASS
 16.RTC Test................................PASS
 BOOTLOADER: trying to boot from partition /dev/hda1
 Decompressing done
 Decompressing done.

 [ "CoLo" v1.17 ]
 stage2: 8ffa0000-90000000
 cpu: clock 250.000MHz
 pci: unit type <RaQ2>
 tulip: #0 device 21143
 tulip: #1 device 21143
 tulip: {00:10:e0:00:33:94}
 ide: resetting
 boot: running boot menu
 1> lcd 'Booting...'
 1> mount
 ide: {HDS722580VLAT20}
 ide: LBA48 156250000
 ide: supports PIO mode 4
 ide: mode 4 timing
 ide: partition 1
 ext2: revision 0
 1> lcd 'Booting...' /dev/{mounted-volume}
 1> -load /boot/default.colo
 ext2: {boot/default.colo} --> {./default.colo}
 000002f6 758t
 1> -script
 2> var _image vmlinux-2.6.11.5-jg-1.gz
 2> var _console ''
 2> -var _console console=ttyS0,{console-speed}
 2> -noop {menu-option}
 2> select 'BOOT KERNEL' 100 2.6.11.5-jg-1 2.6.11.4-jg-1 2.6.9-jg-2 
2.6.9 vmlinux.old
 2> goto {menu-option}
 2> lcd 'Loading ...' {_image}
 2> mount
 ide: partition 1
 ext2: revision 0
 2> cd /boot
 ext2: {boot} --> {.}
 /
 2> load {_image}
 0013161a 1250842t
 2> execute root=/dev/hda2 {_console} ide1=noprobe
 elf32: 00080000 - 0032401f (802f1000) (ffffffff.80000000)
 elf32: 80080000 (80080000) 2670725t + 98203t
 Linux version 2.6.11.5-jg-1 (root@lfs) (gcc version 3.4.3) #1 Sun Mar 
20 01:22:16 PST 2005
 CPU revision is: 000028a0
 FPU revision is: 000028a0
 Cobalt board ID: 6
 Determined physical RAM map:
 memory: 10000000 @ 00000000 (usable)
 Built 1 zonelists
 Kernel command line: root=/dev/hda2 console=ttyS0,115200 ide1=noprobe
 ide_setup: ide1=noprobe
 Primary instruction cache 32kB, physically tagged, 2-way, linesize 32 
bytes.
 Primary data cache 32kB, 2-way, linesize 32 bytes.
 Synthesized TLB refill handler (21 instructions).
 Synthesized TLB load handler fastpath (34 instructions).
 Synthesized TLB store handler fastpath (34 instructions).
 Synthesized TLB modify handler fastpath (33 instructions).
 PID hash table entries: 2048 (order: 11, 32768 bytes)
 Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
 Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
 Memory: 256256k/262144k available (2074k kernel code, 5692k reserved, 
421k data, 112k init, 0k highmem)
 Mount-cache hash table entries: 512 (order: 0, 4096 bytes)
 Checking for 'wait' instruction...  available.
 NET: Registered protocol family 16
 Galileo ID: 17
 Activating ISA DMA hang workarounds.
 Break instruction in kernel code in arch/mips/kernel/traps.c::do_bp, 
line 560[#1]:
 Cpu 0
 $ 0   : 00000000 90004400 00000000 10000000
 $ 4   : 80350008 803142f4 fffb6ced 80310000
 $ 8   : 10000000 00000008 80310000 80310000
 $12   : 80310000 00100100 00200200 812a6674
 $16   : 000005af 000005af 8126bb78 90004401
 $20   : 802b1fb8 fffffa51 80310000 0000003c
 $24   : 812a667c 00000000                 $28   : 80350000 80351de0 
80351de0 80081338
 Hi    : 00000000
 Lo    : 00000000
 epc   : 802833f0     Not tainted
 ra    : 80081338 Status: 90004402    KERNEL EXL
 Cause : 00808024
 PrId  : 000028a0
 Modules linked in:
 Process swapper (pid: 1, threadinfo=80350000, task=8126bb78)
 Stack : 802b1fb8 80080a30 000005af 800ae97c 000005af 000005af 802b0000 
0000003e
        80081338 800dd5d8 8126bb78 00000000 802b37fc 800d8038 0000000d 
e0000000
        00000000 90004400 80310000 802e7bc0 000005af 000005af 00000001 
803186a4
        000005af 802b1fb8 80310000 80310000 80310000 00100100 00200200 
812a6674
        000005af 000005af 802b0000 90004401 802b1fb8 fffffa51 80310000 
0000003c
        ...
 Call Trace: [<80080a30>]  [<800ae97c>]  [<80081338>]  [<800dd5d8>]  
[<800d8038>]  [<800a6c18>]  [<800a70c4>]  <800a70e0>]  [<800a75a0>]  
[<801cb638>]  [<80113424>]  [<801a8d28>]  [<800a7738>]  [<801a829c>]  
<801a9614>]  [<801a7220>]  [<80080538>]  [<80082d9c>]  [<80082d8c>]>
 Code: 8fb00010  03e00008  27bd0028 <0200000d> 080a0cd9  8f820010  
27bdffb0  afbe0048  afb00040
 Kernel panic - not syncing: Attempted to kill init!

-- 
----
Jim Gifford
[email-masked]

---

From: Jim Gifford <[email-masked]>
Date: Mon, 21 Mar 2005 11:51:09 -0800

Ralf,
    Here are the warnings with ksym working.

Linux version 2.6.11.5-jg-2 (root@lfs) (gcc version 3.4.3) #1 Mon Mar 21 
11:07:30 PST 2005
CPU revision is: 000028a0
FPU revision is: 000028a0
Cobalt board ID: 6
Determined physical RAM map:
 memory: 10000000 @ 00000000 (usable)
Built 1 zonelists
Kernel command line: root=/dev/hda2 console=ttyS0,115200 ide1=noprobe
ide_setup: ide1=noprobe
Primary instruction cache 32kB, physically tagged, 2-way, linesize 32 bytes.
Primary data cache 32kB, 2-way, linesize 32 bytes.
Synthesized TLB refill handler (21 instructions).
Synthesized TLB load handler fastpath (34 instructions).
Synthesized TLB store handler fastpath (34 instructions).
Synthesized TLB modify handler fastpath (33 instructions).
PID hash table entries: 2048 (order: 11, 32768 bytes)
Dentry cache hash table entries: 65536 (order: 6, 262144 bytes)
Inode-cache hash table entries: 32768 (order: 5, 131072 bytes)
Memory: 256000k/262144k available (2079k kernel code, 5940k reserved, 
664k data, 112k init, 0k highmem)
Mount-cache hash table entries: 512 (order: 0, 4096 bytes)
Checking for 'wait' instruction...  available.
Break instruction in kernel code in arch/mips/kernel/traps.c::do_bp, 
line 560[#1]:
Cpu 0
$ 0   : 00000000 90004400 00000000 10000000
$ 4   : 802b0008 80352164 fffb6cbb 80350000
$ 8   : 10000000 00000008 80350000 00008000
$12   : 7fffffff 00100100 00200200 7fffffff
$16   : 80082958 afff62a8 802b2000 00000001
$20   : 8ffa0000 8ffc0000 8ffc0000 00000000
$24   : 00000000 802b1e23                 
$28   : 802b0000 802b1e78 802b1e78 80081338
Hi    : 000f41fa
Lo    : 2fc92280
epc   : 802849b0 preempt_schedule_irq+0xcc/0xd8     Not tainted
ra    : 80081338 ret_from_fork+0x0/0x8
Status: 90004402    KERNEL EXL
Cause : 00808024
PrId  : 000028a0
Modules linked in:
Process swapper (pid: 0, threadinfo=802b0000, task=802b2000)
Stack : 8ffa0000 80080a30 80082958 800ae97c 80082958 afff62a8 00000000 
802b1f50
        80081338 80080470 00000a00 00000001 8ffa0000 8ffc0000 80082e18 
80363274
        00000000 90004400 efffffff 802b0008 802b9430 802b2000 00000000 
0000001d
        802b1f80 81291f30 00008000 00008000 7fffffff 00100100 00200200 
7fffffff
        80082958 afff62a8 00000000 00000001 8ffa0000 8ffc0000 8ffc0000 
00000000
        ...
Call Trace:
 [<80080a30>] cobalt_irq+0x170/0x240
 [<80082958>] cpu_idle+0x48/0x50
 [<800ae97c>] irq_exit+0x5c/0x74
 [<80082958>] cpu_idle+0x48/0x50
 [<80081338>] ret_from_fork+0x0/0x8
 [<80080470>] init+0x0/0x270
 [<80082e18>] kernel_thread+0x74/0x8c
 [<80082958>] cpu_idle+0x48/0x50
 [<80082958>] cpu_idle+0x48/0x50
 [<80283dc0>] schedule+0x4c/0xacc
 [<80082958>] cpu_idle+0x48/0x50
 [<8019e514>] idr_cache_ctor+0x0/0xc
 [<8032f764>] start_kernel+0x1b4/0x25c
 [<8032f0fc>] unknown_bootoption+0x0/0x310

Code: 8fb00010  03e00008  27bd0028 <0200000d> 080a1249  8f820010  
27bdffb0  afbe0048  afb00040
Kernel panic - not syncing: Attempted to kill the idle task

-- 
----
Jim Gifford
[email-masked]

---

From: Jim Gifford <[email-masked]>
Date: Mon, 21 Mar 2005 12:00:09 -0800

Here is the output of ksymoops.
ksymoops 2.4.11 on mips 2.6.9-jg-2.  Options used
     -v /usr/src/linux/vmlinux (specified)
     -K (specified)
     -L (specified)
     -o /lib/modules/2.6.11.5-jg-2/ (specified)
     -m /boot/System-2.6.11.5-jg-2.map (specified)

No modules in ksyms, skipping objects
000002ae 686t
0014ea7f 1370751t
Cpu 0
Using defaults from ksymoops -t elf32-tradlittlemips -a mips:8000

 >>$16; 0000000080082958 <cpu_idle+48/50>
 >>$18; 00000000802b2000 <init_task+0/3c8>
 >>$25; 00000000802b1e23 <init_thread_union+1e23/2000>
 >>$28; 00000000802b0000 <init_thread_union+0/2000>
 >>$29; 00000000802b1e78 <init_thread_union+1e78/2000>
 >>$30; 00000000802b1e78 <init_thread_union+1e78/2000>
 >>$31; 0000000080081338 <ret_from_fork+0/8>

 >>PC;  00000000802849b0 <preempt_schedule_irq+cc/d8>   <=====

Trace; 0000000080080a30 <cobalt_irq+170/240>
Trace; 0000000080082958 <cpu_idle+48/50>
Trace; 00000000800ae97c <irq_exit+5c/74>
Trace; 0000000080082958 <cpu_idle+48/50>
Trace; 0000000080081338 <ret_from_fork+0/8>
Trace; 0000000080080470 <init+0/270>
Trace; 0000000080082e18 <kernel_thread+74/8c>
Trace; 0000000080082958 <cpu_idle+48/50>
Trace; 0000000080082958 <cpu_idle+48/50>
Trace; 0000000080283dc0 <schedule+4c/acc>
Trace; 0000000080082958 <cpu_idle+48/50>
Trace; 000000008019e514 <idr_cache_ctor+0/c>
Trace; 000000008032f764 <start_kernel+1b4/25c>
Trace; 000000008032f0fc <unknown_bootoption+0/310>

Code;  00000000802849a4 <preempt_schedule_irq+c0/d8>
00000000 <_PC>:
Code;  00000000802849a4 <preempt_schedule_irq+c0/d8>
   0:   8fb00010  lw      s0,16(sp)
Code;  00000000802849a8 <preempt_schedule_irq+c4/d8>
   4:   03e00008  jr      ra
Code;  00000000802849ac <preempt_schedule_irq+c8/d8>
   8:   27bd0028  addiu   sp,sp,40
Code;  00000000802849b0 <preempt_schedule_irq+cc/d8>   <=====
   c:   0200000d  break   0x200   <=====
Code;  00000000802849b4 <preempt_schedule_irq+d0/d8>
  10:   080a1249  j       284924 <_PC+0x284924>
Code;  00000000802849b8 <preempt_schedule_irq+d4/d8>
  14:   8f820010  lw      v0,16(gp)
Code;  00000000802849bc <wait_for_completion+0/1d4>
  18:   27bdffb0  addiu   sp,sp,-80
Code;  00000000802849c0 <wait_for_completion+4/1d4>
  1c:   afbe0048  sw      s8,72(sp)
Code;  00000000802849c4 <wait_for_completion+8/1d4>
  20:   afb00040  sw      s0,64(sp)

Kernel panic - not syncing: Attempted to kill the idle task!

-- 
----
Jim Gifford
[email-masked]

---

From: Atsushi Nemoto <[email-masked]>
Date: Tue, 22 Mar 2005 09:40:53 +0900 (JST)

>>>>> On Mon, 21 Mar 2005 11:51:09 -0800, Jim Gifford <[email-masked]> said:
Jim>     Here are the warnings with ksym working.
...
Jim> epc   : 802849b0 preempt_schedule_irq+0xcc/0xd8     Not tainted
Jim> ra    : 80081338 ret_from_fork+0x0/0x8

Already fixed in CVS.

http://www.linux-mips.org/cgi-bin/mesg.cgi?a=linux-cvs-patches&i=aad20843b7b1d6b691c1401c495959a1%40NO-ID-FOUND.mhonarc.org