Subject: Porting new board

From: "Mile Davidovic" <[email-masked]>
Date: Thu, 7 Apr 2005 15:35:08 +0200

Hello all
I try to port new board (MIPS 4KEC processor) to latest version
of linux-mips kernel. I have question regarding Kconfig and adding
new board.
In arch/mips/Kconfig I add next lines:

config MIPS_VGCA_EVA
  bool "Support for VGCA-Eva board"
  select SYS_SUPPORTS_BIG_ENDIAN
  help
	  This enables support for the VGCA-EVA board.

and in arch/mips/Makefile I add next lines:
core-$(MIPS_VGCA_EVA)	+= arch/mips/vgca-eva/
cflags-$(MIPS_VGCA_EVA)   += -Iinclude/asm-mips/vgca-eva
load-$(MIPS_VGCA_EVA)	+= 0xffffffff80100000

But when I try to build kernel with:
	make menuconfig  		---> choose VGCA-Eva board
	make arch=mips V=1 CROSS_COMPILE=mips-linux- 

it stop forever. When I try to choose some other board it work nice. 
Any comment?

Thanks a lot.
Best regards Mile

---

From: Geert Uytterhoeven <[email-masked]>
Date: Thu, 7 Apr 2005 16:04:38 +0200 (CEST)

> core-$(MIPS_VGCA_EVA)	+= arch/mips/vgca-eva/
         ^^^^^^^^^^^^^
> cflags-$(MIPS_VGCA_EVA)   += -Iinclude/asm-mips/vgca-eva
           ^^^^^^^^^^^^^
> load-$(MIPS_VGCA_EVA)	+= 0xffffffff80100000
         ^^^^^^^^^^^^^

All of these should be `CONFIG_MIPS_VGCA_EVA' instead of `MIPS_VGCA_EVA'.

> it stop forever. When I try to choose some other board it work nice. 

Gr{oetje,eeting}s,

						Geert

--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- [email-masked]

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
							    -- Linus Torvalds

---

From: "Mile Davidovic" <[email-masked]>
Date: Thu, 7 Apr 2005 17:23:54 +0200

Thank for Your comment. Yes this was obviouse error but unfortunately it
does not work.

Best regards mile

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Geert Uytterhoeven
Sent: Thursday, April 07, 2005 4:05 PM
To: Mile Davidovic
Cc: Linux/MIPS Development
Subject: Re: Porting new board

On Thu, 7 Apr 2005, Mile Davidovic wrote:
> I try to port new board (MIPS 4KEC processor) to latest version of 
> linux-mips kernel. I have question regarding Kconfig and adding new 
> board.
         ^^^^^^^^^^^^^
           ^^^^^^^^^^^^^
         ^^^^^^^^^^^^^

Gr{oetje,eeting}s,

						Geert

--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 --
[email-masked]

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like
that.
							    -- Linus
Torvalds

---

From: "Mile Davidovic" <[email-masked]>
Date: Thu, 7 Apr 2005 17:37:45 +0200

I found what cause my problem after adding 
  select SYS_SUPPORTS_BIG_ENDIAN
  select SYS_SUPPORTS_32BIT_KERNEL
in Kconfig compilation start.

Sorry for posting stupid questions..

Best regards Mile
-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Mile Davidovic
Sent: Thursday, April 07, 2005 5:24 PM
To: 'Geert Uytterhoeven'
Cc: 'Linux/MIPS Development'
Subject: RE: Porting new board

Best regards mile

-----Original Message-----

         ^^^^^^^^^^^^^
           ^^^^^^^^^^^^^
         ^^^^^^^^^^^^^

Gr{oetje,eeting}s,

						Geert