Subject: How to keep uptodate a mips-linux port

From: moreau francis <[email-masked]>
Date: Fri, 1 Apr 2005 09:34:05 +0200 (CEST)

Hi,

I plan to keep uptodate a port that I realized during
last months. But I don't know how to proceed...

Explanation: I used "linux-2.6.10-rc2-mips" snapshot
as starting point. I did some minor changes on generic
files (files which are not part of mips branch) as
well as mips specific files and added specific board
files.

Now, let say I would like to update my customized
"linux-2.6.10-rc2-mips" to "Linux 2.6.11-mips".
What is the best approach ?

Thanks for your advices

      Francis

		
__________________________________________________________________
Découvrez le nouveau Yahoo! Mail : 250 Mo d'espace de stockage pour vos mails ! 
Créez votre Yahoo! Mail sur http://fr.mail.yahoo.com/

---

From: Jan-Benedict Glaw <[email-masked]>
Date: Fri, 1 Apr 2005 09:37:42 +0200

On Fri, 2005-04-01 09:34:05 +0200, moreau francis <[email-masked]>

> What is the best approach ?

The best approach is to cleanly break out all your changes into
semantical patches and submit them to the prople who care about the
individual files. The MIPS-specific patches go to this list.

MfG, JBG

-- 
Jan-Benedict Glaw       [email-masked]    . +49-172-7608481             _ O _
"Eine Freie Meinung in  einem Freien Kopf    | Gegen Zensur | Gegen Krieg  _ _ O
 fuer einen Freien Staat voll Freier Bürger" | im Internet! |   im Irak!   O O O
ret = do_actions((curr | FREE_SPEECH) & ~(NEW_COPYRIGHT_LAW | DRM | TCPA));