Subject: RE: No PCI memory response

From: "Gill Robles-Thome" <[email-masked]>
Date: Tue, 5 Apr 2005 16:28:37 +0100

...we found the cause of the problem!  Need to select "Support for
64-bit physical address space" option!

Gill

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Gill Robles-Thome
Sent: 05 April 2005 09:11
To: [email-masked]
Subject: RE: No PCI memory response

Hi -

I'm certainly seeing what looks like random reads...however, is the
static bus controller actually implicated in PCI bus operations?  The
product brief for the Au1100 doesn't mention PCI, so I'm not sure that
we're looking at the same problem.

Thanks,
Gill

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of Ulrich Eckhardt
Sent: 04 April 2005 15:53
To: [email-masked]
Subject: Re: No PCI memory response

Gill wrote:
> Can anyone help?  We're trying to talk to a RealTek RTL8139 device
> across the PCI bus, and, although linux can access configuration 
> registers on the device, it does not access memory space correctly, 
> and we are unable to read back any sensible values from the RTL8139 
> registers.
>
> We are using the latest 2.6 linux on an Alchemy DB1550 board.

Random reads, discarded data after writing? I had the same problem and
solved 
it by simply configuring the static bus controller of my Au1100 properly
(of 
which before I didn't even know it existed...).

hth

Uli

---

From: Pete Popov <[email-masked]>
Date: Tue, 05 Apr 2005 09:27:40 -0700

> 64-bit physical address space" option!

That option should be in the defconfig already - was it not?

I should just hardcode that option and get it over with.

Pete