Subject: Toolchain question

From: "Mile Davidovic" <[email-masked]>
Date: Mon, 11 Apr 2005 12:13:50 +0200

Hello all
I would like to port board (with MIPS 4kec) to latest linux 2.6 kernel.
Using porting guide 
from (http://www.linux-mips.org/wiki/index.php/Porting) I successfully made
console and
serial driver. But problem appears with first printk (in start_kernel) I got
exception.  

I used toolchain which uclibc buildroot script produced (gcc-3.4.2,
binutils-2.15.91.0.2),
and I am not sure is this correct combination.

From 
http://www.linux-mips.org/wiki/index.php/Toolchains I saw that next
recommendations:
1. SDE MIPS - unfortunately this is 2.9x compiler.
2. Mr. Rozycki offer only mipsel toolchain
3. Mr. Kegel's crosstool but from
http://kegel.com/crosstool/crosstool-0.31/buildlogs/ it seems that 
this toolchain is not good for MIPS.
4. Toolchain from ucLibc, I tried but I have trouble with.

So my question: which toolchains I have to use? 

Best regards Mile

---

From: Ralf Baechle <[email-masked]>
Date: Mon, 11 Apr 2005 14:38:41 +0100

On Mon, Apr 11, 2005 at 12:13:50PM +0200, Mile Davidovic wrote:
> From:	"Mile Davidovic" <[email-masked]>
> To:	"'Linux/MIPS Development'" <[email-masked]>
> Subject: Toolchain question
> Date:	Mon, 11 Apr 2005 12:13:50 +0200
> Content-Type: text/plain;
> 	charset="iso-8859-2"
> 
> Hello all

Which should be perfectly find for the kernel.  And no, SDE isn't really
a 2.96-based compiler with _vastly_ improved code generation for MIPS
processors.

Less than a week ago SDE 5 was released which is based on gcc 3.4 and
similarly contains a large number of mostly MIPS-specific improvments.

> 2. Mr. Rozycki offer only mipsel toolchain

Recompiling is easy.

> this toolchain is not good for MIPS.

Plenty of success reports to this list contradict it.

> 4. Toolchain from ucLibc, I tried but I have trouble with.

No idea about this one.

> So my question: which toolchains I have to use? 

Since you have problems with all of these you may want to describe those ...

  Ralf