Subject: questions about early-printk

From: dfsd df <[email-masked]>
Date: Mon, 4 Apr 2005 12:49:53 +0800 (CST)

Hi:
  Had somebody used early-printk? Now, I'm porting
linux to a MIPS machine under instructions of "Linux
MIPS Porting Guide" from junsun.net.

But at the first step, I want to modify the source
code of the barebone program to display "helloworld".

The program uses memory map addr as the UART device's
"base addr",and access the UART by adding offset to
this "base addr".

The "base addr" is assigned to a constant value. and
from the other early-printk patchs, the value of "base
addr" are not equals. So I want to know can I assign
the right value to this "base addr"?

Thanks!

_________________________________________________________
Do You Yahoo!?
150万曲MP3疯狂搜，带您闯入音乐殿堂
http://music.yisou.com/
美女明星应有尽有，搜遍美图、艳图和酷图
http://image.yisou.com
1G就是1000兆，雅虎电邮自助扩容！
http://cn.rd.yahoo.com/mail_cn/tag/1g/*http://cn.mail.yahoo.com/event/mail_1g/

---

From: Ralf Baechle <[email-masked]>
Date: Mon, 4 Apr 2005 12:01:52 +0100

> MIPS Porting Guide" from junsun.net.

There's an updated version in the www.linux-mips.org wiki.

> the right value to this "base addr"?

You haven't even mentioned what hardware you're using so don't expect
answer ...

  Ralf