Subject: RE: Porting davicom driver to pmon

From: Brad Larson <[email-masked]>
Date: Mon, 4 Apr 2005 10:38:19 -0700

It's a DEC Tulip type chip handled by the dc driver. Should work with "dc* at pci ?".
Should because I have no own experience with that particular chip.

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]]On Behalf Of priya
Sent: Monday, April 04, 2005 7:55 AM
To: [email-masked]
Subject: Porting davicom driver to pmon

Hi,
I am using a custom board which has mips
processor and davicom ethernet chip. Iam
using pmon bootloader. Has anyone ported
davicom driver for pmon. Iam facing a
lot of problem in sending even a set up
frame

regards
priya

---

From: priya <[email-masked]>
Date: Tue, 05 Apr 2005 10:05:20 +0530

Hi Brad,
Its a davicom chip. I tried porting the linux driver to pmon - but still iam facing
problems sending the set up frame - actually in the linux the set up frame is sent 5
times. Iam doing the same thing out here too. But while trying to send the setup frame
for the second time the network status report register(cr5) value is 0xfc200007 (which
indicates - move setup frame from host memory, transmit buffer un-available, and transmit
process complete)

Also the network operation mode (register cr6) gets set to hash filtering, while i have
enabled perfect filtering mode in the transmit descriptor. Any idea why this corruption
is happening?

regards
priya