Subject: Re: Some questions about kernel tailoring

From: Wolfgang Denk <[email-masked]>
Date: Fri, 01 Apr 2005 02:29:55 +0200

In message <[email-masked]> you wrote:
>  
> So I want to write a very simple bootloader and make a self-decompressed kernel.

Don't re-invent the wheel. Consider using (porting) U-Boot.

Best regards,

Wolfgang Denk

-- 
Software Engineering:  Embedded and Realtime Systems,  Embedded Linux
Phone: (+49)-8142-66989-10 Fax: (+49)-8142-66989-80 Email: [email-masked]
A supercomputer is a machine that runs an endless loop in 2 seconds.

---

From: dfsd df <[email-masked]>
Date: Fri, 1 Apr 2005 09:08:39 +0800 (CST)

Sorry, I used YAHOO web e-mail.I'm not familiar with
it.and I have set the edit mode to plain text. Pls
help me to check whether the e-mail is still on HTML,
thanks!

Now, I have 4M flash memory and 8M SDRAM can use.any
suggestion?

Thanks again!

--- Stuart Longland <[email-masked]>
wrote:
> dfsd df wrote:
> > Thanks again!
> 
> BTW: Your mail client has just switched back to its
> fixation on HTML.
> Could you please have a close look at the settings
> and disable HTML mail
> composition?  (at least for this email
> address/domain)
> 
> > Because of the limitation of memory, I don't want
> to use YAMON.
> > Using gzip -9, I can get a kernel more small than
> the kernel made by
> > "make zImage".
> > So I want to write a very simple bootloader and
> make a self-decompressed
> > kernel.
> 
> AFAIK the bootloader is only resident during the
> initial bootup, and is
> normally gone by the time userland kicks in.  (Think
> about it -- what's
>  the point in it sticking around, its job is done
> ;-)
> 
> If you've got at least 8MB RAM you should be okay. 
> (And lets face it --
> Linux on 4MB *IS NOT PRETTY* -- Been there, done
> that)  How much RAM are
> you working with?
> -- 
>
+-------------------------------------------------------------+
> | Stuart Longland -oOo-
> http://stuartl.longlandclan.hopto.org |
> | Atomic Linux Project     -oOo-   
> http://atomicl.berlios.de |
> | - - - - - - - - - - - - - - - - - - - - - - - - -
> - - - - - |
> | I haven't lost my mind - it's backed up on a tape
> somewhere |
>
+-------------------------------------------------------------+

_________________________________________________________
Do You Yahoo!?
150万曲MP3疯狂搜，带您闯入音乐殿堂
http://music.yisou.com/
美女明星应有尽有，搜遍美图、艳图和酷图
http://image.yisou.com
1G就是1000兆，雅虎电邮自助扩容！
http://cn.rd.yahoo.com/mail_cn/tag/1g/*http://cn.mail.yahoo.com/event/mail_1g/