Subject: RE: Big Endian au1550

From: Prashant Viswanathan <[email-masked]>
Date: Wed, 27 Apr 2005 20:44:32 -0700

> Prashant Viswanathan wrote:
> 
> >Is there a reason why the default configuration file doesn't support Big
> >Endian for the dbAu1550?
> >
> >Even if I edit .config to set the endianness to "BIG" it seems to change
> to
> >"Little Endian" every time a make is run.
> >
> >Thanks
> >Prashant
> >
> >
> >
> >
> In arch/mips/Kconfig,
> 
> config CPU_LITTLE_ENDIAN
>         bool "Generate little endian code"
>         default y if ACER_PICA_61 || CASIO_E55 || DDB5074 || DDB5476 ||
> DDB5477 || MACH_DECSTATION
> || IBM_WORKPAD || LASAT || MIPS_COBALT || MIPS_ITE8172 || MIPS_IVR ||
> SOC_AU1X00 || NEC_OSPREY || OLIVETTI_M700 || SNI_RM200_PCI ||
> VICTOR_MPC30X || ZAO_CAPCELLA
>         default n if MIPS_EV64120 || MIPS_EV96100 || MOMENCO_OCELOT ||
> MOMENCO_OCELOT_G || SGI_IP22 || SGI_IP27 || SGI_IP32 || TOSHIBA_JMR3927
>         help
>           Some MIPS machines can be configured for either little or big
> endian
>           byte order. These modes require different kernels. Say Y if your
>           machine is little endian, N if it's a big endian machine.
> 
> So, it appears that if you have SOC_AU1X00 set, it will always be
> configured little endian.

Is there a reason for this? 

Many months ago I was able to build a big-endian image and load it on my
dbAu1550 (also configured to be BE). I just decided to update and now I find
that it is almost as if it is not meant to be built BE.

---

From: [email-masked]
Date: Wed, 27 Apr 2005 20:57:23 -0700

>Is there a reason for this? 
It's the more common configuration.

>that it is almost as if it is not meant to be built BE.
BE should be fine too.  We should fix this in Kconfig.

Pete

---

From: JP <[email-masked]>
Date: Thu, 28 Apr 2005 09:56:23 +0100

I can confirm that BE works fine on the db1550 board. Just add line

select SYS_SUPPORTS_BIG_ENDIAN

to the db1550 section of arch/mips/Kconfig. That allows you to choose
BE.

I guess all the alchemy boards will work LE and BE. At least allowing
the setting will mean they get tested rather than folk getting put off
by the fact they can't select it.

JP

-- 
mailto:[email-masked]
http://jaypee.org.uk