Subject: ramfs

From: Dmitriy Tochansky <[email-masked]>
Date: Wed, 27 Apr 2005 19:55:52 +0400

Hello!

Im trying to use embedded ramdisk on boot.
The error is:

[4294668.794000] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(1,0) 

In make menuconfig I pass to initrdfs directory with my root("/mips/root"),
there are no errors on make. 
Ramdisk size set to 7777k
([4294668.691000] RAMDISK driver initialized: 2 RAM disks of 7777K size 1024 blocksize)

populate_rootfs() works fine:

[4294667.502000] init/initramfs.c void __init populate_rootfs(void);
[4294668.313000] checking if image is initramfs... it is

then on do_mounts in void __init mount_block_root(char *name, int flags)
it tryes to mount initrd with no result. :( As final:

[4294668.794000] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(1,0)

Any ideas?

Kernel from cvs(yesterday updated).

Which type of fs is initrd? AFAIK gen_init_cpio just generates cpio archive with my root. Seems like it unpacked fine but who did mkfs on /dev/ram0?

-- 
Dmitriy Tochansky
[email-masked]
JID: [email-masked]

---

From: Franck Bui-Huu <[email-masked]>
Date: Thu, 28 Apr 2005 15:34:48 +0200

Hi

>[4294668.313000] checking if image is initramfs... it is
why using initramfs with initrd ?

>[4294668.794000] Kernel panic - not syncing: VFS: Unable to mount root fs on unknown-block(1,0)
maybe try to add in your kernel command option: "rootfstype=ramfs"

>Which type of fs is initrd? AFAIK gen_init_cpio just generates cpio archive with my root. Seems like it unpacked fine but who did mkfs on /dev/ram0?
initrd fs depends on how your initrd image is built.
initramfs fs is ramfs.

cheers,

                Franck

-------------------------------------------------------------------------------
Come to visit Innova Card at Cards Asia (Singapore, April 27-29, 2005) on booth 4A04 !

links:
 - www.worldofcards.biz/2005/cardsa_SG/

-------------------------------------------------------------------------------
This message contains confidential information and is intended only for the
individual named. If you are not the named addressee you should not
disseminate, distribute or copy this e-mail. Please notify the sender
immediately by e-mail if you have received this e-mail by mistake and delete
this e-mail from your system.
Innova Card will not therefore be liable for the message if modified.