Subject: [PATCH 2.6] vr41xx: update setup functions

From: Yoichi Yuasa <[email-masked]>
Date: Sun, 22 May 2005 11:20:30 +0900

Hi,

This patch had updated vr41xx setup functions.
o add __init
o change from early_initcall to arch_initcall

Please apply.

Yoichi

Signed-off-by: Yoichi Yuasa <[email-masked]>

diff -urN -X dontdiff b-orig/arch/mips/vr41xx/casio-e55/setup.c b/arch/mips/vr41xx/casio-e55/setup.c
--- b-orig/arch/mips/vr41xx/casio-e55/setup.c	Sat Apr 23 22:59:07 2005
+++ b/arch/mips/vr41xx/casio-e55/setup.c	Sat Apr 23 23:32:33 2005
@@ -17,6 +17,7 @@
  *  along with this program; if not, write to the Free Software
  *  Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
  */
+#include <linux/init.h>
 #include <linux/ioport.h>
 
 #include <asm/io.h>
@@ -27,7 +28,7 @@
 	return "CASIO CASSIOPEIA E-11/15/55/65";
 }
 
-static int casio_e55_setup(void)
+static int __init casio_e55_setup(void)
 {
 	set_io_port_base(IO_PORT_BASE);
 	ioport_resource.start = IO_PORT_RESOURCE_START;
@@ -36,4 +37,4 @@
 	return 0;
 }
 
-early_initcall(casio_e55_setup);
+arch_initcall(casio_e55_setup);
diff -urN -X dontdiff b-orig/arch/mips/vr41xx/ibm-workpad/setup.c b/arch/mips/vr41xx/ibm-workpad/setup.c
--- b-orig/arch/mips/vr41xx/ibm-workpad/setup.c	Sat Apr 23 22:59:08 2005
+++ b/arch/mips/vr41xx/ibm-workpad/setup.c	Sat Apr 23 23:32:33 2005
@@ -17,6 +17,7 @@
  *  along with this program; if not, write to the Free Software
  *  Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
  */
+#include <linux/init.h>
 #include <linux/ioport.h>
 
 #include <asm/io.h>
@@ -27,7 +28,7 @@
 	return "IBM WorkPad z50";
 }
 
-static int ibm_workpad_setup(void)
+static int __init ibm_workpad_setup(void)
 {
 	set_io_port_base(IO_PORT_BASE);
 	ioport_resource.start = IO_PORT_RESOURCE_START;
@@ -36,4 +37,4 @@
 	return 0;
 }
 
-early_initcall(ibm_workpad_setup);
+arch_initcall(ibm_workpad_setup);

---

From: Ralf Baechle <[email-masked]>
Date: Mon, 23 May 2005 12:14:51 +0100

> o change from early_initcall to arch_initcall

Applied,

  Ralf