Subject: Re: 64 bit kernel for BCM1250

From: Michael Belamina <[email-masked]>
Date: Thu, 19 May 2005 06:52:07 -0700 (PDT)

Hi,

   Thanks very much for your replies and the valuable
info. 
   I am still not sure about the following:

   1. Is this problem related only to kernels
downloaded from linux-mips.org or it is a more general
one?

   2. Can someone point to a known to work 64 bit
versions of gcc and binutil for BCM1250 (the problem
that started this thread was actually a problem of the
mip64-linux-ld I was using).
    
Thanks,
 Michael

--- David Daney <[email-masked]> wrote:
> Maciej W. Rozycki wrote:
> > On Wed, 18 May 2005, David Daney wrote:
> > 
> > 
> >>I saw this with a 32 bit kernel (for a 32 bit
> target).  As far as I know, no
> >>2.4.x kernels from linux-mips.org will work with
> gcc 3.4.x.
> > 
> > 
> >  That could actually be true -- I've been using
> GCC 4.0.0 for quite some 
> > time now (that includes CVS snapshots from before
> the release), so I have 
> > no slightest idea whether it's OK to use older
> versions. ;-)
> > 
> > 
> >>I have previously posted patches to this list that
> fixed the problem for me.
> >>Specifically I think the messages in this thread
> are relevant:
> >>
>
>>http://www.linux-mips.org/cgi-bin/mesg.cgi?a=linux-mips&i=41AFDA18.2010906%40avtrex.com
> > 
> > 
> >  Hasn't one of the proposed fixes for the bug made
> its way to Linux in the 
> > end?  That would be regrettable...
> > 
> 
> WRT the 2.4 kernel the answer seems to be no.  And
> yes I think it is 
> regrettable.
> 
> If anybody thinks it would be useful, I could post
> my current patch again.
> 
> David Daney.
> 

__________________________________ 
Do you Yahoo!? 
Yahoo! Mail - Helps protect you from nasty viruses. 
http://promotions.yahoo.com/new_mail

---

From: "Maciej W. Rozycki" <[email-masked]>
Date: Thu, 19 May 2005 16:19:14 +0100 (BST)

> downloaded from linux-mips.org or it is a more general

 The problem is Linux 2.4 is generally in the maintenance mode, which 
means no new development is done on it (although still an occasional 
backport from 2.6 may happen).  As a result maintainers are rather 
hesitant about applying changes unless they fix critical bugs.  Bugs 
revealed by new versions of build tools are not usually considered as 
critical, because you may work them around by using an old version of the 
triggering tool.

 Still for the MIPS port what you can get from linux-mips.org is probably 
less behind than what there is at kernel.org.

> mip64-linux-ld I was using).

 For 64-bit builds you probably want to use fairly recent versions or you 
risk hitting serious bugs that used to exist in older versions.  Using 
David's patch (or preferably mine ;-) -- as available here: 
"http://www.linux-mips.org/cgi-bin/mesg.cgi?a=linux-mips&i=Pine.LNX.4.55.0406281509170.23162%40jurand.ds.pg.gda.pl"; 
which I keep using with GCC 4.0.0) is probably the lesser evil.

  Maciej

---

From: Jerry <[email-masked]>
Date: Mon, 23 May 2005 18:26:09 +0300

Hello Maciej,

> which I keep using with GCC 4.0.0) is probably the lesser evil.

 Without going into details - what difference between your and David's
patch ? :) I'm in doubts which one is more suitable for me...

   ()_()
 -( ^,^ )- -[21398845]- -<The Bat! 3.0.1.33>- -<23/05/2005 18:18>-
  (") (")

---

From: David Daney <[email-masked]>
Date: Mon, 23 May 2005 08:39:21 -0700

> patch ? :) I'm in doubts which one is more suitable for me...

FWIW: My current patch is quite similar to Maciej's.

David Daney.