Subject: Re:

From: Alex Gonzalez <[email-masked]>
Date: Wed, 04 May 2005 14:55:49 +0100

I had no problems compiling the linux-2.6.10 kernel from pmc-sierra's
ftp.

>       Make[3]: *** [drivers/char/agp/backend.o] Error 1

Do you need AGP support? My kernel is configured without it.

Alex

On Thu, 2005-04-28 at 20:15, Bryan Althouse wrote:
> Hello,
> 
> I would like to use a 2.6.x kernel with my Yosemite/HalfDome board.
> Somehow, I am unable to compile the kernel.  I have tried the 2.6.10 kernel
> trees from ftp.pmc-sierra.com and also the latest 2.6.12 snapshot from
> linux-mips.  I am using the 3.3.x cross compile tools from
> ftp.pmc-sierra.com .  The 2.4.x kernels from PMC compile fine.
> 
> In the case of 2.6.10 from ftp.pmc-sierra.com, my error looks like:
>        Make[3]: *** [drivers/char/agp/backend.o] Error 1
> 
> 	
> In the case of 2.6.12 from linux-mips, my error looks like:
> 	drivers/net/titan_ge.c1950: error: 'titan_device_remove"  undeclared
> here (not in a function)
> 
> My compile process is like so:
> make mrproper
> make xconfig
> make oldconfig
> make ARCH=mips CROSS_COMPILE=/<tool_path>/mips64-linux-gnu-    vmlinux
> 
> Could someone share their .config with me, or make some suggestions?
> 
> Thank you,
> Bryan
> 
>

---

From: "Bryan Althouse" <[email-masked]>
Date: Wed, 4 May 2005 10:22:08 -0400

Thanks for your help.  Yes I do need SMP.  Jason Liu of PMC did a check on
my serial number, and found that I have rev 1.1 silicon.  He says I need rev
1.2 in order to use a 2.6.x kernel.  I have shipped my hardware back to them
for an upgrade.  Hopefully, I'll be back in business in a week or two.

Bryan

-----Original Message-----
From: Alex Gonzalez [mailto:[email-masked]] 
Sent: Wednesday, May 04, 2005 9:56 AM
To: Bryan Althouse
Cc: [email-masked]; [email-masked]
Subject: Re:

Alex

---

From: Ralf Baechle <[email-masked]>
Date: Wed, 4 May 2005 17:42:27 +0100

> for an upgrade.  Hopefully, I'll be back in business in a week or two.

That is correct.  Earlier revisions didn't implement some functionality
that is crucial to SMP.  Since only PMC and a small number outside parties
have pre-1.2 silicon I agreed with PMC to not try to support earlier
revisions.

  Ralf

---

From: Ralf Baechle <[email-masked]>
Date: Thu, 5 May 2005 15:55:09 +0100

> Do you need AGP support? My kernel is configured without it.

I'm not aware of any AGP bridge for MIPS systems.

  Ralf

---

From: "Bryan Althouse" <[email-masked]>
Date: Thu, 5 May 2005 11:08:39 -0400

Ralf,

Right, there is no AGP.  At first, I was unable to locate the
yosemite_defconfig, so I was running xconfig without a properly defaulted
.config.  I inadvertently left the AGP support enabled.  Now that I am
starting with yosemite_defcofig as a base-line, I have no problems compiling
the kernel.

Thanks,
Bryan

-----Original Message-----
From: Ralf Baechle [mailto:[email-masked]] 
Sent: Thursday, May 05, 2005 10:55 AM
To: Alex Gonzalez
Cc: Bryan Althouse; [email-masked]; [email-masked]
Subject: Re:

  Ralf

---

From: Ralf Baechle <[email-masked]>
Date: Thu, 5 May 2005 16:11:47 +0100

> starting with yosemite_defcofig as a base-line, I have no problems compiling

Oh, I was pretty sure you'd not have AGP.  However there are a few systems
which need high graphics performance and that's where AGP would make sense,
so while it's not very likely I could see some need for AGP for such
systems and did my posting in the hope somebody would raise his hand in
case there's AGP for MIPS after all ...

  Ralf

---

From: Geert Uytterhoeven <[email-masked]>
Date: Thu, 5 May 2005 17:57:33 +0200 (CEST)

> I'm not aware of any AGP bridge for MIPS systems.

And you cannot even select it, since it depends on ALPHA || IA64 || PPC || X86.

Gr{oetje,eeting}s,

						Geert

--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- [email-masked]

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
							    -- Linus Torvalds

---

From: Christoph Hellwig <[email-masked]>
Date: Thu, 5 May 2005 19:13:43 +0200

> I'm not aware of any AGP bridge for MIPS systems.

The SGI Onyx 4 and Tezro systems have AGP slots, but they a really
running as PCI-X with an odd form factor and there's no AGP GART
(which isn't needed as the systems have a real iommu)