Subject: crosscompiler

From: [email-masked]
Date: Sun, 15 May 2005 05:52:47 -0700 (PDT)

Hi,

I wanna set up a crosscompiler on my intel machine (
using debian woody ) in order to cross-compile a
self-written kernel ( no Linux/Mips ) for a MIPS 4kc (
little endian ) CPU. 

I've set up the binutils ( 2.15 ). While trying to
compile gcc 3.3.4 ( --target=mipsel
--prefix=/usr/local/mipscross --enable-languages=c,c++
--without-headers ) the following error occurs:

 xgcc: installation problem, cannot exec `mips-tfile':
No such file or directory
make[2]: *** [libgcc/./_m16addsf3.o] Error 1
make[2]: Leaving directory
`/home/cag/finaltry/gcc-3.3.4/gcc'
make[1]: *** [stmp-multilib] Error 2
make[1]: Leaving directory
`/home/cag/finaltry/gcc-3.3.4/gcc'
make: *** [all-gcc] Error 2

Any ideas how to fix that ?? Can I alternatively use
the mipsel-linux-gcc for the kernel ( I'm not quite
sure what sort of compiler that is... )

Thanks,

neoxx

---

From: Ulrich Eckhardt <[email-masked]>
Date: Tue, 17 May 2005 09:14:48 +0200

> self-written kernel ( no Linux/Mips ) for a MIPS 4kc (

I'm using Debian/testing here and roughly followed
http://people.debian.org/~debacle/cross.html in order to get a working system. 
Almost no problems encountered.

> Can I alternatively use

mips= for MIPS
el= endianess little

IOW, this is precisely what I got from installing the crosscompiler and 
probably what you want. In order to compile non-Linux programs (i.e. programs 
launched directly from YAMON) I used these 
  CFLAGS += -Wall -mips32 -fno-builtin -mno-abicalls -fno-pic -GO -O2
though some of them might be redundant/unnecessary - I just tried combinations 
until it worked.

hth

Uli