Subject: [PATCH 2.6] vr41xx: remove old TB0219 driver

From: Yoichi Yuasa <[email-masked]>
Date: Fri, 13 May 2005 22:25:28 +0900

Hi,

This patch had removed old TB0219 driver.
Please apply.

Yoichi

Signed-off-by: Yoichi Yuasa <[email-masked]>

diff -urN -X dontdiff b-orig/arch/mips/vr41xx/tanbac-tb0229/Makefile b/arch/mips/vr41xx/tanbac-tb0229/Makefile
--- b-orig/arch/mips/vr41xx/tanbac-tb0229/Makefile	Thu Apr 29 10:42:49 2004
+++ b/arch/mips/vr41xx/tanbac-tb0229/Makefile	Sun Apr 24 00:18:11 2005
@@ -3,5 +3,3 @@
 #
 
 obj-y				:= setup.o
-
-obj-$(CONFIG_TANBAC_TB0219)	+= tb0219.o
diff -urN -X dontdiff b-orig/arch/mips/vr41xx/tanbac-tb0229/tb0219.c b/arch/mips/vr41xx/tanbac-tb0229/tb0219.c
--- b-orig/arch/mips/vr41xx/tanbac-tb0229/tb0219.c	Thu May 27 08:14:29 2004
+++ b/arch/mips/vr41xx/tanbac-tb0229/tb0219.c	Thu Jan  1 09:00:00 1970
@@ -1,44 +0,0 @@
-/*
- *  tb0219.c, Setup for the TANBAC TB0219
- *
- *  Copyright (C) 2003  Megasolution Inc. <[email-masked]>
- *  Copyright (C) 2004  Yoichi Yuasa <[email-masked]>
- *
- *  This program is free software; you can redistribute it and/or modify
- *  it under the terms of the GNU General Public License as published by
- *  the Free Software Foundation; either version 2 of the License, or
- *  (at your option) any later version.
- *
- *  This program is distributed in the hope that it will be useful,
- *  but WITHOUT ANY WARRANTY; without even the implied warranty of
- *  MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  See the
- *  GNU General Public License for more details.
- *
- *  You should have received a copy of the GNU General Public License
- *  along with this program; if not, write to the Free Software
- *  Foundation, Inc., 59 Temple Place, Suite 330, Boston, MA  02111-1307  USA
- */
-#include <linux/init.h>
-
-#include <asm/io.h>
-#include <asm/reboot.h>
-
-#define TB0219_RESET_REGS	KSEG1ADDR(0x0a00000e)
-
-#define tb0219_hard_reset()	writew(0, TB0219_RESET_REGS)
-
-static void tanbac_tb0219_restart(char *command)
-{
-	local_irq_disable();
-	tb0219_hard_reset();
-	while (1);
-}
-
-static int __init tanbac_tb0219_setup(void)
-{
-	_machine_restart = tanbac_tb0219_restart;
-
-	return 0;
-}
-
-early_initcall(tanbac_tb0219_setup);

---

From: "Steve Alexander" <[email-masked]>
Date: Tue, 17 May 2005 02:20:33 -0400

help

---

From: Ralf Baechle <[email-masked]>
Date: Thu, 19 May 2005 16:43:02 +0100

> This patch had removed old TB0219 driver.

Applied.  Thanks Yoichi,

 Ralf