Subject: pcibios_bus_to_resource prototype.

From: Atsushi Nemoto <[email-masked]>
Date: Wed, 31 Aug 2005 01:42:36 +0900 (JST)

MIPS lacks pcibios_bus_to_resource prototype which is new on 2.6.13.

Index: include/asm-mips/pci.h
===================================================================
RCS file: /home/cvs/linux/include/asm-mips/pci.h,v
retrieving revision 1.63
diff -u -r1.63 pci.h
--- include/asm-mips/pci.h	15 Aug 2005 15:16:56 -0000	1.63
+++ include/asm-mips/pci.h	30 Aug 2005 16:31:55 -0000
@@ -143,6 +143,9 @@
 extern void pcibios_resource_to_bus(struct pci_dev *dev,
 	struct pci_bus_region *region, struct resource *res);
 
+extern void pcibios_bus_to_resource(struct pci_dev *dev, struct resource *res,
+				    struct pci_bus_region *region);
+
 #ifdef CONFIG_PCI_DOMAINS
 
 #define pci_domain_nr(bus) ((struct pci_controller *)(bus)->sysdata)->index

---

From: Ralf Baechle <[email-masked]>
Date: Tue, 30 Aug 2005 17:52:13 +0100

> MIPS lacks pcibios_bus_to_resource prototype which is new on 2.6.13.

Applied.  Thanks,

  Ralf