Subject: IP30 hang on warm boot

From: Aaron Walker <[email-masked]>
Date: Thu, 11 Aug 2005 11:42:12 -0400

Gentoo has been running flawlessly on this IP30 for the last month I've had it,
except for one thing.  I've noticed that when I reboot, it hangs at the below
denoted spot:

<dmesg>
Serial: 8250/16550 driver $Revision: 1.90 $ 4 ports, IRQ sharing enabled
io scheduler noop registered
io scheduler anticipatory registered
io scheduler deadline registered
io scheduler cfq registered
loop: loaded (max 8 devices)

 >>> HANGS HERE

IOC3 SuperIO: registered IOC3 at 900000001f600000, IRQ 12 (chip 0).
ttyS0 at IOC3 0x1f620178 (irq = 64) is a 16550A
ttyS1 at IOC3 0x1f620170 (irq = 65) is a 16550A
Found DS2502 NIC registration number 21:e5:b0:02:00:00, CRC 9b.
Ethernet address is 08:00:69:13:6f:e1.
eth0: link up, 100Mbps, full-duplex, lpa 0x01E1
eth0: Using PHY 1, vendor 0x15f42, model 2, rev 3.
eth0: IOC3 SSRAM has 128 kbyte.
qla1280: QLA1040 found on PCI bus 0, dev 0
PCI: Enabling device 0000:00:00.0 (0006 -> 0007)
</dmesg>

This happens every single warm boot, and never on a cold boot.  This box is
running gentoo's mips-sources-2.6.12 kernel (l-m.org cvs 20050703).  I've 
posted the actual config[1] if it helps.

[1] http://dev.gentoo.org/~ka0ttic/mips/ip30/ip30-config

Thanks
-- 
Science and religion are in full accord but science and faith are in complete
discord.

Aaron Walker <[email-masked]>
[ BSD | commonbox | cron | cvs-utils | mips | netmon | shell-tools | vim ]

---

From: Stanislaw Skowronek <[email-masked]>
Date: Thu, 11 Aug 2005 18:20:42 +0200 (MET DST)

Hello,

Try the current (R25) Octane patches at
http://www.linux-mips.org/~skylark/.

The IOC3 support code has been in for a massive overhaul since the gentoo
sources have been done by `K. Also, the PCI code is completely new. And
ALSA supports many more features of the RAD1.

I hope you will be pleasantly surprised,

Stanislaw Skowronek

--<=>--
  "I wish for that night-time
   To last for a lifetime.
   The darkness around me
   Shores of a solar sea."

---

From: Aaron Walker <[email-masked]>
Date: Thu, 11 Aug 2005 12:31:37 -0400

> ALSA supports many more features of the RAD1.

Sweet. Thanks.
-- 
I smell a wumpus.