Subject: NPTL info needed

From: "mohanlal jangir" <[email-masked]>
Date: Thu, 18 Aug 2005 16:41:25 +0530

Does Linux 2.6 have NPTL support for MIPS architecture? A line at 
http://www.linux-mips.org/wiki/NPTL says "Currently NPTL for Linux/MIPS is 
work in progress". Where can I get NPTL source? Do I need new/patched 
compiler and glibc to compile NPTL source? If yes, what are the patches and 
where can I find them?

Regards,
Mohanlal

---

From: "Ton Truong" <[email-masked]>
Date: Thu, 18 Aug 2005 11:04:48 -0700

Daniel Jacobowitz announced support for MIPS NPTL a while back (Apr 05),
complete with patch set for toolchain and kernel.  Check kernel.org archive
for that.

A uClibc port is being done by Steve Hill and infos can be found here:

http://www.realitydiluted.com/nptl-uclibc/

HTH,

/?TT

-----Original Message-----
From: [email-masked]
[mailto:[email-masked]] On Behalf Of mohanlal jangir
Sent: Thursday, August 18, 2005 4:11 AM
To: [email-masked]
Subject: NPTL info needed

Regards,
Mohanlal

---

From: mlachwani <[email-masked]>
Date: Thu, 18 Aug 2005 11:22:57 -0700

This may help:

http://www.linux-mips.org/archives/linux-mips/2005-03/msg00088.html

Thanks
Manish Lachwani

---

From: "mohanlal jangir" <[email-masked]>
Date: Fri, 19 Aug 2005 19:32:51 +0530

> http://www.linux-mips.org/archives/linux-mips/2005-03/msg00088.html

Hi Manish,
Thanks for your help. I tried to apply this patch on Linux-2.6.10 and many 
hunks failed. Could you tell me which kernel version this patch should be 
applied? Also do I need to apply any patch to gcc, glibc sources (and build 
a new toolchain)?

Regards,
Mohanlal

---

From: "Steven J. Hill" <[email-masked]>
Date: Sun, 21 Aug 2005 14:34:53 -0500

mohanlal jangir wrote:
>
> Thanks for your help. I tried to apply this patch on Linux-2.6.10 and 
> many hunks failed. Could you tell me which kernel version this patch 
> should be applied? Also do I need to apply any patch to gcc, glibc 
> sources (and build a new toolchain)?
>
Mohanlal,

If you are wanting to work with NPTL and MIPS, please use the latest
Linux version from the Linux/MIPS cvs tree. The latest releases of
binutils-2.16.x contain NPTL support for MIPS. You will need to use
the HEAD of gcc cvs and the HEAD of glibc cvs in order to get the
MIPS NPTL support. Please note that NO backport of NPTL will be done
to versions of GCC older than 4.1.0. Have fun.

-Steve

---

From: Chris Wedgwood <[email-masked]>
Date: Sun, 21 Aug 2005 13:01:51 -0700

> to versions of GCC older than 4.1.0. Have fun.

How stable is GCC is head?  Hostorically thre have been periods of
time when gcc itself wasn't stable or the code it produce wasn't
stable.

---

From: "Steven J. Hill" <[email-masked]>
Date: Mon, 22 Aug 2005 11:59:15 -0500

> time when gcc itself wasn't stable or the code it produce wasn't
The last working GCC 4.1.0 I checked out was on 20050604. I have yet
to get a cross build to work with uClibc. glibc-based toolchains seem
to work okay, but yes, GCC 4.1.0 is a piece of ****.

-Steve