Subject: [PATCH 06/15] mips: remove use of asm/segment.h

From: Kumar Gala <[email-masked]>
Date: Wed, 24 Aug 2005 11:54:27 -0500 (CDT)

Removed MIPS architecture specific users of asm/segment.h and
asm-mips/segment.h itself

Signed-off-by: Kumar Gala <[email-masked]>

---
commit 8f20e153d5d5c3efd95835e814fae7b3ccbfcd08
tree 17e9ae88b3fe1762302179a4ea08e61360805a29
parent 503a812c1f9cef08e6f96b2b2cf1f32bbfef2bc6
author Kumar K. Gala <[email-masked]> Wed, 24 Aug 2005 10:59:09 -0500
committer Kumar K. Gala <[email-masked]> Wed, 24 Aug 2005 10:59:09 -0500

 arch/mips/au1000/db1x00/mirage_ts.c |    1 -
 include/asm-mips/segment.h          |    6 ------
 2 files changed, 0 insertions(+), 7 deletions(-)

diff --git a/arch/mips/au1000/db1x00/mirage_ts.c b/arch/mips/au1000/db1x00/mirage_ts.c
--- a/arch/mips/au1000/db1x00/mirage_ts.c
+++ b/arch/mips/au1000/db1x00/mirage_ts.c
@@ -44,7 +44,6 @@
 #include <linux/smp_lock.h>
 #include <linux/wait.h>
 
-#include <asm/segment.h>
 #include <asm/irq.h>
 #include <asm/uaccess.h>
 #include <asm/delay.h>
diff --git a/include/asm-mips/segment.h b/include/asm-mips/segment.h
deleted file mode 100644
--- a/include/asm-mips/segment.h
+++ /dev/null
@@ -1,6 +0,0 @@
-#ifndef _ASM_SEGMENT_H
-#define _ASM_SEGMENT_H
-
-/* Only here because we have some old header files that expect it.. */
-
-#endif /* _ASM_SEGMENT_H */

---

From: Ralf Baechle <[email-masked]>
Date: Wed, 24 Aug 2005 18:02:59 +0100

> asm-mips/segment.h itself

Thanks, applied.

  Ralf