Subject: Re: Question regarding compiling a toolchain for a Broadcom SB1

From: Daniel Kegel <[email-masked]>
Date: Thu, 08 Sep 2005 10:33:53 -0700

Jonathan Day <imipak at yahoo dot com> wrote:
> Crosstool, for example, only supports 32-bit MIPS -
> and even then the build matrix is a pretty shade of
> red for the most part.

[ The build matrix: http://kegel.com/crosstool/current/buildlogs/ ]

There are quite a few combinations that build for 32-bit mips with crosstool, e.g.
  mips-gcc-3.2.3-glibc-2.2.5
  mips-gcc-3.2.3-glibc-2.3.2
  mips-gcc-3.3.6-glibc-2.2.5
  mips-gcc-3.3.6-glibc-2.3.5
  mips-gcc-3.4.4-glibc-2.3.2-hdrs-2.6.11.2
  mips-gcc-3.4.4-glibc-2.3.5-hdrs-2.6.11.2
  mips-gcc-4.1-20050702-glibc-2.3.2-hdrs-2.6.11.2
  mips-gcc-4.1-20050709-glibc-2.3.2-hdrs-2.6.11.2
so the situation isn't that dire.

For the record, I would be more than happy to add mips64 support to crosstool.
http://www.linux-mips.org/archives/linux-mips/2005-07/msg00189.html
http://documents.jg555.com/cross-lfs/mips64-64/cross-tools/glibc.html
http://documents.jg555.com/cross-lfs/mips64-64/cross-tools/gcc-final.html
mentions some patches that might be needed.
I haven't had time to chase them down and add them to crosstool,
but if anybody else felt like it, I'd gladly accept the patches.
I'm sure a lot of mips64 users would be very happy.
- Dan

---

From: Jonathan Day <[email-masked]>
Date: Thu, 8 Sep 2005 14:11:26 -0700 (PDT)

Here's the web link to all of the patches needed by
the Linux From Scratch group.

http://documents.jg555.com/cross-lfs/mips64-64/materials/patches.html

I'm doing a build from the binutils, gcc and glibc
from CVS, for an initial run. Results so far:

Binutils patches cleanly, using the patch on file. It
seems to build fine, when patched, but until all
stages are complete, there's no easy way to verify
that.

GCC won't take the Posix patch and some of the other
patches need massaging, but there doesn't seem to be
any major problems. HOWEVER, this does say that you'd
best stick with the intended version (GCC 4.0.1) for
your build scripts.

Glibc will take the 64-bit fixes but all other patches
are rejected. It failed on the forced unwinding test,
when configuring. According to the LFS docs, NPTL is
broken for MIPS64, but I don't know if that is still
the case. I decided to backtrack to the glibc that
works, according to the LFS, and have classed the
status of Glibc for MIPS64 as uncertain.

--- Daniel Kegel <[email-masked]> wrote:

> > and even then the build matrix is a pretty sh
ade
> of
> > red for the most part.
> 
> [ The build matrix:
> http://kegel.com/crosstool/current/buildlogs/ ]
> 
> I'm sure a lot of mips64 users would be very happy.

		
______________________________________________________
Click here to donate to the Hurricane Katrina relief effort.
http://store.yahoo.com/redcross-donate3/