Subject: [PATCH] minor fix in asm-mips/module.h

From: Franck <[email-masked]>
Date: Mon, 26 Sep 2005 09:06:50 +0200

This patch replaces an empty preprocessor condition #elif by #else. It
adds 4ksc and 4ksd as well.

Thanks.
--
               Franck

---

From: Ralf Baechle <[email-masked]>
Date: Mon, 26 Sep 2005 13:55:39 +0200

> adds 4ksc and 4ksd as well.

You forgot to include the patch ...

  Ralf

---

From: Franck <[email-masked]>
Date: Mon, 26 Sep 2005 14:05:36 +0200

> You forgot to include the patch ...

sorry for that, here it is...

Thanks
--
               Franck
--- module.h~old	2005-09-26 14:02:32.000000000 +0200
+++ module.h	2005-09-26 09:54:08.000000000 +0200
@@ -113,7 +113,11 @@ search_module_dbetables(unsigned long ad
 #define MODULE_PROC_FAMILY "RM9000"
 #elif defined CONFIG_CPU_SB1
 #define MODULE_PROC_FAMILY "SB1"
-#elif
+#elif defined CONFIG_CPU_4KSC
+#define MODULE_PROC_FAMILY "4KSC"
+#elif defined CONFIG_CPU_4KSD
+#define MODULE_PROC_FAMILY "4KSD"
+#else
 #error MODULE_PROC_FAMILY undefined for your processor configuration
 #endif

---

From: Ralf Baechle <[email-masked]>
Date: Fri, 30 Sep 2005 00:45:42 +0100

On Mon, Sep 26, 2005 at 02:05:36PM +0200, Franck wrote:

> > > This patch replaces an empty preprocessor condition #elif by #else.

Thanks for noticing.

> > > It adds 4ksc and 4ksd as well.

There are no CONFIG_CPU_4KSC and CONFIG_CPU_4KSD configuration options.
Did you really create this patch against the linux module of the CVS
repository or was it a different tree?

Thanks,

  Ralf

---

From: Franck <[email-masked]>
Date: Fri, 30 Sep 2005 14:36:01 +0200

Hi Ralf,

> repository or was it a different tree?

The patch was created against linux-mips CVS repository. I added 4KSC
and 4KSD support in this tree. I thougth seeing reference of 4KSC
somewhere. Anyway, if you don't want to include them in your tree
that's ok.

Thanks
--
               Franck

---

From: Ralf Baechle <[email-masked]>
Date: Fri, 30 Sep 2005 14:09:28 +0100

> somewhere. Anyway, if you don't want to include them in your tree

It's just that references to CONFIG_* symbols that are being defined
nowhere don't make sense.  If however you want to contribute improved
support for these processors, by all means I'm certainly going to appreciate
a patch!

  Ralf

---

From: Franck <[email-masked]>
Date: Fri, 30 Sep 2005 17:44:01 +0200

> support for these processors, by all means I'm certainly going to appreciate

I'm surprised you're interested in added support for 4KSC and 4KSD
cpu...Anyway I could send a trivial patch to you if so.

Thanks
--
               Franck

---

From: Ralf Baechle <[email-masked]>
Date: Fri, 30 Sep 2005 17:09:52 +0100

> cpu...Anyway I could send a trivial patch to you if so.

Yes, some people do strange things with Linux :-)

  Ralf