Subject: debug user-level application with ejtag

From: "Zheng BaoJian <郑保建>" <[email-masked]>
Date: Fri, 16 Sep 2005 17:20:30 +0800

Hi all:

I want to debug a user-level application with ejtag,during app running i
list cpu register with ejtag,system report "Bus error",Who have debuged
user app with ejtag?
Best Regards.

-- 
Baojian Zheng
Institute of Computing Technology
Chinese Academy of Sciences
P.O. Box 2704-25
Beijing, China,100080
Tel: 86-10-62565533 ex. 9311
E-mail: [email-masked]

---

From: Chris Wedgwood <[email-masked]>
Date: Fri, 16 Sep 2005 02:27:18 -0700

On Fri, Sep 16, 2005 at 05:20:30PM +0800, "Zheng BaoJian <??????>" wrote:

> I want to debug a user-level application with ejtag,during app
> running i list cpu register with ejtag,system report "Bus error",Who
> have debuged user app with ejtag?

generally speaking this won't work in any reliable manner (it probably
could be made to work reliably given enough effort but i doubt anyone
will bother)

try gdbserver instead