Subject: Problem in detecting RAM size by bootloader

From: Arravind babu <[email-masked]>
Date: Thu, 29 Sep 2005 13:52:51 +0100 (BST)

Hi all,

         We are using PMON bootloader on MIPS based
board.Earlier we have 64MB of RAM.Now we upgraded to
128MB RAM.But bootloader is not detecting as 128MB.It
is giving 64MB only.Where i have to look to resolve
this issue?

Thanks in advance,
Aravind.

__________________________________________________________ 
Yahoo! India Matrimony: Find your partner now. Go to http://yahoo.shaadi.com

---

From: David Daney <[email-masked]>
Date: Thu, 29 Sep 2005 08:43:41 -0700

> is giving 64MB only.Where i have to look to resolve

I would look at the boot monitor source code.  On some systems (Xilleon 
for example) the memory configuration is hardcoded.  In this case, if 
you change the physical memory configuration, you have to make a 
corresponding change to the boot monitor.

David Daney