Subject: scheduling with irqs disabled: init

From: <[email-masked]>
Date: Fri, 9 Sep 2005 10:25:55 +0530

hi,
	I'm porting MVL4.0 kernel on to a mips board. I've been getting
a call trace as follows.

BUG: scheduling with irqs disabled: init/0x00000000/1
caller is schedule_timeout+0x84/0xe8
Call Trace:
 [<8030a0a8>] schedule_timeout+0x84/0xe8
 [<803090b8>] schedule+0x114/0x160
 [<803090b0>] schedule+0x10c/0x160
 [<8030a0a8>] schedule_timeout+0x84/0xe8
 [<80132610>] process_timeout+0x0/0x8
 [<80132c0c>] msleep_interruptible+0x4c/0x70
 [<802300a8>] gs_wait_tx_flushed+0x1fc/0x3b0
 [<8022fc44>] gs_write+0x25c/0x264
 [<802310cc>] gs_close+0x260/0x394
 [<80216364>] tty_fasync+0x8c/0x134
 [<80216b00>] release_dev+0x6f4/0xa08
 [<8021dddc>] write_chan+0x420/0x48c
 [<8012107c>] __wake_up+0x44/0x80
 [<80120f58>] default_wake_function+0x0/0x28
 [<8017a734>] get_empty_filp+0x64/0x13c
 [<80215234>] tty_ldisc_deref+0xcc/0x110
 [<80215b28>] tty_write+0x2bc/0x454
 [<80216e24>] tty_release+0x10/0x20
 [<80179988>] vfs_write+0xac/0x114
 [<8017aacc>] __fput+0x298/0x2d0
 [<8018e9b8>] getname+0x28/0xfc
 [<80178d2c>] filp_close+0x54/0xb4
 [<80178d24>] filp_close+0x4c/0xb4
 [<8010bc64>] stack_done+0x20/0x3c

I'm totally unaware of the bug. Can anyone help me fix it?

Thanking u in advance,

vadi.

The information contained in this e-mail message and in any annexure is
confidential to the  recipient and may contain privileged information. If you are not
the intended recipient, please notify the sender and delete the message along with
any annexure. You should not disclose, copy or otherwise use the information contained
in the message or any annexure. Any views expressed in this e-mail are those of the
individual sender except where the sender specifically states them to be the views of
SoCrates Software India Pvt Ltd., Bangalore.

---

From: Alan Cox <[email-masked]>
Date: Fri, 09 Sep 2005 13:54:52 +0100

> 	I'm porting MVL4.0 kernel on to a mips board. I've been getting

You should report vendor kernel bugs to the vendor really. I've not seen
an equivalent report for the base kernel and looking at the code the
base kernel appears to correctly drop the lock before calling the wait
for chars level.

---

From: Pete Popov <[email-masked]>
Date: Fri, 09 Sep 2005 09:03:39 -0700

> I'm totally unaware of the bug. Can anyone help me fix it?

Few developers have access to MVL4.0, especially since it just shipped.
Most likely this is a bug in your board port though so unless you get
help directly on MVL4.0, I would suggest you first port linux-mips to
your board and then move your patch to MVL4.0.

Pete