Subject: Re: CVS [email-masked]: linux

From: Ralf Baechle <[email-masked]>
Date: Thu, 1 Sep 2005 12:18:36 +0100

On Thu, Sep 01, 2005 at 09:56:30AM +0100, [email-masked] wrote:

> diff -urN linux/include/asm-mips/mach-ip22/spaces.h linux/include/asm-mips/mach-ip22/spaces.h
> --- linux/include/asm-mips/mach-ip22/spaces.h	2005/07/14 12:05:11	1.3
> +++ linux/include/asm-mips/mach-ip22/spaces.h	2005/09/01 08:56:18	1.4
> @@ -44,7 +44,7 @@
>  #define CAC_BASE		0xffffffff80000000
>  #define IO_BASE			0xffffffffa0000000
>  #define UNCAC_BASE		0xffffffffa0000000
> -#define MAP_BASE		0xffffffffc0000000
> +#define MAP_BASE		0xc000000000000000

You just broke the R5000.

  Ralf

---

From: Ralf Baechle <[email-masked]>
Date: Thu, 1 Sep 2005 12:31:10 +0100

> You just broke the R5000.

Forgot it, was thinking of something else, the ll/sc in XKPHYS bug ...

  Ralf