Subject: unresolved symbol

From: "vasanth" <[email-masked]>
Date: Thu, 8 Sep 2005 19:26:17 +0530

Hi,

I am getting the folowing error message when i do insmod .
insmod: unresolved symbol __udelay
insmod: unresolved symbol atomic_add
insmod: unresolved symbol atomic_sub

I complied the driver code for mips processor using the folowing command
mips-linux-gcc -G O -mno-abicalls -fno-pic -pipe -mtune=4kc -mips32 -c lcddriver.c -I/mykernel/include
It is compiling without any error . 
Can anybody know how to solve this problem.?

Regards,
Vasanth.

---

From: Ralf Baechle <[email-masked]>
Date: Thu, 8 Sep 2005 15:05:13 +0100

> It is compiling without any error . 

Use -O2.  In fact use _exactly_ the same options as for the kernel build
itself.

  Ralf

---

From: Daniel Jacobowitz <[email-masked]>
Date: Thu, 8 Sep 2005 11:33:37 -0400

> Can anybody know how to solve this problem.?

Turn on optimization.

-- 
Daniel Jacobowitz
CodeSourcery, LLC