Subject: [PATCH] Export IP32 mace symbol

From: Arnaud Giersch <[email-masked]>
Date: Sun, 13 Nov 2005 00:38:18 +0100

Export mace symbol so that it can be used in modules.

Signed-off-by: Arnaud Giersch <[email-masked]>
---

 Ralf, you told me that this was OK but you did not committed it.

 crime.c |    3 +++
 1 files changed, 3 insertions(+)

diff --git a/arch/mips/sgi-ip32/crime.c b/arch/mips/sgi-ip32/crime.c
--- a/arch/mips/sgi-ip32/crime.c
+++ b/arch/mips/sgi-ip32/crime.c
@@ -10,6 +10,7 @@
 #include <linux/init.h>
 #include <linux/kernel.h>
 #include <linux/interrupt.h>
+#include <linux/module.h>
 #include <asm/bootinfo.h>
 #include <asm/io.h>
 #include <asm/mipsregs.h>
@@ -21,6 +22,8 @@
 struct sgi_crime *crime;
 struct sgi_mace *mace;
 
+EXPORT_SYMBOL_GPL(mace);
+
 void __init crime_init(void)
 {
 	unsigned int id, rev;

---

From: Ralf Baechle <[email-masked]>
Date: Sun, 13 Nov 2005 18:16:20 +0000

On Sun, Nov 13, 2005 at 12:38:18AM +0100, Arnaud Giersch wrote:

All 5 patches applied.  Thanks,

  Ralf

---

From: Dominique Quatravaux <[email-masked]>
Date: Mon, 14 Nov 2005 09:29:56 +0100

Ralf Baechle a écrit :

>All 5 patches applied.
So it looks like crime.c pays, after all?

M. Ralf with the mace symbol, in the code depot? :-)

-- 
<< Tout n'y est pas parfait, mais on y honore certainement les jardiniers >>

			Dominique Quatravaux <[email-masked]>

---

From: Ralf Baechle <[email-masked]>
Date: Mon, 14 Nov 2005 16:03:13 +0000

> M. Ralf with the mace symbol, in the code depot? :-)

Reminds me of Batman his opponent, the pinguin ;-)

  Ralf