Subject: git and tags...

From: Franck <[email-masked]>
Date: Tue, 8 Nov 2005 11:49:48 +0100

Hi,

I'm trying to retrieve a linux kernel by tag using git. Let's say for
example I want my working tree to be a linux 2.6.12 copy from git
repository. How can I do that ?

I tried these commands but it seems that there's no tag in git repository

git clone rsync://ftp.linux-mips.org/git/linux.git linux.git
git pull http://www.linux-mips.org/pub/scm/linux.git tag linux_2_6_12

Thanks
--
               Franck

---

From: Ralf Baechle <[email-masked]>
Date: Tue, 8 Nov 2005 11:01:34 +0000

> git pull http://www.linux-mips.org/pub/scm/linux.git tag linux_2_6_12

ls .git/refs/tags to see the tag names.  

  Ralf

---

From: Franck <[email-masked]>
Date: Tue, 8 Nov 2005 18:25:06 +0100

> ls .git/refs/tags to see the tag names.

OK, so tags have been renamed into "linux-2.6.x". Why not using the
same mainline name convention (v2.6.x) ?

I have another question (which is the first one in my previous email),
how can I make my working tree a kernel version 2.6.9 for example ?

And the last question related to mips git repository, why does kernel
v2.2, v2.4, v2.6 are in the same repository ? Why not seperate
different major version of the kernel in a seperate repository ?

Thanks
--
               Franck

---

From: Ralf Baechle <[email-masked]>
Date: Tue, 8 Nov 2005 18:45:21 +0000

> same mainline name convention (v2.6.x) ?

The same reason that some people like blue and others prefer green ;-)

> how can I make my working tree a kernel version 2.6.9 for example ?

git-read-tree $(cat .git/refs/tags/linux-2.6.9)
git-checkout-index -f -a -u -q

> different major version of the kernel in a seperate repository ?

The extra space consumption for all these historic versions in a
compressed git repository is extremly little.

  Ralf

---

From: Daniel Jacobowitz <[email-masked]>
Date: Tue, 8 Nov 2005 16:31:03 -0500

> git-checkout-index -f -a -u -q

IIUC, this is just "git checkout linux-2.6.9" nowadays.

-- 
Daniel Jacobowitz
CodeSourcery, LLC

---

From: Franck <[email-masked]>
Date: Wed, 9 Nov 2005 10:15:07 +0100

> The same reason that some people like blue and others prefer green ;-)

yet, mips branch follows mainline coding style...Actually it's just
more convenient to remember only one tag name convention. Anyways....

> git-checkout-index -f -a -u -q

thanks for that

> compressed git repository is extremly little.

hmm...still I get:

# du linux-mips.git/.git
263M
# du linux-mainline.git/.git
104M

Thanks
--
               Franck

---

From: Franck <[email-masked]>
Date: Wed, 9 Nov 2005 10:43:31 +0100

> IIUC, this is just "git checkout linux-2.6.9" nowadays.

"checkout" command seems to work with branch, not tag. Which version
of git are you using ?

Thanks
--
               Franck