Subject: Problems with Linux kernel on Broadcom SB1

From: Jonathan Day <[email-masked]>
Date: Tue, 15 Nov 2005 12:48:28 -0800 (PST)

Hi,

Trying to build the Linux kernel currently in the git
archive on a Broadcom SB1 (specifically, the 1250 dual
processor system).

I've not been able to get any of the page sizes other
than the 4K pages to work at all - it stops at boot,
no error messages, just a straight lock-up. If this is
a problem with the SB1, it might be wise to disable
the changing of the page size for that processor.

When enabling GDB support, I get the following
compile-time error:

arch/mips/sibyte/sb1250/irq.c: In function
'arch_init_irq':
arch/mips/sibyte/sb1250/irq.c:385: error: 'kgdb_flag'
undeclared (first use in this function)
arch/mips/sibyte/sb1250/irq.c:385: error: (Each
undeclared identifier is reported only once
arch/mips/sibyte/sb1250/irq.c:385: error: for each
function it appears in.)
arch/mips/sibyte/sb1250/irq.c: In function
'sb1250_kgdb_interrupt':
arch/mips/sibyte/sb1250/irq.c:423: warning: implicit
declaration of function 'set_async_breakpoint'

A quick inspection suggests copy-and-pasting lines 63
to 85 (inclusive) from arch/mips/bcm1480/irq.c to
arch/mips/sb1250/irq.c, overwriting lines 63 to 71, as
the bcm1480 lines seem to be much more up-to-date and
do seem to fix the problem.

The configure options allows me to enable MT on the
SB1, but I'm pretty sure the SB1 does not support MT.
If this is indeed the case, then someone might want to
have this option disabled when the SB1 is selected. In
fact, it might be good to hunt for core-specific
options and have them in their own section. That way,
you don't have obscenely-complex checks for every
option.

ipc/msg.c is giving a bunch of warnings -
setbuf.qbytes, setbuf.uid, setbuf.gid and setbuf.mode
may be being used uninitialized in the sys_msgctl and
the sys_semctl functions. Probably nothing
significant, and GCC does love to throw out errors for
conditions that aren't actually possible, but it
probably wouldn't hurt to see if there's a problem
there.

From time to time, I compile unexpectedly non-working
kernels - does anyone know of a good set of options to
enable to identify where kernel lockups could be
occuring?

Thanks,

Jonathan
(The weirdo with weekly SB1 problems)

		
__________________________________ 
Yahoo! Mail - PC Magazine Editors' Choice 2005 
http://mail.yahoo.com

---

From: "Maciej W. Rozycki" <[email-masked]>
Date: Wed, 16 Nov 2005 12:07:24 +0000 (GMT)

> the changing of the page size for that processor.

 It's known broken for any processor.  The option is there for us to 
remember to fix it one day. ;-)

  Maciej

---

From: Ralf Baechle <[email-masked]>
Date: Wed, 16 Nov 2005 14:32:11 +0000

> than the 4K pages to work at all - it stops at boot,

This option is marked experimental.  So you choose to experiment and you
saw the pyrotechnics fly ;-)

  Ralf