Subject: 2.6.14-git9 cobalt build fails

From: Andre <[email-masked]>
Date: Sun, 6 Nov 2005 07:23:14 -0800 (PST)

Not sure if the cobalt support that's just gone into the mainstream
kernel is even supposed to compile yet... but it doesn't ;-) I tried
2.6.14 + git9 patch from kernel.org.

Note that default config was tweaked slightly (to enable IDE DMA and
a network driver).

  ...
  CC      arch/mips/pci/pci.o
  CC      arch/mips/pci/ops-gt64111.o
  CC      arch/mips/pci/fixup-cobalt.o
arch/mips/pci/fixup-cobalt.c:35: error:
`PCI_DEVICE_ID_MARVELL_GT64111' undeclared here (not in a function)
arch/mips/pci/fixup-cobalt.c:35: error: initializer element is not
constant
arch/mips/pci/fixup-cobalt.c:35: error: (near initialization for
`__pci_fixup_PCI_VENDOR_ID_MARVELLPCI_DEVICE_ID_MARVELL_GT64111qube_raq_galileo_early_fixup.device')
arch/mips/pci/fixup-cobalt.c:116: error: initializer element is not
constant
arch/mips/pci/fixup-cobalt.c:116: error: (near initialization for
`__pci_fixup_PCI_VENDOR_ID_MARVELLPCI_DEVICE_ID_MARVELL_GT64111qube_raq_galileo_fixup.device')
arch/mips/pci/fixup-cobalt.c:58: error:
__pci_fixup_PCI_VENDOR_ID_VIAPCI_DEVICE_ID_VIA_82C586_1qube_raq_via_bmIDE_fixup
causes a section type conflict
make[1]: *** [arch/mips/pci/fixup-cobalt.o] Error 1
make: *** [arch/mips/pci] Error 2
root@qube2:/usr/src/linux-2.6.14# 

__________________________________ 
Yahoo! FareChase: Search multiple travel sites in one click.
http://farechase.yahoo.com

---

From: Stuart Longland <[email-masked]>
Date: Mon, 07 Nov 2005 13:05:22 +1000

> 2.6.14 + git9 patch from kernel.org.
  ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^

I think I see the cause.  You should always use sources from Linux/MIPS
git, as these are more likely to work.

http://www.linux-mips.org/wiki/Git should have some useful resources.

-- 
Stuart Longland (aka Redhatter)              .'''.
Gentoo Linux/MIPS Cobalt and Docs Developer  '.'` :
. . . . . . . . . . . . . . . . . . . . . .   .'.'
http://dev.gentoo.org/~redhatter             :.'

---

From: Yoichi Yuasa <[email-masked]>
Date: Mon, 7 Nov 2005 13:17:02 +0900

Hi Andre,

> root@qube2:/usr/src/linux-2.6.14#

PCI_DEVICE_ID_MARVELL_GT64111 was removed from kernel.org git(I don't know why).
Please add the following device ID to include/linux/pci_ids.h

#define PCI_DEVICE_ID_MARVELL_GT64111 0x4146

Yoichi

---

From: Geert Uytterhoeven <[email-masked]>
Date: Mon, 7 Nov 2005 09:53:00 +0100 (CET)

> PCI_DEVICE_ID_MARVELL_GT64111 was removed from kernel.org git(I don't know why).

All `unused' definitions were removed from pci_ids.h. Hence if fixup-cobalt.c
in Linus' tree was not in sync, it was removed.

Gr{oetje,eeting}s,

						Geert

--
Geert Uytterhoeven -- There's lots of Linux beyond ia32 -- [email-masked]

In personal conversations with technical people, I call myself a hacker. But
when I'm talking to journalists I just say "programmer" or something like that.
							    -- Linus Torvalds