Subject: [PATCH] remove mips_rtc_lock

From: Atsushi Nemoto <[email-masked]>
Date: Thu, 03 Nov 2005 01:02:40 +0900 (JST)

The mips_rtc_lock is no longer needed because RTC operations should be
protected already by other mechanism. (rtc_lock, local_irq_save, etc.)

Also, locking whole rtc_get_time/rtc_set_time should be avoided while
some RTC routines might take very long time (a few seconds).

Signed-off-by: Atsushi Nemoto <[email-masked]>

diff --git a/include/asm-mips/rtc.h b/include/asm-mips/rtc.h
--- a/include/asm-mips/rtc.h
+++ b/include/asm-mips/rtc.h
@@ -14,7 +14,6 @@
 
 #ifdef __KERNEL__
 
-#include <linux/spinlock.h>
 #include <linux/rtc.h>
 #include <asm/time.h>
 
@@ -29,17 +28,13 @@
 #define RTC_24H 0x02            /* 24 hour mode - else hours bit 7 means pm */
 #define RTC_DST_EN 0x01         /* auto switch DST - works f. USA only */
 
-static DEFINE_SPINLOCK(mips_rtc_lock);
-
 static inline unsigned int get_rtc_time(struct rtc_time *time)
 {
 	unsigned long nowtime;
 
-	spin_lock(&mips_rtc_lock);
 	nowtime = rtc_get_time();
 	to_tm(nowtime, time);
 	time->tm_year -= 1900;
-	spin_unlock(&mips_rtc_lock);
 
 	return RTC_24H;
 }
@@ -49,12 +44,10 @@ static inline int set_rtc_time(struct rt
 	unsigned long nowtime;
 	int ret;
 
-	spin_lock(&mips_rtc_lock);
 	nowtime = mktime(time->tm_year+1900, time->tm_mon+1,
 			time->tm_mday, time->tm_hour, time->tm_min,
 			time->tm_sec);
 	ret = rtc_set_time(nowtime);
-	spin_unlock(&mips_rtc_lock);
 
 	return ret;
 }

---

From: Ralf Baechle <[email-masked]>
Date: Thu, 3 Nov 2005 11:05:53 +0000

> Signed-off-by: Atsushi Nemoto <[email-masked]>

Applied.  Thanks alot for the janitor work.

And also the function names are clear as mud:

[...]

        nowtime = rtc_get_time();
[...]
static inline int set_rtc_time(struct rtc_time *time)
{
        unsigned long nowtime;
        int ret;

[...]

The difference between and get_rtc_time and rtc_get_time is less than
obvious.  Same for set_rtc_time and rtc_set_time ...

   Ralf

---

From: Atsushi Nemoto <[email-masked]>
Date: Thu, 03 Nov 2005 23:12:50 +0900 (JST)

>>>>> On Thu, 3 Nov 2005 11:05:53 +0000, Ralf Baechle <[email-masked]> said:

ralf> The difference between and get_rtc_time and rtc_get_time is less
ralf> than obvious.  Same for set_rtc_time and rtc_set_time ...

Sure.  Also I suppose majority of RTC prefer struct rtc_time than
unsigned long.  Is it time for redesign the mips RTC interface? ;-)

---
Atsushi Nemoto

---

From: Ralf Baechle <[email-masked]>
Date: Thu, 3 Nov 2005 14:26:43 +0000

> unsigned long.  Is it time for redesign the mips RTC interface? ;-)

More than that, the whole MIPS time code while functional is such a
beauty it could make a grown man cry ...

  Ralf