Subject: Calibrating delay loop... crashes

From: Nguyen Thanh Binh <[email-masked]>
Date: Wed, 16 Nov 2005 01:36:34 +0000 (GMT)

Hello all,

When booting Monta Vista Linux on Memec board
(Virtex-4 FX12 LC), it crashed after printing the
following message:

    "Calibrating delay loop..."

By looking at the source code, I found that in the
init/main.c the problem came from the calibrate_delay
function: jiffies was not incremented (jiffies was
always equal to 0).

Have anyone get the similar problem or any experience
to fix it?

Thank you.

Binh Nguyen

___________________________________________________________ 
To help you stay safe and secure online, we've developed the all new Yahoo! Security Centre. http://uk.security.yahoo.com

---

From: "Kevin D. Kissell" <[email-masked]>
Date: Wed, 16 Nov 2005 02:47:13 +0100

> Have anyone get the similar problem or any experience

I take it that by "crashed", you mean it hung?  If so,
it sounds like you aren't getting any timer interrupts.

		Regards,

		Kevin K.

---

From: Manish Lachwani <[email-masked]>
Date: Tue, 15 Nov 2005 17:59:32 -0800 (PST)

Its probably hung at that point since the timer
interrupt never came.

Thanks
Manish Lachwani

> 
> To help you stay safe and secure online, we've
> developed the all new Yahoo! Security Centre.
> http://uk.security.yahoo.com
> 
>

---

From: Nguyen Thanh Binh <[email-masked]>
Date: Wed, 16 Nov 2005 02:10:26 +0000 (GMT)

Hi Kevin,

> it sounds like you aren't getting any timer

You are right. Because jiffies was not incremented so
the below code segment in function calibrate_delay in
file init/mian.c hung:

   ticks = jiffies;
   while (ticks == jiffies) ;

As I am a newbie, I did not find how to fix it.

Thank you for any help.

Binh Nguyen

Nguy&#7877;n Thanh Bình

___________________________________________________________ 
How much free photo storage do you get? Store your holiday 
snaps for FREE with Yahoo! Photos http://uk.photos.yahoo.com

---

From: Manish Lachwani <[email-masked]>
Date: Tue, 15 Nov 2005 18:24:39 -0800 (PST)

Hi !

There is a porting guide at:

http://linux.junsun.net/porting-howto/

which is quite useful. Read the "System time and
timer" section. It describes to some extent
implementing timer services.

Thanks
Manish Lachwani

---

From: Ralf Baechle <[email-masked]>
Date: Wed, 16 Nov 2005 14:07:18 +0000

> implementing timer services.

Except it being outdated, totally 2.4 centric and having been superseeded
by the version that's now in the www.linux-mips.org wiki since almost a
year.

  Ralf