Subject: pci_iomap issues?

From: Scott Ashcroft <[email-masked]>
Date: Tue, 6 Dec 2005 00:23:12 +0000 (GMT)

What will it take to get a pci_iomap implementation
into the kernel.
Looking back in the list archives I've seen comments
that the patches posted to the list don't support
multiple PCI busses.
I can't see any difference between the patches and the
support in other archs.
Are the other archs broken or am I missing something?

Cheers,
Scott

---

From: Jim Gifford <[email-masked]>
Date: Mon, 05 Dec 2005 17:47:52 -0800

How many machines are affected by multiple pci busses. I can only thing 
of the Origin systems. Couldn't we get a base iomap.c in and add one's 
specific to the multiple bus machines?

-- 
----
Jim Gifford
[email-masked]

---

From: "Mark Mason" <[email-masked]>
Date: Tue, 06 Dec 2005 15:24:49 -0800

Hello,

Jim Gifford wrote:

> How many machines are affected by multiple pci busses. I can only
> thing of the Origin systems. Couldn't we get a base iomap.c in and add
> one's specific to the multiple bus machines?

Any system based on BCM1480s could have multiple pci busses (one PCI-X
directly, and additional busses through HT/PCI-X bridges).  For the
BCM91480B board, we had to turn on PCI_DOMAINS to get this to work
correctly.

/Mark

---

From: Scott Ashcroft <[email-masked]>
Date: Wed, 7 Dec 2005 17:45:59 +0000 (GMT)

> BCM91480B board, we had to turn on PCI_DOMAINS to

I understand that there are machines with multiple PCI
busses out there but comparing the ppc64 code with the
proposed mips patches I don't see much difference.
Are the ppc64 people just breaking multiple PCI bus
machines, did something happen in the generic PCI code
which fixed the issue or is there just a difference I
can't see?

Cheers,
Scott