Subject: Build error: undefined reference to `__ashrdi3'

From: "P. Christeas" <[email-masked]>
Date: Sat, 17 Dec 2005 04:34:19 +0200

Please, a little help here..
I tried to rebuild the toolchain, giving --with-float=soft, and still get the 
same (as with no such option). It is gcc 4.0.2 + μClibc
I am porting mips to a new board, so this may be my mistake. Somewhere I can 
kick-start this?
How can a kernel build (which should be autonomous) depend on some compiler 
setup?

---

From: "P. Christeas" <[email-masked]>
Date: Sun, 18 Dec 2005 16:27:58 +0200

> I tried to rebuild the toolchain, giving --with-float=soft, and still get
> the same (as with no such option). It is gcc 4.0.2 + μClibc
> I am porting mips to a new board, so this may be my mistake. Somewhere I
> can kick-start this?

FYI, I have copied prototypes for these fn's from arch/ppc and it builds now.