Subject: zero copy

From: kernel coder <[email-masked]>
Date: Tue, 6 Dec 2005 04:06:06 -0800

hi,
    i'm trying to track the code flow of sendfile system call.Mine
ethernet card doesn't have scatter gather and checksum calculation
features.So stack should be making a copy of data.

Please tell me where in sendfile code flow,check for scatter gather
and cecksum features is made so that stack can decide whether to copy
data from user space or not.

lhrkernelcoder

---

From: Matt Porter <[email-masked]>
Date: Tue, 6 Dec 2005 08:53:47 -0700

> data from user space or not.

Is your grep really that broken? :)

net/ipv4/tcp.c:tcp_sendpage() is where you find the check and
fallback to sendmsg if you follow it through.

-Matt