Subject: MIPS processors gain GNU/Linux binary prelinker

From: Tim Bird <[email-masked]>
Date: Wed, 01 Nov 2006 14:47:35 -0800

FYI - For those interested in bootup time improvements on MIPS
processors, here is some information about the recently
developed MIPS prelinking feature, done by CodeSourcery
and MIPS Technologies.

http://www.linuxdevices.com/news/NS6220941326.html

This press release does not mention CELF, but it should
be noted that the first public demonstration of this
technology was performed (I believe) at the recent CELF technical
jamboree, in Tokyo Japan, held just last Friday (Oct 27).

See http://tree.celinuxforum.org/CelfPubWiki/JapanTechnicalJamboree11
for information about the jamboree.  The presentation about
this technology which was delivered at the meeting is at:

http://tree.celinuxforum.org/CelfPubWiki/JapanTechnicalJamboree11?action=AttachFile&do=get&target=MIPS-Prelinker.pdf

MIPS and CodeSourcery brought a demo so we got to do
some actual speed comparisons live at the event.  It was fun!

Regards,
 -- Tim

=============================
Tim Bird
Architecture Group Chair, CE Linux Forum
Senior Staff Engineer, Sony Electronics
=============================

---

From: Thiemo Seufer <[email-masked]>
Date: Tue, 7 Nov 2006 14:04:37 +0000

> developed MIPS prelinking feature, done by CodeSourcery

The patches are showing up piecemeal now on the various mailing lists,
I also dumped a debian-styleish patchset at
ftp://ftp.linux-mips.org/pub/linux/mips/people/ths/mips-prelinker-patches-debian/

Thiemo

---

From: 김민찬 <[email-masked]>
Date: Wed, 8 Nov 2006 15:04:41 +0900

Who know anymore about prelink for mips architecture? 
Let me know prelink for mips detaily.
Thanks in advance.

-----Original Message-----
From: [email-masked] [mailto:linux-mips-bounce@linux-mips.
org] On Behalf Of Thiemo Seufer
Sent: Tuesday, November 07, 2006 11:05 PM
To: Tim Bird
Cc: CE Linux Developers List; [email-masked]
Subject: Re: MIPS processors gain GNU/Linux binary prelinker

The patches are showing up piecemeal now on the various mailing lists,
I also dumped a debian-styleish patchset at
ftp://ftp.linux-mips.org/pub/linux/mips/people/ths/mips-prelinker-patches-
debian/

Thiemo

---

From: "Fu, He Wei PSE NKG" <[email-masked]>
Date: Wed, 8 Nov 2006 16:41:42 +0800

http://people.redhat.com/jakub/prelink.pdf
I don’t know whether is it useful? 

-----Original Message-----

Thiemo

---

From: Tim Bird <[email-masked]>
Date: Wed, 08 Nov 2006 09:18:31 -0800

> Let me know prelink for mips detaily.

There's a white paper available.  See the linuxdevices article
for a link to it:

--