Subject: process created when pthread_create is used ??????????

From: "chandrashekar mogilicherla" <[email-masked]>
Date: Tue, 14 Nov 2006 16:58:46 +0530

Iam using fedora core 2.6.11 kernel on mips machine ,

"process is getting created when i try to create thread using pthread
library."

Can anybody explain what is happening  out  there

Thanking you in advance,
Chandra shekar

---

From: Ralf Baechle <[email-masked]>
Date: Tue, 14 Nov 2006 12:55:14 +0000

> Iam using fedora core 2.6.11 kernel on mips machine ,

Interesting, I wonder where you got that Fedora port from?

> Can anybody explain what is happening  out  there

On a kernel level thread and process are almost identical things which is
why they look the same in ps output.  The fine differences are more
special properties such as a having a private address space.

  Ralf