Subject: Add -mfix7000 to CONFIG_SGI_IP22

From: Martin Michlmayr <[email-masked]>
Date: Sun, 19 Nov 2006 14:58:43 +0000

What was the rationale to add that to CONFIG_SGI_IP22?  Shouldn't it
be added to CONFIG_SGI_IP32, i.e. O2?

From: Thiemo Seufer <[email-masked]>

Add -mfix7000 to CONFIG_SGI_IP22

Signed-off-by: Thiemo Seufer <[email-masked]>
Signed-off-by: Martin Michlmayr <[email-masked]>

--- a/arch/mips/Makefile
+++ b/arch/mips/Makefile
@@ -478,7 +478,7 @@ load-$(CONFIG_PNX8550_JBS)	+= 0xffffffff
 # address by 8kb.
 #
 core-$(CONFIG_SGI_IP22)		+= arch/mips/sgi-ip22/
-cflags-$(CONFIG_SGI_IP22)	+= -Iinclude/asm-mips/mach-ip22
+cflags-$(CONFIG_SGI_IP22)	+= -Iinclude/asm-mips/mach-ip22 -Wa,-mfix7000
 ifdef CONFIG_32BIT
 load-$(CONFIG_SGI_IP22)		+= 0xffffffff88002000
 endif

-- 
Martin Michlmayr
http://www.cyrius.com/

---

From: Ralf Baechle <[email-masked]>
Date: Sun, 19 Nov 2006 17:34:13 +0100

> be added to CONFIG_SGI_IP32, i.e. O2?

Indeed.

And a workaround for what CPU bug is that supposed to be anyway?  My errata
don't document anything that looks like what -mfix7000 claims to fix.

  Ralf

---

From: Ralf Baechle <[email-masked]>
Date: Sun, 19 Nov 2006 22:14:09 +0100

Thanks to gcc doing scheduling itself this patch has actually become a
dysfunctional placebo -> /dev/null.

  Ralf