Subject: [PATCH][MIPS] Enable SSB_DRIVER_EXTIF on BCM47XX platform

From: Aurelien Jarno <[email-masked]>
Date: Mon, 10 Dec 2007 11:22:32 +0100

Hi,

arch/mips/bcm47xx/gpio.c uses ssb_extif_* functions. The patch below 
makes sure those functions are available on the BCM47XX platform.

Aurelien

Signed-off-by: Aurelien Jarno <[email-masked]>

diff --git a/arch/mips/Kconfig b/arch/mips/Kconfig
index c6fc405..e46b076 100644
--- a/arch/mips/Kconfig
+++ b/arch/mips/Kconfig
@@ -59,6 +59,7 @@ config BCM47XX
 	select SYS_SUPPORTS_LITTLE_ENDIAN
 	select SSB
 	select SSB_DRIVER_MIPS
+	select SSB_DRIVER_EXTIF
 	select GENERIC_GPIO
 	select SYS_HAS_EARLY_PRINTK
 	select CFE

-- 
  .''`.  Aurelien Jarno	            | GPG: 1024D/F1BCDB73
 : :' :  Debian developer           | Electrical Engineer
 `. `'   [email-masked]         | [email-masked]
   `-    people.debian.org/~aurel32 | www.aurel32.net

---

From: Aurelien Jarno <[email-masked]>
Date: Tue, 11 Dec 2007 11:30:34 +0100

Hi,

The patch below fixes two problems for Kconfig on the BCM47xx platform:
- arch/mips/bcm47xx/gpio.c uses ssb_extif_* functions. Selecting 
  SSB_DRIVER_EXTIF makes sure those functions are available.
- arch/mips/pci/pci.c needs, when enabled, platform specific functions,
  which are defined when SSB_PCICORE_HOSTMODE is enabled.

This patch replaces the one called "Enable SSB_DRIVER_EXTIF on BCM47XX
platform" posted yesterday.

Aurelien

diff --git a/arch/mips/Kconfig b/arch/mips/Kconfig
index c6fc405..b4ffcae 100644
--- a/arch/mips/Kconfig
+++ b/arch/mips/Kconfig
@@ -59,6 +59,8 @@ config BCM47XX
 	select SYS_SUPPORTS_LITTLE_ENDIAN
 	select SSB
 	select SSB_DRIVER_MIPS
+	select SSB_DRIVER_EXTIF
+	select SSB_PCICORE_HOSTMODE if PCI
 	select GENERIC_GPIO
 	select SYS_HAS_EARLY_PRINTK
 	select CFE