Subject: [PATCH][2/2][MIPS] remove unused lasat definitions

From: Yoichi Yuasa <[email-masked]>
Date: Sun, 16 Dec 2007 22:54:26 +0900

Removed unused lasat definitions.

Signed-off-by: Yoichi Yuasa <[email-masked]>

diff -pruN -X mips/Documentation/dontdiff mips-orig/include/asm-mips/lasat/lasat.h mips/include/asm-mips/lasat/lasat.h
--- mips-orig/include/asm-mips/lasat/lasat.h	2007-12-11 23:12:53.674363750 +0900
+++ mips/include/asm-mips/lasat/lasat.h	2007-12-12 00:14:56.073369250 +0900
@@ -245,9 +245,6 @@ static inline void lasat_ndelay(unsigned
 #define LASAT_SERVICEMODE_MAGIC_1     0xdeadbeef
 #define LASAT_SERVICEMODE_MAGIC_2     0xfedeabba
 
-/* Lasat 100 boards */
-#define LASAT_GT_BASE           (KSEG1ADDR(0x14000000))
-
 /* Lasat 200 boards */
 #define Vrc5074_PHYS_BASE       0x1fa00000
 #define Vrc5074_BASE            (KSEG1ADDR(Vrc5074_PHYS_BASE))
diff -pruN -X mips/Documentation/dontdiff mips-orig/include/asm-mips/mach-lasat/mach-gt64120.h mips/include/asm-mips/mach-lasat/mach-gt64120.h
--- mips-orig/include/asm-mips/mach-lasat/mach-gt64120.h	2007-12-11 23:12:54.162394250 +0900
+++ mips/include/asm-mips/mach-lasat/mach-gt64120.h	2007-12-12 00:13:39.216566000 +0900
@@ -11,17 +11,6 @@
 /*
  *   GT64120 config space base address on Lasat 100
  */
-#define GT64120_BASE	(KSEG1ADDR(0x14000000))
-
-/*
- *   PCI Bus allocation
- *
- *   (Guessing ...)
- */
-#define GT_PCI_MEM_BASE	0x12000000UL
-#define GT_PCI_MEM_SIZE	0x02000000UL
-#define GT_PCI_IO_BASE	0x10000000UL
-#define GT_PCI_IO_SIZE	0x02000000UL
-#define GT_ISA_IO_BASE	PCI_IO_BASE
+#define GT64120_BASE	KSEG1ADDR(GT_DEF_BASE)
 
 #endif /* _ASM_GT64120_LASAT_GT64120_DEP_H */

---

From: Yoichi Yuasa <[email-masked]>
Date: Sun, 16 Dec 2007 22:53:00 +0900

Removed unused struct bootloader_header.

diff -pruN -X mips/Documentation/dontdiff mips-orig/arch/mips/lasat/image/head.S mips/arch/mips/lasat/image/head.S
--- mips-orig/arch/mips/lasat/image/head.S	2007-11-05 08:41:37.923119250 +0900
+++ mips/arch/mips/lasat/image/head.S	2007-11-05 08:31:39.865743000 +0900
@@ -1,4 +1,5 @@
-#include <asm/lasat/head.h>
+#define LASAT_K_MAGIC0_VAL	0xfedeabba
+#define LASAT_K_MAGIC1_VAL	0xbedead
 
 	.text
 	.section .text.start, "ax"
@@ -21,7 +22,6 @@
 	.word	_kernel_entry
 
 	/* Here we have room for future flags */
-
 	.org	0x40
 reldate:
 	.word	TIMESTAMP
diff -pruN -X mips/Documentation/dontdiff mips-orig/include/asm-mips/lasat/head.h mips/include/asm-mips/lasat/head.h
--- mips-orig/include/asm-mips/lasat/head.h	2007-11-05 08:41:37.991123500 +0900
+++ mips/include/asm-mips/lasat/head.h	1970-01-01 09:00:00.000000000 +0900
@@ -1,22 +0,0 @@
-/*
- * Image header stuff
- */
-#ifndef _HEAD_H
-#define _HEAD_H
-
-#define LASAT_K_MAGIC0_VAL	0xfedeabba
-#define LASAT_K_MAGIC1_VAL	0x00bedead
-
-#ifndef _LANGUAGE_ASSEMBLY
-#include <linux/types.h>
-struct bootloader_header {
-	u32 magic[2];
-	u32 version;
-	u32 image_start;
-	u32 image_size;
-	u32 kernel_start;
-	u32 kernel_entry;
-};
-#endif
-
-#endif /* _HEAD_H */