Subject: question about oprofile support

From: "Anirban Sinha" <[email-masked]>
Date: Wed, 26 Dec 2007 18:28:58 -0800

Hi:

Linux-mips.org states: (http://www.linux-mips.org/wiki/Oprofile) 

"Oprofile support is available at the time of this writing only in the
Sourceforge Oprofile CVS repository; released versions are either
lacking support for MIPS or are unusable due to bugs"

I am wondering if this is still true. If we want to have oprofile
support on mips hardware, do we have to checkout the HEAD revision from
oprofile cvs repository or is it already available from the standard
0.9.3 release? 

Thanks in advance to anyone who can throw any lights on this.

Cheers,

Ani

---

From: "Anirban Sinha" <[email-masked]>
Date: Wed, 26 Dec 2007 21:44:41 -0800

If I am not too wrong, I think this is what the picture is like as far as the mips support for oprfile goes:

Oprofile 0.9.2 release version supports mips architecture partially. Their release notes says:

"Support for MIPS 5K, 20K, 25K, and 34K added."

However, support for R10000, R12000, R12000, RM7000, RM9000, SB1 / SB1A, VR5432, VR5500 processors are only available through the CVS checkout:

"The R10000, R12000, R12000, RM7000, RM9000, SB1 / SB1A, VR5432, VR5500 processors are supported by the CVS version of the userspace tools; support for further is in the queue."

If I am wrong in understanding this, please correct me.

Cheers,

Ani

From: [email-masked] [mailto:[email-masked]] On Behalf Of Anirban Sinha
Sent: Wednesday, December 26, 2007 6:29 PM
To: [email-masked]
Subject: question about oprofile support 

Hi:

"Oprofile support is available at the time of this writing only in the Sourceforge Oprofile CVS repository; released versions are either lacking support for MIPS or are unusable due to bugs"

I am wondering if this is still true. If we want to have oprofile support on mips hardware, do we have to checkout the HEAD revision from oprofile cvs repository or is it already available from the standard 0.9.3 release? 

Cheers,

Ani