Subject: [PATCH 1/4] Introduced GPI_RM9000 configuration parameter

From: Thomas Koeller <[email-masked]>
Date: Tue, 18 Dec 2007 01:26:19 +0100

Signed-off-by: Thomas Koeller <[email-masked]>

diff --git a/arch/mips/Kconfig b/arch/mips/Kconfig
index c6fc405..62bc553 100644
--- a/arch/mips/Kconfig
+++ b/arch/mips/Kconfig
@@ -856,6 +856,9 @@ config GENERIC_ISA_DMA_SUPPORT_BROKEN
 config GENERIC_GPIO
 	bool
 
+config GPI_RM9000
+       bool
+
 #
 # Endianess selection.  Sufficiently obscure so many users don't know what to
 # answer,so we try hard to limit the available choices.  Also the use of a
@@ -927,6 +930,7 @@ config MIPS_TX3927
 config MIPS_RM9122
 	bool
 	select SERIAL_RM9000
+	select GPI_RM9000
 
 config PNX8550
 	bool
-- 
1.5.3.6

---

From: Ralf Baechle <[email-masked]>
Date: Tue, 18 Dec 2007 11:52:54 +0100

> @@ -927,6 +930,7 @@ config MIPS_TX3927

See my earlier reply to http://www.linux-mips.org/cgi-bin/mesg.cgi?a=linux-mips&i=20070911122005.GC24679%40linux-mips.org

Technically the patch is ok but please only introduce new config symbols
only together with an actual user.

  Ralf