Subject: [PATCH][MIPS] remove mips_timer_state()

From: Yoichi Yuasa <[email-masked]>
Date: Sun, 9 Dec 2007 21:19:36 +0900

Remove mips_timer_state().
It is not used at all.

Signed-off-by: Yoichi Yuasa <[email-masked]>

diff -pruN -X mips/Documentation/dontdiff mips-orig/arch/mips/dec/time.c mips/arch/mips/dec/time.c
--- mips-orig/arch/mips/dec/time.c	2007-12-06 18:27:03.461092000 +0900
+++ mips/arch/mips/dec/time.c	2007-12-09 20:55:08.231255000 +0900
@@ -161,7 +161,6 @@ static cycle_t dec_ioasic_hpt_read(void)
 
 void __init plat_time_init(void)
 {
-	mips_timer_state = dec_timer_state;
 	mips_timer_ack = dec_timer_ack;
 
 	if (!cpu_has_counter && IOASIC)
diff -pruN -X mips/Documentation/dontdiff mips-orig/arch/mips/kernel/time.c mips/arch/mips/kernel/time.c
--- mips-orig/arch/mips/kernel/time.c	2007-12-06 18:27:04.629165000 +0900
+++ mips/arch/mips/kernel/time.c	2007-12-09 20:52:04.111748250 +0900
@@ -50,8 +50,6 @@ int update_persistent_clock(struct times
 	return rtc_mips_set_mmss(now.tv_sec);
 }
 
-int (*mips_timer_state)(void);
-
 int null_perf_irq(void)
 {
 	return 0;
diff -pruN -X mips/Documentation/dontdiff mips-orig/include/asm-mips/time.h mips/include/asm-mips/time.h
--- mips-orig/include/asm-mips/time.h	2007-12-06 18:30:02.548284250 +0900
+++ mips/include/asm-mips/time.h	2007-12-09 20:54:28.116748000 +0900
@@ -31,20 +31,13 @@ extern int rtc_mips_set_time(unsigned lo
 extern int rtc_mips_set_mmss(unsigned long);
 
 /*
- * Timer interrupt functions.
- * mips_timer_state is needed for high precision timer calibration.
- */
-extern int (*mips_timer_state)(void);
-
-/*
  * board specific routines required by time_init().
  */
 extern void plat_time_init(void);
 
 /*
  * mips_hpt_frequency - must be set if you intend to use an R4k-compatible
- * counter as a timer interrupt source; otherwise it can be set up
- * automagically with an aid of mips_timer_state.
+ * counter as a timer interrupt source.
  */
 extern unsigned int mips_hpt_frequency;

---

From: Ralf Baechle <[email-masked]>
Date: Sun, 9 Dec 2007 19:10:15 +0000

> Signed-off-by: Yoichi Yuasa <[email-masked]>

Queued for 2.6.25.

Thanks,

  Ralf