Subject: [PATCH][MIPS] move the eXcite local config to excitedirectory

From: Yoichi Yuasa <[email-masked]>
Date: Wed, 12 Dec 2007 22:39:54 +0900

Moved the eXcite local config to excite directory.

Signed-off-by: Yoichi Yuasa <[email-masked]>

diff -pruN -X mips/Documentation/dontdiff mips-orig/arch/mips/Kconfig mips/arch/mips/Kconfig
--- mips-orig/arch/mips/Kconfig	2007-12-12 00:06:19.245069500 +0900
+++ mips/arch/mips/Kconfig	2007-12-12 00:09:53.974489250 +0900
@@ -37,16 +37,6 @@ config BASLER_EXCITE
 	  The eXcite is a smart camera platform manufactured by
 	  Basler Vision Technologies AG.
 
-config BASLER_EXCITE_PROTOTYPE
-	bool "Support for pre-release units"
-	depends on BASLER_EXCITE
-	default n
-	help
-	  Pre-series (prototype) units are different from later ones in
-	  some ways. Select this option if you have one of these. Please
-	  note that a kernel built with this option selected will not be
-	  able to run on normal units.
-
 config BCM47XX
 	bool "BCM47XX based boards"
 	select CEVT_R4K
@@ -688,6 +678,7 @@ config WR_PPMC
 endchoice
 
 source "arch/mips/au1000/Kconfig"
+source "arch/mips/basler/excite/Kconfig"
 source "arch/mips/jazz/Kconfig"
 source "arch/mips/lasat/Kconfig"
 source "arch/mips/pmc-sierra/Kconfig"
diff -pruN -X mips/Documentation/dontdiff mips-orig/arch/mips/basler/excite/Kconfig mips/arch/mips/basler/excite/Kconfig
--- mips-orig/arch/mips/basler/excite/Kconfig	1970-01-01 09:00:00.000000000 +0900
+++ mips/arch/mips/basler/excite/Kconfig	2007-12-12 00:09:53.974489250 +0900
@@ -0,0 +1,9 @@
+config BASLER_EXCITE_PROTOTYPE
+	bool "Support for pre-release units"
+	depends on BASLER_EXCITE
+	default n
+	help
+	  Pre-series (prototype) units are different from later ones in
+	  some ways. Select this option if you have one of these. Please
+	  note that a kernel built with this option selected will not be
+	  able to run on normal units.

---

From: Ralf Baechle <[email-masked]>
Date: Fri, 14 Dec 2007 01:07:58 +0000

> Moved the eXcite local config to excite directory.

Queued for 2.6.25 - though a file for a single statement doesn't make
verribly much sense.

Thanks,

  Ralf.