Subject: [PATCH] Alchemy: Fix Au1x SD controller IRQ

From: Manuel Lauss <[email-masked]>
Date: Thu, 6 Dec 2007 08:11:56 +0100

With the introduction of MIPS_CPU_IRQ_BASE, the hardcoded IRQ number
of the au1100/au1200 SD controller(s) is no longer valid.

Signed-off-by: Manuel Lauss <[email-masked]>

--- linux-2.6.24-rc4/include/asm-mips/mach-au1x00/au1100_mmc.h	2007-12-04 08:31:24.613002000 +0100
+++ linux-2.6.24-rc4-work/include/asm-mips/mach-au1x00/au1100_mmc.h	2007-12-06 15:33:35.000000000 +0100
@@ -41,8 +41,11 @@
 
 #define NUM_AU1100_MMC_CONTROLLERS	2
 
-
-#define AU1100_SD_IRQ	2
+#if defined(CONFIG_SOC_AU1100)
+#define AU1100_SD_IRQ	AU1100_SD_INT
+#elif defined(CONFIG_SOC_AU1200)
+#define AU1100_SD_IRQ	AU1200_SD_INT
+#endif

 #define SD0_BASE	0xB0600000

---

From: Ralf Baechle <[email-masked]>
Date: Fri, 7 Dec 2007 01:55:20 +0000

> Signed-off-by: Manuel Lauss <[email-masked]>

Thanks, applied.

  Ralf