Subject: Fill rectangle is not filling the screen with the COLOR(ALways filling the screen with Black color)

From: kaka <[email-masked]>
Date: Thu, 20 Dec 2007 23:41:42 +0530

>
> Hi Denis,
>
> I am writing gfx driver for DirectFB on BroadCom chip.
> Right now i am using FBdev system to display graphics on BCM chip(MIPS
> platform)  which should use software fallbacks from DirectFB.Later on i
> 'll add hardware accelerartion also.
> My framebuffer driver for BCM chip is working fine. I have checked it by
> running a small example. Also the gfxdriver for directFB is working fine for
> Video and Image.
> The problem which i am facing right now is that i am running the fill
> rectangle example.
> IT is not filling any color in the rectangle. I am always getting the
> black screen.
>
> Could you plz provide some clue on it ?
> Also could you plz specify the file name and function in which directFB
> library is writing into the framebuffer memory the color pixel information?
>
> Thanks in Advance.
> kaka
>
>
>
> On 12/17/07, Denis Oliver Kropp <[email-masked]> wrote:
> >
> > kaka wrote:
> > > HI ALL,
> > >
> > > We have successfully cross compiled GTK and DIRECTFB with all its
> > > dependencies for MIPS board.
> > > On running the basic test example of GTK, it is getting struck in the
> > thread
> > > loop infinitely.
> > > We had put the  "debug printf"  statement in the gtkmain.c and
> > debugged the
> > > test example.
> > > It is getting struck in the * g_main_loop_run (loop);* given below is
> > > the  code(code
> > > snippet from gtkmain.c)
> > >
> > > void
> > > gtk_main (void)
> > > {
> > >   GList *tmp_list;
> > >   GList *functions;
> > >   GtkInitFunction *init;
> > >   GMainLoop *loop;
> > > printf("\n%s :: %d\n",__FILE__,__LINE__);
> > >   gtk_main_loop_level++;
> > >
> > >   loop = g_main_loop_new (NULL, TRUE);
> > >   main_loops = g_slist_prepend (main_loops, loop);
> > > printf("\n%s :: %d\n",__FILE__,__LINE__);
> > >   tmp_list = functions = init_functions;
> > >   init_functions = NULL;
> > >
> > >   while (tmp_list)
> > >     {
> > >       init = tmp_list->data;
> > >       tmp_list = tmp_list->next;
> > >
> > >       (* init->function) (init->data);
> > >       g_free (init);
> > >     }
> > >   g_list_free (functions);
> > > printf("\n%s :: %d\n",__FILE__,__LINE__);
> > >   if (g_main_loop_is_running (main_loops->data))
> > >     {
> > >    * printf("\n%s :: %d\n",__FILE__,__LINE__);
> > >       GDK_THREADS_LEAVE ();
> > >       g_main_loop_run (loop);
> > >       GDK_THREADS_ENTER ();
> > > *      printf("\n%s :: %d\n",__FILE__,__LINE__);
> >
> > That's normal. If you want runtime you have to create a timer or
> > register idle or timeout functions.
> >
> > >       gtk_container_add (GTK_CONTAINER (window), pMainWidget);
> > >  printf("\n\n\ngtk_container_add (GTK_CONTAINER (window),
> > > pMainWidget);\n\n\n") ;
> > >       gtk_widget_show (window);
> > > printf("\n\n\nABHISHEK START OF gtk_main\n\n\n");
> > >       gtk_main ();
> > > printf("\n\n\nABHISHEK END OF gtk_main\n\n\n");
> > >       return 0;
> >
> > Simply/weakly put: it should not return before the application is quit.
> >
> > --
> > Best regards,
> > Denis Oliver Kropp
> >
> > .------------------------------------------.
> > | DirectFB - Hardware accelerated graphics |
> > | http://www.directfb.org/                 |
> > "------------------------------------------"
> >
>
>
>
> --
> Thanks & Regards,
> kaka

-- 
Thanks & Regards,
kaka

---

From: "Asho Yeh" <[email-masked]>
Date: Sun, 30 Dec 2007 15:00:29 +0800

Hi If your fillrectangle is software only, maybe the the drawing and
bliiting function in generic.c can help.

I remembered the drawing function will set the color in the
gAcquire(). How about give it a try to see the color is really set in
the function.

2007/12/21, kaka <[email-masked]>:
> platform)  which should use software fallbacks from DirectFB.Later on i 'll
> add hardware accelerartion also.
> > On 12/17/07, Denis Oliver Kropp < [email-masked]> wrote:
> >
> > > kaka wrote:
> > > > HI ALL,
> > > >
> _______________________________________________
> directfb-users mailing list
> [email-masked]
> http://mail.directfb.org/cgi-bin/mailman/listinfo/directfb-users
>
>