Subject: [MIPS] MEM_SDREFCFG is not defined for Alchemy DB1550 (compile fail)

From: "Alon Bar-Lev" <[email-masked]>
Date: Sun, 23 Dec 2007 17:33:58 +0200

Hello,

When I have:
CONFIG_MIPS_DB1550
CONFIG_SOC_AU1550
CONFIG_SOC_AU1X00
CONFIG_PM

MEM_SDREFCFG is used at:
arch/mips/au1000/common/power.c::pm_do_freq()

While the MEM_SDREFCFG constant is declare only for CONFIG_SOC_AU1000,
CONFIG_SOC_AU1500, CONFIG_SOC_AU1100 at:
include/asm-mips/mach-au1x00/au1000.h

Maybe MEM_SDREFCFG should be defined for CONFIG_SOC_AU1X00?
Or there should be #ifdef for its usage in power.c?

Best Regards,
Alon Bar-Lev.

---

From: "Alon Bar-Lev" <[email-masked]>
Date: Sun, 23 Dec 2007 20:22:13 +0200

Hello,

Forgot to write that I checked mips & linus gits, and the problem still exists.

Best Regards,
Alon Bar-Lev.

---

From: Sergei Shtylyov <[email-masked]>
Date: Tue, 25 Dec 2007 13:41:21 +0300

Hello.

> arch/mips/au1000/common/power.c::pm_do_freq()

    PM code is generally broken and unmaintained, so no wonder. I don't 
remember if anyone has fixed CPU context restoration code (it uses a "skewed" 
stack frame).

> Maybe MEM_SDREFCFG should be defined for CONFIG_SOC_AU1X00?

    I've just looked into the Au1550 datasheet and indeed it doesn't have such 
register; its SDDRAM controller is not compatible with older SoCs.

> Or there should be #ifdef for its usage in power.c?

    Looks like you'll have to invent something... ;-)

> Alon Bar-Lev.

WBR, Sergei

---

From: Ralf Baechle <[email-masked]>
Date: Tue, 25 Dec 2007 15:32:41 +0100

On Tue, Dec 25, 2007 at 01:41:21PM +0300, Sergei Shtylyov wrote:

> remember if anyone has fixed CPU context restoration code (it uses a 
> "skewed" stack frame).
>
>    I've just looked into the Au1550 datasheet and indeed it doesn't have 
> such register; its SDDRAM controller is not compatible with older SoCs.
>

So I guess it's time to mark the whole PM stuff as BROKEN?

  Ralf

---

From: "Alon Bar-Lev" <[email-masked]>
Date: Tue, 25 Dec 2007 19:04:14 +0200

Thank you for your reply!

> remember if anyone has fixed CPU context restoration code (it uses a "skewed"

So suspend modes on these boards are not supported?
Only "Always On" configuration is supported?
Or there is another method to preserve power?

Best Regards,
Alon Bar-Lev.

---

From: Sergei Shtylyov <[email-masked]>
Date: Tue, 25 Dec 2007 20:18:50 +0300

> Only "Always On" configuration is supported?

    Sleep mode is supported according to the code. But as I've said PM bits 
haven't been maintained -- probably since the submission.

WBR, Sergei

---

From: "Alon Bar-Lev" <[email-masked]>
Date: Tue, 25 Dec 2007 19:35:38 +0200

> haven't been maintained -- probably since the submission.

Thanks!
Will it be maintained? Are there any plans?
Is there, a missing features list (TODO)?
Or this is completely unsupported board?

Best Regards,
Alon Bar-Lev.