Subject: Rename Sibyte duart devices?

From: Ralf Baechle <[email-masked]>
Date: Mon, 3 Dec 2007 13:05:13 +0000

Devices created by udev have been named duart? instead of the common
ttyS?.  This is a nuisance because it requires changes to all sorts of
config files such as /etc/inittab, /etc/securetty etc. to work.  I
suggest to kill the problem by the root by something like the below
patch.  Comments?

  Ralf

Signed-off-by: Ralf Baechle <[email-masked]>

 drivers/serial/sb1250-duart.c |    4 ++--
 1 files changed, 2 insertions(+), 2 deletions(-)

diff --git a/drivers/serial/sb1250-duart.c b/drivers/serial/sb1250-duart.c
index 2d6c08b..0defbd6 100644
--- a/drivers/serial/sb1250-duart.c
+++ b/drivers/serial/sb1250-duart.c
@@ -897,7 +897,7 @@ static int __init sbd_console_setup(struct console *co, char *options)
 
 static struct uart_driver sbd_reg;
 static struct console sbd_console = {
-	.name	= "duart",
+	.name	= "ttyS",
 	.write	= sbd_console_write,
 	.device	= uart_console_device,
 	.setup	= sbd_console_setup,
@@ -925,7 +925,7 @@ console_initcall(sbd_serial_console_init);
 static struct uart_driver sbd_reg = {
 	.owner		= THIS_MODULE,
 	.driver_name	= "serial",
-	.dev_name	= "duart",
+	.dev_name	= "ttyS",
 	.major		= TTY_MAJOR,
 	.minor		= SB1250_DUART_MINOR_BASE,
 	.nr		= DUART_MAX_CHIP * DUART_MAX_SIDE,

---

From: "Maciej W. Rozycki" <[email-masked]>
Date: Mon, 3 Dec 2007 14:18:35 +0000 (GMT)

> suggest to kill the problem by the root by something like the below

 Well, there is no problem with naming your device nodes in the filesystem 
however you like and the only place that only cares is the "console=" 
command line option.  I think the root is ttyS devices should really be 
only used for 8250-based devices and if you plug a standard PC serial 
option card into one of the PCI slots, then all the hell will break loose.  
I might be wrong though and the issue I am referring to may have gone now.

  Maciej