Subject: Extraneous line in interrupt.h in 2.6.16.60 kernel?

From: Larry Stefani <[email-masked]>
Date: Fri, 21 Mar 2008 09:00:52 -0700 (PDT)

Hi,

Back in 2.6.16.29, there were a lot changes made to
support MT_SMTC.  Among them were changes to the
include/asm-mips/interrupt.h:

__asm__ (
  " .macro  local_irq_enable        \n"
  " .set  push            \n"
  " .set  reorder           \n"
  " .set  noat            \n"
#ifdef CONFIG_CPU_MIPSR2
  " .set  mips32r2          \n"
#ifdef CONFIG_MIPS_MT_SMTC
  "mfc0 $1, $2, 1 # SMTC - clear TCStatus.IXMT    \n"
  "ori  $1, 0x400           \n"
  "xori $1, 0x400           \n"
  "mtc0 $1, $2, 1           \n"
#else
  " .set  mips32r2          \n"
  " ei              \n"
  " .set  mips0           \n"
#endif
#else
  " mfc0  $1,$12            \n"
  " ori $1,0x1f           \n"
  " xori  $1,0x1e           \n"
  " mtc0  $1,$12            \n"
#endif
  " irq_enable_hazard         \n"
  " .set  pop           \n"
  " .endm");

Am I missing something, or is the second ".set 
mips32r2  \n" (line 51) redundant?

Thanks,
Larry Stefani
[email-masked]

      ____________________________________________________________________________________
Be a better friend, newshound, and 
know-it-all with Yahoo! Mobile.  Try it now.  http://mobile.yahoo.com/;_ylt=Ahu06i62sR8HDtDypao8Wcj9tAcJ

---

From: "Maciej W. Rozycki" <[email-masked]>
Date: Fri, 21 Mar 2008 21:14:42 +0000 (GMT)

Hi Larry,

> mips32r2  \n" (line 51) redundant?

 You are not missing anything, but it is harmless and the piece of code is 
gone in the current version.  Welcome to the world of MIPS, BTW. :-)

  Maciej