Subject: [PATCH] Add missing 4KEC TLB refill handler

From: Thomas Bogendoerfer <[email-masked]>
Date: Wed, 26 Mar 2008 16:42:54 +0100 (CET)

Early 4KEc were MIPS32r1 and therefore need some love to get a TLB 
refill handler.

Signed-off-by: Thomas Bogendoerfer <[email-masked]>
---

 arch/mips/mm/tlbex.c |    1 +
 1 files changed, 1 insertions(+), 0 deletions(-)

diff --git a/arch/mips/mm/tlbex.c b/arch/mips/mm/tlbex.c
index 3a93d4c..382738c 100644
--- a/arch/mips/mm/tlbex.c
+++ b/arch/mips/mm/tlbex.c
@@ -307,6 +307,7 @@ static void __cpuinit build_tlb_write_entry(u32 **p, struct uasm_label **l,
 	case CPU_R12000:
 	case CPU_R14000:
 	case CPU_4KC:
+	case CPU_4KEC:
 	case CPU_SB1:
 	case CPU_SB1A:
 	case CPU_4KSC:

---

From: Ralf Baechle <[email-masked]>
Date: Thu, 27 Mar 2008 11:10:19 +0000

> Early 4KEc were MIPS32r1 and therefore need some love to get a TLB 

Good catch.  Thanks!

  Ralf