Subject: Re: drivers/net/wireless/b43legacy/ on mips

From: Ralf Baechle <[email-masked]>
Date: Tue, 4 Mar 2008 09:02:20 +0000

On Mon, Mar 03, 2008 at 11:36:51PM -0800, Andrew Morton wrote:

> ERROR: "__ucmpdi2" [drivers/net/wireless/b43legacy/b43legacy.ko] undefined!
> ERROR: "__ucmpdi2" [drivers/net/wireless/b43/b43.ko] undefined!
> 
> int b43legacy_dma_init(struct b43legacy_wldev *dev)
> {
>         struct b43legacy_dma *dma = &dev->dma;
>         struct b43legacy_dmaring *ring;
>         int err;
>         u64 dmamask;
>         enum b43legacy_dmatype type;
> 
>         dmamask = supported_dma_mask(dev);
>         switch (dmamask) {
>         default:
>                 B43legacy_WARN_ON(1);
>         case DMA_30BIT_MASK:
>                 type = B43legacy_DMA_30BIT;
>                 break;
>         case DMA_32BIT_MASK:
>                 type = B43legacy_DMA_32BIT;
>                 break;
>         case DMA_64BIT_MASK:
>                 type = B43legacy_DMA_64BIT;
>                 break;
>         }
> 
> because some versions of gcc emit a __ucmpdi2 call for switch statements. 

Was this when optimizing for size btw?  It seems gcc is emitting alot more
calls to libgcc when optimizing for size.

> It might be fixable by switching to an open-coded if/compare/else sequence.

It was just a EXPORT_SYMBOL(__ucmpdi2) missing.

> Or maybe my mips compiler (gcc-3.4.5) is just too old..

I'm trying to keep the tools requirements the same as for x86.  So for
32-bit kernels gcc 3.2 is the minimum but 3.2 is broken beyond recovery
for 64-bit code so there a minimum of 3.3 is required.

In practive it is ages that I've last seen a compiler older than gcc 3.4
being used to build a modern kernel for any architecture and 3.2 and 3.3
are a sufficient special case that maybe we should think about deprecating
3.2 and 3.3?

  Ralf

---

From: Andrew Morton <[email-masked]>
Date: Tue, 4 Mar 2008 01:19:05 -0800

On Tue, 4 Mar 2008 09:02:20 +0000 Ralf Baechle <[email-masked]> wrote:

> Was this when optimizing for size btw?

mips allmodconfig.  So: yes.

>  It seems gcc is emitting alot more

doh.

> are a sufficient special case that maybe we should think about deprecating

That would make life easier for us.  I don't know what the downstream
implications would be.  I'd need a new cross-compiler, for a start ;)