Subject: RE: [PATCH][MIPS][5/6]: AR7: serial hack

From: "Nico Coesel" <[email-masked]>
Date: Tue, 18 Mar 2008 16:40:23 +0100

Hello all,
I didn't follow the entire discussion, but I might have similar problems
on the AU1100 SoC. The AU1100 also has 16550 style serial ports. The
serial console doesn't work even though I specify console=/dev/ttyS0 on
the kernel command line. Once a getty is started, the serial port is
active and working fine.

Nico

> -----Oorspronkelijk bericht-----
> Van: [email-masked] 
> [mailto:[email-masked]] Namens Alan Cox
> Verzonden: dinsdag 18 maart 2008 15:02
> Aan: Thomas Bogendoerfer
> CC: Matteo Croce; [email-masked]; Florian 
> Fainelli; Felix Fietkau; Nicolas Thill; 
> [email-masked]; Andrew Morton
> Onderwerp: Re: [PATCH][MIPS][5/6]: AR7: serial hack
> 
> > Is there a good reason, why we don't check for BOTH_EMPTY in
> > serial8250_console_putchar() ? To match the 2.6.10 behaviour we
> 
> A very good one - we have at least 1 byte of FIFO and the 
> serial-ethernet magic console devices also use that fifo 
> emptying entirely to deduce when to send a new packet.
> 
> > would need that and this would fix the AR7 case without any special 
> > handling.
> 
> If the AR7 is an 8250 why does it need special handling? and 
> indeed why does serial work on it except for console - or 
> does that fail too.
> 
>

---

From: Sergei Shtylyov <[email-masked]>
Date: Tue, 18 Mar 2008 19:43:39 +0300

Hello.

> the kernel command line. Once a getty is started, the serial port is

    This is not at all related to the discussed issue, so I've changed the 
subject. The console works like charm (seemingly for everybody, which kernel 
version are you using?

> Nico

WBR, Sergei