Subject: RE: Serial console on Au1100

From: "Nico Coesel" <[email-masked]>
Date: Wed, 19 Mar 2008 10:34:40 +0100

Sergei,
I'm using kernel 2.6.24 now (before I used 2.6.21-rc4). I do see the
console messages on the framebuffer device.

Kernel options:
console=ttyS0 root=/dev/mtdblock0 rootfstype=jffs2 rw
video=au1100fb:panel:KERN_AU1100 tsdev.xres=320 tsdev.yres=234
console=tty0

If I omit console=tty0, then there is no output on the framebuffer
device or the serial port. I also tried setting the I/O address and so
on, but no luck.

Nico Coesel

> -----Oorspronkelijk bericht-----
> Van: Sergei Shtylyov [mailto:[email-masked]] 
> Verzonden: dinsdag 18 maart 2008 17:44
> Aan: Nico Coesel
> CC: [email-masked]
> Onderwerp: Serial console on Au1100 
> 
> Hello.
> 
> Nico Coesel wrote:
> 
> > Hello all,
> > I didn't follow the entire discussion, but I might have similar 
> > problems on the AU1100 SoC. The AU1100 also has 16550 style serial 
> > ports. The serial console doesn't work even though I specify 
> > console=/dev/ttyS0 on the kernel command line. Once a getty is 
> > started, the serial port is active and working fine.
> 
>     This is not at all related to the discussed issue, so 
> I've changed the subject. The console works like charm 
> (seemingly for everybody, which kernel version are you using?
> 
> > Nico
> 
> WBR, Sergei
>

---

From: Manuel Lauss <[email-masked]>
Date: Wed, 19 Mar 2008 11:52:17 +0100

> console=ttyS0 root=/dev/mtdblock0 rootfstype=jffs2 rw

try adding a baudrate to the commandline, like so:
 console=ttyS0,115200

-- 
 Manuel Lauss

---

From: Sergei Shtylyov <[email-masked]>
Date: Fri, 21 Mar 2008 18:21:31 +0300

Hello.

> If I omit console=tty0, then there is no output on the framebuffer

    You're specifying console twice, but without a baud rate. Also, do you 
have  CONFIG_SERIAL_8250_CONSOLE enabled?

WBR, Sergei