Subject: unexpected irq 71 on ip32

From: Giuseppe Sacco <[email-masked]>
Date: Mon, 17 Mar 2008 10:41:44 +0100

Hi all,
since 2.6.24 I find this message on the console. The message is
displayed very randomly (or, I cannot find any related event), once or
twice a week.

irq 71, desc: ffffffff803fccf0, depth: 1, count: 0, unhandled: 0
->handle_irq():  ffffffff80069510, handle_bad_irq+0x0/0x2c0
->chip(): ffffffff803f6610, 0xffffffff803f6610
->action(): 0000000000000000
  IRQ_DISABLED set
   IRQ_NOPROBE set

from what I understand, this is an irq related to serial line ttyS1. On
this line I have a modem managed by hylafax, but those messages are
displayed even when there is no activity on the modem line.

Bye,
Giuseppe

---

From: [email-masked] (Thomas Bogendoerfer)
Date: Mon, 17 Mar 2008 11:01:09 +0100

> from what I understand, this is an irq related to serial line ttyS1. On

not on my O2:

serial8250.0: ttyS0 at MMIO 0x1f390000 (irq = 60) is a 16550A
console [ttyS0] enabled
serial8250.0: ttyS1 at MMIO 0x1f398000 (irq = 66) is a 16550A

Is there something listed for irq 71 in /proc/interrupts ?

Thomas.

-- 
Crap can work. Given enough thrust pigs will fly, but it's not necessary a
good idea.                                                [ RFC1925, 2.3 ]

---

From: Giuseppe Sacco <[email-masked]>
Date: Mon, 17 Mar 2008 11:07:20 +0100

Hi Thomas,

Il giorno lun, 17/03/2008 alle 11.01 +0100, Thomas Bogendoerfer ha
> > from what I understand, this is an irq related to serial line ttyS1. On

my understanding is due to:

$ grep 71 arch/mips/sgi-ip32/*irq*
arch/mips/sgi-ip32/ip32-irq.c: * 26-31 -> 66-71 Serial 2 (28 E)

> Is there something listed for irq 71 in /proc/interrupts ?

nope:
giuseppe@sgi:~$ cat /proc/interrupts 
           CPU0       
  7:    1949649            MIPS  timer
 11:     106073       IP32 MACE  SGI O2 Fast Ethernet
 15:          0       IP32 MACE  MACE PCI error
 16:     487646   IP32 MACE PCI  aic7xxx
 17:         15   IP32 MACE PCI  aic7xxx
 18:          0   IP32 MACE PCI  ohci_hcd:usb1
 21:          0   IP32 MACE PCI  ohci_hcd:usb2
 22:      62066   IP32 MACE PCI  ehci_hcd:usb3, eth100
 28:          0      IP32 CRIME  CRIME CPU error
 29:          1      IP32 CRIME  CRIME memory error
 48:          0   IP32 MACE ISA  rtc
 49:         10   IP32 MACE ISA  PS2 port
 51:        133   IP32 MACE ISA  PS2 port
 60:        133   IP32 MACE ISA  serial

ERR:          0

Bye,
Giuseppe

---

From: [email-masked] (Thomas Bogendoerfer)
Date: Mon, 17 Mar 2008 11:08:15 +0100

> from what I understand, this is an irq related to serial line ttyS1. On

I had a closer look, and it's related to ttyS1. Looks like the DMA
interface for serial (probably RX DMA overrun). I'll have a look
later, why we don't ignore this interrupt.

Thomas.