Subject: RE: FW: Alchemy power managment code.

From: "Nico Coesel" <[email-masked]>
Date: Thu, 27 Mar 2008 14:46:50 +0100

> -----Oorspronkelijk bericht-----
> Van: Sergei Shtylyov [mailto:[email-masked]] 
> Verzonden: woensdag 26 maart 2008 17:32
> Aan: Nico Coesel
> CC: [email-masked]
> Onderwerp: Re: FW: Alchemy power managment code.
> 
> Hello all.
> 
> Nico Coesel wrote:
> 
> > Ralf,
> > Funny you ask because I tried this yesterday on a AU1100 
> system with 
> > the
> > 2.6.24 kernel (from kernel.org). I'm afraid I must say the kernel 
> > crashes when I enable power management. The reason I want 
> to use power 
> > management is because I need to send the CPU to sleep when 
> the system 
> > shuts down. I hacked power.c and reset.c a bit so 
> au_sleep() is called 
> > when the system is shut down. Perhaps someone can confirm the 
> > powermanagement can be made to work with some fixes (it didn't work 
> > with
> > 2.6.21-rc4 either).
> 
>     BTW, for anybody interested in Alchemy PM code, here's 
> the interesting
> link: [ftp|http]://ftp.enneenne.com/pub/misc/au1100-patches/linux/.
>     It contains  a lot of unmerged PM patches by Rodolfo 
> Giometti (and not only that) from around 2.6.17 time.
> 

Sergei,
Is there a reason why these patches didn't make it into the official
kernel? IIRC Rodolfo has been quite active on this mailing list.

Nico Coesel

---

From: Sergei Shtylyov <[email-masked]>
Date: Thu, 27 Mar 2008 19:41:28 +0300

> kernel? IIRC Rodolfo has been quite active on this mailing list.

    Keywords are "on this mailing list" -- most of his patches were for other 
mailing lists (e.g. he did much to support PM in the peripheral drivers but 
never pushed that stuff to the respective maintainers AFAIK). He just wasn't 
consistent about the upstream submission.

> Nico Coesel

WBR, Sergei

---

From: Ralf Baechle <[email-masked]>
Date: Thu, 27 Mar 2008 22:33:54 +0000

> kernel? IIRC Rodolfo has been quite active on this mailing list.

At times it simply takes nagging me :)

  Ralf