Subject: Re: kexec on mips - anyone has it working?

From: wurststulle <[email-masked]>
Date: Sun, 22 Feb 2009 08:50:27 -0800 (PST)

is there any solution for this, i have the same problem

mangoo wrote:
> 
> Nicolas Schichan schrieb:
> 
>> +	printk("image->start = %lx", image->start);
>> +
>>  	reboot_code_buffer =
>>  	  (unsigned long)page_address(image->control_code_page);
> 
> # kexec -e
> b44: eth0: powering down PHY
> Starting new kernel
> image->start = 304000Will call new kernel at 00304000
> Bye ...
> 
> 
> 
> -- 
> Tomasz Chmielewski
> http://wpkg.org
> 
> 
> 

-- 
View this message in context: http://www.nabble.com/kexec-on-mips---anyone-has-it-working--tp17485898p22148789.html
Sent from the linux-mips main mailing list archive at Nabble.com.

---

From: Arnaud Patard <[email-masked]>
Date: Mon, 23 Feb 2009 10:30:36 +0100

wurststulle <[email-masked]> writes:

Hi,

> is there any solution for this, i have the same problem

What's your exact problem ? It hangs right after saying 'Bye...' ?
Some monthes ago, I played with the patch from M. Syrchin [ sorry, I don't
remember if it was on linux-mips or on the kexec list ]. I've made on it
a small modification (compare the machine_kexec_prepare function in my
version [1] and the original function) and it was somewhat working on
Qemu and on my box. It was not perfect but at least with a very minimal
test system, it was working. Maybe you can try it and see if it works
for you too. Depending on your platform, you may have to define machine
specific hooks too.

Regards,
Arnaud

[1] http://people.mandriva.com/~apatard/kexec_mips.patch

---

From: wurststulle <[email-masked]>
Date: Mon, 23 Feb 2009 10:42:35 -0800 (PST)

hi, thank you for the patch, but there is a mistake, that i can not fix:

+#ifdef CONFIG_CRASH_DUMP
+    if (crashk_res.start != crashk_res.end)
+        reserve_bootmem(crashk_res.start,
+                crashk_res.end - crashk_res.start + 1);
+#endif

the function reserve_bootmem need i think three arguments. while compiling
this error occurs:

arch/mips/kernel/setup.c: In function 'arch_mem_init':
arch/mips/kernel/setup.c:493: error: too few arguments to function
'reserve_bootmem'
make[6]: *** [arch/mips/kernel/setup.o] Error 1

thanks!

-- 
View this message in context: http://www.nabble.com/kexec-on-mips---anyone-has-it-working--tp17485898p22167417.html
Sent from the linux-mips main mailing list archive at Nabble.com.

---

From: Arnaud Patard <[email-masked]>
Date: Mon, 23 Feb 2009 22:29:00 +0100

> arch/mips/kernel/setup.c:493: error: too few arguments to function

oops. Adding BOOTMEM_DEFAULT as 3rd parameter should cure the problem I
think.

Arnaud