Subject: gcc-4.4 svn and 2.6.29-rc4 compile error

From: Andrew Randrianasulu <[email-masked]>
Date: Fri, 13 Feb 2009 15:10:13 -0800 (PST)

I have cross-compiler build in this way:

(cross-compiled binutils-2.19 was already installed in /home/guest/cross-compiler/mips/ )

export PATH="${PATH}":/home/guest/cross-compiler/mips/bin

mkdir build-gcc-bootstrap
cd build-gcc-bootstrap/

.../gcc-svn/./configure  --target=mips-unknown-linux-gnu --prefix=/home/guest/cross-compiler/mips --enable-languages=c --without-headers --with-gnu-ld --with-gnu-as --disable-shared --disable-threads --disable-libmudflap  --disable-libssp

make all-gcc install-gcc

(gcc rev. r144149)

Then i have linux kernel from kernel.org main git tree, up to 
commit 37bed90094fdb1eea6e4afec6a200d4e60143e55
(Date:   Thu Feb 12 17:47:15 2009 -0800

Merge git://git.kernel.org/pub/scm/linux/kernel/git/davem/net-2.6)

-rc5 already released, but i see only sound fixes there ...

after trying 
make ARCH=mips CROSS_COMPILE=mips-unknown-linux-gnu- menuconfig
make ARCH=mips CROSS_COMPILE=mips-unknown-linux-gnu- 

i got this error:
CC      init/version.o
  CC      init/do_mounts.o
  CC      init/do_mounts_rd.o
  CC      init/do_mounts_initrd.o
  LD      init/mounts.o
  CC      init/initramfs.o
  CC      init/calibrate.o
  LD      init/built-in.o
  HOSTCC  usr/gen_init_cpio
  GEN     usr/initramfs_data.cpio.gz
  AS      usr/initramfs_data.o
  LD      usr/built-in.o
  CC      arch/mips/sgi-ip32/ip32-berr.o
  CC      arch/mips/sgi-ip32/ip32-irq.o
  CC      arch/mips/sgi-ip32/ip32-platform.o
  CC      arch/mips/sgi-ip32/ip32-setup.o
  CC      arch/mips/sgi-ip32/ip32-reset.o
cc1: warnings being treated as errors
arch/mips/sgi-ip32/ip32-reset.c: Â ôóíêöèè 'debounce':
arch/mips/sgi-ip32/ip32-reset.c:97: îøèáêà: 'reg_a' is used uninitialized in this function
make[1]: *** [arch/mips/sgi-ip32/ip32-reset.o] Îøèáêà 1
make: *** [arch/mips/sgi-ip32] Îøèáêà 2

and restart make with with LANG=C give this

guest@slax:/mnt/hdb1/src/linux-git/linux-2.6$ make ARCH=mips CROSS_COMPILE=mips-unknown-linux-gnu- 
  CHK     include/linux/version.h
  CHK     include/linux/utsrelease.h
  SYMLINK include/asm -> include/asm-mips
  Checking missing-syscalls for O32
  CALL    scripts/checksyscalls.sh
  CALL    scripts/checksyscalls.sh
  CHK     include/linux/compile.h
  CC      arch/mips/sgi-ip32/ip32-reset.o
cc1: warnings being treated as errors
arch/mips/sgi-ip32/ip32-reset.c: In function 'debounce':
arch/mips/sgi-ip32/ip32-reset.c:97: error: 'reg_a' is used uninitialized in this function
make[1]: *** [arch/mips/sgi-ip32/ip32-reset.o] Error 1
make: *** [arch/mips/sgi-ip32] Error 2

Is this known error? Or I should downgrade toolchain/kernel?

i actually have SGI o2 hardware now, but my SGI machine only run standalone so far, i was played with dvhtools/genisoimage and slightly older self-compiled kernel, without any luck. Should putting kernel in fake volume header work at all on CD-ROM?

---

From: Ralf Baechle <[email-masked]>
Date: Sat, 14 Feb 2009 18:13:55 +0000

> Is this known error? Or I should downgrade toolchain/kernel?

The error message is correct.  Congratulations, you (or gcc) have found a
bug that's lurking in the kernel since April 7, 2003 :-)

  Ralf