Subject: Re: [PATCH] cleanup vmalloc_fault for 64bit kernel

From: David Daney <[email-masked]>
Date: Wed, 09 Sep 2009 08:35:26 -0700

Wu Fei wrote:
> 64bit kernel won't arrive vmalloc_fault, it's not necessary or possible
> to copy the page table from init_mm.pgd. swapper_pg_dir, module_pg_dir
> and the process's pgd represent the different virtual address area, and
> the tlb exception handler accesses the suitable one directly.
> 
> Signed-off-by: Wu Fei <[email-masked]>
> ---
>  arch/mips/mm/fault.c |    6 +++---
>  1 files changed, 3 insertions(+), 3 deletions(-)
> 
> diff --git a/arch/mips/mm/fault.c b/arch/mips/mm/fault.c
> index f956ecb..e769789 100644
> --- a/arch/mips/mm/fault.c
> +++ b/arch/mips/mm/fault.c
> @@ -58,11 +58,9 @@ asmlinkage void do_page_fault(struct pt_regs *regs, unsigned long write,
>  	 * only copy the information from the master page table,
>  	 * nothing more.
>  	 */
> +#ifdef CONFIG_32BIT
>  	if (unlikely(address >= VMALLOC_START && address <= VMALLOC_END))
>  		goto vmalloc_fault;
> -#ifdef MODULE_START
> -	if (unlikely(address >= MODULE_START && address < MODULE_END))
> -		goto vmalloc_fault;
>  #endif
>  

That is not correct.  You can still arrive at do_page_fault() from 
faults in the vmalloc range.  We need to go directly to the panic code 
as I did in my patch: Message-Id: 
<[email-masked]>

AKA: [PATCH] MIPS: Don't corrupt page tables on vmalloc fault.

>  	/*
> @@ -203,6 +201,7 @@ do_sigbus:
>  	force_sig_info(SIGBUS, &info, tsk);
>  
>  	return;
> +#ifdef CONFIG_32BIT
>  vmalloc_fault:
>  	{
>  		/*
> @@ -241,4 +240,5 @@ vmalloc_fault:
>  			goto no_context;
>  		return;
>  	}
> +#endif
>  }

---

From: Wu Fei <[email-masked]>
Date: Thu, 10 Sep 2009 19:42:38 +0800

> faults in the vmalloc range.  We need to go directly to the panic code  

That's not a real problem, if do_page_fault() from faults in the vmalloc
range, find_vma() returns NULL and eventually it will arrive no_context.
But anyway, I think your patch is better and readable.

Thanks,
Wufei.