Subject: [PATCH] MIPS: includecheck fix: smp.c

From: Jaswinder Singh Rajput <[email-masked]>
Date: Tue, 22 Sep 2009 18:59:27 +0530

fix the following 'make includecheck' warning:

  arch/mips/kernel/smp.c: linux/smp.h is included more than once.

Signed-off-by: Jaswinder Singh Rajput <[email-masked]>
---
 arch/mips/kernel/smp.c |    1 -
 1 files changed, 0 insertions(+), 1 deletions(-)

diff --git a/arch/mips/kernel/smp.c b/arch/mips/kernel/smp.c
index 64668a9..119a95e 100644
--- a/arch/mips/kernel/smp.c
+++ b/arch/mips/kernel/smp.c
@@ -32,7 +32,6 @@
 #include <linux/cpumask.h>
 #include <linux/cpu.h>
 #include <linux/err.h>
-#include <linux/smp.h>
 
 #include <asm/atomic.h>
 #include <asm/cpu.h>
-- 
1.6.0.6

---

From: Ralf Baechle <[email-masked]>
Date: Wed, 23 Sep 2009 10:11:35 +0100

> Signed-off-by: Jaswinder Singh Rajput <[email-masked]>

I've already merged a patch which didn't yet make it to kernel.org for this 
issue a few days ago.

Thanks anyway!

  Ralf