Subject: [PATCH] MIPS: TXx9: Fix error handling / Fix for noenexisting gpio_remove.

From: Ralf Roesch <[email-masked]>
Date: Wed, 16 Sep 2009 08:01:20 +0200

error was introduced by commit 0385d1f3d394c6814be0b165c153fc3fc254469a

Signed-off-by: Ralf Roesch <[email-masked]>
---
 arch/mips/txx9/generic/setup.c |    3 ++-
 1 files changed, 2 insertions(+), 1 deletions(-)

diff --git a/arch/mips/txx9/generic/setup.c b/arch/mips/txx9/generic/setup.c
index ed794c1..cff5578 100644
--- a/arch/mips/txx9/generic/setup.c
+++ b/arch/mips/txx9/generic/setup.c
@@ -835,7 +835,8 @@ void __init txx9_iocled_init(unsigned long baseaddr,
 out_pdev:
 	platform_device_put(pdev);
 out_gpio:
-	gpio_remove(&iocled->chip);
+	if (gpiochip_remove(&iocled->chip))
+		return;
 out_unmap:
 	iounmap(iocled->mmioaddr);
 out_free:
-- 
1.6.3.3

---

From: Atsushi Nemoto <[email-masked]>
Date: Thu, 17 Sep 2009 22:52:59 +0900 (JST)

> error was introduced by commit 0385d1f3d394c6814be0b165c153fc3fc254469a

Thanks, this patch should be holded into the original commit before
mainlining.  The result should be same as Julia's revised patch.

I don't mind ether way, I just hope keeping bisectability on mainline.
Is it too late, (yet another) Ralf ?

---
Atsushi Nemoto

---

From: Ralf Roesch <[email-masked]>
Date: Fri, 18 Sep 2009 10:12:32 +0200

> Is it too late, (yet another) Ralf ?
Not for me Atshushi, thanks.
--
the other Ralf ;-)

---

From: Sergei Shtylyov <[email-masked]>
Date: Fri, 18 Sep 2009 20:22:17 +0400

Hello.

> Is it too late, (yet another) Ralf ?

    Well, Ralf B. has already committed Julia's broken patch at 9/14.

> Atsushi Nemoto

WBR, Sergei

---

From: Atsushi Nemoto <[email-masked]>
Date: Fri, 25 Sep 2009 22:57:33 +0900 (JST)

>     Well, Ralf B. has already committed Julia's broken patch at 9/14.

Then,
Acked-by: Atsushi Nemoto <[email-masked]>

---
Atsushi Nemoto