Subject: linux-mips.git broken compiling for smp targets

From: Mark Mason <[email-masked]>
Date: Thu, 24 Sep 2009 15:27:19 -0700

Hello all,

I'm getting the following compiling for my bcm1480:

  CALL    scripts/checksyscalls.sh
  CHK     include/linux/compile.h
  CC      arch/mips/kernel/smp.o
arch/mips/kernel/smp.c: In function `arch_send_call_function_single_ipi':
arch/mips/kernel/smp.c:140: error: incompatible type for argument 1 of indirect function call
make[1]: *** [arch/mips/kernel/smp.o] Error 1
make: *** [arch/mips/kernel] Error 2

Anyone else running into this?

Thanks,
Mark

---

From: Ralf Baechle <[email-masked]>
Date: Fri, 25 Sep 2009 21:01:22 +0100

> Anyone else running into this?

Yes, the code got Rusty.  I fixed that a few hours ago.

  Ralf