Subject: [PATCH] MTD: nand: Convert au1550nd to use module_platform_driver()

From: Axel Lin <[email-masked]>
Date: Thu, 01 Dec 2011 22:04:07 +0800

Cc: Manuel Lauss <[email-masked]>
Cc: Artem Bityutskiy <[email-masked]>
Cc: Ralf Baechle <[email-masked]>
Signed-off-by: Axel Lin <[email-masked]>
---
Hi Ralf,
This patch converts au1550nd to use module_platform_driver().
You have committed a5bd32fd "MTD: nand: make au1550nd.c a platform_driver".
Currently this patch can only apply to either your tree or linux-next.
Could you help to take it.
( committed a5bd32fd does not exist in l2-mtd-2.6.git,
so Artem cannot apply it.)

Thanks,
Axel

 drivers/mtd/nand/au1550nd.c |   12 +-----------
 1 files changed, 1 insertions(+), 11 deletions(-)

diff --git a/drivers/mtd/nand/au1550nd.c b/drivers/mtd/nand/au1550nd.c
index 77fb4e6..73abbc3 100644
--- a/drivers/mtd/nand/au1550nd.c
+++ b/drivers/mtd/nand/au1550nd.c
@@ -560,17 +560,7 @@ static struct platform_driver au1550nd_driver = {
 	.remove		= __devexit_p(au1550nd_remove),
 };
 
-static int __init au1550nd_load(void)
-{
-	return platform_driver_register(&au1550nd_driver);
-};
-
-static void __exit au1550nd_exit(void)
-{
-	platform_driver_unregister(&au1550nd_driver);
-};
-module_init(au1550nd_load);
-module_exit(au1550nd_exit);
+module_platform_driver(au1550nd_driver);
 
 MODULE_LICENSE("GPL");
 MODULE_AUTHOR("Embedded Edge, LLC");
-- 
1.7.5.4

---

From: Artem Bityutskiy <[email-masked]>
Date: Sun, 04 Dec 2011 16:15:32 +0200

> so Artem cannot apply it.)

Yes, please, merge the au1550nd.c piece via Ralf, thanks!

-- 
Best Regards,
Artem Bityutskiy

---

From: Ralf Baechle <[email-masked]>
Date: Thu, 8 Dec 2011 10:45:23 +0000

> Yes, please, merge the au1550nd.c piece via Ralf, thanks!

No point in adding code to change it again first commit so I've folded
this patch into "MTD: nand: make au1550nd.c a platform_driver".

Thanks folks!

  Ralf