Subject: linux-next: build failure after merge of the final tree (mips tree related)

From: Stephen Rothwell <[email-masked]>
Date: Sat, 17 Dec 2011 15:50:44 +1100

Hi all,

After merging the final tree, today's linux-next build (mips almost all
configs) failed like this:

arch/mips/mm/tlb-r4k.c: In function 'local_flush_tlb_range':
arch/mips/mm/tlb-r4k.c:128: error: 'HPAGE_SIZE' undeclared (first use in this function)
arch/mips/mm/tlb-r4k.c:130: error: 'HPAGE_SHIFT' undeclared (first use in this function)

Probably caused by commit 0b07e859f87b ("MIPS: Flush huge TLB").
-- 
Cheers,
Stephen Rothwell                    [email-masked]
http://www.canb.auug.org.au/~sfr/

---

From: David Daney <[email-masked]>
Date: Sat, 17 Dec 2011 10:06:59 -0800

> Probably caused by commit 0b07e859f87b ("MIPS: Flush huge TLB").

Indeed that is the case.

We have a patch for this issue:  http://patchwork.linux-mips.org/patch/3114/

Perhaps Ralf will push out a mips-for-linux-next containing this patch 
in the near future.

David Daney