Subject: [PATCH] MIPS: Fix duplicate instances of ARCH_SPARSEMEM_ENABLE

From: Kevin Cernekee <[email-masked]>
Date: Sat, 28 Jan 2012 15:07:49 -0800

"config ARCH_SPARSEMEM_ENABLE" exists in both arch/mips/Kconfig and
arch/mips/cavium-octeon/Kconfig, but the dependencies are not the same.
This results in warnings when a non-Cavium platform tries to select
ARCH_SPARSEMEM_ENABLE:

    $ make lemote2f_defconfig ARCH=mips
    warning: (LEMOTE_FULOONG2E && LEMOTE_MACH2F) selects ARCH_SPARSEMEM_ENABLE which has unmet direct dependencies (CPU_CAVIUM_OCTEON)
    warning: (LEMOTE_FULOONG2E && LEMOTE_MACH2F) selects ARCH_SPARSEMEM_ENABLE which has unmet direct dependencies (CPU_CAVIUM_OCTEON)
    #
    # configuration written to .config
    #

Proposed workaround is to use a Cavium-specific config option which
"select"s the desired options.

Signed-off-by: Kevin Cernekee <[email-masked]>
---
 arch/mips/cavium-octeon/Kconfig |    3 ++-
 1 files changed, 2 insertions(+), 1 deletions(-)

diff --git a/arch/mips/cavium-octeon/Kconfig b/arch/mips/cavium-octeon/Kconfig
index f9e275a..eda8266 100644
--- a/arch/mips/cavium-octeon/Kconfig
+++ b/arch/mips/cavium-octeon/Kconfig
@@ -82,8 +82,9 @@ config CAVIUM_OCTEON_LOCK_L2_MEMCPY
 	help
 	  Lock the kernel's implementation of memcpy() into L2.
 
-config ARCH_SPARSEMEM_ENABLE
+config CAVIUM_OCTEON_SPARSEMEM_ENABLE
 	def_bool y
+	select ARCH_SPARSEMEM_ENABLE
 	select SPARSEMEM_STATIC
 
 config IOMMU_HELPER
-- 
1.7.6.3

---

From: David Daney <[email-masked]>
Date: Mon, 30 Jan 2012 09:03:04 -0800

On 01/28/2012 03:07 PM, Kevin Cernekee wrote:
>      warning: (LEMOTE_FULOONG2E&&  LEMOTE_MACH2F) selects ARCH_SPARSEMEM_ENABLE which has unmet direct dependencies (CPU_CAVIUM_OCTEON)
>      warning: (LEMOTE_FULOONG2E&&  LEMOTE_MACH2F) selects ARCH_SPARSEMEM_ENABLE which has unmet direct dependencies (CPU_CAVIUM_OCTEON)
>      #
> Signed-off-by: Kevin Cernekee<[email-masked]>
> ---

NAK!

A cleaner patch for this was already done here:

http://patchwork.linux-mips.org/patch/3285/

---

From: Kevin Cernekee <[email-masked]>
Date: Mon, 30 Jan 2012 10:38:02 -0800

> http://patchwork.linux-mips.org/patch/3285/

This patch fixed the problem for me, but it doesn't apply cleanly to
the current head of tree since the context (CAVIUM_OCTEON_HELPER) has
changed.

Lluis, do you want to go ahead and submit a V2?

Thanks.