Subject: [PATCH] MIPS: fix tc_id calculation

From: [email-masked]
Date: Mon, 2 Jul 2012 12:34:30 +0800

From: RongQing.Li <[email-masked]>

Now the tc_id is:
  (read_c0_tcbind() >> TCBIND_CURTC_SHIFT) & TCBIND_CURTC;
After substitute macro:
  (read_c0_tcbind() >> 21) & ((0xff) << 21)
It should be:
  (read_c0_tcbind() & ((0xff)<< 21)) >>21

Signed-off-by: RongQing.Li <[email-masked]>
---
 arch/mips/kernel/smp-cmp.c |    2 +-
 1 files changed, 1 insertions(+), 1 deletions(-)

diff --git a/arch/mips/kernel/smp-cmp.c b/arch/mips/kernel/smp-cmp.c
index e7e03ec..afc379c 100644
--- a/arch/mips/kernel/smp-cmp.c
+++ b/arch/mips/kernel/smp-cmp.c
@@ -102,7 +102,7 @@ static void cmp_init_secondary(void)
 	c->vpe_id = (read_c0_tcbind() >> TCBIND_CURVPE_SHIFT) & TCBIND_CURVPE;
 #endif
 #ifdef CONFIG_MIPS_MT_SMTC
-	c->tc_id  = (read_c0_tcbind() >> TCBIND_CURTC_SHIFT) & TCBIND_CURTC;
+	c->tc_id  = (read_c0_tcbind() & TCBIND_CURTC) >> TCBIND_CURTC_SHIFT;
 #endif
 }
 
-- 
1.7.1

---

From: RongQing Li <[email-masked]>
Date: Sat, 28 Jul 2012 17:08:59 +0800

Any advice

---

From: Hillf Danton <[email-masked]>
Date: Sun, 29 Jul 2012 09:19:23 +0800

>> Signed-off-by: RongQing.Li <[email-masked]>

Good catch ;)

Thanks,
               Hillf

> To unsubscribe from this list: send the line "unsubscribe linux-kernel" in
> the body of a message to [email-masked]
> More majordomo info at  http://vger.kernel.org/majordomo-info.html
> Please read the FAQ at  http://www.tux.org/lkml/
>
>