Subject: [PATCH] MIPS: sead3_led: Use LED_CORE_SUSPENDRESUME

From: Lars-Peter Clausen <[email-masked]>
Date: Sun, 17 Feb 2013 13:28:22 +0100

Setting the LED_CORE_SUSPENDRESUME flag causes the LED driver core to call
led_classdev_suspend/led_classdev_resume during suspend/resume. Since this is
exactly what the driver's custom suspend/resume callbacks do we can replace them
by setting the LED_CORE_SUSPENDRESUME flag.

Signed-off-by: Lars-Peter Clausen <[email-masked]>
---
 arch/mips/mti-sead3/leds-sead3.c |   24 ++----------------------
 1 files changed, 2 insertions(+), 22 deletions(-)

diff --git a/arch/mips/mti-sead3/leds-sead3.c b/arch/mips/mti-sead3/leds-sead3.c
index 322148c..0a168c9 100644
--- a/arch/mips/mti-sead3/leds-sead3.c
+++ b/arch/mips/mti-sead3/leds-sead3.c
@@ -34,33 +34,15 @@ static void sead3_fled_set(struct led_classdev *led_cdev,
 static struct led_classdev sead3_pled = {
 	.name		= "sead3::pled",
 	.brightness_set = sead3_pled_set,
+	.flags		= LED_CORE_SUSPENDRESUME,
 };
 
 static struct led_classdev sead3_fled = {
 	.name		= "sead3::fled",
 	.brightness_set = sead3_fled_set,
+	.flags		= LED_CORE_SUSPENDRESUME,
 };
 
-#ifdef CONFIG_PM
-static int sead3_led_suspend(struct platform_device *dev,
-		pm_message_t state)
-{
-	led_classdev_suspend(&sead3_pled);
-	led_classdev_suspend(&sead3_fled);
-	return 0;
-}
-
-static int sead3_led_resume(struct platform_device *dev)
-{
-	led_classdev_resume(&sead3_pled);
-	led_classdev_resume(&sead3_fled);
-	return 0;
-}
-#else
-#define sead3_led_suspend NULL
-#define sead3_led_resume NULL
-#endif
-
 static int sead3_led_probe(struct platform_device *pdev)
 {
 	int ret;
@@ -86,8 +68,6 @@ static int sead3_led_remove(struct platform_device *pdev)
 static struct platform_driver sead3_led_driver = {
 	.probe		= sead3_led_probe,
 	.remove		= sead3_led_remove,
-	.suspend	= sead3_led_suspend,
-	.resume		= sead3_led_resume,
 	.driver		= {
 		.name		= DRVNAME,
 		.owner		= THIS_MODULE,
-- 
1.7.2.5

---

From: Steven Hill <[email-masked]>
Date: Wed, 20 Feb 2013 20:31:57 +0000

Hello.

This patch does not apply cleanly because of space/tab differences. In both of the lines below with '.brightness_set' the character between 't' and '=' needs to be a tab, not a space.

-Steve

---

From: Lars-Peter Clausen <[email-masked]>
Date: Wed, 20 Feb 2013 21:42:25 +0100

> This patch does not apply cleanly because of space/tab differences. In both of the lines below with '.brightness_set' the character between 't' and '=' needs to be a tab, not a space.

Hi,

The patch depends on commit 70342287 ("MIPS: Whitespace cleanup.").

- Lars

---

From: Steven Hill <[email-masked]>
Date: Wed, 20 Feb 2013 20:44:23 +0000

Lars,

Please format patches for Malta and SEAD-3 to be against my 'linux-sjhill.git' repo and the 'mti-next' branch. Thanks.

-Steve

---

From: Lars-Peter Clausen <[email-masked]>
Date: Wed, 20 Feb 2013 22:02:37 +0100

Hi,

Can you fixup the patch manually in this case? It's probably faster for both of
us than having me re-send the patch.

Btw. I think it would be a good idea to add the information about your git repo
to MAINTAINERS.

- Lars

---

From: Steven Hill <[email-masked]>
Date: Wed, 20 Feb 2013 21:07:33 +0000

Sure, I'll take care of it.