Subject: [PATCH] MIPS: SMTC: fix implicit declaration of set_vi_handler

From: Florian Fainelli <[email-masked]>
Date: Fri, 8 Feb 2013 11:45:14 +0100

This patch fixes the following implicit declaration while building with
MIPS SMTC support enabled:

arch/mips/kernel/smtc.c: In function 'setup_cross_vpe_interrupts':
arch/mips/kernel/smtc.c:1205:2: error: implicit declaration of function
'set_vi_handler' [-Werror=implicit-function-declaration]
cc1: all warnings being treated as errors

Signed-off-by: Florian Fainelli <[email-masked]>
---
Ralf, John,

This is applicable to both mips-for-linux-next and master.

 arch/mips/kernel/smtc.c |    1 +
 1 file changed, 1 insertion(+)

diff --git a/arch/mips/kernel/smtc.c b/arch/mips/kernel/smtc.c
index 1c152a9..7186222 100644
--- a/arch/mips/kernel/smtc.c
+++ b/arch/mips/kernel/smtc.c
@@ -41,6 +41,7 @@
 #include <asm/addrspace.h>
 #include <asm/smtc.h>
 #include <asm/smtc_proc.h>
+#include <asm/setup.h>
 
 /*
  * SMTC Kernel needs to manipulate low-level CPU interrupt mask
-- 
1.7.10.4

---

From: Florian Fainelli <[email-masked]>
Date: Fri, 08 Feb 2013 11:53:38 +0100

> cc1: all warnings being treated as errors

And attached the config file to reproduce the build failure.
--
Florian