Subject: [PATCH] mips: remove unecessary __linux__ check

From: liguang <[email-masked]>
Date: Tue, 19 Feb 2013 16:12:51 +0800

sgidefs.h has strict check for __linux__,
it seems too harsh, as far as I test, 2 cross
compiler for mips will not define it automatically,
and exit build process with error
"#error Use a Linux compiler or give up".
remove it will not hurt, I think.

Signed-off-by: liguang <[email-masked]>
---
 arch/mips/include/uapi/asm/sgidefs.h |    8 --------
 1 files changed, 0 insertions(+), 8 deletions(-)

diff --git a/arch/mips/include/uapi/asm/sgidefs.h b/arch/mips/include/uapi/asm/sgidefs.h
index 876442f..5be81f8 100644
--- a/arch/mips/include/uapi/asm/sgidefs.h
+++ b/arch/mips/include/uapi/asm/sgidefs.h
@@ -11,14 +11,6 @@
 #define __ASM_SGIDEFS_H
 
 /*
- * Using a Linux compiler for building Linux seems logic but not to
- * everybody.
- */
-#ifndef __linux__
-#error Use a Linux compiler or give up.
-#endif
-
-/*
  * Definitions for the ISA levels
  *
  * With the introduction of MIPS32 / MIPS64 instruction sets definitions
-- 
1.7.2.5

---

From: Ralf Baechle <[email-masked]>
Date: Tue, 19 Feb 2013 11:04:25 +0100

> remove it will not hurt, I think.

My mailbox used to get flooded by people who attempted to build a kernel
using something like a mips-elf, mips-sde-elf or even stranger targets.
There are further differences than just the definition of __linux__ so
I eventually applied this check.

  Ralf