Subject: [PATCH] MIPS: tlbex: fix broken build in v3.11-rc1

From: Aaro Koskinen <[email-masked]>
Date: Mon, 15 Jul 2013 11:21:57 +0300

Commit 6ba045f9fbdafb48da42aa8576ea7a3980443136 (MIPS: Move generated code
to .text for microMIPS) deleted tlbmiss_handler_setup_pgd_array, but some
references were not converted. Fix that to enable building a MIPS kernel.

Signed-off-by: Aaro Koskinen <[email-masked]>
---
 arch/mips/mm/tlbex.c | 2 +-
 1 file changed, 1 insertion(+), 1 deletion(-)

diff --git a/arch/mips/mm/tlbex.c b/arch/mips/mm/tlbex.c
index 9ab0f90..cc34521 100644
--- a/arch/mips/mm/tlbex.c
+++ b/arch/mips/mm/tlbex.c
@@ -1466,7 +1466,7 @@ static void __cpuinit build_r4000_setup_pgd(void)
 {
 	const int a0 = 4;
 	const int a1 = 5;
-	u32 *p = tlbmiss_handler_setup_pgd_array;
+	u32 *p = tlbmiss_handler_setup_pgd;
 	const int tlbmiss_handler_setup_pgd_size =
 		tlbmiss_handler_setup_pgd_end - tlbmiss_handler_setup_pgd;
 	struct uasm_label *l = labels;
-- 
1.8.3.1

---

From: "Jayachandran C." <[email-masked]>
Date: Mon, 15 Jul 2013 15:25:02 +0530

>  	struct uasm_label *l = labels;

Acked-by: "Jayachandran C." <[email-masked]>

Thanks, looks like I made a mistake splitting the patchset, this part went
into the next patch which didn't make it to 3.11.

JC.

---

From: David Daney <[email-masked]>
Date: Thu, 18 Jul 2013 10:19:51 -0700

> Signed-off-by: Aaro Koskinen <[email-masked]>

Yes, this appears to be needed.

Acked-by: David Daney <[email-masked]>